Mensagem de erro quando você tenta exibir o calendário de serviço no Microsoft Dynamics CRM 3.0: "uma exceção sem tratamento foi gerada durante a execução de solicitação da web atual"

Traduções deste artigo Traduções deste artigo
ID do artigo: 917545 - Exibir os produtos aos quais esse artigo se aplica.
importante Este artigo contém informações sobre como modificar o registro. Certifique-se de que você faça backup do registro antes de modificá-lo. Certifique-se que você sabe como restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756Como fazer backup e restaurar o registro no Windows


O hotfix discutido neste artigo não está disponível para a versão em chinês do Microsoft Dynamics CRM ou para a versão em japonês do Microsoft Dynamics CRM.
Expandir tudo | Recolher tudo

Sintomas

Não é possível exibir o calendário de serviço no Microsoft Dynamics CRM 3.0. Além disso, você receber a seguinte mensagem de erro:
Uma exceção não tratada foi gerada durante a execução de solicitação da web atual. Informações sobre a origem e o local da exceção podem ser identificadas usando o rastreamento de pilha de exceção abaixo.

Causa

Esse problema ocorre quando você tem que trabalhar horas definidas no Microsoft Dynamics CRM 3.0 e quando uma das seguintes condições for verdadeira:
  • Alterar fuso horário no seu computador.
  • Você alterar de horário de verão para a hora padrão ou alterar da hora padrão para o horário de verão.

Resolução

Esse problema é corrigido no Update Rollup 1 do Microsoft Dynamics CRM 3.0. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
922815Pacote cumulativo de atualizações 1 para o Microsoft Dynamics CRM 3.0 está disponível

Mais Informações

Aviso Podem ocorrer sérios problemas se você modificar o registro incorretamente usando o Editor do registro ou usando outro método. Esses problemas podem exigir que você reinstalar o sistema operacional. A Microsoft não garante que esses problemas possam ser solucionados. Modificar o registro por sua própria conta e risco.

Para habilitar o hotfix, adicione o valor DWORD ForceTimeZone para a seguinte subchave do Registro:
HKLM\Software\Microsoft\MSCRM
O valor DWORD ForceTimeZone deve ter um valor de 1 decimal. Para adicionar o valor de DWORD ForceTimeZone, execute estas etapas:
  1. No servidor do Microsoft Dynamics CRM, clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Clique com o botão direito na chave de registro HKLM\Software\Microsoft\MSCRM , clique em novo e, em seguida, clique em valor DWORD .
  3. Digite ForceTimeZone e, em seguida, pressione ENTER.
  4. Clique duas vezes em ForceTimeZone , digite 1 na caixa dados do valor e, em seguida, clique em OK .
Esse hotfix corrige o problema constante avanço. No entanto, talvez seja necessário corrigir manualmente alguns registros de calendário. Você deve corrigir manualmente alguns registros do calendário se você receber as seguintes mensagens de erro quando você clicar em Horas de trabalho depois de abrir um registro de usuário no Microsoft Dynamics CRM.
Mensagem de erro 1
Falha na solicitação SOAP:
Url:http://n30/MSCRMServices/calendar.asmx >
>MethodName: Expandir
Resposta >: >
<? xml versão = codificação "1.0" = "utf-8"? > >
<soap: Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" >
><soap:Body>
><soap:Fault>
><faultcode> soap: Server </faultcode>
><faultstring> System.Web.Services.Protocols.SoapException: servidor não pôde processar solicitação.---&gt; System.InvalidOperationException: recorrência relativa gerado um intervalo que não está contido pelo escopo. >no Microsoft.Crm.Scheduling.RelativeRecurrenceRule.Expand (TimeIntervalCollection escopos) >
Mensagem de erro 2
>CrmSoapExtension detectou não-CrmException ? relatório será enviado ao Watson: System.Web.Services.Protocols.SoapException: servidor não pôde processar a solicitação. ---> System.InvalidOperationException: recorrência relativa gerado um intervalo que não está contido pelo escopo. em Microsoft.Crm.Scheduling.RelativeRecurrenceRule.Expand (TimeIntervalCollection escopos) em Microsoft.Crm.Scheduling.Engine.LeafCalendarRule.ExpandRecurrence (TimeIntervalCollection effectiveScopeIntervals TimeIntervalCollection instanceIntervals, Int32 effectiveTimeZoneCode) em Microsoft.Crm.Scheduling.Engine.CalendarRule.Expand (TimeIntervalCollection scopeIntervals TimeIntervalCollection instanceIntervals, Int32 fallbackTimeZoneCode)
Observação Você recebe essas mensagens de erro se você ativar a configuração DevErrors ou se você examinar os arquivos de log de rastreamento de plataforma.

Para resolver esse problema imediatamente, contate o Atendimento de cliente Microsoft. Para obter uma lista completa de telefones do serviço de suporte a clientes da Microsoft e informações sobre os custos de suporte, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação Em alguns casos, as taxas cobradas pelas ligações para chamadas de suporte podem ser canceladas se um profissional de suporte da Microsoft determinar que uma atualização específica resolverá o problema. Os custos normais de suporte serão aplicados a questões e problemas que não se qualificam à atualização específica em questão de suporte adicionais.

Para obter mais informações sobre terminologia de atualização de software, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software
887283Padrões de nomenclatura do pacote de Microsoft Business Solutions CRM software hotfix e atualização

Propriedades

ID do artigo: 917545 - Última revisão: sexta-feira, 11 de janeiro de 2008 - Revisão: 4.3
A informação contida neste artigo aplica-se a:
  • Microsoft CRM 3.0
Palavras-chave: 
kbmt kbfix kbbug kberrmsg kbhotfixserver kbqfe kbmbsmigrate KB917545 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 917545

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com