Mensagem de erro quando tenta visualizar o calendário de serviço no Microsoft Dynamics CRM 3.0: "uma exceção sem tratamento foi gerada durante a execução da solicitação da web atual"

Traduções de Artigos Traduções de Artigos
Artigo: 917545 - Ver produtos para os quais este artigo se aplica.
importante Este artigo contém informações sobre como modificar o registo. Certifique-se uma que a cópia de segurança do registo antes de o modificar. Certifique-se que sabe como restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança, restaurar e modificar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756Como efectuar uma cópia de segurança e restaurar o registo no Windows


A correcção descrita neste artigo não está disponível para a versão em chinês do Microsoft Dynamics CRM ou para a versão japonesa do Microsoft Dynamics CRM.
Expandir tudo | Reduzir tudo

Sintomas

Não pode ver o calendário de serviço no Microsoft Dynamics CRM 3.0. Além disso, recebe a seguinte mensagem de erro:
Foi gerada uma excepção não processada durante a execução da solicitação da web actual. Informações sobre a origem e a localização da excepção podem ser identificadas utilizando o rastreio de pilha de excepção abaixo.

Causa

Este problema ocorre quando tiver trabalhar horas definidas no Microsoft Dynamics CRM 3.0 e quando uma das seguintes condições for verdadeira:
  • Mudar de fuso horário no computador.
  • Alterar a hora de Verão para a hora padrão ou alterar da hora padrão para a hora de Verão.

Resolução

Este problema é corrigido no Microsoft Dynamics CRM 3.0 Update Rollup 1. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
922815Pacote cumulativo de atualizações 1 para o Microsoft Dynamics CRM 3.0 está disponível

Mais Informação

aviso Podem ocorrer problemas graves se modificar o registo incorrectamente utilizando o Editor de registo ou utilizando outro método. Estes problemas poderão forçar a reinstalação do sistema operativo. Microsoft não garante que estes problemas podem ser resolvidos. Modificar o registo por sua conta e risco.

Para activar a correcção, adicione o valor DWORD ForceTimeZone à seguinte subchave do registo:
HKLM\Software\Microsoft\MSCRM
O valor DWORD ForceTimeZone tem de ter um valor decimal 1. Para adicionar o valor de DWORD ForceTimeZone, siga estes passos:
  1. No servidor do Microsoft Dynamics CRM, clique em Iniciar , clique em Executar , escreva regedit e, em seguida, clique em OK .
  2. Clique com o botão direito do rato a chave de registo HKLM\Software\Microsoft\MSCRM , clique em Novo e, em seguida, clique em valor DWORD .
  3. Escreva ForceTimeZone e, em seguida, prima ENTER.
  4. Faça duplo clique em ForceTimeZone , escreva 1 na caixa dados do valor e, em seguida, clique em OK .
Esta correcção corrige o problema vai para a frente. No entanto, poderá ter de corrigir manualmente alguns registos de calendário. Tem de corrigir manualmente alguns registos de calendário se receber as seguintes mensagens de erro quando clica em Horas de trabalho depois de abrir um registo de utilizador no Microsoft Dynamics CRM.
Mensagem de erro 1
Falhou o pedido de SOAP:
>Url:http://n30/MSCRMServices/calendar.asmx
>MethodName: expandir
>Resposta: >
<? versão xml = codificação "1.0" = "utf-8"? > >
<soap: Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" >
><soap:Body>
><soap:Fault>
><faultcode> Soap: servidor </faultcode>
><faultstring> System.Web.Services.Protocols.SoapException: Server was unable to process pedido.---&gt; System.InvalidOperationException: periodicidade relativamente gerado um intervalo que não está contido pelo âmbito. >no Microsoft.Crm.Scheduling.RelativeRecurrenceRule.Expand (TimeIntervalCollection âmbitos) >
Mensagem de erro 2
>CrmSoapExtension detectou não-CrmException ? relatório será enviado ao Watson: System.Web.Services.Protocols.SoapException: Server não conseguiu processar o pedido. ---> System.InvalidOperationException: periodicidade relativamente gerado um intervalo que não está contido pelo âmbito. em Microsoft.Crm.Scheduling.RelativeRecurrenceRule.Expand (TimeIntervalCollection âmbitos) em Microsoft.Crm.Scheduling.Engine.LeafCalendarRule.ExpandRecurrence (TimeIntervalCollection effectiveScopeIntervals TimeIntervalCollection instanceIntervals, Int32 effectiveTimeZoneCode) em Microsoft.Crm.Scheduling.Engine.CalendarRule.Expand (TimeIntervalCollection scopeIntervals TimeIntervalCollection instanceIntervals, Int32 fallbackTimeZoneCode)
Nota Receber estas mensagens de erro se activar a definição DevErrors ou se consultar os ficheiros de registo de rastreio de plataforma.

Para resolver este problema imediatamente, contacte o suporte técnico da Microsoft. Para obter uma lista completa dos números de telefone de suporte técnico da Microsoft e informações sobre os custos de suporte, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Em casos especiais, os custos normalmente inerentes às chamadas de suporte poderão ser anulados, se um técnico de suporte da Microsoft determinar que uma actualização específica resolverá o problema. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem na atualização específica em questão.

Para obter mais informações sobre a terminologia de actualização de software, clique números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft:
824684Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft
887283Padrões de nomenclatura do pacote de Microsoft Business Solutions CRM software hotfix e atualização

Propriedades

Artigo: 917545 - Última revisão: 11 de janeiro de 2008 - Revisão: 4.3
A informação contida neste artigo aplica-se a:
  • Microsoft CRM 3.0
Palavras-chave: 
kbmt kbfix kbbug kberrmsg kbhotfixserver kbqfe kbmbsmigrate KB917545 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 917545

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com