Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

You may experience slow performance on a computer that is running Microsoft Internet Information Services (IIS) 6.0. This problem occurs when the following conditions are true:

  • You use Integrated Windows authentication together with IIS 6.0.

  • You use the Kerberos authentication protocol to authenticate the user on the Web site.

Note Visitors to a Web site that is hosted on the computer may also experience slow performance. This problem is more likely to occur if the visitors have limited bandwidth.

Cause

When you use the Kerberos authentication protocol, IIS 6.0 requires the client to be reauthenticated for each HTTP request. This behavior causes an increase in network traffic.



This behavior differs from Microsoft Internet Information Services (IIS) 5.0. In IIS 5.0, a client that is authenticated by Kerberos after an initial HTTP request stays authenticated for the duration of the HTTP Keep-Alive session.

Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows Server 2003 Service Pack 1 (SP1) installed to apply this hotfix.

Registry Information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756 How to back up and restore the registry in WindowsAfter you apply this hotfix, you must add and configure the EnableKerbAuthPersist registry value. To do this, follow these steps:

  1. Click Start, click Run, type regedit, and then click OK.

  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\W3SVC\Parameters

  3. On the Edit menu, point to New, and then click DWORD Value.

  4. Type EnableKerbAuthPersist for the entry name, and then press ENTER.

  5. Right-click EnableKerbAuthPersist, and then click Modify.

  6. In the Value data box, type 1 or any nonzero value to enable the hotfix, and then click OK.

    Note To return the IIS service to the default behavior, set the value to 0.

  7. Exit Registry Editor.

  8. Restart the IIS service. To do this, follow these steps:

    1. Click Start, click Run, type cmd, and then click OK.

    2. Type the following commands. Press ENTER after each command:

      net stop iisadmin

      net start iisadmin

Restart requirement

If the IIS service is running when you apply this hotfix, you must restart the IIS service.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003, Itanium architecture

File name

File version

File size

Date

Time

W3core.dll

6.0.3790.2683

1,059,328

15-Apr-2006

18:19

Windows Server 2003, x64

File name

File version

File size

Date

Time

W3core.dll

6.0.3790.2683

569,344

15-Apr-2006

06:04

Windows Server 2003, x86

File name

File version

File size

Date

Time

W3core.dll

6.0.3790.2683

348,672

15-Apr-2006

05:29

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows Server 2003 Service Pack 2.

More Information















After you enable the EnableKerbAuthPersist registry value and restart the IIS service, IIS 6.0 no longer requires the client to reauthenticate for each HTTP request. Clients only have to reauthenticate if they make another HTTP request by using a different client TCP port. This scenario occurs when a new HTTP Keep-Alive session must be established. For more information about HTTP Keep-Alive sessions, visit the following Internet Engineering Task Force (IETF) Web site:

http://www.ietf.org/rfc/rfc2616.txtFor more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×