Article ID: 917676 - Last Review: October 27, 2006 - Revision: 1.4

A Systems Management Server (SMS) 2003 Advanced Client computer may be slow to receive SMS advertisements

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SYMPTOMS

If you distribute software to a Microsoft Systems Management Server (SMS) 2003 Advanced Client computer, the computer may take longer than you expect to receive and run the SMS advertisement. If you examine the Ccmexec.log file on the client computer, you may not see any updates to this file for up to several days. This problem may occur if all the following conditions are true:
  • The client computer is also a Terminal Server that is running in Application mode.
  • No one is logged into the console session on the client computer.
Additionally, if you run System Monitor on the client computer and view the Thread Count counter for the Process performance object for the SMS Agent Host (Ccmexec.exe) process, you will experience something unusual. You will notice that this process has a much larger number of threads open than usual. Typically, a Ccmexec.exe process has around 10-15 threads open.

CAUSE

This problem occurs when many users are logged into the Terminal Server, but no one is logged into the console session. In this scenario, SMS Agent Host (Ccmexec.exe) is busy processing logon notifications. Therefore, policy processing from the Management Point may be delayed.

WORKAROUND

To work around this problem, you must configure the ShellWaitTime registry value. For more information about how to configure the ShellWaitTime registry value, click the following article number to view the article in the Microsoft Knowledge Base:
870653  (http://support.microsoft.com/kb/870653/ ) The SMS Agent Host service may take as long as 15 minutes to quit on an SMS 2003 Advanced Client
Alternatively, work around this problem by making sure that someone is always logged into the console session on the client computer.

Starting with Systems Management Server 2003 Service Pack 3 (SP3), the following entry will be listed repeatedly in the CCMExec.log file when this problem occurs and verbose client logging is not enabled:
WTSQueryUserToken[2](SessionID=0) failed with GLE=1245
It is expected that this message will appear occasionally in the CCMExec.log file. However, if the message is repeated, it may indicate that the problem this article describes has occurred. For example, the problem may have occurred if the message is repeated five or more times successively. Before SMS SP3, this entry appeared only if verbose logging was enabled on the SMS client.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Systems Management Server 2003
  • Microsoft Systems Management Server 2003 Service Pack 1
  • Microsoft Systems Management Server 2003 Service Pack 2
  • Microsoft Systems Management Server 2003 Service Pack 3
Keywords: 
kbsmsmp kbsmsclients kbtshoot kbprb KB917676
 

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