El asistente o posición del cuadro de diálogo Impresoras responder en un equipo basado en Windows Server 2003, basado en Windows XP o basado en Windows 2000

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Síntomas

Puede experimentar uno o varios de los siguientes problemas de impresora en un equipo que ejecuta Microsoft Windows Server 2003, Microsoft Windows XP o Microsoft Windows 2000:
  • Cuando intenta abrir el cuadro de diálogo Imprimir, se tarda un para abrir.
  • Cuando utiliza el Asistente para instalar a una impresora de red que está alojada en un servidor que está ejecutando el servicio SMB, el Asistente para agregar impresoras puede dejar de responder. El problema se produce después de copiarán los archivos del controlador.
  • Cuando se selecciona una impresora de red diferente en el cuadro de nombre de la impresora en el Asistente para agregar impresoras, puede un retraso antes de aplica el cambio. Este problema puede producirse incluso aunque las condiciones de la sección "Causa" no se aplican a la impresora de red que seleccione.

Causa

Este problema se produce debido a un error en la cola (spoolss.dll). El problema se produce cuando se cumplen las condiciones siguientes:
  • El tamaño de la estructura DEVMODE que se utiliza el controlador de impresora es mayor que 4096 bytes.
  • El nombre de la impresora tiene un número impar de caracteres. Por ejemplo, en el siguiente nombre de impresora de red, MyPrinterName contiene un número impar de caracteres (13):
    \\SMBPrinterServer\ MyPrinterName
    El problema no se produce si el nombre de la impresora tiene un número par de caracteres.

Solución

Información de paquete de servicio de Windows Server 2003

Para resolver este problema, obtenga el service pack más reciente para Windows Server 2003. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
889100Cómo obtener la versión más reciente del Service Pack para Windows Server 2003

Información sobre hotfix de Windows Server 2003

Requisitos previos

Para aplicar este hotfix, debe tener instalado en el equipo Windows Server 2003 Service Pack 1 (SP1).

Nota Windows Server 2003, versiones basadas en 64 x no requieren Windows Server 2003 SP1 aplicar esta revisión.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Windows Server 2003, versiones basadas en 64 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Spoolss.dll5.2.3790.2805167,93604-Oct-200617: 31x 64
Windows Server 2003, versiones basadas en Itanium
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Spoolss.dll5.2.3790.2805253,95204-Oct-200617: 32IA-64
Windows Server 2003, versiones basadas en 86 en x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Spoolss.dll5.2.3790.280587,55204-Oct-200617: 15x 86

Información sobre hotfix de Windows XP

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

No se necesita ningún requisito previo.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.
Información acerca de la sustitución de la revisión
Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Windows XP, versiones de 86 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Spoolss.dll5.1.2600.300874,75204-Oct-200617: 13x 86

Windows 2000

Para evitar este problema en Windows 2000, use un número par de caracteres para el nombre de la impresora.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:". Este problema se corrigió por primera vez en Windows Server 2003 Service Pack 2.

Más información

Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Soporte técnico para x 64 versiones de Microsoft Windows

El fabricante del hardware proporciona soporte técnico y asistencia para versiones basadas en 64 de Windows en x. El fabricante del hardware proporciona soporte técnico, porque incluyó una versión x 64 de Windows con el hardware. El fabricante de hardware podría haber personalizado la instalación de Windows con componentes únicos. Esos componentes exclusivos podrían incluir controladores de dispositivo específicos o configuraciones opcionales para maximizar el rendimiento del hardware. Si necesita ayuda técnica con su versión de x 64 de Windows, Microsoft ofrecerá asistencia de esfuerzo razonable. Sin embargo, es posible que deba contactar directamente con el fabricante. El fabricante es el mejor cualificado para proporcionar el soporte técnico del software que él mismo instaló en el hardware.

Para información de producto acerca de Microsoft Windows XP Professional x 64 Edition, visite el siguiente sitio Web de Microsoft:
http://www.microsoft.com/windowsxp/64bit/default.mspx
Para información de producto acerca de x 64 de Microsoft Windows Server 2003, visite el siguiente sitio Web de Microsoft:
http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx

Propiedades

Id. de artículo: 917777 - Última revisión: miércoles, 29 de agosto de 2007 - Versión: 3.4
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Palabras clave: 
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Haga clic aquí para ver el artículo original (en inglés): 917777

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