Erleben Sie blockieren, deadlock Bedingungen oder andere SQL Server-Probleme, wenn Sie versuchen, eine Verbindung mit der Datenbank BizTalkMsgBoxDb in BizTalk Server

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Problembeschreibung

In Microsoft BizTalk Server auftreten, blockieren, Bedingungen oder andere Probleme für Microsoft SQL Server einen deadlock, wenn Sie versuchen, eine Verbindung mit der Datenbank BizTalkMsgBoxDb.

Ursache

Dieses Problem kann auftreten, wenn eine oder mehrere der folgenden Bedingungen erfüllt sind:
  • Die Auto Create Statistics Option ist für die Datenbank BizTalkMsgBoxDb aktiviert.
  • Die Auto Update Statistics Option ist für die Datenbank BizTalkMsgBoxDb aktiviert.
  • Die max Degree of parallelism Option ist festgelegt auf einen anderen Wert als 1 auf dem Computer, auf dem SQL Server ausgeführt wird und, der als Host der Datenbank BizTalkMsgBoxDb.
  • Sie defragmentieren oder Neuerstellung eines Indexes in der Datenbank BizTalkMsgBoxDb, wenn BizTalk Server Daten verarbeitet.

Lösung

Um dieses Problem zu beheben, verwenden Sie eine der folgenden Methoden.

Methode 1: Deaktivieren Sie die Option Auto Create Statistics und Auto Update Statistics-option

Um dieses Problem zu beheben, deaktivieren Sie die Auto Create Statistics Option und die Auto Update Statistics Option in der BizTalkMsgBoxDb-Datenbank in SQL Server.

Methode 2: Legen Sie die Option max Degree of Parallelism auf 1

Um dieses Problem zu beheben, legen Sie die max Degree of parallelism Option 1 auf dem Computer, auf dem SQL Server ausgeführt wird.

Methode 3: Führen Sie keine Neuerstellung eines Indexes bei der Verarbeitung von Daten durch BizTalk Server

Um dieses Problem zu beheben, führen Sie nicht die bts_RebuildIndexes gespeicherte Prozedur oder eine beliebige SQL-Befehl, die einen Index in einer BizTalk Server-Datenbank, wiederherstellt Wenn BizTalk Server Daten verarbeitet.

Hinweis Defragmentieren einen Index in einer BizTalk Server-Datenbank wird nicht unterstützt.

Weitere Informationen

Die Bts_RebuildIndexes, gespeicherte Prozedur

Die einzige unterstützte Methode für eine Indexneuerstellung in der Datenbank BizTalkMsgBoxDb ist zum Ausführen der bts_RebuildIndexes gespeicherte Prozedur. In BizTalk Server 2006 und höheren Versionen können Sie Ausführen der dtasp_RebuildIndexes gespeicherte Prozedur in der Datenbank BizTalkDTADb Indizes neu zu erstellen.

Die meisten der BizTalk-Indizes sind GUID-basierten. Viele Tests haben gezeigt, dass, solange die Tabellen nicht gescannt werden, besser als identitätsbasierte Indizes für BizTalk-spezifische Arbeitslasten GUID-basierten Indizes durchführen können. Dies kann die Fragmentierung führen. Da Daten in einer der Tabellen in einer stetigen Tempo fließen, kann jedoch Fragmentierung keine Probleme führen. Wenn große Datenmengen wird erwartet, dass in der Datenbank BizTalkMsgBox ansammeln, können Sie in regelmäßigen Abständen während der geplanten Ausfallzeiten neu Indizes erstellen. Die gleichen Richtlinien gelten für die Überwachungsdatenbank.

Den DBCC DBREINDEX-SQL-Befehl können Sie einen Index in der BizTalk Server-Datenbanken neu erstellen. Ein Beispiel für die Verwendung von DBCC DBREINDEX SQL-Befehl, mit der rechten Maustaste die bts_RebuildIndexes gespeicherte Prozedur, und klicken Sie dann auf Eigenschaften.

HinweisMicrosoft unterstützt nur die Datenbankindizes neu erstellt werden, während der BizTalk Server-Ausfallzeiten. Sie sollten alle Instanzen von Host und SQL Server-Agent beenden, bevor Sie einen Index neu erstellen. Beim Ausführen derbts_RebuildIndexes gespeicherte Prozedur in BizTalk Server 2006 und späteren Versionen möglicherweise eine der folgenden Fehlermeldungen angezeigt:
Fehlermeldung 1
Msg 5239, Ebene 16, Status 1, Prozedur-Bts_RebuildIndexes, Zeile 4
Objekt-ID 674101442 ('Trackingdata'-Objekt) konnte nicht verarbeitet
Diese Art von Objekt unterstützt dieser Database Consistency Checker (DBCC)-Befehl nicht.
Fehlermeldung 2
Msg 5239, Ebene 16, Status 1, Prozedur-Bts_RebuildIndexes, Zeile 4 Objekt-ID 722101613 ('Trackingdata'-Objekt) zu verarbeiten, weil dieser DBCC-Befehl Objekte dieses Typs nicht unterstützt.

Dieses Problem tritt auf, weil dieTrackingDataObjekt ist eine Ansicht in BizTalk Server 2006 oder höher. Um dieses Problem zu beheben, führen Sie die folgenden Schritte aus, und führen Sie dann diebts_RebuildIndexes gespeicherte Prozedur:
  1. Kommentieren Sie die folgende Zeile in der bts_RebuildIndexes gespeicherte Prozedur.
    DBCC DBREINDEX ('[dbo].[TrackingData]') WITH NO_INFOMSGS
    
  2. Fügen Sie folgende Zeilen an die bts_RebuildIndexes gespeicherte Prozedur.
    DBCC DBREINDEX ('[dbo].[TrackingData_0_0]') WITH NO_INFOMSGS
    DBCC DBREINDEX ('[dbo].[TrackingData_0_1]') WITH NO_INFOMSGS
    DBCC DBREINDEX ('[dbo].[TrackingData_0_2]') WITH NO_INFOMSGS
    DBCC DBREINDEX ('[dbo].[TrackingData_0_3]') WITH NO_INFOMSGS
    DBCC DBREINDEX ('[dbo].[TrackingData_1_0]') WITH NO_INFOMSGS
    DBCC DBREINDEX ('[dbo].[TrackingData_1_1]') WITH NO_INFOMSGS
    DBCC DBREINDEX ('[dbo].[TrackingData_1_2]') WITH NO_INFOMSGS
    DBCC DBREINDEX ('[dbo].[TrackingData_1_3]') WITH NO_INFOMSGS
    

Eigenschaften

Artikel-ID: 917845 - Geändert am: Samstag, 28. Mai 2011 - Version: 2.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft BizTalk Server Branch 2010
  • Microsoft BizTalk Server Developer 2010
  • Microsoft BizTalk Server Enterprise 2010
  • Microsoft BizTalk Server Standard 2010
  • Microsoft BizTalk Server 2009 Branch
  • Microsoft BizTalk Server 2009 Developer
  • Microsoft BizTalk Server 2009 Enterprise
  • Microsoft BizTalk Server 2009 Standard
  • Microsoft BizTalk Server 2006 R2 Branch
  • Microsoft BizTalk Server 2006 R2 Developer Edition
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  • Microsoft BizTalk Server 2006 R2 Standard Edition
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 917845
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