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The MasSync service stops responding when a user tries to manually synchronize a Windows Mobile device with a Windows 2000-based computer that is running Exchange Server 2003 SP2

Article ID:917875
Last Review:October 30, 2007
Revision:1.3
Important This article contains information about editing the metabase. Before you edit the metabase, verify that you have a backup copy that you can restore if a problem occurs. For information about how to do this, see the "Configuration Backup/Restore" Help topic in Microsoft Management Console (MMC).

SYMPTOMS

When a user tries to manually synchronize a Microsoft Windows Mobile device with a Microsoft Windows 2000 Server-based computer that is running Microsoft Exchange Server 2003 Service Pack 2 (SP2), the MasSync service stops responding. When this behavior occurs, other users cannot synchronize their mobile devices until the World Wide Web Publishing service is restarted.

This problem occurs when the Direct Push feature is turned on in Exchange Server 2003.

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CAUSE

This problem occurs if the value of the CacheISAPI metabase property is set to 0. This property is in the Microsoft-Server-ActiveSync folder in the Microsoft Internet Information Services (IIS) 5.0 metabase. In the scenario that is described in the "Symptoms" section, a conflict occurs between Direct Push and manual synchronization.

Note The default value for the CacheISAPI metabase property is 1.

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RESOLUTION

To resolve this issue, set the CacheISAPI metabase property to 1. To do this, follow these steps.

Warning If you edit the metabase incorrectly, you can cause serious problems that may require you to reinstall any product that uses the metabase. Microsoft cannot guarantee that problems that result if you incorrectly edit the metabase can be solved. Edit the metabase at your own risk.

Note Always back up the metabase before you edit it.
1.Click Start, click Run, type cmd, and then click OK.
2.Move to the Drive_letter:\Inetpub\Adminscripts folder. In this folder path, Drive_letter is the drive in which you installed Windows 2000.
3.Type the following command, and then press ENTER:
cscript.exe adsutil.vbs set w3svc/1/root/Microsoft-Server-ActiveSync/cacheisapi 1
4.Close the Command Prompt window.
5.Click Start, click Run, type Services.msc, and then click OK.
6.Right-click World Wide Web Publishing Service, and then click Restart.

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MORE INFORMATION

This issue occurs when the following conditions are true:
Direct Push is turned on.
Device users manually synchronize their devices.
When a Direct Push notification message is sent to a device, the device initiates the Direct Push sync as expected. However, after the Direct Push sync is completed, the MasSync service stops responding if the user tries to manually synchronize the same device. When this behavior occurs, all users cannot synchronize their devices until the IIS service is restarted. When Direct Push is turned off, users can manually synchronize their devices as expected. When Direct Push is turned on, users can use a method other than manual synchronization to successfully synchronize their devices.

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REFERENCES

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
312883 (http://support.microsoft.com/kb/312883/) You cannot change the "Cache ISAPI Applications" property

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APPLIES TO
Microsoft Exchange Server 2003 Service Pack 2, when used with:
  Microsoft Windows 2000 Service Pack 4

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Keywords: 
kbtshoot kbprb KB917875

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