รายการอีเมล์ทั้งหมดอาจหายไปเมื่อคุณเริ่ม Outlook Express 6.0 Service Pack 1 หรือ Outlook Express 6.0 Service Pack 2

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 918069 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

เมื่อคุณเริ่ม Microsoft Outlook Express 6.0 Service Pack 1 (SP1) หรือคุณเริ่ม Microsoft Outlook Express 6.0 Service Pack 2 (SP2), รายการอีเมล์ทั้งหมดอาจหายไป

สาเหตุ

ปัญหานี้อาจเกิดขึ้นหากแฟ้มฐานข้อมูล (.dbx) จดหมายและที่ติดต่อเสียหายเมื่อมีการกระชับแฟ้ม.dbx

หมายเหตุ:มีการรายงานความเสียหายของแฟ้ม.dbx จะเกิดขึ้นบ่อยครั้งเมื่อมีเงื่อนไขใด ๆ ต่อไปนี้อย่างน้อยหนึ่งเป็นจริง:
  • ปิด outlook Express ในขณะที่กำลังมีการกระชับแฟ้ม.dbx
  • กระบวนการกระชับจะหยุดการทำงาน
  • คุณมักจะปล่อย Outlook Express รันสำหรับช่วงเวลาที่ยาว โดยไม่มีการปิดไว้ ตัวอย่างเช่น คุณมักจะเริ่ม Outlook Express ในเช้า ออกแล้ว คุณไม่จาก Outlook Express จนกว่าคุณปิดเครื่องคอมพิวเตอร์ในที่เย็น
  • แฟ้ม.dbx มีขนาดใหญ่มาก ตัวอย่างเช่น แฟ้ม.dbx มีขนาดใหญ่กว่า 1 กิกะไบต์ (GB)

การแก้ไข

ข้อมูลการปรับปรุง

เมื่อต้องการแก้ไขปัญหานี้ ติดตั้งการปรับปรุงการรักษาความปลอดภัย MS06-076 การปรับปรุงการรักษาความปลอดภัยนี้จะรวมอยู่ในบทความฐานความรู้ของ Microsoft ต่อไปนี้:
923694ms06-076: การปรับปรุงการรักษาความปลอดภัยที่สะสมสำหรับ Outlook Express
นอกจากนี้ การแก้ไขปัญหานี้ ต่อไปนี้แฟ้มดังกล่าวสามารถดาวน์โหลดได้จากศูนย์ดาวน์โหลดของไมโครซอฟท์:

ยุบรูปภาพนี้ขยายรูปภาพนี้
ดาวน์โหลด
ดาวน์โหลดแพคเกจ KB918766วันวางจำหน่าย: 20 เมษายน 2006

หากต้องการทราบข้อมูลเพิ่มเติมเกี่ยวกับการดาวน์โหลดไฟล์การสนับสนุนของไมโครซอฟท์ โปรดคลิกที่หมายเลขบทความต่อไปนี้เพื่อดูบทความใน Microsoft Knowledge Base::
119591วิธีรับแฟ้มการสนับสนุนของไมโครซอฟท์จากบริการออนไลน์
Microsoft สแกนแฟ้มนี้เพื่อหาไวรัส Microsoft ใช้ซอฟต์แวร์ตรวจสอบไวรัสล่าสุด ณ วันที่มีการประกาศแฟ้มนั้นๆ แฟ้มดังกล่าวจะถูกจัดเก็บในเซิร์ฟเวอร์เพิ่มการรักษาความปลอดภัย ซึ่งช่วยป้องกันการเปลี่ยนแปลงแฟ้มโดยไม่ได้รับอนุญาต

ข้อมูลแฟ้ม

การปรับปรุงที่เป็นภาษาอังกฤษมีแอตทริบิวต์แฟ้ม (หรือแอตทริบิวต์แฟ้มหลังจากนั้น) ที่อยู่ในตารางต่อไปนี้ วันที่และเวลาของแฟ้มเหล่านี้จะปรากฏในรูปแบบเวลามาตรฐานสากล (UTC) เมื่อคุณดูข้อมูลแฟ้ม ข้อมูลจะถูกแปลงเป็นเวลาท้องถิ่น เมื่อต้องการค้นหาความแตกต่างระหว่างเวลา UTC กับเวลาท้องถิ่น ใช้โซนเวลาแท็บในรายการวันและเวลาใน'แผงควบคุม'
ยุบตารางนี้ขยายตารางนี้
ชื่อแฟ้มรุ่นของแฟ้มขนาดแฟ้มวันที่เวลาแพลทฟอร์มความต้องการเซอร์วิสแพ็ค
Directdb.dll6.0.2900.289281,92020 2006 Apr14:23x86SP2
Msoe.dll6.0.2900.28921,311,74420 2006 Apr14:23x86SP2

หลังจากที่คุณติดตั้งโปรแกรมปรับปรุงนี้ สำเนาสำรองของแฟ้ม.dbx ถูกสร้างขึ้นทุกครั้งที่มีกระชับฐานข้อมูล หลังจากฐานข้อมูลเสร็จเรียบร้อยแล้ว กำลังกระชับสำเนาสำรองของแฟ้ม.dbx ถูกย้ายไปยังถังรีไซเคิล

หากโฟลเดอร์จดหมายเสียหายในขณะที่กำลังมีการกระชับฐานข้อมูลหลังจากที่คุณติดตั้งโปรแกรมปรับปรุงนี้ ทำตามขั้นตอนเหล่านี้เพื่อคืนค่าโฟลเดอร์

หมายเหตุ:การปรับปรุงนี้ไม่มีผลกับแฟ้มที่เสียหายก่อนที่คุณติดตั้งการปรับปรุง Follow these steps to resolve corruption issues that occur after you install the update.
  1. Exit Outlook Express.
  2. On the desktop, double-click theถังรีไซเคิลไอคอน
  3. Locate the backup file. The file should have a name that resemblesmail_folder_name.bak.

    หมายเหตุ:ในชื่อแฟ้มนี้mail_folder_namecorresponds to the mail folder that is missing in Outlook Express. If more than one file is corrupted, you may have to restore more than one file. When this occurs, the Recycle Bin contains more than onemail_folder_name.bak file.
  4. Right-click each Outlook Express backup file, and then clickคืนค่า. The file is restored to theโปรไฟล์ผู้ใช้%%\local settings\application data\identities\user guid\microsoft\outlook express\ folder.

    หมายเหตุ
    • ในเส้นทางนี้โปรไฟล์ผู้ใช้%%is typically C:\Documents and Settings\user_name.
    • ในเส้นทางนี้user guidresembles {05A26C0D-1173-4013-84A0-EAC2A1FE40F6}.
    • If more than one identity profile is used with Outlook Express, there may be more than oneuser guid. Each uniqueuser guidcorresponds to a separate profile.
  5. ค้นหานี้โปรไฟล์ผู้ใช้%%\local settings\application data\identities\user guid\microsoft\outlook express\ folder.

    หมายเหตุ:This path contains hidden folders. If you want to view this folder, enable theแสดงแฟ้มที่ซ่อนไว้และโฟลเดอร์option in Folder Options.

    If the %userprofile%\local settings\application data\identities\user guid\microsoft\outlook express\ folder contains amail_folder_name.dbx file that is the same as the file that you want to restore, move the existingmail_folder_name.dbx file to a different folder. You can delete this file after you successfully restore your e-mail items.
  6. คลิกขวาmail_folder_name.bakแล้ว คลิกเปลี่ยนชื่อ.
  7. Change the .bak file name extension to.dbx.
  8. เปิด Outlook Express Your e-mail items should be restored.
If e-mail is missing from more than one folder, you may have to follow these steps for multiple backup files. If Outlook Express does not start, you may have to follow these steps to restore the Folders.dbx file. You can delete the .bak files from the Recycle Bin when you are sure that the database was successfully compacted.

How to compact mail folders manually

After you install this update, the counter in Outlook Express is reset when you compact your mail folders manually. Mail folders will not be compacted automatically until Outlook Express has been closed 100 times. If you have many e-mail items, regularly compact the database manually to help prevent data loss.

To compact mail folders manually, use one of the following methods:
  • ในการแฟ้ม:เมนู ให้ชี้ไปที่โฟลเดอร์แล้ว คลิกกระชับหรือCompact All Folders.
  • ในการเครื่องมือเมนู คลิกตัวเลือก. คลิกการการบำรุงรักษาแท็บ คลิกClean Up Nowแล้ว คลิกกระชับ.

สถานะ

Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน "การใช้งาน"

ข้อมูลเพิ่มเติม

สำหรับข้อมูลเพิ่มเติม ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
824684คำอธิบายของคำศัพท์มาตรฐานที่ใช้เพื่ออธิบายปรับปรุงซอฟต์แวร์ของ Microsoft

คุณสมบัติ

หมายเลขบทความ (Article ID): 918069 - รีวิวครั้งสุดท้าย: 21 กันยายน 2554 - Revision: 3.0
ใช้กับ
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Keywords: 
atdownload kbexpertisebeginner kbwinxppresp3fix kbbug kbfix kbqfe kbmt KB918069 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:918069

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com