Fehlermeldung beim Versuch, die Onlineverbindung eines Laptopclients zu beenden, der Microsoft Dynamics CRM 3.0 ausführt: Fehler beim Verschieben von Daten für Entität

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Der Hotfix, der in diesem Artikel behandelt wird, ist für die chinesische Version von Microsoft Dynamics CRM und für die japanische Version von Microsoft Dynamics CRM nicht verfügbar.
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Problembeschreibung

Sie versuchen vergeblich, die Onlineverbindung eines Laptopclients zu beenden, der Microsoft Dynamics CRM 3.0 ausführt. Sie erhalten dabei folgende Fehlermeldung:
Fehler beim Verschieben von Daten für Entität 'Name der Entität' während der Aktion saInsert, countRows=1. Wenden Sie sich an den Systemadministrator, um Unterstützung zu erhalten, und gehen Sie wieder offline.
Außerdem wird im Anwendungsprotokoll des Laptopclients folgende Fehlermeldung protokolliert:

Ereignistyp: Fehler
Ereignisquelle: MSCRMOfflineSync
Ereigniskategorie: Keine
Ereignis-ID: 6000
Datum: Datum
Uhrzeit: Uhrzeit
Benutzer: Benutzername
Computer: Computername

Beschreibung:

Während der Offlinesynchronisierung ist ein Fehler aufgetreten. Versuchen Sie noch einmal, die Onlineverbindung zu beenden, oder starten Sie Microsoft Outlook neu. Aktion "saInsert" fehlgeschlagen für Entität 'Account', batchRows=0 mit Ausnahme von System.Data.SqlClient.SqlException: Fehler bei Masseneinfügung. Die Spalte in der Datendatei ist zu lang für Zeile 1, Spalte 71. Stellen Sie sicher, dass das Feldabschlusszeichen und das Zeilenabschlusszeichen richtig angegeben sind.

Der OLE DB-Provider 'STREAM' meldete einen Fehler. Der Provider hat keine Informationen zum dem Fehler bereitgestellt.
OLE DB-Fehlertrace [OLE/DB Provider 'STREAM' IRowset::GetNextRows returned 0x80004005: Der Provider hat keine Informationen zum dem Fehler bereitgestellt.].
Die Anweisung wurde beendet.
at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
at Microsoft.Crm.Application.Outlook.OfflineSync.Utility.ExecuteSql(String strCommand, CrmDbConnection dbConnection)
at Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.PopulateTempTable(String tempTableName, String fileName, CrmDbConnection dbConnection, Int32 count, String formatFile)
at Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.DoInsertTable(EntityMetadata entity, String fileName, Int32 count, Boolean extension, String attributes)
at Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.DoInsert(EntityMetadata entity, String fileName, Int32 count)
at Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.ExecuteInsert(String entityName, Int32 count)
at Microsoft.Crm.Application.Outlook.OfflineSync.SyncData.DoBatchStep(ITransferDataProvider transferDataProvider, String entityName, SyncAction action, Int32 batchRows).

Ursache

Das Problem kann auftreten, wenn folgende Bedingungen erfüllt sind:
  • Sie haben dem Hauptformular einer Entität ein benutzerdefiniertes Attributfeld hinzugefügt, das den NTEXT-Typ verwendet.
  • Das benutzerdefinierte Attributfeld eines verbundenen Datensatzes enthält mehr als 4.000 Zeichen.

Lösung

Gehen Sie wie folgt vor, um dieses Problem zu lösen:
  1. Installieren Sie den Hotfix, der in diesem Artikel beschrieben wird.
  2. Installieren Sie den Microsoft SQL Server-Hotfix, der in folgendem KB-Artikel beschrieben wird:
    923327 HOTFIX: Zugriffsverletzungs-Fehlermeldung beim Importieren von Daten mithilfe des Masseneinfügungsbefehls in SQL Server 2000
    Hinweise
    • Installieren Sie den Hotfix, der in diesem Artikel beschrieben ist, auf jeder Client-Arbeitsstation unter dem Computernamen\der CRM-Instanz von SQL Server.
    • Der Hotfix deckt einen Programmfehler im Masseneinfügungsprozess von Microsoft SQL Server auf. Der Programmfehler muss zeitgleich mit der Installation des Hotfix behandelt werden.
  3. Löschen Sie nach der Installation dieser beiden Hotfixes den Inhalt der folgenden Ordner. Melden Sie sich anschließend ab:
    C:\Dokumente und Einstellungen\<Benutzer des CRM-Laptopclient>\Anwendungsdaten\Microsoft\MSCRM\BCP\FMT\
Hinweis: <Benutzer des CRM-Laptopclient> ist der Platzhalter für den Benutzer des CRM-Laptopclient.

Informationen zum Hotfix

Microsoft bietet nun einen unterstützten Hotfix an. Dieser behebt allerdings nur das Problem, das in diesem Artikel beschrieben wird. Wenden Sie den Hotfix nur auf Systeme an, bei denen dieses Problem genau mit den beschriebenen Symptomen auftritt. Es kann sein, dass der Hotfix noch weiteren Tests unterzogen wird. Wenn das Problem keine schwerwiegenden Auswirkungen nach sich zieht, warten Sie am besten, bis das nächste Service Pack zu Microsoft Dynamics CRM 3.0 erscheint. Der Hotfix ist darin enthalten.

Wenn das Problem sofort behoben werden muss, fordern Sie beim Kundensupport von Microsoft den Hotfix an. Eine vollständige Liste aller Telefonnummern des Microsoft-Produktsupports sowie Informationen über Supportkosten erhalten Sie auf folgender Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support/de
Hinweis: Normalerweise werden für Supportanfragen Gebühren erhoben. In Einzelfällen können die Gebühren entfallen, wenn ein Microsoft-Supportmitarbeiter feststellt, dass ein bestimmtes Update Ihr Problem behebt. Für zusätzliche Supportfragen und Probleme, die nicht mit dem spezifischen Problem in Zusammenhang stehen, werden die normalen Supportkosten in Rechnung gestellt.

Informationen zur Datei

Die englische Version dieses Hotfix verfügt jetzt oder auch erst später über die in der folgenden Tabelle aufgeführten Dateiattribute. Datum und Uhrzeit dieser Dateien sind in UTC (Coordinated Universal Time) angegeben. Bei der Anzeige der Dateiinformationen werden die Zeitangaben in die Ortszeit umgerechnet. Die Zeitverschiebung zwischen UTC und der Ortszeit ist in der Systemsteuerung unter Datum und Uhrzeit auf der Registerkarte Zeitzone angegeben.

Microsoft Dynamics CRM 3.0 Professional Edition für Dienstanbieter ? Client für Microsoft Office Outlook

Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeit
Microsoft.crm.application.outlook.offlinesync.dll3.0.5745.103083.30419.01.200711:06

Microsoft Dynamics CRM 3.0-Client für Microsoft Office Outlook

Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeit
Microsoft.crm.application.outlook.offlinesync.dll3.0.5300.127880.76028.08.200613:42

Informationen zur Installation

Installieren Sie diesen Hotfix auf den Laptopclients, auf denen die Clientkomponenten von Microsoft Dynamics CRM 3.0 oder von Microsoft Dynamics CRM 3.0 Professional Edition für Dienstanbieter ausgeführt wird.

Systemvoraussetzungen

Für diesen Hotfix sind keine besonderen Systemvoraussetzungen zu beachten.

Informationen zur Deinstallation

Um diesen Hotfix von einem Computer zu entfernen, auf dem Microsoft Windows 2000, Microsoft Windows XP oder Microsoft Windows Server 2003 ausgeführt wird, klicken Sie in der Systemsteuerung auf Software.

Systemadministratoren können das Dienstprogramm Spuninst.exe verwenden, wenn sie diesen Hotfix von einem Computer entfernen möchten, auf dem Microsoft Windows 2000, Windows XP oder Windows Server 2003 ausgeführt wird. Das Dienstprogramm Spuninst.exe ist unter folgendem Ordner abgelegt:
%Windir%\$NTUninstallKB918108$\Spuninst
Informationen zu den Paketinstallationsparametern erhalten Sie, indem Sie auf die folgende Artikelnummer klicken. Der Artikel der Microsoft Knowledge Base wird angezeigt.
832475 Beschreibung der neuen Funktionen in dem Paketinstallationsprogramm für Windows-Softwareupdates

Aufforderung zum Computerneustart

Wenn Sie den Hotfix installiert haben, starten Sie den Computer bei Aufforderung neu.

Status

Das Problem wurde im Updaterollup 1 zu Microsoft Dynamics CRM 3.0 behoben. Für die Dienstanbieter-Professional Edition von Microsoft Dynamics CRM 3.0 ist allerdings noch kein Updaterollup 1 für Microsoft Dynamics CRM 3.0 verfügbar. Wenn Sie mit Microsoft Dynamics CRM 3.0 Professional Edition für Dienstanbieter arbeiten, müssen Sie deshalb diesen Hotfix installieren.

Weitere Informationen erhalten Sie, indem Sie auf die folgende Artikelnummer klicken. Der Artikel der Microsoft Knowledge Base wird angezeigt:
922815 Updaterollup 1 für Microsoft Dynamics CRM 3.0 ist verfügbar

Weitere Informationen

Tritt das Problem, das unter "Problembeschreibung" vorgestellt wird, nach der Installation des Hotfix weiterhin auf, klicken Sie auf die folgende Artikelnummer. Der Artikel der Microsoft Knowledge Base wird angezeigt.
916165 Fehlermeldung beim Versuch, die Onlineverbindung zum Outlook-Laptopclient von Microsoft Dynamics CRM zu beenden: "Fehler beim Verschieben von Daten für Entität <Name> während der Aktion "saInsert", countRows=<Anzahl Zeilen>. Wenden Sie sich an den Systemadministrator"

Informationsquellen

Weitere Informationen zur Terminologie, mit der Microsoft-Softwareupdates beschrieben werden, erhalten Sie, indem Sie auf die folgende Artikelnummer klicken. Der Artikel der Microsoft Knowledge Base wird angezeigt:
824684 Erläuterung von Standardbegriffen bei Microsoft Software Updates
887283 Benennungskonventionen für Softwarehotfixes und Updatepakete zu Microsoft Business Solutions CRM

Eigenschaften

Artikel-ID: 918108 - Geändert am: Mittwoch, 13. Juni 2007 - Version: 7.3
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers
  • Microsoft Dynamics CRM 3.0
  • Microsoft CRM client for Microsoft Office Outlook, wenn verwendet mit:
    • Microsoft Dynamics CRM 3.0
Keywords: 
kbcrmv3cno kberrmsg kbbug kbmbscustomization kbhotfixserver kbqfe kbmbsmigrate kbpubtypekc KB918108
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