Ошибка при попытке перехода в автономный режим на переносном ПК с Microsoft Dynamics CRM: «Ошибка при перемещении данных для объекта»

Переводы статьи Переводы статьи
Код статьи: 918108 - Vizualiza?i produsele pentru care se aplic? acest articol.
Исправление, описываемое в этой статье, недоступно для китайской и японской версий Microsoft Dynamics CRM.
Развернуть все | Свернуть все

В этой статье

Проблема

При попытке перехода в автономный режим на переносном ПК с Microsoft Dynamics CRM 3.0 это не удается сделать успешно. Появляется следующее сообщение об ошибке:
Ошибка при перемещении данных для объекта «имя_объекта» при действии salnsert, число строк = 1. Обратитесь к системному администратору за помощью и попытайтесь снова перейти в автономный режим.
Кроме того, следующее сообщение об ошибке записывается в журнал приложения на клиентском переносном ПК:

Тип события: Ошибка
Источник события: MSCRMOfflineSync
Категория события: нет
Код события: 6000
Дата: дата
Время: время
Пользователь имя_пользователя
Компьютер: имя_компьютера

Описание:

Произошла ошибка при синхронизации автономных данных. Попробуйте снова перейти в автономный режим или перезапустить Microsoft Outlook. Ошибка saInsert для объекта «Account», batchRows=0 с исключением System.Data.SqlClient.SqlException: Bulk Insert fails. Column is too long in the data file for row 1, column 71. Make sure the field terminator and row terminator are specified correctly.

OLE DB provider 'STREAM' reported an error. The provider did not give any information about the error.
OLE DB error trace [OLE/DB Provider 'STREAM' IRowset::GetNextRows returned 0x80004005: The provider did not give any information about the error.].
The statement has been terminated.
at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
at Microsoft.Crm.Application.Outlook.OfflineSync.Utility.ExecuteSql(String strCommand, CrmDbConnection dbConnection)
at Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.PopulateTempTable(String tempTableName, String fileName, CrmDbConnection dbConnection, Int32 count, String formatFile)
at Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.DoInsertTable(EntityMetadata entity, String fileName, Int32 count, Boolean extension, String attributes)
at Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.DoInsert(EntityMetadata entity, String fileName, Int32 count)
at Microsoft.Crm.Application.Outlook.OfflineSync.BcpTransferDataProvider.ExecuteInsert(String entityName, Int32 count)
at Microsoft.Crm.Application.Outlook.OfflineSync.SyncData.DoBatchStep(ITransferDataProvider transferDataProvider, String entityName, SyncAction action, Int32 batchRows).

Причина

Эта проблема возникает при следующих условиях:
  • В главную форму объекта было добавлено настраиваемое поле атрибута типа NTEXT.
  • Поле настраиваемого атрибута в связанной записи содержит более 4000 знаков.

Решение

Чтобы устранить эту проблему, выполните следующие действия.
  1. Установите исправление, описываемое в данной статье.
  2. Установите исправление Microsoft SQL Server, описанное в следующей статье базы знаний:
    923327 ИСПРАВЛЕНИЕ: При импорте данных при помощи команды «Bulk Insert» в SQL Server 2000 может возникнуть сообщение об ошибке нарушения доступа
    Примечания
    • Установите исправление, описанное в этой статье, на каждый клиентский компьютер в экземпляр SQL Server MachineName\CRM.
    • Исправление для Microsoft SQL Server устраняет ошибку в процессе массовой вставки. Эта ошибка должна быть устранена одновременно с установкой исправления.
  3. После установки этих двух исправлений удалите содержимое следующей папки перед выходом из системы:
    C:\Documents and Settings\<имя пользователя переносного ПК с клиентом CRM>\Application Data\Microsoft\MSCRM\BCP\FMT\
Примечание. Замещающий текст <имя пользователя переносного ПК с клиентом CRM> означает текущего пользователя.

Сведения об исправлении

Корпорация Майкрософт выпустила поддерживаемое исправление, которое, однако, предназначено исключительно для устранения проблемы, описываемой в данной статье. Оно должно применяться только в системах, где наблюдается описанная выше проблема. Данное исправление находится на стадии дополнительного тестирования. По этой причине рекомендуется во всех случаях, когда проблема не представляет особой важности, отложить ее решение до выхода ближайшего пакета обновления для Microsoft Dynamics CRM 3.0, в который это исправление будет включено.

Чтобы получить исправление и немедленно устранить данную проблему, свяжитесь со службой технической поддержки Microsoft. Полный список телефонов службы поддержки Майкрософт, а также сведения о стоимости обслуживания см. на веб-узле Майкрософт по адресу:
http://support.microsoft.com/contactus/?ws=support
Примечание. В отдельных случаях, если специалистом службы технической поддержки Microsoft будет определено, что ваша проблема может быть решена путем установки данного обновления, оплата, предусмотренная за обращение в службу технической поддержки, может не взиматься. Рассмотрение службой технической поддержки дополнительных вопросов и проблем, не связанных с рассматриваемым здесь обновлением, оплачивается по обычным тарифам.

Сведения о файле

Английская версия данного исправления содержит атрибуты файла (или последние атрибуты файла), которые перечислены в представленной ниже таблице. Дата и время создания этих файлов представлены в формате единого всемирного времени. При просмотре сведений о файле эти значения преобразуются в местное время. Чтобы определить разницу между временем UTC и местным временем, откройте на панели управления в разделе "Дата и время" вкладку Часовой пояс.

Клиент Microsoft Dynamics CRM 3.0 Professional Edition для поставщиков услуг для Microsoft Office Outlook

Свернуть эту таблицуРазвернуть эту таблицу
Имя файлаВерсия файлаРазмер файлаДатаВремя
Microsoft.crm.application.outlook.offlinesync.dll3.0.5745.103083,30419.01.0711:06

Клиент Microsoft Dynamics CRM 3.0 для Microsoft Office Outlook

Свернуть эту таблицуРазвернуть эту таблицу
Имя файлаВерсия файлаРазмер файлаДатаВремя
Microsoft.crm.application.outlook.offlinesync.dll3.0.5300.127880,76028.08.0613:42

Сведения об установке

Установите это исправление на переносные ПК, на которых установлены клиенты Microsoft Dynamics CRM 3.0 или Microsoft Dynamics CRM 3.0 Professional Edition для поставщиков услуг.

Предварительные условия

Применение данного исправления производится без предварительных условий.

Сведения об удалении

Для удаления этого исправления с компьютеров под управлением Microsoft Windows 2000, Microsoft Windows XP или Microsoft Windows Server 2003 используйте элемент панели управления «Установка и удаление программ».

Для удаления этого исправления с компьютеров под управлением Microsoft Windows 2000, Microsoft Windows XP или Microsoft Windows Server 2003 системные администраторы могут использовать программу Spuninst.exe, которая находится в следующей папке:
%Windir%\$NTUninstallKB918108$\Spuninst
Чтобы получить дополнительные сведения о параметрах пакета установки, щелкните следующий номер статьи в базе знаний Майкрософт:
832475 Описание новых возможностей установочного пакета обновлений программного обеспечения Windows

Требование перезагрузки

Если появится запрос на перезагрузку компьютера, перезагрузите компьютер после установки исправления.

Статус

Эта проблема была устранена в накопительном пакете обновления 1 для Microsoft Dynamics CRM 3.0. Однако накопительный пакет обновления 1 еще недоступен для Microsoft Dynamics CRM 3.0 Professional Edition для поставщиков услуг. Поэтому следует установить это исправление, если используется Microsoft Dynamics CRM 3.0 Professional Edition для поставщиков услуг.

Чтобы получить дополнительные сведения, щелкните следующий номер статьи в базе знаний Майкрософт:
922815 Выпущен накопительный пакет обновления 1 для Microsoft Dynamics CRM 3.0

Дополнительная информация

Если после установки исправления ошибка, описанная в разделе «Проблема», по-прежнему возникает, см. следующую статью базы знаний Майкрософт:
916165 При переходе в автономный режим на клиенте Microsoft Dynamics CRM для переносных ПК для Outlook появляется сообщение: «Ошибка перемещения данных для объекта <имя_объекта> при действии saInsert, число строк = <число_строк>. Обратитесь к системному администратору».

Ссылки

Дополнительные сведения о терминах, используемых при описании обновлений программных продуктов Майкрософт, см. в следующей статье базы знаний Майкрософт:
824684 Стандартные термины, используемые при описании обновлений программных продуктов Майкрософт
887283 Стандарты наименования программных исправлений и обновлений Microsoft Business Solutions CRM

Свойства

Код статьи: 918108 - Последний отзыв: 14 июня 2007 г. - Revision: 7.3
Информация в данной статье относится к следующим продуктам.
  • Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers
  • Microsoft Dynamics CRM 3.0
  • Microsoft CRM client for Microsoft Office Outlook на следующих платформах
    • Microsoft Dynamics CRM 3.0
Ключевые слова: 
kbcrmv3cno kberrmsg kbbug kbmbscustomization kbhotfixserver kbqfe kbmbsmigrate kbpubtypekc KB918108

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com