Article ID: 918176 - Last Review: October 9, 2011 - Revision: 2.0

You receive duplicate alerts after you click to select the "Suppress duplicate alerts" check box and then commit configuration changes in Microsoft Operations Manager 2005

Hotfix download is availableHotfix Download Available
View and request hotfix downloads
System TipThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.

On This Page

Expand all | Collapse all

SYMPTOMS

Consider the following scenario:
  • You use a managed code application to programmatically monitor one or more computers that are not running Windows-based operating systems.
  • This application runs a script to generate events.
  • You create an event rule to generate an alert in Microsoft Operations Manager (MOM) 2005.
  • The Enable state alert properties check box on the Alert tab of the Event Rule Properties dialog box is selected.
In this scenario, after you click to select the Suppress duplicate alerts check box in the Event Rule Properties dialog box, every time that you commit configuration changes in MOM 2005, you experience duplicate alerts.

Note You click to select the Enable state alert properties check box to let you use the MOM 2005 Operator console to determine which computer generated the alert.

CAUSE

This problem occurs because the computer records on the computers that are not running Windows-based operating systems are removed from the MOM 2005 database. These records are removed when the following stored procedure is called:
dbo.P_DiscoveryDataGrooming

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have MOM 2005 Service Pack 1 (SP1) installed to apply this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Eula.rtfNot applicable9,22302-Nov-200523:18Not applicable
Momrunscript.exe5.0.2911.0124,92823-Feb-200621:25x86
Q918176.sqlNot applicable55,82221-Apr-200615:28Not applicable
Relnote.htmNot applicable7,42421-Apr-200615:38Not applicable

WORKAROUND

To work around this problem, click to clear the Enable state alert properties check box on the Alert tab of the Event Rule Properties dialog box.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Operations Manager (MOM) 2005
Keywords: 
kbautohotfix kbbug kbfix kbhotfixserver kbqfe KB918176