Artigo: 918283 - Última revisão: terça-feira, 30 de Outubro de 2007 - Revisão: 2.3

O desempenho do servidor deteriorates ao longo do tempo depois de activar o Sender ID Filtering no Exchange Server 2003 Service Pack 2

Está disponível transferência de hotfixDisponível transferência de hotfix
Ver e solicitar transferências de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Depois de activar o Sender ID Filtering num servidor com o Microsoft Exchange Server 2003 Service Pack 2 (SP2), o desempenho do servidor do Exchange deteriorates ao longo do tempo. Se executar o seguinte comando numa linha de comandos, pode Repare que existem várias ligações à porta SMTP num estado de CLOSE_WAIT:
netstat ? ano
Além disso, detectar os seguintes sintomas:
  • Computadores cliente não é possível efectuar quaisquer novas ligações de SMTP para o servidor do Exchange.
  • Não reinicie o serviço publicação de World Wide Web. Terá de eliminar e, em seguida, reiniciar o processo inetinfo.exe executando o seguinte comando:
    iisreset /restart
Nota Para activar o Sender ID Filtering, tem de configurar opções no separador Geral da caixa de diálogo de propriedades de objecto entrega de mensagens no Exchange System Manager. Além disso, tem de clicar em para seleccionar a caixa de verificação Aplicar filtro de ID de remetente na área de endereço IP da caixa de diálogo de propriedades do Servidor Virtual de SMTP predefinido .

Causa

Este problema ocorre devido a uma acumulação de threads do processo que estão bloqueadas em operações de filtragem. Os threads do processo bloqueado aguardar indefinidamente para concluir a validar o remetente como parte do processo de validação ID de remetente.

Resolução

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Tem de instalar o Exchange Server 2003 Service Pack 2 (SP2) antes de aplicar a correcção. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
836993  (http://support.microsoft.com/kb/836993/ ) Como obter os service packs mais recentes para o Exchange Server 2003

Requisito de reinício

Não é necessário reiniciar o computador depois de aplicar a correcção.

Informações sobre substituição de correcções

Esta correcção não substitui quaisquer outras correcções.

Informações do ficheiro

A versão global desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item data e hora no painel de controlo.
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
Msgfilter.dll6.5.7651.19205,82422-Abr-200603: 45x 86

Como contornar

Para contornar este problema, pode libertar threads do processo bloqueado no processo de filtragem. Para efectuar este procedimento, reiniciar os serviços de informações Internet (IIS). Poderá ter de reiniciar o IIS uma vez por mês. Se não conseguir reiniciar o serviço de publicação na World Wide Web a partir do snap-in Serviços, poderá ter de eliminar o processo inetinfo.exe e, em seguida, reiniciá-lo. Para efectuar este procedimento, execute o seguinte comando numa linha de comandos:
iisreset /restart

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

Para obter mais informações sobre a terminologia utilizada para descrever actualizações de software da Microsoft, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft
Para obter mais informações sobre o esquema de atribuição de nomes para actualizações de software do Exchange Server, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
817903  (http://support.microsoft.com/kb/817903/ ) Novo esquema de atribuição de nomes de ficheiros para pacotes de actualização de software do Exchange Server

A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 2003 Service Pack 2
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbfix kbbug kbpubtypekc KB918283 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 918283  (http://support.microsoft.com/kb/918283/en-us/ )