ID do artigo: 918283 - Última revisão: terça-feira, 30 de outubro de 2007 - Revisão: 2.3

Diminui o desempenho do servidor com o tempo após ativar o Sender ID Filtering no Exchange Server 2003 Service Pack 2

Download do hotfix está disponívelDownload do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Depois de habilitar o Sender ID Filtering em um servidor que está executando o Microsoft Exchange Server 2003 Service Pack 2 (SP2), o desempenho do servidor do Exchange cai longo do tempo. Se você executar o seguinte comando em um prompt de comando, você pode observar que há muitas conexões à porta SMTP em um estado de ENCERRADO_ESPERA:
netstat ?ano
Além disso, você os seguintes sintomas:
  • Computadores cliente não podem fazer novas conexões SMTP para o servidor do Exchange.
  • Não é possível reiniciar o serviço de publicação World Wide Web. Você precisa eliminar e, em seguida, reiniciar o processo inetinfo.exe, executando o comando a seguir:
    iisreset /restart
Observação Para ativar o Sender ID Filtering, você deve configurar opções na guia Geral da caixa de diálogo Message Delivery objeto propriedades no Exchange System Manager. Além disso, você deve clicar para marcar a caixa de seleção Aplicar filtro de ID do remetente na área de endereço IP da caixa de diálogo propriedades Default SMTP Virtual Server .

Causa

Esse problema ocorre devido a um acúmulo de segmentos do processo que são bloqueados em operações de filtragem. Os segmentos de processo bloqueado esperam indefinidamente para concluir a validar o remetente como parte do processo de validação a ID do remetente.

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Você deve instalar o Exchange Server 2003 Service Pack 2 (SP2) antes de aplicar o hotfix. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
836993  (http://support.microsoft.com/kb/836993/ ) Como obter os service packs mais recentes para o Exchange Server 2003

Requisitos de reinicialização

Não é necessário reiniciar o computador após aplicar o hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão global deste hotfix apresenta os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Msgfilter.dll6.5.7651.19205,82422 De abril de 200603: 45x 86

Como Contornar

Para contornar esse problema, você pode liberar segmentos de processo bloqueado no processo de filtragem. Para fazer isso, reinicie o Internet Information Services (IIS). Talvez você precise reiniciar o IIS uma vez por mês. Se você não puder reiniciar o serviço de publicação da World Wide Web do snap-in Serviços de, talvez você precise finalizar o processo inetinfo.exe e, em seguida, reinicie. Para fazer isso, execute o seguinte comando em um prompt de comando:
iisreset /restart

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre a terminologia que é usada para descrever as atualizações de software da Microsoft, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software
Para obter mais informações sobre o esquema de nomeação para atualizações de software Exchange Server, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
817903  (http://support.microsoft.com/kb/817903/ ) Novo esquema para nomeação para pacotes de atualização de software do Exchange Server

A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 2003 Service Pack 2
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbfix kbbug kbpubtypekc KB918283 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 918283  (http://support.microsoft.com/kb/918283/en-us/ )