Wenn Sie ein Win32-Programm ausführen, die CreateFile-Funktionsaufrufe von einem Windows XP-basierten Clientcomputer zu einem Server vornimmt, erhalten eine Fehlermeldung

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Problembeschreibung

Stellen Sie sich das folgende Szenario vor. Ein Win32-Programm, die das SMB (Server Message Block)-Protokoll verwendet für Funktionsaufrufe von einem Windows XP-Clientcomputer zu einem Server ausführen. Die Anwendung verwendet die Funktion CreateFile zum Öffnen einer Datei auf dem Server. In diesem Szenario wird wenn das Programm versucht, dieselbe Datei erneut zu öffnen möglicherweise die folgenden Fehlermeldung auf dem Clientcomputer angezeigt:
Systemfehler 32. Der Prozess kann nicht auf die Datei zugreifen, da sie bereits von einem anderen Prozess verwendet wird.
Eine Netzwerkmonitor-Ablaufverfolgung zeigt folgende Fehlermeldung:
Systemfehler, Code = (67) STATUS_SHARING_VIOLATION

Ursache

Dieses Problem tritt auf, wenn Windows-Redirector dynamische Reauthentifizierung für das Kerberos-Protokoll verwendet. Wenn Kerberos-Ticket abläuft, wird automatisch nach dem ersten Aufruf von Funktion CreateFile erneuert, sendet der Redirector einen Befehl nicht an den Server die Datei schließen. Da die Datei auf dem Server geöffnet bleibt, erhalten Sie die Fehlermeldung, das im Abschnitt "Problembeschreibung" genannt wird.

Lösung

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Sie müssen Windows XP Service Pack 1 oder Windows XP Service Pack 2, um diesen Hotfix anwenden ausgeführt werden.

Neustartanforderung

Sie müssen den Computer nach der Installation dieses Hotfixes neu starten.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Windows XP Service Pack 1
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Cscdll.dll5.1.2600.159992,16028-Okt-200401: 29X 86
Mrxsmb.sys5.1.2600.1856433,15215-Jun-200608: 43X 86
Rdbss.sys5.1.2600.1856166,65615-Jun-200608: 52X 86
Windows XP Service Pack 2
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Mrxsmb.sys5.1.2600.2930454,40015-Jun-200609: 28X 86
Rdbss.sys5.1.2600.2930174,59215-Jun-200609: 35X 86

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Weitere Informationen zu den Bedingungen, die in diesem Artikel verwendet werden, finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Eigenschaften

Artikel-ID: 918334 - Geändert am: Mittwoch, 29. August 2007 - Version: 2.1
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows XP Service Pack 1
  • Microsoft Windows XP Service Pack 2
Keywords: 
kbmt kbautohotfix kbfix kbbug kbhotfixserver kbqfe kbpubtypekc KB918334 KbMtde
Maschinell übersetzter Artikel
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 918334
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