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Error message when you try to run Windows Defender: "Windows Defender Definitions haven't been updated"

Article ID:918355
Last Review:February 4, 2008
Revision:3.2
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SYMPTOMS

When you try to run Windows Defender, you may receive the following warning message:
Windows Defender Definitions haven't been updated

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CAUSE

The problem may occur because of one or more of the following circumstances:
You may be experiencing a Windows Update issue.
If you are in a corporate environment, a network administrator may be blocking access to Windows Update. Or, you may have a networking configuration problem that relates to third-party products.
In a corporate environment, a network administrator may have deployed the Microsoft Software Update Services server on the network. For example, the network may be using Software Update Service (SUS) 1.0. Windows Defender cannot receive updates from SUS 1.0.

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RESOLUTION

To update definitions for Windows Defender, follow these steps.

Step 1: Manually install the update definitions

Microsoft delivers Windows Defender updates by using Windows Update. In some cases, you may receive errors because of problems from one of these services that are not related to Windows Defender itself. The first step is to try to manually install the update definitions.
To manually install the update definitions, follow these steps:
1.Visit the Security Portal at the one of the following Microsoft Web sites:
If you are using the English version of Windows, visit the Security Portal at the following Microsoft Web site:
http://www.microsoft.com/security/portal/ADL.aspx (http://www.microsoft.com/security/portal/ADL.aspx)
For more information about the Security Portal for a non-English version of Windows, click the following article number to view the article in the Microsoft Knowledge Base:
923159 (http://support.microsoft.com/kb/923159/) How to manually download the latest definition updates for Windows Defender
2.Follow the appropriate steps on the Web site.
3.If you still receive "Windows Defender Definitions haven't been updated" warning messages, you might want to ask someone for help or contact support.
No-charge support is available for consumers by calling 1-866-PCSAFETY in the United States and Canada or by contacting your local Microsoft subsidiary. For more information about how to contact your local Microsoft subsidiary for security update support issues, visit the International Support Web site.
http://support.microsoft.com/contactUS/ (http://support.microsoft.com/contactus/)
Enterprise customers can obtain support for security updates through their usual support contacts.
4. If you were able to manually install the update definitions, your problem is most likely caused by a Windows Update issue, so you should continue to step 2.
Step 2: Verify that you have the required Microsoft Windows Update files

To verify that you have the required Microsoft Windows Update files, follow these steps:
1.Open Internet Explorer, and then visit the following Microsoft Web site:
http://www.windowsupdate.com (http://www.windowsupdate.com)
2. Install all updates that are available by clicking Express on the Windows Update home page. If you experience problems with Windows Update, you might want to ask someone for help or contact support. For information about how to do this, visit the following Microsoft Web site:
http://go.microsoft.com/fwlink/?linkID=21608 (http://go.microsoft.com/fwlink/?linkID=21608)

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Information for users on an enterprise network

If you are in a corporate environment, the network administrator may have configured the network in a manner that is keeping you from downloading the definitions. If you are in a corporate network, you may want to contact the network administrator for more information about how you can update definitions for Windows Defender.

Additionally, a network administrator may have deployed the Microsoft Software Update Services server on the network. For example, the network may be using Software Update Service (SUS) 1.0. Windows Defender cannot receive updates from SUS 1.0. Contact the network administrator to determine whether this is the problem. In this case, the network administrator must deploy Windows Server Update Services (WSUS). Definitions for Windows Defender must be offered from the WSUS server.

For more information about WSUS, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/wsus/default.aspx (http://technet.microsoft.com/en-us/wsus/default.aspx)

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Advanced troubleshooting

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Verify that you do not have any Microsoft Windows Update, Automatic Updates, and Windows Server Update Service (WSUS) problems

Microsoft delivers Windows Defender updates by using Microsoft Windows Update, Automatic Updates, and Windows Server Update Service (WSUS). In some cases, you may have received errors caused by problems with one of these services, and these errors are not related to Windows Defender itself. To troubleshoot a potential Windows Update problem, follow these steps.

Windows Vista
1.Examine the Windowsupdate.log file for error messages, To view the log file, follow these steps:
a. Click Start, type %windir%\windowsupdate.log in the Start Search box, and then press ENTER.
b. For more information about how to read the Windowsupdate.log file, click the following article number to view the article in the Microsoft Knowledge Base:
902093 (http://support.microsoft.com/kb/902093/) How to read the Windowsupdate.log file
2.Visit the following Microsoft Web site:
http://windowshelp.microsoft.com/windows/en-us/search.aspx?=&qu=%22windows+update+error%22 (http://windowshelp.microsoft.com/windows/en-us/search.aspx?=&qu=%22windows+update+error%22)
3.On the Windows Help and How-to Web page, enter the keywords that describe the problem.
Windows 2000, Windows XP, and Windows Server 2003
1.Examine the Windowsupdate.log file for error messages, To view the log file, follow these steps:
a. Click Start, click Run, type %windir%\windowsupdate.log, and then press ENTER.
b. For more information about how to read the Windowsupdate.log file, click the following article number to view the article in the Microsoft Knowledge Base:
902093 (http://support.microsoft.com/kb/902093/) How to read the Windowsupdate.log file
2.Visit the following Microsoft Web site:
http://v5.windowsupdate.microsoft.com/windowsupdate/v6/troubleshoot.aspx (http://v5.windowsupdate.microsoft.com/windowsupdate/v6/troubleshoot.aspx)
3.On the Options Web page, enter keywords that describe the problem.

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MORE INFORMATION

For more information about how to troubleshoot these problems, click the following article numbers to view the articles in the Microsoft Knowledge Base:
836941 (http://support.microsoft.com/kb/836941/) You may receive an "Error 0x80072EE2," "Error 0x80072EE7," "Error 0x80072EFD," "Error 0x80072F76," or "Error 0x80072F78" error message when you try to use the Windows Update Web site or the Microsoft Update Web site
924123 (http://support.microsoft.com/kb/924123/) Error message when you update Windows Defender definitions in Windows 2000: "0x80240022 - the wrong diskette is in the drive."
919448 (http://support.microsoft.com/kb/919448/) Error message when you try to update the Windows Defender definition set: "error 0x8024002b"
818018 (http://support.microsoft.com/kb/818018/) How to troubleshoot problems connecting to Windows Update or to Microsoft Update
906602 (http://support.microsoft.com/kb/906602/) How to troubleshoot common Windows Update, Microsoft Update, and Windows Server Update Services installation issues

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To see frequently asked questions about Windows Defender, visit the following Microsoft Web site:
http://www.microsoft.com/athome/security/spyware/software/about/faq.mspx (http://www.microsoft.com/athome/security/spyware/software/about/faq.mspx)
To see frequently asked questions about Windows Update, visit the following Microsoft Web site:
http://v5.windowsupdate.microsoft.com/windowsupdate/v6/about.aspx (http://v5.windowsupdate.microsoft.com/windowsupdate/v6/about.aspx)
To see the Windows Defender release notes, visit the following Microsoft Web site:
http://www.microsoft.com/athome/security/spyware/software/about/releasenotes.mspx (http://www.microsoft.com/athome/security/spyware/software/about/releasenotes.mspx)

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APPLIES TO
Windows Defender

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Keywords: 
kbinfo kbtshoot kbsecantivirus kbdefenderrtwyes kbdefenderrtwswept kbresolve KB918355

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