ID článku: 918429 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

Tento článek popisuje, jak v aplikaci Microsoft Office Word 2007 a Microsoft Office Word 2010 rozpoznat poškozený dokument. Dále tento článek obsahuje postup, kterým lze následně z dokumentu obnovit text a data.

Tento článek je určený pro začátečníky až středně pokročilé uživatele.
Provedení popsaných postupů může být snadnější, pokud si článek nejprve vytisknete.

Rozpoznání poškozeného dokumentu

Metoda 1: Znaky podivného chování

Mnoho poškozených dokumentů vykazuje podivné chování. Takové chování může souviset s poškozením dokumentu nebo šablony, na které je dokument postaven. Toto chování může zahrnovat následující:
  • opakované přečíslování existujících stránek v dokumentu,
  • opakované zalamování stránek v dokumentu,
  • nesprávné rozložení a formátování dokumentu,
  • nečitelné znaky na obrazovce,
  • chybové zprávy v průběhu zpracování,
  • počítač přestane reagovat při otevření souboru,
  • jakékoli jiné neočekávané chování, které nelze považovat za typické fungování programu.
Pokud dokument vykazuje některý z těchto příznaků nebo jej nelze otevřít, přejděte k metodě 2.

Metoda 2: Kontrola ostatních dokumentů a programů

Někdy může být toto chování způsobeno jinými faktory než poškozením dokumentu. Chcete-li vyloučit tyto faktory, postupujte podle následujících kroků:
  1. Vyhledejte podobné chování v jiných dokumentech.
  2. Vyhledejte podobné chování v jiných aplikacích systému Microsoft Office 2007 nebo Microsoft Office 2010.
Pokud kterýkoli z těchto kroků ukazuje, že se nejedná o problém dokumentu, bude nutné vyřešit potíže s aplikací Word 2007 nebo Word 2010, systémem Office 2007 nebo Office 2010 nebo operačním systémem v počítači.

Kroky, které mohou vést k vyřešení potíží, pokud lze otevřít poškozený dokument

Metoda 1: Změna šablony, kterou dokument používá

Krok 1: Určení šablony, kterou dokument používá

  1. Otevřete poškozený dokument v aplikaci Word.
  2. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na tlačítko Možnosti.

    V aplikaci Word 2010 klikněte na pásu na položku Soubor a pak klikněte na příkaz Možnosti.
  3. Klikněte na tlačítko Doplňky.
  4. V podokně Zobrazení a správa doplňků sady Office klikněte v rozevíracím seznamu Spravovat na možnost Šablony.
  5. Klikněte na tlačítko Přejít.
V poli Šablona dokumentu bude uvedena šablona, kterou dokument používá. Pokud je uvedena jiná šablona než Normal, přejděte ke kroku 2. Jinak přejděte ke kroku 3.

Krok 2: Přejmenování globální šablony (Normal.dotm)

Postupujte podle kroků uvedených pro operační systém, který používáte:

Windows Vista a Windows 7
  1. Ukončete aplikaci Word.
  2. Klikněte na tlačítko Start
    Zmenšit tento obrázekZvětšit tento obrázek
    Tlačítko Start
    .
  3. Do pole Zahájit hledání zadejte následující text a stiskněte klávesu ENTER:
    %userprofile%\appdata\roaming\microsoft\templates
  4. Klikněte pravým tlačítkem myši na soubor Normal.dotm a potom klikněte na příkaz Přejmenovat.
  5. Zadejte text Oldword.old a stiskněte klávesu ENTER.
  6. Ukončete program Průzkumník Windows.
  7. Spusťte aplikaci Word a otevřete dokument.
Microsoft Windows XP
  1. Ukončete aplikaci Word.
  2. Klikněte na tlačítko Start a potom na příkaz Spustit.
  3. Do pole Otevřít zadejte následující text a stiskněte klávesu ENTER:
    %userprofile%\Application Data\Microsoft\Templates
  4. Klikněte pravým tlačítkem myši na soubor Normal.dotm a potom klikněte na příkaz Přejmenovat.
  5. Zadejte text Oldword.old a stiskněte klávesu ENTER.
  6. Ukončete program Průzkumník Windows.

Krok 3: Změna šablony dokumentu

  1. Otevřete poškozený dokument v aplikaci Word.
  2. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na tlačítko Možnosti aplikace Word.

    V aplikaci Word 2010 klikněte na pásu na položku Soubor a pak klikněte na příkaz Možnosti.
  3. Klikněte na tlačítko Doplňky.
  4. V rámečku Spravovat klikněte na položku Šablony a poté klikněte na tlačítko Přejít.
  5. Klikněte na tlačítko Připojit.
  6. Ve složce Šablony klikněte na položku Normal.dotm a potom klikněte na tlačítko Otevřít.
  7. Kliknutím na tlačítko OK zavřete dialogové okno Šablony a doplňky.
  8. Ukončete aplikaci Word.

Krok 4: Ověření, zda byla šablona úspěšně změněna

  1. Spusťte aplikaci Word.
  2. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na tlačítko Možnosti aplikace Word.

    V aplikaci Word 2010 klikněte na pásu na položku Soubor a pak klikněte na příkaz Možnosti.
  3. Klikněte na poškozený dokument a potom na tlačítko Otevřít.
Pokud podivné chování přetrvává, přejděte k metodě 2.

Metoda 2: Spuštění aplikace Word s použití výchozího nastavení

Ke spuštění aplikace Word ve výchozím nastavení můžete použít přepínač /a. Použijete-li přepínač /a, aplikace Word nenačte žádné doplňky. Aplikace Word navíc nepoužije stávající šablonu Normal.dotm. Restartujte aplikaci Word pomocí přepínače /a.

Krok 1: Spuštění aplikace Word 2007 s přepínačem /a

Windows Vista a Windows 7
  1. Ukončete aplikaci Word.
  2. Klikněte na tlačítko Start
    Zmenšit tento obrázekZvětšit tento obrázek
    Tlačítko Start
    .

  3. Do pole Zahájit hledání zadejte následující text a stiskněte klávesu ENTER.

    Word 2007:
    "%programfiles%\microsoft office\office12\winword.exe" /a
    Word 2010:
    "%programfiles%\microsoft office\office14\winword.exe" /a
Windows XP
  1. Ukončete aplikaci Word.
  2. Klikněte na tlačítko Start a potom na příkaz Spustit.
  3. Do pole Otevřít zadejte následující text a stiskněte klávesu ENTER.

    Word 2007:
    "%programfiles%\microsoft office\office12\winword.exe" /a
    Word 2010:
    "%programfiles%\microsoft office\office14\winword.exe" /a

Krok 2: Otevření dokumentu

  1. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na příkaz Otevřít.

    V aplikaci Word 2010 klikněte na pásu na položku Soubor a pak klikněte na příkaz Otevřít.
  2. Klikněte na poškozený dokument a potom na tlačítko Otevřít.
Pokud podivné chování přetrvává, přejděte k metodě 3.

Metoda 3: Změna ovladačů tiskárny

Krok 1: Použití jiného ovladače tiskárny

Windows Vista a Windows 7
Krok a: Otevření okna Přidat tiskárnu
  1. V systému Windows Vista klikněte na tlačítko Start
    Zmenšit tento obrázekZvětšit tento obrázek
    Tlačítko Start
    a poté klikněte na příkaz Tiskárny.

    V systému Windows 7 klikněte na tlačítko Start
    Zmenšit tento obrázekZvětšit tento obrázek
    Tlačítko Start
    a poté klikněte na příkaz Zařízení a tiskárny.
  2. Klikněte na položku Přidat tiskárnu.
Krok b: Přidání nové tiskárny
  1. V dialogovém okně Přidat tiskárnu klikněte na možnost Přidat místní tiskárnu.
  2. Klikněte na možnost Použít stávající port a pak klikněte na tlačítko Další.
  3. V seznamu Výrobce klikněte na položku Microsoft.
  4. Klikněte na položku Microsoft XPS Document Writer a potom klikněte na tlačítko Další.
  5. Klikněte na možnost Použít aktuálně nainstalovaný ovladač (doporučeno) a poté klikněte na tlačítko Další.
  6. Kliknutím zaškrtněte políčko Nastavit jako výchozí tiskárnu a potom klikněte na tlačítko Další.
  7. Klikněte na tlačítko Dokončit.
Windows XP
Krok a: Otevření okna Přidat tiskárnu
  1. Klikněte na tlačítko Start a potom na příkaz Tiskárny a faxy.
  2. V části Práce s tiskárnou klikněte na odkaz Přidat tiskárnu.
Krok b: Přidání nové tiskárny


Po dokončení instalace následujících oprav se ve složce Tiskárny a faxy automaticky zobrazí ikona Zapisovací modul dokumentů Microsoft XPS.
  1. Nainstalujte rozhraní Microsoft .NET Framework 3.0.
  2. Nainstalujte službu Microsoft Core XML Services (MSXML) 6.0.
  3. Nainstalujte sadu Microsoft XPS Essentials Pack.
Další informace o instalaci výše uvedených oprav XPS naleznete na následujícím webu společnosti Microsoft:
http://www.microsoft.com/whdc/xps/viewxps.mspx

Krok 2: Ověření, zda změna ovladačů tiskárny vyřešila problém

  1. Spusťte aplikaci Word.
  2. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na příkaz Otevřít.

    V aplikaci Word 2010 klikněte na pásu na položku Soubor a pak klikněte na příkaz Otevřít.
  3. Klikněte na poškozený dokument a potom na tlačítko Otevřít.
Pokud podivné chování přetrvává, přejděte ke kroku 3.

Krok 3: Přeinstalujte původní ovladač tiskárny.

Windows Vista a Windows 7
  1. Klikněte na tlačítko Start
    Zmenšit tento obrázekZvětšit tento obrázek
     Tlačítko Start
    a poté klikněte na příkaz Tiskárny nebo Zařízení a tiskárny.
  2. Klikněte pravým tlačítkem myši na původní výchozí tiskárnu a potom na příkaz Odstranit.
    Zmenšit tento obrázekZvětšit tento obrázek
    Povolení v nástroji Řízení uživatelských účtů
    Jestliže se zobrazí výzva k zadání hesla správce nebo k potvrzení, zadejte heslo nebo klikněte na tlačítko Pokračovat.
  3. Pokud se zobrazí výzva k odebrání všech souborů přidružených k tiskárně, klikněte na tlačítko Ano.
  4. Klikněte na položku Přidat tiskárnu a podle pokynů zobrazených v Průvodci přidáním tiskárny přeinstalujte ovladač tiskárny.
Windows XP
  1. Klikněte na tlačítko Start a potom na příkaz Tiskárny a faxy.
  2. Klikněte pravým tlačítkem myši na původní výchozí tiskárnu a potom na příkaz Odstranit.
  3. Pokud se zobrazí výzva k odebrání všech souborů přidružených k tiskárně, klikněte na tlačítko Ano.
  4. V části Práce s tiskárnou klikněte na odkaz Přidat tiskárnu a podle pokynů zobrazených v Průvodci přidáním tiskárny přeinstalujte ovladač tiskárny.

Krok 4: Ověření, zda změna ovladačů tiskárny vyřešila problém

  1. Spusťte aplikaci Word 2007.
  2. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na příkaz Otevřít.

    V aplikaci Word 2010 klikněte na pásu na položku Soubor a pak klikněte na příkaz Otevřít.
  3. Klikněte na poškozený dokument a potom na tlačítko Otevřít.
Pokud podivné chování přetrvává, přejděte k metodě 4.

Metoda 4: Použití nouzového režimu

Krok 1: Spuštění systému Windows v nouzovém režimu

Windows Vista a Windows 7
  1. Vyjměte všechny diskety a disky CD a DVD z počítače a potom restartujte počítač.
  2. Klikněte na tlačítko Start
    Zmenšit tento obrázekZvětšit tento obrázek
     Tlačítko Start
    , klikněte na šipku vedle tlačítka Zamknout nebo Vypnout a potom klikněte na příkaz Restartovat.
  3. Postupujte některým z následujících způsobů:
    • Pokud je v počítači nainstalovaný jediný operační systém, stiskněte a podržte klávesu F8 během restartování počítače. Klávesu F8 je nutné stisknout předtím, než se objeví logo systému Windows. Pokud se objeví logo systému Windows, bude nutné akci opakovat. Počkejte, než se objeví přihlašovací obrazovka systému Windows, a potom znovu restartujte počítač.
    • Pokud je v počítači více operačních systémů, vyberte pomocí kláves se šipkami ten operační systém, který chcete spustit v nouzovém režimu, a poté stiskněte klávesu F8.
  4. Na obrazovce Rozšířené možnosti spuštění vyberte pomocí kláves se šipkami položku Nouzový režim a potom stiskněte klávesu ENTER.
  5. Přihlaste se k počítači pomocí uživatelského účtu s oprávněními správce.
Windows XP
  1. Vyjměte všechny diskety a disky CD a DVD z počítače a potom restartujte počítač.
  2. Klikněte na tlačítko Start a potom klikněte na příkaz Vypnout.
  3. V seznamu Co chcete s počítačem udělat? klikněte na možnost Restartovat a potom klikněte na tlačítko OK.
  4. Během restartování počítače stiskněte a podržte klávesu CTRL.
  5. Jakmile se objeví zpráva Spouštění systému Windows, stiskněte klávesu F8, pomocí kláves se šipkami vyberte v nabídce Spuštění možnost Nouzový režim a potom stiskněte klávesu ENTER.

Krok 2: Ověření, zda spuštění v nouzovém režimu vyřešilo potíže

  1. Spusťte aplikaci Word.
  2. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na příkaz Otevřít.
    V aplikaci Word 2010 klikněte na pásu na položku Soubor a pak klikněte na příkaz Otevřít.
  3. Klikněte na poškozený dokument a potom na tlačítko Otevřít.
Pokud podivné chování přetrvává, restartujte systém Windows a přejděte k metodě 5.

Metoda 5: Vynucení opravy souboru aplikací Word

Krok 1: Oprava dokumentu

  1. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na příkaz Otevřít.

    V aplikaci Word 2010 klikněte na pásu na položku Soubor a pak klikněte na příkaz Otevřít.
  2. V dialogovém okně Otevřít kliknutím zvýrazněte požadovaný dokument aplikace Word.
  3. Klikněte na šipku na tlačítku Otevřít a potom klikněte na příkaz Otevřít a opravit.

Krok 2: Ověření, zda oprava dokumentu vyřešila potíže

Ověřte, zda již nedochází k podivnému chování. Pokud podivné chování přetrvává, restartujte systém Windows a přejděte k metodě 6.

Metoda 6: Změna formátu dokumentu a následné převedení dokumentu zpět do formátu aplikace Word

Krok 1: Otevření dokumentu

  1. Spusťte aplikaci Word.
  2. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na příkaz Otevřít.

    V aplikaci Word 2010 klikněte na pásu na položku Soubor a pak klikněte na příkaz Otevřít.
  3. Klikněte na poškozený dokument a potom na tlačítko Otevřít.

Krok 2: Uložení dokumentu v jiném formátu souboru

  1. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na příkaz Uložit jako.

    V aplikaci Word 2010 klikněte na pásu na položku Soubor a pak klikněte na příkaz Uložit jako.
  2. V aplikaci Word 2007 klikněte na položku Jiné formáty.
  3. V seznamu Uložit jako soubor typu vyberte možnost Formát RTF (*.rtf).
  4. Klikněte na tlačítko Uložit.
  5. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na tlačítko Zavřít.

    V aplikaci Word 2010 klikněte na pásu na položku Soubor a pak klikněte na příkaz Zavřít.

Krok 3: Otevření dokumentu a následné převedení zpět do formátu souboru aplikace Word

  1. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na příkaz Otevřít.

    V aplikaci Word 2010 klikněte na pásu na položku Soubor a pak klikněte na příkaz Otevřít.
  2. Klikněte na převedený dokument a potom klikněte na tlačítko Otevřít.
  3. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na příkaz Uložit jako.

    V aplikaci Word 2010 klikněte na pásu na položku Soubor a pak klikněte na příkaz Uložit jako.
  4. V poli Uložit jako vyberte možnost Dokument aplikace Word.
  5. Přejmenujte soubor dokumentu a potom klikněte na tlačítko Uložit.

Krok 4: Ověření, zda převod formátu souboru dokumentu vyřešil potíže

Ověřte, zda již nedochází k podivnému chování. Jestliže toto chování přetrvává, pokuste se soubor uložit v jiném formátu. Opakujte kroky 1 až 4 a potom zkuste soubor uložit v následujících formátech v následujícím pořadí:
  • webová stránka (s příponou HTM nebo HTML),
  • jakýkoli jiný formát zpracování textu,
  • prostý text (s příponou TXT).
Poznámka: Uložení souborů ve formátu Prostý text (TXT) může vyřešit problém s poškozením dokumentu. Bude však ztraceno veškeré formátování dokumentu, kódy maker a grafika. Po uložení souborů ve formátu Prostý text (TXT) je třeba dokument znovu zformátovat. Formát Prostý text (TXT) proto použijte jen v případě, že problém nebylo možné vyřešit pomocí jiných formátů souborů.

Pokud podivné chování přetrvává, přejděte k metodě 7.

Metoda 7: Zkopírování všeho kromě značky posledního odstavce do nového dokumentu

Krok 1: Vytvoření nového dokumentu

  1. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na příkaz Nový.

    V aplikaci Word 2010 klikněte na pásu na položku Soubor a pak klikněte na příkaz Nový.
  2. Klikněte na položku Prázdný dokument a potom klikněte na tlačítko Vytvořit.

Krok 2: Otevření poškozeného dokumentu

  1. Spusťte aplikaci Word.
  2. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na příkaz Otevřít.

    V aplikaci Word 2010 klikněte na pásu na položku Soubor a pak klikněte na příkaz Otevřít.
  3. Klikněte na poškozený dokument a potom na tlačítko Otevřít.

Krok 3: Zkopírování obsahu dokumentu a vložení tohoto obsahu do nového dokumentu

Poznámka: Pokud dokument obsahuje konce oddílů, kopírujte pouze text umístěný mezi konci oddílů. Konce oddílů nekopírujte, protože by poškození mohlo být tímto způsobem přeneseno do nového dokumentu. Změňte zobrazení dokumentu na koncept, aby při kopírování mezi dokumenty nedošlo k přenesení konců oddílů. Chcete-li přejít do zobrazení konceptu, klikněte na kartě Zobrazit ve skupině Zobrazení dokumentu na tlačítko Koncept.
  1. V poškozeném dokumentu stiskněte klávesy CTRL+END a potom stiskněte klávesy CTRL+SHIFT+HOME.
  2. Na kartě Domů klikněte ve skupině Schránka na tlačítko Kopírovat.
  3. Na kartě Zobrazit ve skupině Okno klikněte na tlačítko Přepnout okna.
  4. Klikněte na dokument vytvořený v kroku 1.
  5. Na kartě Domů klikněte ve skupině Schránka na tlačítko Kopírovat.
Pokud podivné chování přetrvává, přejděte k metodě 8.

Metoda 8: Zkopírování nepoškozených částí poškozeného dokumentu do nového dokumentu

Krok 1: Vytvoření nového dokumentu

  1. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na příkaz Nový.

    V aplikaci Word 2010 klikněte na pásu na položku Soubor a pak klikněte na příkaz Nový.
  2. Klikněte na položku Prázdný dokument a potom klikněte na tlačítko Vytvořit.

Krok 2: Otevření poškozeného dokumentu

  1. Spusťte aplikaci Word.
  2. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na příkaz Otevřít.

    V aplikaci Word 2010 klikněte na pásu na položku Soubor a pak klikněte na příkaz Otevřít.
  3. Klikněte na poškozený dokument a potom na tlačítko Otevřít.

Krok 3: Zkopírování nepoškozených částí dokumentu a jejich vložení do nového dokumentu

Poznámka: Pokud dokument obsahuje konce oddílů, kopírujte pouze text umístěný mezi konci oddílů. Konce oddílů nekopírujte, protože by poškození mohlo být tímto způsobem přeneseno do nového dokumentu. Změňte zobrazení dokumentu na koncept, aby při kopírování mezi dokumenty nedošlo k přenesení konců oddílů. Chcete-li přejít do zobrazení konceptu, klikněte na kartě Zobrazit ve skupině Zobrazení dokumentu na tlačítko Koncept.
  1. V poškozeném dokumentu nalezněte a vyberte jeho nepoškozenou část.
  2. Na kartě Domů klikněte ve skupině Schránka na tlačítko Kopírovat.
  3. Na kartě Zobrazit ve skupině Okno klikněte na tlačítko Přepnout okna.
  4. Klikněte na dokument vytvořený v kroku 1.
  5. Na kartě Domů klikněte ve skupině Schránka na tlačítko Kopírovat.
  6. Opakujte kroky 3a až 3e pro každou nepoškozenou část dokumentu. Poškozené části dokumentu bude nutné rekonstruovat.

Metoda 9: Přepnutí zobrazení dokumentu a odebrání poškozeného obsahu

Pokud se dokument zdá být zkrácený (nezobrazují se všechny stránky dokumentu), bude pravděpodobně možné přepnout zobrazení dokumentu a odebrat z dokumentu poškozený obsah.
  1. Určete číslo stránky, na níž poškozený obsah způsobuje, že se dokument zobrazuje zkrácený.
    1. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na příkaz Otevřít.

      V aplikaci Word 2010 klikněte na pásu na položku Soubor a pak klikněte na příkaz Otevřít.
    2. Klikněte na poškozený dokument a potom na tlačítko Otevřít.
    3. Přejděte k poslední stránce, která se zobrazuje před zkrácením dokumentu. Poznamenejte si obsah této stránky.
  2. Přepněte zobrazení a odeberte poškozený obsah.
    1. Na kartě Zobrazit ve skupině Zobrazení dokumentů klikněte na položku Rozložení webové stránky nebo Zobrazení konceptu.
    2. Přejděte k zobrazení obsahu, který byl zobrazen před zkrácením dokumentu.
    3. Vyberte a odstraňte následující odstavec, tabulku nebo objekt.
    4. Na kartě Zobrazit ve skupině Zobrazení dokumentů klikněte na tlačítko Rozložení při tisku. Pokud se dokument i nadále zdá být zkrácen, pokračujte v přepínání zobrazení a odstraňování obsahu, dokud v zobrazení Rozložení při tisku nepřestane být zkrácený.
    5. Uložte dokument.

Kroky, které mohou vést k vyřešení potíží, pokud nelze otevřít poškozený dokument

Metoda 1: Otevření poškozeného dokumentu v režimu konceptu bez aktualizace propojení

Krok 1: Konfigurace aplikace Word

  1. Spusťte aplikaci Word.
  2. Na kartě Zobrazit ve skupině Zobrazení dokumentů klikněte na tlačítko Koncept.
  3. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na tlačítko Možnosti.

    V aplikaci Word 2010 klikněte do nabídky Soubor a pak klikněte na příkaz Možnosti.
  4. V podokně Upřesňující možnosti práce s aplikací Word ve skupinovém rámečku Zobrazit obsah dokumentu zaškrtněte políčka Písmo konceptu a Zobrazit symboly obrázků.
  5. V podokně Upřesňující možnosti práce s aplikací Word ve skupinovém rámečku Obecné zrušte zaškrtnutí políčka Automaticky aktualizovat propojení při otevření. Poté klikněte na tlačítko OK.

Krok 2: Otevření poškozeného dokumentu

  1. Spusťte aplikaci Word.
  2. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na příkaz Otevřít.

    V aplikaci Word 2010 klikněte do nabídky Soubor a pak klikněte na příkaz Otevřít.
  3. Klikněte na poškozený dokument a potom na tlačítko Otevřít.
Pokud můžete dokument otevřít, zavřete jej a znovu otevřete pomocí postupu uvedeného v metodě 6. Potom dokument opravte. V opačném případě přejděte k metodě 2.

Metoda 2: Vložení dokumentu jako souboru do nového dokumentu

Krok 1: Vytvoření nového prázdného dokumentu

  1. Klikněte na Tlačítko Office a potom na příkaz Nový.

    V aplikaci Word 2010 klikněte do nabídky Soubor a pak klikněte na příkaz Nový.
  2. Klikněte na položku Prázdný dokument a potom klikněte na tlačítko Vytvořit.
Poznámka: Je možné, že u posledního oddílu nového dokumentu bude třeba znovu provést formátování.

Krok 2: Vložení poškozeného dokumentu do nového dokumentu

  1. Na kartě Vložení klikněte na tlačítko Vložit objekt a poté klikněte na příkaz Text ze souboru.
  2. V dialogovém okně Vložit soubor vyhledejte poškozený dokument a klikněte na něj. Poté klikněte na tlačítko Vložit.
Poznámka: Je možné, že u posledního oddílu nového dokumentu bude třeba znovu provést formátování.

Metoda 3: Vytvoření odkazu na poškozený dokument

Krok 1: Vytvoření prázdného dokumentu

  1. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na příkaz Nový.

    V aplikaci Word 2010 klikněte do nabídky Soubor a pak klikněte na příkaz Nový.
  2. Klikněte na položku Prázdný dokument a potom klikněte na tlačítko Vytvořit.
  3. Do nového dokumentu napište text Toto je test.
  4. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na příkaz Uložit.

    V aplikaci Word 2010 klikněte do nabídky Soubor a pak klikněte na příkaz Uložit.
  5. Zadejte text Záchranné propojení a klikněte na tlačítko Uložit.

Krok 2: Vytvoření odkazu

  1. Vyberte text, který jste napsali v kroku 1c.
  2. Na kartě Domů klikněte ve skupině Schránka na tlačítko Kopírovat.
  3. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na příkaz Nový.

    V aplikaci Word 2010 klikněte do nabídky Soubor a pak klikněte na příkaz Nový.
  4. Klikněte na položku Prázdný dokument a potom klikněte na tlačítko Vytvořit.
  5. Na kartě Domů klikněte ve skupině Schránka na šipku u tlačítka Vložit a poté klikněte na příkaz Vložit jinak.
  6. Klikněte na možnost Vložit propojení a Formátovaný text (RTF).
  7. Klikněte na tlačítko OK.

Krok 3: Změna propojení na poškozený dokument

  1. Klikněte pravým tlačítkem myši na propojený text v dokumentu, přejděte na položku Propojený objekt typu Dokument a poté klikněte na příkaz Propojení.
  2. V dialogovém okně Propojení vyberte název souboru propojeného dokumentu a potom klikněte na tlačítko Změnit zdroj.
  3. V dialogovém okně Změnit zdroj vyberte dokument, který nelze otevřít, a klikněte na tlačítko Otevřít.
  4. Kliknutím na tlačítko OK zavřete dialogové okno Propojení.

    Poznámka: Zobrazí se informace z poškozeného dokumentu (pokud obsahoval obnovitelná data nebo text).
  5. Klikněte pravým tlačítkem myši na propojený text, přejděte na položku Propojený objekt typu Dokument a poté klikněte na příkaz Propojení.
  6. V dialogovém okně Propojení klikněte na tlačítko Zrušit propojení.
  7. Jestliže se zobrazí následující zpráva, klikněte na tlačítko Ano:
    Jste si jisti, že chcete zrušit vybraná propojení?

Metoda 4: Použití převaděče Obnovení textu z libovolného souboru

Poznámka: Převaděč Obnovení textu z libovolného souboru má určitá omezení. Dojde například ke ztrátě formátování dokumentu. Také bude ztracena grafika, pole, nakreslené objekty a ostatní položky, které nejsou textové. Text polí, záhlaví, zápatí, poznámky pod čarou a vysvětlivky jsou však uchovány jako prostý text.
  1. V aplikaci Word 2007 klikněte na Tlačítko Office a potom na příkaz Otevřít.

    V aplikaci Word 2010 klikněte do nabídky Soubor a pak klikněte na příkaz Otevřít.
  2. V rozevíracím seznamu Soubory typu klikněte na možnost Obnovení textu z libovolného souboru.
  3. Klikněte na dokument, ze kterého chcete text obnovit.
  4. Klikněte na tlačítko Otevřít.
Po obnovení pomocí převaděče Obnovení textu z libovolného souboru se dále v dokumentu nacházejí text nepřevedených binárních dat. Tento text se nachází především na začátku a na konci dokumentu. Tento text tvořený binárními daty je nutné před uložením souboru jako dokumentu aplikace Word odstranit.

Vlastnosti

ID článku: 918429 - Poslední aktualizace: 26. dubna 2012 - Revize: 3.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Office Word 2007
  • Microsoft Word 2010
Klíčová slova: 
kbproductlink kbprb kbinfo kbnomt kbceip kbcorrupt kbopenfile kbtshoot kbexpertisebeginner kbhowto KB918429

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com