Numer ID artykułu: 918429 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Streszczenie

W tym artykule opisano sposób identyfikowania uszkodzonego dokumentu w programach Microsoft Office Word 2007 i Microsoft Office Word 2010. Ten artykuł zawiera także procedurę odzyskiwania tekstu i danych zawartych w dokumencie po zidentyfikowaniu dokumentu jako uszkodzonego.

Ten artykuł jest przeznaczony dla początkujących lub średnio zaawansowanych użytkowników komputerów.
Wydrukowanie tego artykułu może ułatwić wykonanie opisanych w nim kroków.

Jak rozpoznać uszkodzony dokument

Metoda 1. Sprawdzanie, czy występuje nietypowe zachowanie

Wiele uszkodzonych dokumentów wykazuje nietypowe zachowanie. Takie zachowanie może być związane z uszkodzeniem dokumentu lub szablonu, na którym dokument jest oparty. Przykłady takiego zachowania:
  • wielokrotne ponowne numerowanie istniejących stron w dokumencie;
  • wielokrotne ponowne tworzenie podziałów stron w dokumencie;
  • niepoprawny układ i formatowanie dokumentu;
  • na ekranie są wyświetlane znaki niemożliwe do odczytania;
  • w trakcie przetwarzania dokumentu pojawiają się komunikaty o błędach;
  • komputer przestaje odpowiadać podczas otwierania pliku;
  • program zachowuje się zdecydowanie inaczej niż podczas zwykłego działania.
Jeśli dokument nie wykazuje żadnego z tych symptomów lub jeśli nie można otworzyć dokumentu, przejdź do metody 2.

Metoda 2. Sprawdzanie innych dokumentów i programów

Czasami takie zachowanie może być spowodowane czynnikami innymi niż uszkodzenie dokumentu. Aby wyeliminować inne czynniki, wykonaj następujące kroki:
  1. Sprawdź, czy podobne zachowanie nie występuje w innych dokumentach.
  2. Sprawdź, czy podobne zachowanie nie występuje w innych programach pakietu Microsoft Office 2007 lub Microsoft Office 2010.
Jeśli po wykonaniu dowolnej z tych procedur okaże się, że problem nie jest związany z dokumentem, należy rozwiązać problemy z programem Word 2007 lub Word 2010, pakietem Office 2007 lub Office 2010 bądź systemem operacyjnym komputera.

Procedura rozwiązywania problemów do wykonania, jeśli uszkodzony dokument otwiera się

Metoda 1. Zmienianie szablonu używanego w dokumencie

Krok 1. Ustalenie szablonu używanego w dokumencie

  1. W programie Word otwórz dokument, którego dotyczy problem.
  2. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Opcje.

    W programie Word 2010 kliknij pozycję Plik na Wstążce, a następnie kliknij pozycję Opcje.
  3. Kliknij pozycję Dodatki.
  4. W polu Zarządzaj kliknij pozycję Szablony w obszarze Wyświetlanie dodatków pakietu Office i zarządzanie nimi
  5. Kliknij przycisk Przejdź.
W polu Szablon dokumentu zostanie wyświetlony szablon używany przez dokument. Jeśli zostanie wyświetlona nazwa szablonu Normal, przejdź do kroku 2. W przeciwnym razie przejdź do kroku 3.

Krok 2. Zmiana nazwy szablonu globalnego (Normal.dotm)

Należy wykonać czynności dotyczące używanego systemu operacyjnego:

Windows Vista i Windows 7
  1. Zakończ pracę programu Word.
  2. Kliknij przycisk Start
    Zwiń ten obrazekRozwiń ten obrazek
     Przycisk Start
    .
  3. W polu Rozpocznij wyszukiwanie wpisz następujący tekst, a następnie naciśnij klawisz ENTER:
    %userprofile%\appdata\roaming\microsoft\templates
  4. Kliknij prawym przyciskiem myszy plik Normal.dotm, a następnie kliknij polecenie Zmień nazwę.
  5. Wpisz nazwę Oldword.old, a następnie naciśnij klawisz ENTER.
  6. Zamknij Eksploratora Windows.
  7. Uruchom program Word, a następnie otwórz dokument.
System Microsoft Windows XP
  1. Zakończ pracę programu Word.
  2. Kliknij przycisk Start, a następnie kliknij polecenie Uruchom.
  3. W polu Otwórz wpisz następujący tekst, a następnie naciśnij klawisz ENTER:
    %userprofile%\Application Data\Microsoft\Templates
  4. Kliknij prawym przyciskiem myszy plik Normal.dotm, a następnie kliknij polecenie Zmień nazwę.
  5. Wpisz nazwę Oldword.old, a następnie naciśnij klawisz ENTER.
  6. Zamknij Eksploratora Windows.

Krok 3: Zmiana szablonu dokumentu

  1. W programie Word otwórz dokument, którego dotyczy problem.
  2. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Opcje programu Word.

    W programie Word 2010 kliknij pozycję Plik na Wstążce, a następnie kliknij pozycję Opcje.
  3. Kliknij pozycję Dodatki.
  4. W polu Zarządzaj kliknij pozycję Szablony, a następnie kliknij pozycję Przejdź.
  5. Kliknij przycisk Dołącz.
  6. W folderze Szablony kliknij pozycję Normal.dotm, a następnie kliknij przycisk Otwórz.
  7. Kliknij przycisk OK, aby zamknąć okno dialogowe Szablony i dodatki.
  8. Zakończ pracę programu Word.

Krok 4: Sprawdzenie, czy zmiana szablonu pomogła

  1. Uruchom program Word.
  2. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Opcje programu Word.

    W pakiecie Office 2010 kliknij pozycję Plik na Wstążce, a następnie kliknij pozycję Opcje.
  3. Kliknij uszkodzony dokument, a następnie kliknij pozycję Otwórz.
Jeśli nadal występuje nietypowe zachowanie, przejdź do metody 2.

Metoda 2. Uruchamianie programu Word przy użyciu ustawień domyślnych

Przełącznik /a pozwala uruchomić program Word przy użyciu tylko ustawień domyślnych tego programu. Po zastosowaniu przełącznika /a program Word nie ładuje żadnych dodatków. Ponadto program Word nie używa istniejącego szablonu Normal.dotm. Należy uruchomić ponownie program Word, używając przełącznika /a.

Krok 1: Uruchomienie programu Word 2007 przy użyciu przełącznika /a

Windows Vista i Windows 7
  1. Zakończ pracę programu Word.
  2. Kliknij przycisk Start
    Zwiń ten obrazekRozwiń ten obrazek
     Przycisk Start
    .

  3. W polu Rozpocznij wyszukiwanie wpisz poniższy tekst, a następnie naciśnij klawisz ENTER.

    W przypadku programu Word 2007:
    "%programfiles%\microsoft office\office12\winword.exe" /a
    W przypadku programu Word 2010:
    "%programfiles%\microsoft office\office14\winword.exe" /a
System Windows XP
  1. Zakończ pracę programu Word.
  2. Kliknij przycisk Start, a następnie kliknij polecenie Uruchom.
  3. W polu Otwórz wpisz poniższy tekst, a następnie naciśnij klawisz ENTER.

    W przypadku programu Word 2007:
    "%programfiles%\microsoft office\office12\winword.exe" /a
    W przypadku programu Word 2010:
    "%programfiles%\microsoft office\office14\winword.exe" /a

Krok 2: Otwarcie dokumentu

  1. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Otwórz.

    W programie Word 2010 kliknij pozycję Plik na Wstążce, a następnie kliknij pozycję Otwórz.
  2. Kliknij uszkodzony dokument, a następnie kliknij pozycję Otwórz.
Jeśli nadal występuje nietypowe zachowanie, przejdź do metody 3.

Metoda 3. Zmienianie sterowników drukarki

Krok 1. Użycie innego sterownika drukarki

Windows Vista i Windows 7
Krok a. Otwarcie okna Dodawanie drukarki
  1. W systemie Windows Vista kliknij przycisk Start
    Zwiń ten obrazekRozwiń ten obrazek
    Przycisk Start
    , a następnie kliknij polecenie Drukarki.

    W systemie Windows 7 kliknij przycisk Start
    Zwiń ten obrazekRozwiń ten obrazek
    Przycisk Start
    , a następnie kliknij polecenie Urządzenia i drukarki.
  2. Kliknij polecenie Dodaj drukarkę.
Krok b: Dodanie nowej drukarki
  1. W oknie dialogowym Dodaj drukarkę kliknij przycisk Dodaj drukarkę lokalną.
  2. Kliknij opcję Użyj istniejącego portu, a następnie kliknij przycisk Dalej.
  3. W polu Producent kliknij pozycję Microsoft.
  4. Kliknij opcję Microsoft XPS Document Writer, a następnie kliknij przycisk Dalej.
  5. Kliknij opcję Użyj obecnie zainstalowanego sterownika (zalecane), a następnie kliknij przycisk Dalej.
  6. Zaznacz pole wyboru Ustaw jako drukarkę domyślną, a następnie kliknij przycisk Dalej.
  7. Kliknij przycisk Zakończ.
Windows XP
Krok a. Otwarcie okna Dodawanie drukarki
  1. Kliknij przycisk Start, a następnie kliknij polecenie Drukarki i faksy.
  2. W obszarze Zadania drukarki kliknij pozycję Dodaj drukarkę.
Krok b: Dodanie nowej drukarki


Po zainstalowaniu poniższych poprawek ikona Microsoft XPS Document Writer automatycznie pojawia się w folderze Drukarki i faksy.
  1. Zainstaluj system Microsoft .NET Framework 3.0.
  2. Zainstaluj program Microsoft Core XML Services (MSXML) 6.0.
  3. Zainstaluj dodatek Microsoft XPS Essentials Pack.
Aby uzyskać informacje na temat sposobu instalowania powyższych poprawek związanych z dokumentami XPS, odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://www.microsoft.com/whdc/xps/viewxps.mspx

Krok 2. Sprawdzenie, czy zmiana sterownika drukarki rozwiązała problem

  1. Uruchom program Word.
  2. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Otwórz.

    W programie Word 2010 kliknij pozycję Plik na Wstążce, a następnie kliknij pozycję Otwórz.
  3. Kliknij uszkodzony dokument, a następnie kliknij pozycję Otwórz.
Jeśli nadal występuje nietypowe zachowanie, przejdź do kroku 3.

Krok 3. Ponowne zainstalowanie oryginalnego sterownika drukarki

Windows Vista i Windows 7
  1. Kliknij przycisk Start
    Zwiń ten obrazekRozwiń ten obrazek
    Przycisk Start
    , a następnie kliknij polecenie Drukarki lub Urządzenia i drukarki.
  2. Kliknij prawym przyciskiem myszy oryginalną drukarkę domyślną, a następnie kliknij polecenie Usuń.
    Zwiń ten obrazekRozwiń ten obrazek
    Uprawnienie Kontrola konta użytkownika
    Jeżeli pojawi się monit o hasło administratora lub potwierdzenie, wpisz hasło lub kliknij przycisk Kontynuuj.
  3. Jeśli zostanie wyświetlony monit o usunięcie wszystkich plików związanych z drukarką, kliknij przycisk Tak.
  4. Kliknij pozycję Dodaj drukarkę, a następnie postępuj zgodnie z instrukcjami wyświetlanymi na ekranach Dodaj drukarkę, aby ponownie zainstalować sterownik drukarki.
System Windows XP
  1. Kliknij przycisk Start, a następnie kliknij polecenie Drukarki i faksy.
  2. Kliknij prawym przyciskiem myszy oryginalną drukarkę domyślną, a następnie kliknij polecenie Usuń.
  3. Jeśli zostanie wyświetlony monit o usunięcie wszystkich plików związanych z drukarką, kliknij przycisk Tak.
  4. W obszarze Zadania drukarki kliknij pozycję Dodaj drukarkę, a następnie postępuj zgodnie z instrukcjami wyświetlanymi na ekranach Kreator dodawania drukarki, aby ponownie zainstalować sterownik drukarki.

Krok 4: Sprawdzenie, czy zmiana sterownika drukarki rozwiązała problem

  1. Uruchom program Word 2007.
  2. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Otwórz.

    W programie Word 2010 kliknij pozycję Plik na Wstążce, a następnie kliknij pozycję Otwórz.
  3. Kliknij uszkodzony dokument, a następnie kliknij pozycję Otwórz.
Jeśli nadal występuje nietypowe zachowanie, przejdź do metody 4.

Metoda 4. Używanie trybu awaryjnego

Krok 1. Uruchomienie systemu Windows w trybie awaryjnym

Windows Vista i Windows 7
  1. Usuń z komputera wszystkie dyskietki, dyski CD i dyski DVD, a następnie ponownie uruchom komputer.
  2. Kliknij przycisk Start
    Zwiń ten obrazekRozwiń ten obrazek
    Przycisk Start
    , kliknij strzałkę obok pozycji Zablokuj lub zamknij, a następnie kliknij pozycję Uruchom ponownie.
  3. Wykonaj jedną z następujących procedur:
    • Jeśli na komputerze jest zainstalowany jeden system operacyjny, naciśnij i przytrzymaj klawisz F8 podczas ponownego uruchamiania komputera. Klawisz F8 trzeba nacisnąć przed pojawieniem się logo systemu Windows. Jeśli pojawi się logo systemu Windows, musisz spróbować ponownie: poczekaj, aż zostanie wyświetlony monit o zalogowanie się do systemu Windows, a następnie zamknij i ponownie uruchom komputer.
    • Jeśli na komputerze jest zainstalowany więcej niż jeden system operacyjny, użyj klawiszy strzałek w celu wyróżnienia systemu operacyjnego, który chcesz uruchomić w trybie awaryjnym, a następnie naciśnij klawisz F8.
  4. Na ekranie Advanced Boot Options użyj klawiszy strzałek w celu wybrania opcji Safe Mode, a następnie naciśnij klawisz ENTER.
  5. Zaloguj się do komputera, używając konta użytkownika z prawami administratora.
System Windows XP
  1. Usuń z komputera wszystkie dyskietki, dyski CD i dyski DVD, a następnie ponownie uruchom komputer.
  2. Kliknij przycisk Start, a następnie kliknij przycisk Zamknij system.
  3. Na liście Jaką czynność komputer ma wykonać? kliknij opcję Uruchom ponownie, a następnie kliknij przycisk OK.
  4. Podczas ponownego uruchamiania komputera trzymaj wciśnięty klawisz CTRL.
  5. Gdy pojawi się komunikat Uruchamianie systemu Windows, naciśnij klawisz F8, użyj klawiszy strzałek w celu wybrania opcji Tryb awaryjny w menu Uruchamianie, a następnie naciśnij klawisz ENTER.

Krok 2: Sprawdzenie, czy uruchomienie systemu w trybie awaryjnym rozwiązało problem.

  1. Uruchom program Word.
  2. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Otwórz.
    W programie Word 2010 kliknij pozycję Plik na Wstążce, a następnie kliknij pozycję Otwórz.
  3. Kliknij uszkodzony dokument, a następnie kliknij pozycję Otwórz.
Jeśli nadal występuje nietypowe zachowanie, należy ponownie uruchomić system Windows, a następnie przejść do metody 5.

Metoda 5. Wymuszanie próby naprawienia pliku w programie Word

Krok 1. Naprawa dokumentu

  1. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Otwórz.

    W programie Word 2010 kliknij pozycję Plik na Wstążce, a następnie kliknij pozycję Otwórz.
  2. W oknie dialogowym Otwieranie kliknij, aby wyróżnić dokument programu Word.
  3. KIiknij strzałkę na przycisku Otwórz, a następnie kliknij polecenie Otwórz i napraw.

Krok 2. Sprawdzenie, czy problem został rozwiązany po naprawieniu dokumentu

Należy sprawdzić, czy nietypowe zachowanie już nie występuje. Jeśli nadal występuje nietypowe zachowanie, należy ponownie uruchomić system Windows, a następnie przejść do metody 6.

Metoda 6. Zmienianie formatu dokumentu i konwertowanie go ponownie na format programu Word

Krok 1. Otwarcie dokumentu

  1. Uruchom program Word.
  2. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Otwórz.

    W programie Word 2010 kliknij pozycję Plik na Wstążce, a następnie kliknij pozycję Otwórz.
  3. Kliknij uszkodzony dokument, a następnie kliknij przycisk Otwórz.

Krok 2: Zapisanie dokumentu w innym formacie

  1. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Zapisz jako.

    W programie Word 2010 kliknij pozycję Plik na Wstążce, a następnie kliknij pozycję Zapisz jako.
  2. W programie Word 2007 kliknij pozycję Inne formaty.
  3. Na liście Zapisz jako typ kliknij pozycję Tekst sformatowany RTF (*.rtf).
  4. Kliknij przycisk Zapisz.
  5. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Zamknij.

    W pakiecie Office 2010 kliknij pozycję Plik na Wstążce, a następnie kliknij pozycję Zamknij.

Krok 3. Otwarcie dokumentu i przekonwertowanie go ponownie na format pliku programu Word

  1. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Otwórz.

    W programie Word 2010 kliknij pozycję Plik na Wstążce, a następnie kliknij pozycję Otwórz.
  2. Kliknij przekonwertowany dokument, a następnie kliknij przycisk Otwórz.
  3. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Zapisz jako.

    W programie Word 2010 kliknij pozycję Plik na Wstążce, a następnie kliknij pozycję Zapisz jako.
  4. W polu Zapisz jako typ wybierz pozycję Dokument programu Word.
  5. Zmień nazwę pliku dokumentu, a następnie kliknij przycisk Zapisz.

Krok 4: Sprawdzenie, czy problem został rozwiązany po przekonwertowaniu formatu pliku dokumentu

Należy sprawdzić, czy nietypowe zachowanie już nie występuje. Jeśli to zachowanie nadal występuje, spróbuj zapisać plik w innym formacie pliku. Powtórz kroki od 1 do 4, a następnie spróbuj zapisać plik w innych formatach pliku w następującej kolejności:
  • Strona sieci Web (.htm; .html)
  • Format dowolnego innego edytora tekstów
  • Zwykły tekst (.txt)
Uwaga: Zapisanie pliku w formacie Zwykły tekst (.txt) może rozwiązać problem uszkodzonego dokumentu. Jednak zostanie utracone całe formatowanie dokumentu, kod makr i grafika. W przypadku zapisania pliku w formacie Zwykły tekst (.txt) trzeba ponownie sformatować dokument. Dlatego formatu Zwykły tekst (.txt) należy użyć tylko wtedy, gdy użycie innych formatów nie rozwiązuje problemu.

Jeśli nadal występuje nietypowe zachowanie, przejdź do metody 7.

Metoda 7. Kopiowanie całej zawartości oprócz znacznika ostatniego akapitu do nowego dokumentu

Krok 1. Utworzenie nowego dokumentu

  1. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Nowy.

    W programie Word 2010 kliknij pozycję Plik na Wstążce, a następnie kliknij pozycję Nowy.
  2. Kliknij pozycję Pusty dokument, a następnie kliknij przycisk Utwórz.

Krok 2. Otwarcie uszkodzonego dokumentu

  1. Uruchom program Word.
  2. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Otwórz.

    W programie Word 2010 kliknij pozycję Plik na Wstążce, a następnie kliknij pozycję Otwórz.
  3. Kliknij uszkodzony dokument, a następnie kliknij pozycję Otwórz.

Krok 3. Skopiowanie zawartości dokumentu i wklejenie jej w nowym dokumencie

Uwaga Jeśli dokument zawiera podziały sekcji, należy skopiować tylko tekst między tymi podziałami. Nie należy kopiować znaków podziału sekcji, ponieważ może to być przyczyną przeniesienia uszkodzenia do nowego dokumentu. Aby uniknąć przeniesienia znaków podziału sekcji, na czas wykonywania operacji kopiowania i wklejania między dokumentami, zmień widok dokumentu na widok wersji roboczej. Aby zmienić widok na widok wersji roboczej, na karcie Widok kliknij przycisk Wersja robocza w grupie Widoki dokumentu.
  1. W uszkodzonym dokumencie naciśnij klawisze CTRL+END, a następnie naciśnij klawisze CTRL+SHIFT+HOME.
  2. Na karcie Narzędzia główne kliknij przycisk Kopiuj w grupie Schowek.
  3. Na karcie Widok kliknij przycisk Przełącz okna w grupie Okno.
  4. Kliknij nowy dokument utworzony w kroku 1.
  5. Na karcie Narzędzia główne kliknij przycisk Wklej w grupie Schowek.
Jeśli nadal występuje nietypowe zachowanie, przejdź do metody 8.

Metoda 8. Kopiowanie nieuszkodzonych części uszkodzonego dokumentu do nowego dokumentu

Krok 1. Utworzenie nowego dokumentu

  1. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Nowy.

    W programie Word 2010 kliknij pozycję Plik na Wstążce, a następnie kliknij pozycję Nowe.
  2. Kliknij pozycję Pusty dokument, a następnie kliknij przycisk Utwórz.

Krok 2. Otwarcie uszkodzonego dokumentu

  1. Uruchom program Word.
  2. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Otwórz.

    W programie Word 2010 kliknij pozycję Plik na Wstążce, a następnie kliknij pozycję Otwórz.
  3. Kliknij uszkodzony dokument, a następnie kliknij pozycję Otwórz.

Krok 3. Skopiowanie nieuszkodzonych części dokumentu i wklejenie ich w nowym dokumencie

Uwaga Jeśli dokument zawiera podziały sekcji, należy skopiować tylko tekst między tymi podziałami. Nie należy kopiować znaków podziału sekcji, ponieważ może to być przyczyną przeniesienia uszkodzenia do nowego dokumentu. Aby uniknąć przeniesienia znaków podziału sekcji, na czas wykonywania operacji kopiowania i wklejania między dokumentami, zmień widok dokumentu na widok wersji roboczej. Aby zmienić widok na widok wersji roboczej, na karcie Widok kliknij przycisk Wersja robocza w grupie Widoki dokumentu.
  1. W uszkodzonym dokumencie znajdź i zaznacz nieuszkodzony fragment zawartości dokumentu.
  2. Na karcie Narzędzia główne kliknij przycisk Kopiuj w grupie Schowek.
  3. Na karcie Widok kliknij przycisk Przełącz okna w grupie Okno.
  4. Kliknij nowy dokument utworzony w kroku 1.
  5. Na karcie Narzędzia główne kliknij przycisk Wklej w grupie Schowek.
  6. Powtórz kroki od 3a do 3e dla każdego nieuszkodzonego fragmentu dokumentu. Uszkodzone sekcje dokumentu trzeba zrekonstruować.

Metoda 9. Przełączanie widoku dokumentu w celu usunięcia uszkodzonej zawartości

Jeśli dokument sprawia wrażenie uciętego (nie są wyświetlane wszystkie jego strony), być może można przełączyć widok dokumentu, aby usunąć uszkodzoną zawartość z dokumentu.
  1. Ustal numer strony, na której dokument jest wyświetlany jako ucięty wskutek uszkodzenia zawartości.
    1. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Otwórz.

      W programie Word 2010 kliknij pozycję Plik na Wstążce, a następnie kliknij pozycję Otwórz.
    2. Kliknij uszkodzony dokument, a następnie kliknij pozycję Otwórz.
    3. Przewiń do ostatniej strony wyświetlanej przed miejscem ucięcia dokumentu. Zapamiętaj, jaka zawartość znajduje się na tej stronie.
  2. Przełącz widoki, a następnie usuń uszkodzoną zawartość.
    1. Na karcie Widok w grupie Widoki dokumentu kliknij pozycję Układ sieci Web lub Widok roboczy.
    2. Przewiń dokument w celu wyświetlenia zawartości, która była wyświetlana przed miejscem ucięcia dokumentu.
    3. Zaznacz i usuń następne akapit, tabelę lub obiekt w pliku.
    4. Na karcie Widok w grupie Widoki dokumentu kliknij pozycję Układ wydruku. Jeśli dokument nadal wydaje się ucięty, przełączaj widoki i usuwaj zawartość, aż dokument przestanie być wyświetlany jako ucięty w widoku Układ wydruku.
    5. Zapisz dokument.

Procedura rozwiązywania problemów do wykonania, jeśli uszkodzony dokument nie otwiera się

Metoda 1. Otwieranie uszkodzonego dokumentu w trybie roboczym bez aktualizowania łączy

Krok 1. Skonfigurowanie programu Word

  1. Uruchom program Word.
  2. Na karcie Widok kliknij przycisk Wersja robocza w grupie Widoki dokumentu.
  3. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Opcje.

    W programie Word 2010 kliknij menu Plik, a następnie kliknij pozycję Opcje.
  4. W sekcji Wyświetl zawartość dokumentu zaznacz pola wyboru Czcionka robocza i Symbole zastępcze obrazów w obszarze Zaawansowane opcje pracy z programem Word.
  5. W sekcji Ogólne wyczyść pole wyboru Aktualizuj łącza automatyczne przy otwieraniu w obszarze Zaawansowane opcje pracy z programem Word. Następnie kliknij przycisk OK.

Krok 2. Otwarcie uszkodzonego dokumentu

  1. Uruchom program Word.
  2. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Otwórz.

    W programie Word 2010 kliknij menu Plik, a następnie kliknij pozycję Otwórz.
  3. Kliknij uszkodzony dokument, a następnie kliknij pozycję Otwórz.
Jeśli dokument otwiera się, zamknij dokument, a następnie otwórz go ponownie, stosując metodę 6, i napraw dokument. W przeciwnym razie przejdź do metody 2.

Metoda 2. Wstawianie dokumentu jako pliku w nowym dokumencie

Krok 1. Utworzenie nowego pustego dokumentu

  1. Kliknij Przycisk pakietu Office, a następnie kliknij polecenie Nowy.

    W pakiecie Office 2010 kliknij menu Plik, a następnie kliknij pozycję Nowe.
  2. Kliknij pozycję Pusty dokument, a następnie kliknij przycisk Utwórz.
Uwaga: Konieczne może się okazać ponowne zastosowanie pewnych elementów formatowania do ostatniej sekcji nowego dokumentu.

Krok 2: Wstawienie uszkodzonego dokumentu do nowego dokumentu

  1. Na karcie Wstawianie kliknij przycisk Obiekt, a następnie kliknij pozycję Tekst z pliku.
  2. W oknie dialogowym Wstawianie pliku zlokalizuj, a następnie kliknij uszkodzony dokument. Kliknij przycisk Wstaw.
Uwaga: Konieczne może się okazać ponowne zastosowanie pewnych elementów formatowania do ostatniej sekcji nowego dokumentu.

Metoda 3: Tworzenie łącza do uszkodzonego dokumentu

Krok 1. Utworzenie pustego dokumentu

  1. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Nowy.

    W programie Word 2010 kliknij menu Plik, a następnie kliknij pozycję Nowe.
  2. Kliknij pozycję Pusty dokument, a następnie kliknij przycisk Utwórz.
  3. W nowym dokumencie wpisz tekst To jest test.
  4. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Zapisz.

    W programie Word 2010 kliknij menu Plik, a następnie kliknij pozycję Zapisz.
  5. Wpisz tekst Łącze ratunkowe, a następnie kliknij przycisk Zapisz.

Krok 2: Utworzenie łącza

  1. Zaznacz tekst wpisany w kroku 1c.
  2. Na karcie Narzędzia główne kliknij przycisk Kopiuj w grupie Schowek.
  3. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Nowy.

    W programie Word 2010 kliknij menu Plik, a następnie kliknij pozycję Nowe.
  4. Kliknij pozycję Pusty dokument, a następnie kliknij przycisk Utwórz.
  5. Na karcie Narzędzia główne kliknij strzałkę na przycisku Wklej w grupie Schowek, a następnie kliknij polecenie Wklej specjalnie.
  6. Kliknij przycisk Wklej łącze, a następnie kliknij pozycję Tekst sformatowany (RTF).
  7. Kliknij przycisk OK.

Krok 3: Zmiana łącza do uszkodzonego dokumentu

  1. Kliknij prawym przyciskiem myszy połączony tekst w dokumencie, wskaż pozycję Połączony obiekt Dokument, a następnie kliknij pozycję Łącza.
  2. W oknie dialogowym Łącza kliknij nazwę połączonego dokumentu, a następnie kliknij przycisk Zmień źródło.
  3. W oknie dialogowym Zmień źródło kliknij dokument, którego nie możesz otworzyć, a następnie kliknij przycisk Otwórz.
  4. Kliknij przycisk OK, aby zamknąć okno dialogowe Łącza.

    Uwaga: Informacje z uszkodzonego dokumentu pojawią się, o ile jakieś dane lub tekst są możliwe do odzyskania.
  5. Kliknij połączony tekst prawym przyciskiem myszy, wskaż polecenie Połączony obiekt Document, a następnie kliknij polecenie Łącza.
  6. W oknie dialogowym Łącza kliknij przycisk Przerwij łącze.
  7. Gdy pojawi się poniższy komunikat, kliknij przycisk Tak:
    Czy na pewno chcesz przerwać zaznaczone łącza?

Metoda 4: Używanie konwertera „Odzyskaj tekst z dowolnego pliku”

Uwaga Konwerter „Odzyskaj tekst z dowolnego pliku” ma ograniczenia. Na przykład formatowanie dokumentu zostaje utracone. Ponadto zostają utracone elementy graficzne, pola, obiekty rysunkowe i wszelkie inne elementy, które nie są tekstem. Natomiast pola tekstowe, nagłówki, stopki oraz przypisy dolne i końcowe są zachowywane jako zwykły tekst.
  1. W programie Word 2007 kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Otwórz.

    W programie Word 2010 kliknij menu Plik, a następnie kliknij pozycję Otwórz.
  2. W polu Pliki typu kliknij pozycję Odzyskaj tekst z dowolnego pliku (*.*).
  3. Kliknij dokument, z którego chcesz odzyskać tekst.
  4. Kliknij przycisk Otwórz.
Po odzyskaniu dokumentu za pomocą konwertera „Odzyskaj tekst z dowolnego pliku” pojawia się pewien tekst binarny, który nie jest przekonwertowany. Ten tekst występuje głównie na początku i na końcu dokumentu. Przed zapisaniem pliku jako dokumentu programu Word trzeba usunąć ten tekst.

Właściwości

Numer ID artykułu: 918429 - Ostatnia weryfikacja: 26 kwietnia 2012 - Weryfikacja: 5.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Office Word 2007
  • Microsoft Word 2010
Słowa kluczowe: 
kbproductlink kbprb kbinfo kbnomt kbceip kbcorrupt kbopenfile kbtshoot kbexpertisebeginner kbhowto KB918429

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com