Error message when you try to print or save a document in OneNote 2007 or in Word 2007: "Prop Res DLL not loaded" or "Cannot load Library DLBAPRP.dll"

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Article ID: 918730 - View products that this article applies to.
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SYMPTOMS

When you try to print a document in Microsoft Office OneNote 2007 or in Microsoft Office Word 2007, the document does not print. Additionally, you receive one of the following error messages:
Prop Res DLL not loaded.
Cannot load Library DLBAPRP.dll.
Note This problem may also occur when you try to save the document.

CAUSE

This problem has been reported to occur with certain Lexmark and Dell printers. These printers include the following:
  • Lexmark Z700-P700
  • Lexmark X1180
  • Lexmark X1170
  • Lexmark X1150
  • Lexmark P706
  • Lexmark Z25
  • Dell A940 (Personal All-in-One)

RESOLUTION

For more information, contact the printer manufacturer. For information about your hardware manufacturer, visit the following Web site:
http://support.microsoft.com/gp/vendors/en-us

WORKAROUND

To work around this problem, use one of the following methods.

Method 1: Copy the printer driver files to the System32 folder

To have us copy the printer driver files to the System32 folder for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me



To fix this problem automatically, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.


Fix this problem
Microsoft Fix it 50750


Notes
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Then, go to the "Did this fix the problem?" section.



Let me fix it myself

To copy the printer driver files to the System32 folder, follow these steps:
  1. In Windows Explorer, locate the following folder:
    • On a computer that is running a 32-bit version of Microsoft Windows, locate the following folder:
      drive:\Windows\System32\Spool\Drivers\W32X86\3
    • On a computer that is running a 64-bit version of Windows, locate the following folder:
      drive:\Windows\System32\Spool\Drivers\X64\3
  2. Press and hold CTRL, and then click each printer file.

    Note Each printer driver file has a file name that resembles the following:
    • lx**prpb.dll
    • lx**prpr.dll
    • dl**prpb.dll
    • dl**prpr.dll
    Note ** is a two-letter designation that is associated with the printer.
  3. With the printer driver files selected, right-click the files, and then click Copy.
  4. In Windows Explorer, locate the following folder:
    drive:\Windows\System32
  5. Right-click the System32 folder, and then click Paste.

Method 2: Update the Path environment variable to include the printer driver folder

To have us update the Path environment variable to include the printer driver folder for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me



To fix this problem automatically, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.


Fix this problem
Microsoft Fix it 50749
Notes
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Then, go to the "Did this fix the problem?" section.



Let me fix it myself

To update the Path environment variable, follow these steps:
  1. Click Start, click Control Panel, click Performance and Maintenance, and then click System.
  2. Click the Advanced tab.
  3. Click Environment Variables.
  4. Under System variables, click the Path variable, and then click Edit.
  5. Press END to move the pointer to the end of the path.
  6. Type a semicolon (;), and then type the path of the printer driver file.
    • On a computer that is running a 32-bit version of Microsoft Windows, type the following default path:
      C:\Windows\System32\Spool\Drivers\W32X86\3
    • On a computer that is running a 64-bit version of Windows, type the following default path:
      C:\Windows\System32\Spool\Drivers\X64\3
    For example, after you update the Path variable on a computer that is running a 32-bit version of Windows, the path would resemble the following:
    %SystemRoot%\System32;%systemroot%;C:\Windows\System32\Spool\Drivers\W32X86\3
  7. Click OK to close the Edit System Variable dialog box.
  8. Click OK to close the Environment Variables dialog box.
  9. Click OK to close the System Properties dialog box.

Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support.
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me" blog or send us an email message.

STATUS

Microsoft has confirmed that this is a problem in the printer driver for the printers that are listed in the "Cause" section.

MORE INFORMATION

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Properties

Article ID: 918730 - Last Review: August 19, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft Office OneNote 2007
  • Microsoft Office Word 2007
Keywords: 
kbtshoot kbprinters kbprint kberrmsg kbbug kbexpertisebeginner kbprb kbmsifixme kbfixme KB918730

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