Brak lub niedostępność polecenia Wiadomość e-mail w programie Excel 2007, PowerPoint 2007 lub Word 2007

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 918792 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Symptomy

W programie Microsoft Office Excel 2007, Microsoft Office PowerPoint 2007 lub Microsoft Office Word 2007 kliknięto pozycję Wyślij w menu pakietu Office. Wskutek tego występuje jeden z następujących symptomów:
  • Polecenie Wyślij jest niedostępne.
  • Brakuje polecenia Wiadomość e-mail.

Przyczyna

Ten problem może wystąpić, gdy na komputerze nie zainstalowano programu Microsoft Outlook.

Rozwiązanie

Aby rozwiązać ten problem, należy zastosować jedną z następujących metod.

Metoda 1. Ustawienie programu Outlook jako domyślnego programu poczty e-mail

Aby automatycznie ustawić program Outlook jako domyślny program poczty e-mail, przejdź do sekcji Automatyczne rozwiązywanie problemu. Aby samodzielnie ustawić program Outlook jako domyślny program poczty e-mail, przejdź do sekcji Samodzielne rozwiązywanie problemu.

Automatyczne rozwiązywanie problemu


Aby automatycznie ustawić program Outlook jako domyślny program poczty e-mail, należy kliknąć łącze Rozwiąż ten problem. Następnie należy kliknąć przycisk Uruchom w oknie dialogowym Pobieranie pliku i wykonać kroki kreatora.


Rozwiąż ten problem
Microsoft Fix it 50305


Uwaga Ten kreator może być dostępny tylko w języku angielskim. Jednak ta poprawka automatyczna działa również w innych wersjach językowych systemu Windows.

Uwaga Jeśli używany komputer nie jest tym, którego dotyczy problem, można zapisać tę poprawkę automatyczną na dysku flash lub dysku CD i uruchomić ją na odpowiednim komputerze.

Samodzielne rozwiązywanie problemu

Aby samodzielnie ustawić program Outlook jako domyślny program poczty e-mail, wykonaj następujące czynności:
  1. Uruchom program Microsoft Internet Explorer.
  2. W menu Narzędzia kliknij polecenie Opcje internetowe.
  3. Kliknij kartę Programy.
  4. W polu Poczta e-mail wybierz pozycję Microsoft Outlook.
  5. Kliknij przycisk OK.

Metoda 2. Zweryfikowanie ustawień rejestru

Ważne W tej sekcji, metodzie lub w tym zadaniu podano informacje dotyczące modyfikowania rejestru. Niepoprawne zmodyfikowanie rejestru może jednak być przyczyną poważnych problemów. Dlatego należy uważnie wykonywać podane czynności. Aby zapewnić dodatkową ochronę, przed zmodyfikowaniem rejestru należy wykonać jego kopię zapasową. Dzięki temu w przypadku wystąpienia problemu będzie można przywrócić rejestr. Aby uzyskać więcej informacji dotyczących wykonywania kopii zapasowej i przywracania rejestru, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
322756 Jak wykonać kopię zapasową rejestru i przywrócić go w systemie Windows
  1. Zamknij wszystkie programy.
  2. Kliknij przycisk Start, kliknij polecenie Uruchom, w polu Otwórz wpisz ciąg regedit, a następnie kliknij przycisk OK.
  3. Odszukaj i kliknij następujący podklucz rejestru:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem
  4. Odszukaj następujące wartości rejestru. Zwykle te wartości są wymienione w kluczu Windows Messaging Subsystem.
    Zwiń tę tabelęRozwiń tę tabelę
    NazwaTypDane
    MAPIREG_SZ1
    CMCREG_SZ1
    CMCDLLNAMEREG_SZ Mapi.dll
    CMCDLLNAME32REG_SZ Mapi32.dll
    MAPIXREG_SZ 1
    MAPIXVERREG_SZ 1.0.0.1
    OLEMessagingREG_SZ1
  5. Jeśli brakuje którejkolwiek z tych wartości rejestru, dodaj je, wykonując następujące czynności:
    1. Kliknij podklucz Windows Messaging Subsystem, wskaż polecenie Nowy w menu Edycja, a następnie kliknij pozycję Wartość ciągu.
    2. Wpisz nazwę brakującej wartości, a następnie naciśnij klawisz ENTER.
    3. Kliknij nową wartość, a następnie kliknij polecenie Modyfikuj w menu Edycja.
    4. W oknie dialogowym Edytowanie ciągu w polu Dane wartości wpisz odpowiednią wartość brakującej wartości ciągu.
    5. Powtórz kroki od 6a do 6d dla każdej brakującej wartości z tabeli podanej w kroku 4.
  6. W menu Plik kliknij polecenie Zakończ.
Zazwyczaj gdy występują wymagane klucze rejestru, w programach Excel 2007, PowerPoint 2007 i Word 2007 są automatycznie wyświetlane odpowiednie opcje poczty e-mail. Jeśli po zastosowaniu opisanych tu metod opcje poczty e-mail nie są wyświetlane w tych programach, należy dodać te opcje do tych programów. W tym celu wykonaj następujące czynności:
  1. W menu Plik kliknij polecenie Opcje programu nazwa_produktu.
  2. Kliknij pozycję Dostosowywanie, a następnie na liście Polecenia kliknij pozycję Wszystkie polecenia.
  3. Kliknij odpowiednie polecenie, a następnie kliknij przycisk Dodaj, aby dodać je do paska narzędzi Szybki dostęp. Na przykład kliknij pozycję Wyślij do przeglądu, a następnie kliknij przycisk Dodaj, aby dodać polecenie Wyślij do przeglądu do paska narzędzi.
  4. Kliknij przycisk OK.

Metoda 3. Wysłanie pliku jako załącznika z poziomu programu poczty e-mail

Problem można obejść z poziomu programu poczty e-mail, przechodząc do lokalizacji pliku pakietu Office i dołączając go do wiadomości.

Więcej informacji

W wersjach pakietu Microsoft Office starszych niż Microsoft Office 2003 informacje MAPI są pobierane zarówno z rejestru, jak i z pliku Win.ini. W pakietach Office od wersji Office 2003 informacje MAPI są pobierane tylko z rejestru.

Aby uzyskać więcej informacji, odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://msdn.microsoft.com/pl-pl/library/ms531278.aspx

Właściwości

Numer ID artykułu: 918792 - Ostatnia weryfikacja: 18 września 2011 - Weryfikacja: 2.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Office Excel 2007
  • Microsoft Office PowerPoint 2007
  • Microsoft Office Word 2007
Słowa kluczowe: 
kbfixme kbmsifixme kbtshoot kbexpertisebeginner kbprb KB918792

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com