Article ID: 919150 - Last Review: November 4, 2007 - Revision: 4.4

FIX: Error message when you run SQL Server 2005 Mobile Edition: "80004005 unspecified error"

Hotfix download is availableHotfix Download Available
View and request hotfix downloads

On This Page

Expand all | Collapse all

SYMPTOMS

When you run Microsoft SQL Server 2005 Mobile Edition (SQL Server Mobile Edition) on a Microsoft Windows Powered Pocket PC 2003-based device, you receive the following error message:
80004005 UNSPECIFIED error
This problem occurs when the following conditions are true:
  • The SQL Server Mobile Edition engine tries to access the .sdf database file on the storage card.
  • The device was just restored from the suspend mode.

CAUSE

This problem occurs because the block device driver has not yet started when the device is just restored from the suspend mode. Therefore, when the SQL Server Mobile Edition engine tries to access the .sdf database file on the storage card, the storage system returns the following error message:
device is busy

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

This hotfix is for Windows Powered Pocket PC 2003-based devices that use the ARMV4I microprocessor.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
SqlceMobile30.dll3.0.5207.171,16809-May-200623:56:02ARMV4
Sqlcese30.dll3.0.5207.2400,89610-May-200602:23:26ARMV4
Note Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files. Note This issue was fixed in SQL Server 2005 Compact Edition.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

To apply this hotfix, extract the Sqlce30.PPC.wce4.armv4.cab file and the Sqlce30.repl.PPC.wce4.armv4.cab file from the hotfix. Then, install these files on the device.

This hotfix updates the error message that you receive in SQL Server Mobile Edition when this problem occurs. The updated error message is more descriptive than the error message that is mentioned in the "Symptoms" section. The updated error message is one of the following:
Error message 1
The disk is not ready
Error message 2
The OS storage system (RAM, CF, SD, or IPSM) is not responding. Retry the operation
This hotfix also resolves another problem. For more information about this problem, click the following article number to view the article in the Microsoft Knowledge Base:
919000  (http://support.microsoft.com/kb/919000/ ) FIX: The empty tables in a database do not keep the values in the identity column when you compact the SQL Server 2005 Mobile Edition database

APPLIES TO
  • Microsoft SQL Server 2005 Compact Edition
Keywords: 
kbautohotfix kbfix kbqfe kbhotfixserver kbexpertiseadvanced KB919150
 

Article Translations

 

Related Support Centers