Como solucionar problemas de inicialização do Excel 2007

Traduções deste artigo Traduções deste artigo
ID do artigo: 919196 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

INTRODUÇÃO

Há várias razões por que você pode ter problemas ao iniciar Microsoft Office Excel 2007. Este artigo descreve como solucionar problemas de inicialização do Excel 2007. Além disso, este artigo contém as possíveis soluções para corrigir os problemas.

Observação Controlar de quaisquer novas instalações de software ou atualizações realizadas antes de você experiente o problema de inicialização do Excel 2007. Essas novas instalações ou atualizações podem estar diretamente envolvidas. Além disso, essas informações serão úteis se este artigo não resolve seu problema e você deve telefone Microsoft Product Support Services.

Mais Informações

Quando você inicia o Excel 2007, você pode ter problemas para qualquer um dos seguintes motivos:
  • Atalho corrompido para o programa do Excel 2007
  • Arquivo problemático na pasta de inicialização do Excel ou em uma outra pasta de inicialização
  • Conflito com outro programa
  • Versão incorreta do arquivo core Microsoft Office
  • Arquivo corrompido de barra de ferramentas do Excel (Excel. xlb)
  • Suplemento não é válido
  • Chave do registro não é válido
Se você receber uma mensagem de erro quando inicia o Excel 2007, pesquise o Microsoft Knowledge Base para a mensagem de erro exata. Para pesquisar a Base de dados de Conhecimento da Microsoft, visite o seguinte site da Microsoft:
http://support.microsoft.com/Search
Se você não receber uma mensagem de erro, ou se você não encontrar informações específicas sobre a mensagem de erro na Base de dados de Conhecimento da Microsoft, use as seguintes informações para solucionar o problema de inicialização do Excel 2007.

Primeiro, considere o escopo do problema. O problema ocorre quando você iniciar o Excel 2007 clicando em um arquivo de pasta de trabalho? O problema ocorre quando você executar o Excel no menu Iniciar?

Se o problema ocorre somente quando você abrir uma pasta de trabalho do Excel, consulte a seção Solução de problemas de adicionais. Caso contrário, consulte a seção "Criar um novo atalho para o Excel 2007".

Criar um novo atalho para o Excel 2007

Se o problema ocorre somente quando você iniciar o Excel, siga estas etapas.

Microsoft Windows XP
  1. Clique em Iniciar, clique em Pesquisae clique em Todos os arquivos e pastas.
  2. No Todo ou parte do nome do arquivo caixa, digite Exe.
  3. No Examinar Clique em Meu computadore clique em Pesquisa.
  4. Após o arquivo Excel. exe for encontrado, clique duas vezes no arquivo para iniciar o Excel 2007.

    Observação Por padrão, o arquivo Excel. exe está no seguinte local:
    C:\Arquivos de Programas\Microsoft Office\Office12
O Windows Vista
  1. Clique em Iniciar.
  2. No Iniciar pesquisa caixa, digite Exe.
  3. No Programas lista, escolha o programa aplicável. Pesquisa será iniciada automaticamente.
  4. Após o arquivo Excel. exe for encontrado, clique duas vezes no arquivo para iniciar o Excel 2007.

    Observação Por padrão, o arquivo Excel. exe está no seguinte local: c:\Arquivos de Programas\Microsoft Office\Office12


    1. Clique em Iniciar.

    2. Na caixa Iniciar pesquisa, digite Excel. exe.

    3. Na lista de programas, escolha o programa aplicável. Pesquisa será iniciada automaticamente.

    4. Após o arquivo Excel. exe for encontrado, clique duas vezes no arquivo para iniciar o Excel 2007.

    Observação Por padrão, o arquivo Excel. exe está no seguinte local:

    C:\Arquivos de Programas\Microsoft Office\Office12


Se o Excel é iniciado como esperado, o problema pode ocorrer devido um atalho corrompido para o programa. Para resolver esse problema, crie um novo atalho para o Excel 2007. Use o novo atalho para iniciar o Excel 2007.

Para que possamos criar um novo atalho para o Excel 2007 para você, vá para o "Criá-la para mim"seção.

Criá-la para mim



Para criar automaticamente um novo atalho, clique no Corrigirbotão ou link. Clique em Executarno Download do arquivocaixa de diálogo caixa e siga as etapas na correção-assistente.


Esse problema
Microsoft Fix it 50268


Observação este assistente pode estar em inglês apenas; No entanto, a correção automática também funciona para outras versões de idioma do Windows.

Observação Se você não estiver no computador que tem o problema, você pode salvar a correção automática para uma unidade flash ou um CD e, em seguida, executá-lo no computador que tem o problema.

Em seguida, vá para o "Isso corrigiu o problema?"seção.

Isso corrigiu o problema?

Verifique se o problema foi corrigido. Se o problema é corrigido, terminar com este artigo. Se o problema não for corrigido, tente as etapas na seção "Iniciar Excel 2007 no modo de segurança".

Inicie o Excel 2007 no modo de segurança

Para que possamos iniciar o Excel no modo de segurança para você, vá para o "Inicie-o para mim"seção. Se preferir Iniciar Excel no modo de segurança, vá para o "Deixe-me iniciar sozinho"seção.

Inicie-o para mim



Para iniciar o Excel no modo de segurança automaticamente, clique no Corrigirbotão ou link. Clique em Executarno Download do arquivocaixa de diálogo caixa e siga as etapas na correção-assistente.


Esse problema
Microsoft Fix it 50270


Observação este assistente pode estar em inglês apenas; No entanto, a correção automática também funciona para outras versões de idioma do Windows.

Observação Se você não estiver no computador que tem o problema, você pode salvar a correção automática para uma unidade flash ou um CD e, em seguida, executá-lo no computador que tem o problema.

Em seguida, vá para o "Isso corrigiu o problema?"seção.



Deixe-me iniciar sozinho

Se o Excel não iniciar conforme o esperado usando um novo ícone, siga estas etapas para Iniciar Excel no modo de segurança.
  1. Clique em Iniciar, clique em Executar, clique em Procurare localize a pasta em que o Excel 2007 está instalado.

    Observação Por padrão, o arquivo Excel. exe está no seguinte local:
    C:\Arquivos de Programas\Microsoft Office\Office12
  2. Após localizar o arquivo Excel. exe, clique no arquivo e clique em Abrir.
  3. No Abrir caixa, digite um espaço no final do caminho e digite /s. O caminho deve ser semelhante ao seguinte:
    "C:\Program Files\Microsoft Office\Office12\Excel.exe" /s
  4. No Executar caixa de diálogo, clique em OK para iniciar o Excel 2007.

Isso corrigiu o problema?

Verifique se o Excel é iniciado no modo de segurança. Se o Excel é iniciado no modo de segurança, você tiver terminado com essa seção. Se o Excel não é iniciado no modo de segurança, você pode Contate o suporte. Se o Excel é iniciado como esperado, consulte a "Solução de problemas adicionais" seção posterior Este artigo para obter mais informações.

Iniciar o Windows no modo de segurança

Se o Excel 2007 ainda não iniciar conforme o esperado, pode haver um conflito com outro programa. Tente iniciar o Microsoft Windows no modo de segurança. Siga as etapas na seção "Iniciar Excel 2007 no modo de segurança" para iniciar o Excel no modo de segurança. Para obter mais informações sobre como iniciar o Windows no modo de segurança, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
315222Uma descrição das opções de inicialização no modo seguro no Windows XP
Se não iniciar o Excel 2007 quando você usa o /s Alternar e se estiver executando o Windows no modo de segurança, remova o sistema de Microsoft Office de 2007 (ou autônomo Excel 2007) usando Adicionar ou remover programas no painel de controle. Para obter mais informações sobre como adicionar ou remover programas, consulte a documentação do Windows.

Esta etapa de solução de problemas pode ser necessária porque quando você executa o Windows e o Excel no modo de segurança, Excel está no modo mais básico que é necessário para iniciar o programa. Isso significa que outros programas ou arquivos envolvidos no processo de inicialização do Excel. O problema de inicialização do Excel pode ocorrer devido um arquivo corrompido do Office que o Excel usa para iniciar. Portanto, se você remove e reinstalar o sistema de Microsoft Office (ou autônomo Excel 2007), esse problema deve ser resolvido.

Solução de problemas adicionais

Se o Excel é iniciado quando você usar a opção /s

Se o Excel 2007 é iniciado como esperado quando você usar a opção /s , Modo de segurança aparece na barra de título do Excel. Isso indica que o Excel 2007 está sendo executado como se fosse a primeira vez após a instalação do Excel.

Excel 2007 ignora as áreas a seguir no modo de segurança. Após iniciar o Excel 2007, use um processo de eliminação para solucionar as áreas a seguir até que o problema seja corrigido.
Pastas de inicialização do Excel
Um motivo comum que você pode ter problemas ao iniciar o Excel 2007 é que o Excel é Carregando um arquivo problemático de uma das várias pastas de inicialização diferente.

Se você instalar o Excel 2007 no local padrão, o Excel abre arquivos dos seguintes caminhos:
  • C:\Program Files\Microsoft Office\Office12\Xlstart
  • C:\Documents and Settings \nome de usuário\Dados de Aplicativos\Microsoft\Excel\XLInicio, onde nome de usuário é o nome de usuário de logon.
  • A pasta especificada no Ao inicializar, abrir todos os arquivos caixa. O Ao inicializar, abrir todos os arquivos caixa está na Geral seção em Opções avançadas para trabalhar com o Excel. Para localizar o Geral seção, clique no Botão Microsoft Officee clique em Opções do Excel.
Se você suspeitar que esses arquivos para um problema, remova os arquivos dessas pastas. Em seguida, tente iniciar o Excel 2007. Se o Excel é iniciado como esperado, um dos arquivos é o problema. Para determinar qual arquivo é o problema, adicione cada arquivo para pastas de inicialização, um por vez. Em seguida, tente iniciar o Excel. Repita esse procedimento até determinar o arquivo problemático.
Arquivo de barra de ferramentas e barra de ferramentas de acesso rápido do Excel
Ocasionalmente, o arquivo de barra de ferramentas (Excel. xlb) ou o arquivo de barra de ferramentas de acesso rápido (Excel.qat) para o Excel 2007 pode ser corrompido. Se isso ocorrer, você pode ter problemas ao iniciar o Excel. Nessa situação, localize o arquivo de barra de ferramentas e renomeá-lo. Após renomear o arquivo de barra de ferramentas, o Excel recriará um novo arquivo de barra de ferramentas na próxima vez que iniciar o Excel.

Para renomear o arquivo de barra de ferramentas do Excel 2007, siga estas etapas:
  1. Localize a Xlb arquivo ou o Excel.qat arquivo.

    Anotações
    • Por padrão, o arquivo xlb está localizado na seguinte pasta:
      C:\Documents and Settings \nome de usuário\Application Data\Microsoft\Excel
    • Por padrão, o arquivo Excel.qat exe está localizado na seguinte pasta:

      O Windows Vista
      C:\Users\nome de usuário\AppData\Local\Microsoft\Office
      Windows XP, Windows Server 2003 e Windows 2000
      C:\Documents and Settings \nome de usuário\Local Settings\Application Data\Microsoft\Office
  2. Com o botão direito do Xlb arquivo ou o Excel.qat arquivo e clique em Renomear.
  3. Tipo Excel.xlb.old ou Excel.qat.old, e pressione ENTER.
Observação O arquivo xlb armazena alterações à faixa de opções. Essas alterações incluem botões adicionados por suplementos. O Excel.qat armazena alterações de barra de ferramentas de acesso rápido.

Se o Excel 2007 é iniciado quando o Windows está no modo de segurança

Se o problema de inicialização do Excel 2007 não ocorre quando o Windows está no modo de segurança, algum outro programa está causando o problema com o processo de inicialização do Excel.

Use um processo de eliminação para determinar qual programa está causando o problema. Se você não tiver certeza sobre como fazer isso, contate o fornecedor do Windows para obter mais informações sobre como eliminar cada programa que é carregado durante a inicialização do Windows. Para obter mais informações sobre como solucionar problemas de inicialização do Windows, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
310353Como configurar o Windows XP para iniciar no estado "inicialização limpa"

Um suplemento não é válido

Para determinar se o problema é causado por um suplemento não é válido, execute estas etapas:
  1. Clique no Botão Microsoft Officee clique em Opções do Excel.
  2. Clique em Suplementos.
  3. No Gerenciar Clique no tipo de suplemento que você deseja desativar, como Suplementos do Excele clique em Ir.
  4. Clique para desmarcar a caixa de seleção add-ins add-ins que estão selecionados e clique em OK.

Uma chave do registro não é válida

Para determinar se o problema é causado por uma chave de registro não é válida, remova as seguintes chaves do registro. As chaves do registro são recriadas depois reinicie o Excel e, em seguida, saia do Excel.

Observação Configurações personalizadas do usuário podem ser redefinidas quando você remover essas chaves do registro.
  • HKEY_CURRENT_USER\Software\Microsoft\Office\12.0
  • HKEY_LOCAL_MACHINE\Software\Microsoft\Office\12.0

Um suplemento COM está causando problemas

Suplementos COM podem ser instalados em qualquer local. Programas que interagem com o Excel instalam suplementos COM. Para resolver problemas que podem ocorrer com o Excel, exclua as chaves do registro de suplementos COM e reinicie o Excel.

Para que possamos fazer isso para você, vá para o "Corrigir para mim"seção. Se você preferir fazer isso sozinho, vá para o "Deixe-me a corrigir sozinho"seção.

Corrigir para mim


Para fazer isso automaticamente, clique no Corrigirbotão ou link. Clique em Executarno Download do arquivocaixa de diálogo caixa e siga as etapas na correção-assistente.


Esse problema
Microsoft Fix it 50269


Para substituir o registro de suplementos COM chaves de volta automaticamente, clique no Corrigirbotão ou link. Clique em Executarno Download do arquivocaixa de diálogo caixa e siga as etapas na correção-assistente.


Esse problema
Microsoft Fix it 50272

Observação este assistente pode estar em inglês apenas; No entanto, a correção automática também funciona para outras versões de idioma do Windows.

Observação Se você não estiver no computador que tem o problema, você pode salvar a correção automática para uma unidade flash ou um CD e, em seguida, executá-lo no computador que tem o problema.

Em seguida, vá para o "Isso corrigiu o problema?"seção.



Deixe-me a corrigir sozinho
Importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, podem ocorrer problemas graves se modificar o registro incorretamente. Portanto, certifique-se de seguir estas etapas cuidadosamente. Para proteção adicional, faça backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756 Como fazer backup e restaurar o registro no Windows
Para fazer isso, execute estas etapas:
  1. Feche todos os programas do Office.
  2. Clique em Iniciar, clique em Executar, tipo Regedite clique em OK.
  3. Localize a seguinte subchave do registro:
    HKEY_CURRENT_USER\Software\Microsoft\Office\Excel\AddIns
  4. Clique em AddInse clique em Exportação sobre o Arquivo menu.
  5. Nomeie o arquivo "XLaddinHKCU.reg" e salve o arquivo na área de trabalho.
  6. Selecione o AddIns subchave, clique Excluir sobre o Editar menu e clique Sim.
  7. Localize a seguinte subchave do registro:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Office\Excel\Addins
  8. Clique em AddInse clique em Exportação sobre o Arquivo menu.
  9. Nomeie o arquivo "XLaddinHKLM.reg" e salve o arquivo na área de trabalho.
  10. Selecione o AddIns subchave, clique Excluir sobre o Editar menu e clique Sim.
  11. Saia do Editor do registro.
  12. Inicie o Excel.
Se o problema for resolvido, um programa COM estava causando o problema. Você pode examinar as chaves do registro em suplementos no Editor do registro para determinar o fabricante do suplemento. Em seguida, você pode contatar o fabricante para atualizações.

Isso corrigiu o problema?

Verifique se o problema foi corrigido. Se o problema está corrigido, terminar com esta seção. Se o problema não for corrigido, você pode Contate o suporte.
Graças ao MVP Jan Karel Pieterse para contribuir para a correção soluções continham neste artigo.

Propriedades

ID do artigo: 919196 - Última revisão: quinta-feira, 5 de julho de 2012 - Revisão: 3.0
A informação contida neste artigo aplica-se a:
  • Microsoft Office Excel 2007
  • Microsoft Office Excel 2003
  • Microsoft Excel 2010
Palavras-chave: 
kbsurveynew kbmsifixme kbfixme kbinfo kbstartprogram kbexpertisebeginner kbtshoot kbhowto kbmt KB919196 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 919196

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com