Artikel-ID: 919332 - Geändert am: Donnerstag, 11. Oktober 2007 - Version: 2.6

Ein 32-Bit-Programm möglicherweise nicht Farben richtig gedruckt bei Ausführung auf einer 64-Bit-Version von Windows Server 2003 oder eine 64-Bit-Version von Windows XP

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Problembeschreibung

Ein 32-Bit-Programm möglicherweise Farben nicht richtig gedruckt, beim Drucken einer Datei auf einem Computer, auf dem eine 64-Bit-Version von Windows 2003 oder eine 64-Bit-Version von Microsoft Windows XP ausgeführt wird.

Ursache

Dieses Problem rührt eine internen Strukturen von Graphics Device Interface (GDI) mit 32-Bit-Programme nicht kompatibel ist, die auf 64-Bit-Versionen von Windows ausgeführt werden.

Der Druckertreiber DrvQueryColorProfile -Funktion empfängt ungültige Parameter. Der Druckertreiber kann daher nicht ICC-Profil auswählen.

Lösung

Windows Server 2003

Informationen zu Service Packs

Installieren Sie das neueste Servicepack für Windows Server 2003, um dieses Problem zu beheben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) So erhalten Sie das neueste Servicepack für Windows Server 2003

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.
Voraussetzungen
Es gelten keine Voraussetzungen.
Neustartanforderung
Sie müssen den Computer nach der Installation dieses Hotfixes neu starten.
Ersetzte Hotfixes
Dieser Hotfix ersetzt keine anderen Hotfixes.
Dateiinformationen
Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.

Windows Server 2003, X 64-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-AnforderungServicebereich
Gdi32.dll5.2.3790.2703610,30416-Mai 200603: 03X 64SP1SP1QFE
Wgdi32.dll5.2.3790.2703285,18416-Mai 200603: 03X 86SP1WOW
Windows Server 2003, Itanium-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-AnforderungServicebereich
Gdi32.dll5.2.3790.2703907,77616-Mai 200603: 05IA-64SP1SP1QFE
Wgdi32.dll5.2.3790.2703285,18416-Mai 200603: 05X 86SP1WOW

Windows XP

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.
Voraussetzungen
Es gelten keine Voraussetzungen.
Neustartanforderung
Sie müssen den Computer nach der Installation dieses Hotfixes neu starten.
Ersetzte Hotfixes
Dieser Hotfix ersetzt keine anderen Hotfixes.
Dateiinformationen
Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.

Windows XP Professional X 64 Edition
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-AnforderungServicebereich
Gdi32.dll5.2.3790.2703610,30416-Mai 200603: 03X 64SP1SP1QFE
Wgdi32.dll5.2.3790.2703285,18416-Mai 200603: 03X 86SP1WOW
Windows XP 64-Bit Edition (Itanium)
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-AnforderungServicebereich
Gdi32.dll5.2.3790.2703907,77616-Mai 200603: 05IA-64SP1SP1QFE
Wgdi32.dll5.2.3790.2703285,18416-Mai 200603: 05X 86SP1WOW

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind. Dieses Problem wurde erstmals in Windows Server 2003 Service Pack 2.

Weitere Informationen

Gehen Sie folgendermaßen vor um zu bestätigen, dass Sie dieses Problem auftritt.

Hinweis: Die folgenden Schritte sind für erfahrene Benutzer und Drucker Treiberentwickler.
  1. Klicken Sie auf Start , klicken Sie auf Systemsteuerung und doppelklicken Sie dann auf Drucker und Faxgeräte .
  2. Klicken Sie mit der rechten Maustaste auf den Drucker, und klicken Sie dann auf Eigenschaften .
  3. Klicken Sie auf die Registerkarte Farbverwaltung auf automatisch .
  4. Klicken Sie auf der Registerkarte Allgemein auf Einstellungen und dann auf Erweitert .
  5. Erweitern Sie die Color-Steuerelement .
  6. Klicken Sie in der Liste Farbanpassung auf ICM auf System , und klicken Sie dann auf OK .
  7. Klicken Sie zweimal auf OK .
  8. Starten Sie Internet Explorer.
  9. Starten Sie das Tool WinDbg.exe.
  10. Klicken Sie auf Datei , klicken Sie auf Anfügen an einen Prozess und klicken Sie dann auf Iexplorer.exe .
  11. Klicken Sie auf Datei , klicken Sie auf Anfügen an einen Prozess und klicken Sie dann auf Slpwow64.exe .
  12. Geben Sie im unteren dt Gdi32! QUERYCOLORPROFILEINPUT .
  13. Typ bp Unidrvui! DrvQueryColorProfile einen Haltepunkt am Unidrvui festlegen! DrvQueryColorProfile.
  14. Klicken Sie in Internet Explorer auf Datei , und klicken Sie dann auf Seitenansicht .

    Unterbricht das Debugger-Tool am Unidrvui! DrvQueryColorProfile .
  15. Überprüfen Sie die Parameter der Unidrvui! DrvQueryColorProfile .
Möglicherweise finden Sie die Parameter falsch sind. Beispielsweise kann der PvProfileData-Parameter NULL sein.

Weitere Informationen über das Tool WinDbg.exe der folgenden Microsoft-Website:
http://www.microsoft.com/whdc/devtools/debugging/default.mspx (http://www.microsoft.com/whdc/devtools/debugging/default.mspx)
Weitere Informationen zu den Bedingungen, die in diesem Artikel verwendet werden, finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Professional 64-Bit Edition (Itanium)
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 919332  (http://support.microsoft.com/kb/919332/en-us/ )
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