ID do artigo: 919332 - Última revisão: quinta-feira, 11 de outubro de 2007 - Revisão: 2.6

Um programa de 32 bits pode não imprimir cores corretamente quando ele estiver sendo executado em uma versão de 64 bits do Windows Server 2003 ou em uma versão de 64 bits do Windows XP

Download do hotfix está disponívelDownload do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Um programa de 32 bits pode não ser impressos cores corretamente quando você imprime um arquivo em um computador que esteja executando uma versão de 64 bits do Microsoft Windows Server 2003 ou uma versão de 64 bits do Microsoft Windows XP.

Causa

Esse problema ocorre porque um das estruturas internas da GDI (Graphics Device Interface) é incompatível com programas de 32 bits executados em versões de 64 bits do Windows.

Função de DrvQueryColorProfile do driver da impressora recebe parâmetros inválidos. Portanto, o driver de impressora não pode selecionar um perfil ICC.

Resolução

Windows Server 2003

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Windows Server 2003. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
889100  (http://support.microsoft.com/kb/889100/ ) Como obter o service pack mais recente para o Windows Server 2003

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.
Pré-requisitos
Não pré-requisitos são necessários.
Requisitos de reinicialização
Reinicie o computador após aplicar esse hotfix.
Informações sobre a substituição do hotfix
Esse hotfix não substitui outros hotfixes.
Informações sobre o arquivo
A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.

Windows Server 2003, versões com base em 64 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SPRamificação do serviço
Gdi32.dll5.2.3790.2703610,30416 De maio de 200603: 03x 64SP1SP1QFE
Wgdi32.dll5.2.3790.2703285,18416 De maio de 200603: 03x 86SP1UAU
Windows Server 2003, versões com base em Itanium
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SPRamificação do serviço
Gdi32.dll5.2.3790.2703907,77616 De maio de 200603: 05IA-64SP1SP1QFE
Wgdi32.dll5.2.3790.2703285,18416 De maio de 200603: 05x 86SP1UAU

Windows XP

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.
Pré-requisitos
Não pré-requisitos são necessários.
Requisitos de reinicialização
Reinicie o computador após aplicar esse hotfix.
Informações sobre a substituição do hotfix
Esse hotfix não substitui outros hotfixes.
Informações sobre o arquivo
A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.

Windows XP Professional x 64 Edition
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SPRamificação do serviço
Gdi32.dll5.2.3790.2703610,30416 De maio de 200603: 03x 64SP1SP1QFE
Wgdi32.dll5.2.3790.2703285,18416 De maio de 200603: 03x 86SP1UAU
Windows XP 64-Bit Edition (Itanium)
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SPRamificação do serviço
Gdi32.dll5.2.3790.2703907,77616 De maio de 200603: 05IA-64SP1SP1QFE
Wgdi32.dll5.2.3790.2703285,18416 De maio de 200603: 05x 86SP1UAU

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a". Esse problema foi corrigido primeiro no Windows Server 2003 Service Pack 2.

Mais Informações

Para confirmar se você está enfrentando esse problema, siga estas etapas.

Observação As etapas a seguir são para usuários experientes e para os desenvolvedores de driver de impressora.
  1. Clique em Iniciar , clique em Painel de controle e, em seguida, clique duas vezes em Impressoras e aparelhos de fax .
  2. Clique com o botão direito na impressora e, em seguida, clique em Propriedades .
  3. Na guia de Gerenciamento de cores , clique em automático .
  4. Na guia Geral , clique em Preferências de impressão e, em seguida, clique em Avançado .
  5. Expanda o controle de cor .
  6. Na lista de Correspondência de cores , clique em ICM no sistema e, em seguida, clique em OK .
  7. Clique duas vezes em OK .
  8. Inicie o Internet Explorer.
  9. Inicie a ferramenta WinDbg.exe.
  10. Clique em arquivo , clique em anexar a um processo e, em seguida, clique em Iexplorer.exe .
  11. Clique em arquivo , clique em anexar a um processo e, em seguida, clique em Slpwow64.exe .
  12. No painel inferior, digite dt Gdi32! QUERYCOLORPROFILEINPUT .
  13. Tipo bp unidrvui! DrvQueryColorProfile para definir um ponto de interrupção em unidrvui! DrvQueryColorProfile.
  14. No Internet Explorer, clique em arquivo e, em seguida, clique em Visualizar impressão .

    A ferramenta depurador interromperá no unidrvui! DrvQueryColorProfile .
  15. Verifique se os parâmetros do unidrvui! DrvQueryColorProfile .
Talvez que os parâmetros estão incorretos. Por exemplo, o parâmetro pvProfileData pode ser NULL.

Para obter mais informações sobre a ferramenta WinDbg.exe, visite o seguinte site:
http://www.microsoft.com/whdc/devtools/debugging/default.mspx (http://www.microsoft.com/whdc/devtools/debugging/default.mspx)
Para obter mais informações sobre os termos usados neste artigo, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Professional 64-Bit Edition (Itanium)
Palavras-chave: 
kbmt kbautohotfix kbwinserv2003sp2fix kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB919332 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 919332  (http://support.microsoft.com/kb/919332/en-us/ )