Utilizzo di Outlook 2007 la cache dei moduli e risoluzione dei problemi della cache di moduli

Traduzione articoli Traduzione articoli
Identificativo articolo: 919596 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

Sommario

in questo articolo viene descritto il modo che Microsoft Office Outlook 2007 individua moduli, in cui si trova la cache dei moduli, come modificare la dimensione della cache dei moduli e come utilizzare la chiave di registro ForceFormReload. Questo articolo viene descritto anche alcuni problemi che possono verificarsi con la cache dei moduli di Outlook. Infine, in questo articolo descritti metodi per risolvere questi problemi.

INTRODUZIONE

Questo articolo viene descritto la cache dei moduli di Outlook. Questo articolo viene descritto anche vari problemi di cache di moduli che possono verificarsi in Outlook 2007.

Nota La cache dei moduli di Outlook viene utilizzata per moduli progettati con Outlook 2003 o versioni precedenti e che in genere vengono pubblicati in una libreria di moduli. Outlook 2007 consente di progettare moduli per Outlook 2003 e versioni precedenti. In questo scenario, la cache dei moduli viene utilizzata nello stesso modo in cui la cache dei moduli viene utilizzato nelle versioni precedenti. Tuttavia, Outlook 2007 non utilizza la cache dei moduli con la nuova funzionalitÓ di aree di modulo. Outlook 2007 utilizza solo la cache dei moduli in scenari che implicano le classi di messaggio personalizzato. Se si sta sviluppando un nuovo modulo personalizzato per Outlook 2007, si consiglia di utilizzare la nuova funzionalitÓ area di modulo.

Outlook memorizza una copia locale di un modulo personalizzato in una cache che non necessario recuperare il modulo dal disco ogni volta che viene aperto un elemento. Quando i moduli vengono memorizzati in una cartella pubblica di Microsoft Exchange o nella libreria moduli organizzazione sul computer Exchange Server, Ŕ possibile che Outlook utilizzare la versione di memorizzate nella cache del modulo. Questo consente di migliorare le prestazioni del computer locale e sul server computer.

Possono verificarsi problemi con la cache dei moduli. Questi problemi si verificano solitamente quando si apre un nuovo elemento o un elemento esistente in una cartella. Verranno visualizzati messaggi di errore analoghi ai seguenti:
  • Messaggio 1
    Impossibile visualizzare il modulo desiderato. Contattare l'amministratore.
  • Messaggio 2
    Impossibile visualizzare il modulo necessario per visualizzare questo messaggio. Contattare l'amministratore.
Altri casi, Outlook non verranno visualizzati un messaggio di errore. Invece, Outlook pu˛ aprire un modulo predefinito invece di un modulo personalizzato.

ModalitÓ di ricerca dei moduli

Questa sezione viene descritto il modo Outlook trova il modulo Ŕ obbligatorio quando si apre un elemento. Quando si crea un elemento che utilizza un modulo personalizzato, il campo Classe messaggio dell'elemento Ŕ impostato il nome del modulo. Ad esempio, se si dispone di un modulo attivitÓ personalizzato denominato "Corporate" in una cartella di attivitÓ personalizzato, la classe di messaggio Ŕ IPM.Task.Corporate .

Quando si apre l'elemento, Outlook controlla il campo Classe messaggio per visualizzare il modulo per visualizzare l'elemento necessario utilizzare Outlook. Outlook si cerca quindi il modulo richiesto. Outlook cerca nei percorsi seguenti nell'ordine seguente:
  • Memoria

    Se Ŕ disponibile un altro elemento aprire che utilizza lo stesso modulo, Ŕ ha giÓ il modulo in memoria. Outlook utilizza tale copia del modulo anzichÚ dal ricaricare il modulo.
  • Cache dei moduli

    Outlook controlla nel computer per verificare se il modulo prima Ŕ giÓ stato utilizzato cache dei moduli. Se Outlook trova il modulo nella cache, Outlook carica il modulo dalla cache.
  • Cartella corrente

    Se Outlook non viene trovato il modulo nella cache, Outlook verifica se il modulo Ŕ stato pubblicato nella cartella corrente. Outlook non cerca di altre cartelle. Include le cartelle padre. Outlook memorizza i moduli pubblicati in una cartella come elementi nascosti. Questi elementi non possono essere visualizzati nella visualizzazioni di Outlook.
  • Libreria moduli personale

    Se il modulo non si trova nella cartella corrente, Outlook controlla la libreria moduli personali. I moduli di libreria moduli personali vengono memorizzati come messaggi associati nella cartella nascosta (denominato visualizzazioni comuni) dell'archivio di posta elettronica predefinito. L'archivio di posta elettronica predefinito Ŕ l'insieme di cartelle che contiene la cartella Posta in arrivo che riceve la posta in arrivo.
  • Libreria moduli organizzazione

    Se il modulo non Ŕ disponibile nella libreria moduli personali e si utilizza un computer di Microsoft Exchange Server Ŕ configurato per supportare una libreria moduli organizzazione, Outlook verifica la libreria moduli organizzazione nel computer Microsoft Exchange Server.

Individuare la cache dei moduli

La cache dei moduli Ŕ memorizzata in una cartella nascosta sull'unitÓ disco rigido. ╚ necessario modificare l'impostazione in modo che Microsoft file nascosti e vengono visualizzati i file di sistema. Questa procedura variano a seconda della versione di Windows che si sta utilizzando. ╚ possibile individuare la cache dei moduli nella cartella seguente:
  • Microsoft Windows XP
    \Impostazioni locali\Dati applicazioni\Microsoft\Forms user_name C:\Documents and Settings\
  • Windows Vista
    \AppData\Local\Microsoft\FORMS user_name C:\Users\
Dato che supporta utenti con profilo comune, posizione della cache dei moduli di Outlook 2007 potrebbe cambiare. La posizione della cache di moduli dipende dal quale utente attualmente connesso al computer. Non Ŕ possibile configurare impostazioni utente per indicare la posizione della cache dei moduli. Di conseguenza, non modificare direttamente la posizione della cache dei moduli in un percorso diverso da quello il percorso predefinito.

Comprendere il che architettura della cache dei moduli

importante Questa sezione, metodo o l'attivitÓ sono contenute procedure viene illustrato come modificare il Registro di sistema. Tuttavia, possono causare seri problemi se si modifica il Registro di sistema in modo errato. Pertanto, assicurarsi che questa procedura con attenzione. Per maggiore protezione, Ŕ eseguire il backup del Registro di sistema prima di modificarlo. ╚ quindi possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e ripristino del Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
322756Come eseguire il backup e il ripristino del Registro di sistema in Windows


La cache di form contiene il file Frmcache.dat. Il file Frmcache.dat contiene informazioni di riepilogo e puntatori relativi sia qualsiasi modulo personalizzato consente ai moduli di Outlook predefiniti. Copie dei moduli personalizzati memorizzate nella cache si trovano in sottocartelle della cartella moduli.

Le sottocartelle della cartella Forms hanno nomi casuali. I nomi delle sottocartelle simile, tuttavia, i nomi dei moduli. I moduli memorizzati in queste cartelle sono denominati cryptically. Ma i moduli hanno un'estensione di file tmp. Se non si conosce la cartella contenente la copia di un particolare modulo, Ŕ possibile utilizzare il timestamp della cartella o il timestamp del modulo che consentono di individuare il modulo.

Outlook memorizza inoltre le chiavi che corrispondono ai moduli personalizzati che sono stati memorizzati. Le chiavi di registro di sistema si trovano nel seguente percorso:
HKEY_CURRENT_USER\Software\Classes\CLSID
In Outlook 2002 e nelle versioni precedenti, Outlook non tiene traccia della posizione in cui una maschera proviene da quando il modulo viene memorizzato nella cache. Si supponga, ad esempio, che si dispone di due diversi moduli pubblicati in due cartelle diverse ed entrambi i form con lo stesso nome. Se si accede la prima cartella, Outlook memorizza nella cache il modulo in tale cartella. Quindi, se si accede alla seconda cartella, Ŕ utilizza comunque il modulo memorizzato nella cache dalla prima cartella. Outlook non utilizza il modulo nella seconda cartella. Di conseguenza, ogni nome del modulo o il campo Classe messaggio deve essere univoco in modo che non verifichino conflitti quando si utilizzano i moduli. Questo Ŕ stato la progettazione di moduli cache dopo il rilascio di Microsoft Outlook 97.

La cache dei moduli per Outlook 2003 e Outlook 2007 utilizza un'architettura diversa. Informazioni sulla cartella e dalla libreria dei moduli vengono inoltre memorizzate nella cache. Qualsiasi un problema relativo alla protezione ha portato alla modifica di progettazione. Ad esempio, potrebbe essere dieci cartelle diverse in Outlook 2003. ╚ possibile pubblicare un modulo con lo stesso nome in ognuno di questi dieci cartelle. Nelle versioni precedenti di Outlook, il modulo Ŕ stato memorizzato nella cache una volta e quindi Outlook utilizzato lo stesso modulo dalla cache dei moduli locale ogni volta tutti i form causa lo stesso nome. Tuttavia, in Outlook 2007 memorizza nella cache il modulo da ogni cartella.

A causa di questa modifica della progettazione, si consiglia di pubblicare moduli nella libreria moduli personali anzichÚ in una cartella. Se si elimina un elemento basato su un modulo personalizzato e quindi si apre l'elemento nella cartella Posta eliminata, in Outlook non pu˛ individuare il modulo personalizzato. Outlook utilizza invece il modulo predefinito. Se si pubblicano moduli nella libreria moduli personali, Ŕ possibile evitare questo problema.

Comprendere e modificare le dimensioni della cache di moduli

Per impostazione predefinita, Outlook imposta un limite di 2048 kilobyte (KB) per la dimensione massima della cache dei moduli. Per modificare questa impostazione, attenersi alla seguente procedura:
  1. Scegliere Opzioni dal menu Strumenti .
  2. Scegliere la scheda altro e quindi fare clic su Avanzate .
  3. Fare clic su moduli personalizzati . Nella casella massimo spazio su disco rigido , digitare un numero superiore a 2048 e quindi fare clic su OK .
Dopo che si raggiunge lo spazio massimo impostato per la cache dei moduli, Outlook Elimina il modulo meno recente non utilizzato dalla cache.

Nota Outlook memorizza la dimensione della cache moduli in Frmcache.dat il file. Il formato del file Frmcache.dat non Ŕ documentato. Modifica diretta del file Frmcache.dat non Ŕ supportata. Di conseguenza, non Ŕ possibile modificare a livello di programmazione le dimensioni della cache dei moduli. Microsoft non supporta la modifica diretta a qualsiasi parte del contenuto della cartella Forms che non sia le modifiche Ŕ in sono di documentata da Microsoft o raccomandate dal servizio supporto tecnico clienti Microsoft per la risoluzione dei problemi solo. Prima di modificare il contenuto della cartella Forms, Ŕ necessario renderlo una copia di backup.

Ripristinare i moduli che Ŕ stato eliminato accidentalmente

Se si elimina accidentalmente un modulo pubblicato, e non Ŕ possibile recuperare la maschera dalla cartella che Ŕ stato pubblicato il modulo da, Ŕ possibile ripristinare una copia del modulo la cache dei moduli.

Per ulteriori informazioni su come recuperare un modulo dalla cache dei moduli, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
292494OL2002: Ripristino di un modulo di Outlook da una copia memorizzata nella cache

Risoluzione dei problemi della cache dei moduli

Se la cache dei moduli non sembra funzionare correttamente, o se si verificano problemi quando si aprono elementi oppure quando si apre i moduli personalizzati, altri fattori potrebbero causare il comportamento imprevisto. Utilizzare i metodi di risoluzione dei problemi riportati di seguito prima di eliminare la cache dei moduli.
  • Metodo 1: Verificare che gli articoli utilizzino un modulo one-off

    ╚ possibile memorizzare una definizione di modulo in un elemento anzichÚ in una posizione pubblicata. Se si archiviano una definizione di modulo in un elemento, e quindi si apre l'elemento, il modulo che si utilizza Ŕ sempre quello memorizzato nell'elemento. Se si modifica la versione pubblicata del modulo, l'elemento one-off continuerÓ a utilizzare la versione precedente del modulo memorizzata nell'elemento. Questo potrebbe sembrare un problema con la cache dei moduli. Ma questa Ŕ l'elemento one-off funzionamento.

    Una definizione del modulo Ŕ memorizzata in un elemento pu˛ verificarsi comportamenti imprevisti. Potrebbe causare erroneamente dedurre che il problema riguarda la cache dei moduli.

    Per ulteriori informazioni su come in funzioni di elemento one-off, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
    290657Descrizione delle definizioni dei moduli e moduli one-off in Outlook 2002
  • Metodo 2: Verificare che il problema non sia legati alla memoria

    Outlook non Ŕ possibile che il rilascio di un modulo dalla memoria. Questo problema potrebbe riguardare la modalitÓ di implementazione codice Visual Basic Scripting Edition in un modulo personalizzato. Se Outlook non scarica il modulo dalla memoria, Ŕ necessario chiudere e riavviare Outlook. Questo rimuove il modulo dalla memoria e impone di ricaricare il modulo dalla cache, dalla libreria dei moduli o da una cartella di Outlook.

    ╚ necessario verificare che Outlook venga chiuso. ╚ possibile utilizzare Task Manager di Windows per verificare che Outlook non Ŕ in esecuzione. Tuttavia, si consiglia di riavvio del computer per assicurarsi che il problema non Ŕ legato a qualche elemento che si verifica in memoria.

    Se Outlook non viene chiuso, questa potrebbe essere la causa del problema di cache di moduli. Se il modulo contiene codice Visual Basic Scripting Edition, provare a determinare se qualcosa nel modulo impedisce Outlook uscita. Inoltre, disattivare eventuali componenti aggiuntivi COM o qualsiasi estensione non standard di Microsoft Exchange. Uno di questi pu˛ contribuire a problemi.

Cancellare la cache dei moduli

Esistono vari metodi per cancellare il Outlook cache dei moduli. Ogni metodo presenta vantaggi e svantaggi. Si consiglia di utilizzare il metodo 1.
  • Metodo 1

    Utilizzare il metodo Cancella Cache . Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Dal menu Strumenti , fare clic su Opzioni , quindi sulla scheda altro .
    2. Fare clic su Opzioni avanzate .
    3. Nella casella Opzioni avanzate fare clic su Moduli personalizzati .
    4. Nella casella di Moduli personalizzati fare clic su Gestione moduli .
    5. Nella casella Gestione moduli , fare clic su Cancella Cache .
  • Metodo 2

    Rinominare manualmente o eliminare manualmente specifici componenti della cache che pu˛ causare un problema. Ad esempio, se hai un problema con un modulo specifico, Ŕ possibile avviare eliminando la cartella corrispondente per quel modulo memorizzato nella cache. ╚ consigliabile utilizzare questo metodo solo se si Ŕ un utente avanzato.
  • Metodo 3

    Rinominare il file Frmcache.dat. In caso contrario come il primo tentativo per risolvere un problema con la cache dei moduli, in quanto il file Frmcache.dat potrebbe contenere informazioni su altre forme. Tuttavia, se le altre iniziative di cancellare la cache dei moduli non hanno esito positivo, Ŕ possibile rinominare il file Frmcache.dat. Dopo avere rinominato il file Frmcache.dat, riavviare Outlook.
  • Metodo 4

    Provare a utilizzare le chiavi di registro. Le chiavi di registro di sistema si trovano nel seguente percorso:
    HKEY_CURRENT_USER\Software\Classes\CLSID
    In genere, le chiavi di registro non vengono riprodotti un ruolo nel form problemi della cache. Ma contengono informazioni sui moduli memorizzati nella cache. Se tutte le altre attivitÓ per correggere un modulo di problema non hanno esito positivo, Ŕ possibile verificare che in questa sezione del Registro di sistema vengono fornite informazioni relative al modulo. ╚ possibile rimuovere le informazioni del modulo e quindi riavviare Outlook.

Utilizzare la chiave del Registro di sistema di ForceFormReload

Quando Ŕ Impossibile determinare la causa dei problemi e la cache dei moduli sembra causare problemi in modo discontinuo, Ŕ possibile impostare la chiave di registro
ForceFormReload
in Outlook. Quando si verifica un errore quando Outlook viene aperto un elemento a cui si basa un modulo personalizzato e la chiave di registro
ForceFormReload
Ŕ attivata, in Outlook viene automaticamente Cancella la cache per il modulo specifico. Quindi, Outlook tenta di aprire nuovamente l'elemento. Sebbene questo metodo non risolve la causa del problema della cache moduli, questo metodo rendere trasparente il problema agli utenti che utilizzano moduli personalizzati.

Per attivare la funzionalitÓ chiave di registro
ForceFormReload
, attenersi alla seguente procedura:
  1. Avviare l'editor del Registro di sistema.
  2. Nel Registro di sistema, selezionare la seguente chiave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\12.0\Outlook
  3. Scegliere dal menu Modifica , Aggiungi valore , quindi aggiungere il seguente valore del Registro di sistema:
    Riduci questa tabellaEspandi questa tabella
    Nome valore ForceFormReload
    Tipo di datiREG_DWORD
    Dati valore1
  4. Uscire dall'editor del Registro di sistema.

    Nota Questa funzionalitÓ Ŕ disponibile in Outlook 2000 e Outlook 2002 se si dispone di installati i service pack pi¨ recente. Questa funzionalitÓ Ŕ anche disponibile nella versione originale di Outlook 2003.

    Per ulteriori informazioni su come ottenere i service pack pi¨ recente, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportato di seguito:
    285129Messaggio di errore: "Impossibile visualizzare il modulo Ŕ stato selezionato"
    305403OL2002: Messaggio di errore: il modulo Ŕ stato selezionato... non pu˛ essere visualizzato, contattare l'amministratore

Risolvere i problemi che si verificano quando si apre un elemento basato su un modulo personalizzato specifico

Se un problema si verifica quando si tenta di aprire un elemento a cui si basa un modulo personalizzato specifico, il problema potrebbe essere correlato per tale modulo specifico e non per la cache dei moduli stesso. I metodi riportati di seguito Ŕ descrivere come problemi con un modulo specifico. ╚ necessario eseguire i metodi nell'ordine in cui sono elencate.
  • Metodo 1

    Disattiva nel modulo di codice personalizzato Visual Basic Scripting Edition. Ci˛ potrebbe indicare che il problema Ŕ correlato al codice di Visual Basic Scripting Edition. Per disattivare il codice, tenere premuto il tasto MAIUSC quando si apre un elemento di controllo. Ci˛ impedisce il codice di Visual Basic Scripting Edition in esecuzione.
  • Metodo 2

    Rimuovere tutti i controlli dalle pagine di modulo. Controlli personalizzati nel modulo potrebbero verificarsi problemi durante l'inizializzazione e potrebbero impedire l'apertura di un modulo di Outlook. Impossibile aprire un modulo in presenza di una delle seguenti condizioni:
    • I controlli personalizzati non sono installati sul computer locale.
    • La chiave di registro di sistema Gestione licenze non Ŕ corretta.
    Per eseguire questo metodo, attenersi alla seguente procedura:
    1. Aprire il modulo in modalitÓ progettazione.
    2. Rimuovere tutti i controlli dalle pagine di modulo.
    3. Pubblicare nuovamente il modulo con un nome diverso.
    4. Provare ad aprire un nuovo elemento che si basa il modulo appena pubblicato.
    Se questo metodo consente di risolvere il problema, con i controlli esiste un problema.
  • Metodo 3

    Rimuovere tutti i campi personalizzati da un modulo. Problemi potrebbero essere correlati ai campi in un form. Campi possono contenere formule. Queste formule Ŕ possono creare riferimenti circolari che possono causare problemi di prestazioni o altri problemi che possono influenzare il modo in cui la maschera viene aperta. Non Ŕ comune. Ma se si sospetta che una maschera potrebbe essere danneggiata, rimuovere tutti i campi personalizzati dal modulo. Quindi, pubblicare il modulo con un nome diverso per il test.

ProprietÓ

Identificativo articolo: 919596 - Ultima modifica: lunedý 2 marzo 2009 - Revisione: 2.1
Le informazioni in questo articolo si applicano a:
  • Microsoft Office Outlook 2007
Chiavi:á
kbmt kbproductlink kbexpertiseinter kbhowto KB919596 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 919596
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com