Jak program Outlook 2007 używa pamięci podręcznej formularzy oraz jak rozwiązywać problemy z pamięci podręcznej formularzy

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 919596 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Streszczenie

W tym artykule opisano sposób że Microsoft Office Outlook 2007 lokalizuje formularzy, w którym znajduje się pamięci podręcznej formularzy, jak zmienić rozmiar pamięci podręcznej formularzy i sposobu używania klucza rejestru ForceFormReload. W tym artykule opisano również pewne problemy, które mogą wystąpić w pamięci podręcznej formularzy programu Outlook. Ponadto w tym artykule opisano sposoby rozwiązywania tych problemów.

WPROWADZENIE

W tym artykule opisano pamięć podręczną formularzy programu Outlook. W tym artykule opisano również różne problemy pamięci podręcznej formularzy, które mogą wystąpić w programie Outlook 2007.

Uwaga Pamięć podręczna formularzy programu Outlook jest używany w przypadku formularzy, które zostały zaprojektowane z programu Outlook 2003 lub starszych wersjach i zwykle publikowane w bibliotece formularzy. Program Outlook 2007 umożliwia również projektowanie formularzy dla programu Outlook 2003 i wcześniejszych wersjach. W tym scenariuszu pamięć podręczna formularzy jest używany w taki sam sposób, jak pamięć podręczna formularzy jest używana w starszych wersjach. Jednak program Outlook 2007 nie używa pamięci podręcznej formularzy dzięki nowej funkcji regionów formularza. Program Outlook 2007 używa tylko pamięć podręczna formularzy w scenariuszy, które wymagają klasy niestandardowej wiadomości. Jeśli tworzysz nowy niestandardowy formularz programu Outlook 2007, firma Microsoft zaleca korzystania z niego regionu formularza.

Program Outlook przechowuje w pamięci podręcznej lokalnej kopii formularza niestandardowego, tak aby program Outlook nie ma pobrać formularza z dysku, ilekroć dany element jest otwarty. Kiedy formularze są przechowywane w folderze publicznym Microsoft Exchange lub w bibliotece formularzy organizacyjnych na komputerze Exchange Server, program Outlook można użyć buforowanej wersji formularza. Dzięki temu ulega poprawie wydajności na komputerze lokalnym i na komputerze Exchange Server.

Mogą występować problemy z pamięcią podręczną formularzy. Te problemy występują zazwyczaj po otwarciu nowy element lub istniejący element w folderze. Może pojawić się jeden z następujących komunikatów o błędach:
  • Komunikat 1
    Nie można wyświetlić wybranego formularza. Skontaktuj się z administratorem.
  • Wiadomości 2
    Nie można wyświetlić formularza wymaganego do wyświetlenia tej wiadomości. Skontaktuj się z administratorem.
Innym razem program Outlook może być wyświetlany komunikat o błędzie. Zamiast tego program Outlook może otworzyć formularza domyślnego zamiast formularza niestandardowego.

Jak program Outlook lokalizuje formularzy

W tej sekcji opisano, jak Outlook lokalizuje formularza, który jest wymagany podczas otwierania elementu. Po utworzeniu elementu, który używa formularza niestandardowego pola Klasa wiadomości dla elementu ustawiono nazwę formularza. Na przykład jeśli masz formularza niestandardowego zadania o nazwie "Corporate" w folderze zadania niestandardowego, klasa wiadomości jest IPM.Task.Corporate.

Podczas otwierania elementu programu Outlook sprawdza pole Klasy wiadomości , aby zobaczyć jakie formularz programu Outlook należy użyć, aby wyświetlić element. Program Outlook wyszukuje następnie wymaganej formie. Program Outlook wyszukuje w następujących lokalizacjach w następującej kolejności:
  • Pamięci

    Jeśli masz inny przedmiot, otwórz ten usesthe takie same tworzą, programu Outlook już ma postać w pamięci. Program Outlook używa tej copyof formularzu zamiast ponownego ładowania formularza.
  • Pamięć podręczna formularzy

    Program Outlook sprawdza pamięć podręczna formularzy na thecomputer, aby zobaczyć, czy użyto formularza przed. Jeśli program Outlook lokalizuje formin pamięci podręcznej, program Outlook ładuje formularz z pamięci podręcznej.
  • Bieżący folder

    Jeśli program Outlook nie może znaleźć formin pamięci podręcznej, program Outlook sprawdza, czy formularz został opublikowany na currentfolder. Program Outlook nie wyszukuje inne foldery. Obejmuje to folderów nadrzędnych.Program Outlook przechowuje formularzy, które są publikowane w folderze jako ukryte elementy. Theseitems nie widać w żadnym z widoków programu Outlook.
  • Biblioteka formularzy osobistych

    Jeśli formularz nie znajduje się w bieżącym folderze, program Outlook sprawdza Biblioteka formularzy osobistych. Formularzy z biblioteki formularzy osobistych są przechowywane jako związane z nimi informacje w ukrytym folderze (nazywane Typowe widoki) domyślnego magazynu poczty. Domyślny magazyn poczty to zbiór folderów zawierających folderu Skrzynka odbiorcza, który odbiera pocztę przychodzącą.
  • Biblioteka formularzy organizacyjnych

    Jeśli isunavailable formularz w bibliotece formularzy osobistych i z komputera serwera MicrosoftExchange, który jest skonfigurowany do obsługi Biblioteka formularzy organizacyjnych, program Outlook sprawdza następnie biblioteka formularzy organizacyjnych na komputerze ExchangeServer firmy Microsoft.

Zlokalizuj pamięć podręczna formularzy

Pamięć podręczna formularzy są przechowywane w ukrytym folderze na dysku twardym. Musisz zmienić ustawienie, tak że Microsoft Windows zawiera plików ukrytych i plików systemowych. Kroki te różnią się w zależności od wersji systemu Windows, którego używasz. Pamięć podręczna formularzy może zlokalizować w następującym folderze:
  • Microsoft Windows XP
    C:\Documents and Settings\nazwa_użytkownika\Local aplikacji\Microsoft\Forms
  • system Windows Vista
    C:\Users\nazwa_użytkownika\AppData\Local\Microsoft\FORMS
Ponieważ program Outlook 2007 obsługuje użytkowników mobilnych, może zmienić lokalizację pamięci podręcznej formularzy. Lokalizacja pamięci podręcznej formularzy zależy od tego, co użytkownik jest aktualnie zalogowany do komputera. Nie można skonfigurować ustawienia użytkownika, aby wskazać, gdzie znajduje się pamięci podręcznej formularzy. W związku z tym nie można bezpośrednio zmienić lokalizację pamięci podręcznej formularzy do lokalizacji innej niż domyślna.

Mieć owiadomooć, że architektura pamięć podręczna formularzy

Ważne Niniejszej sekcji, metodzie lub zadanie zawiera kroki dotyczące modyfikowania rejestru. Jednak niepoprawne zmodyfikowanie rejestru może spowodować poważne problemy. W związku z tym wykonaj następujące kroki ostrożnie. W celu dodatkowej ochrony wykonaj kopię zapasową rejestru przed przystąpieniem do modyfikacji. Dzięki temu można przywrócić rejestr w przypadku wystąpienia problemu. Aby uzyskać więcej informacji na temat wykonywania kopii zapasowej i przywracania rejestru kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
322756 Jak wykonać kopię zapasową i przywrócić rejestr w systemie Windows


Pamięć podręczna formularzy zawiera plik Frmcache.dat. Plik Frmcache.dat zawiera informacje podsumowujące i łącza do zarówno domyślne formularze programu Outlook, jak i niestandardowych formularzy, których używasz. Buforowane kopie formularzy niestandardowych znajdują się w podfolderach folderu formularzy.

Podfoldery folderu Formularze mają nazwy losowe. Jednakże nazwy podfolderów przypominają nazwy formularzy. Tajemniczo noszą nazwy rzeczywistych formularzy, które są przechowywane w tych folderach. Ale formularze mają rozszerzenie nazwy pliku .tmp. Jeśli nie znasz folder zawierający kopię określonego formularza, aby zlokalizować formularza można użyć sygnatura czasowa folderu lub sygnatura czasowa formularza.

Program Outlook przechowuje klucze rejestru, które odpowiadają niestandardowych formularzy, które były buforowane. Klucze rejestru znajdują się w następującej lokalizacji:
HKEY_CURRENT_USER\Software\Classes\CLSID
W programie Outlook 2002 i starszych wersjach programu Outlook nie śledzić ilość miejsca, gdzie formularz pochodzi od, gdy formularz jest buforowany. Załóżmy na przykład, że dwie różne formy, które są publikowane w dwóch różnych folderach, a oba formularze mają taką samą nazwę. Jeśli pierwszy folder jest dostęp, program Outlook przechowuje w pamięci podręcznej formularza w tym folderze. Następnie, jeśli dostęp inny folder, program Outlook używa nadal kopia formularza z pierwszego folderu. Program Outlook nie korzysta z formularza, który znajduje się w drugim folderze. W związku z tym co nazwa formularza lub pole Klasy wiadomości musi być unikatowa, aby używać formularzy nie występują konflikty. Zostało to projektowanie pamięci podręcznej formularzy od czasu wydania programu Microsoft Outlook 97.

Pamięć podręczna formularzy dla programu Outlook 2003 i Outlook 2007 korzysta z innego projektu. Informacje o folderze i Biblioteka formularzy jest również buforowany. Kwestii związanych z bezpieczeństwem doprowadziło do zmiany projektu. Na przykład może być dziesięciu różnych folderów w programie Outlook 2003. W każdym z tych folderów dziesięciu może opublikować formularz o tej samej nazwie. W starszych wersjach programu Outlook formularz był buforowanych jeden raz, a następnie program Outlook użyć tego samego formularza z pamięci podręcznej lokalne formularze zawsze, ponieważ wszystkie formularze mają taką samą nazwę. Jednak program Outlook 2007 buforuje formularza z każdego folderu.

Z powodu tej zmiany w projekcie zaleca się Publikuj formularze w bibliotece formularzy osobistych zamiast do folderu. Jeśli usunięcie elementu na podstawie formularza niestandardowego, a następnie otwórz element w folderze Elementy usunięte, program Outlook nie może zlokalizować formularza niestandardowego. Zamiast tego program Outlook używa domyślnego formularza. Jeśli opublikować formularzy w bibliotece formularzy osobistych, można uniknąć tego problemu.

Zrozumieć i zmień rozmiar pamięci podręcznej formularzy

Domyślnie program Outlook ustawia limit 2048 kilobajtów (KB) dla maksymalnego rozmiaru pamięci podręcznej formularzy. Aby zmienić to ustawienie, wykonaj następujące kroki:
  1. W menu Narzędzia kliknij polecenieOpcje.
  2. Kliknij kartę inne , a następnie kliknij przyciskOpcje zaawansowane.
  3. Kliknij przycisk Formularze niestandardowe. W obszarze Maximumspace na dysku twardym, wpisz liczbę większą, niż 2048, a następnie kliknij przycisk OK.
Po osiągnięciu maksymalna ilość miejsca dla pamięci podręcznej formularzy programu Outlook usuwa najstarsze nieużywane formularza z pamięci podręcznej.

Uwaga Program Outlook przechowuje rozmiar pamięci podręcznej formularzy w plik Frmcache.dat. Format plik Frmcache.dat jest nieudokumentowane. Plik Frmcache.dat bezpośredniej modyfikacji nie jest obsługiwane. W związku z tym nie można programowo zmienić rozmiar pamięci podręcznej formularzy. Microsoft nie obsługuje bezpośredniej modyfikacji do jakiejkolwiek części zawartości folderu formularzy, o ile takie zmiany są udokumentowane przez firmę Microsoft lub zalecanych przez Centrum pomocy technicznej firmy Microsoft do rozwiązywania problemów tylko. Przed zmodyfikowaniem zawartość folderu formularzy, musi najpierw zaciągnąć kopii zapasowej.

Odzyskać formularze, które zostały przypadkowo usunięte

Jeśli przypadkowo usuniesz opublikowanego formularza, a nie można odzyskać tego formularza z folderu, który formularz został opublikowany z, można spróbować odzyskać kopię formularza z pamięci podręcznej formularzy.

Aby uzyskać więcej informacji o tym, jak odzyskać formularza z pamięci podręcznej formularzy, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
292494 OL2002: Przywracanie z kopii buforowanej formularz programu Outlook

Rozwiązywanie problemów z pamięci podręcznej formularzy

Jeśli pamięć podręczna formularzy nie wydaje się funkcjonować poprawnie, lub jeśli masz problemy podczas otwierania elementów lub podczas otwierania formularzy niestandardowych, inne czynniki mogą być przyczyną nieoczekiwanego zachowania. Przed usunięciem pamięci podręcznej formularzy, należy skorzystać z następujących metod rozwiązywania problemów.
  • Metoda 1: Sprawdź, czy elementy pomocą jednorazowy formularza

    Definicji formularza można przechowywać w element, a nie w publishedlocation. Jeśli przechowywania definicji formularza w elemencie, a następnie otwórz theitem, formularz, którego można używać zawsze jest formularz, który jest przechowywany w elemencie.Jeśli zmienisz opublikowaną wersję formularza, jednorazowe itemcontinues do używania starszej wersji formularza, która jest przechowywana w elemencie.To może wydawać się problem z pamięci podręcznej formularzy. Ale to jak theone-off element działa.

    Definicji formularza, przechowywaną w maycause element nieoczekiwane zachowanie. To może spowodować niepoprawnie zakładają, że yourproblem jest powiązana z pamięci podręcznej formularzy.

    Aby uzyskać więcej informacji o tym, jak funkcje jednorazowe elementu, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
    290657 Opis definicji formularza i formularzach typu one-off w programie Outlook 2002
  • Metoda 2: Sprawdź, czy problem nie jest związanych z pamięcią

    Program Outlook nie może zwolnić formularza z pamięci. Ten problem może berelated sposób implementacji kodu języka Visual Basic Scripting Edition w postaci acustom. Jeśli program Outlook nie spowoduje usunięcia formularza z pamięci, może mieć toexit i uruchom ponownie program Outlook. Spowoduje to usunięcie formularza z pamięci i forcesOutlook ponownie ładować formularza z pamięci podręcznej, biblioteka formularzy lub katalog, w którym.

    Należy sprawdzić, czy program Outlook kończy pracę. Aby sprawdzić, czy program Outlook nie jest uruchomiony, można użyć Menedżera zadań Microsoft Windows. Jednakże werecommend, uruchom ponownie komputer, aby upewnić się, że problem jest notrelated do czegoś, który występuje w pamięci.

    Jeśli program Outlook nie istnieje, może to być przyczyną problemu pamięci podręcznej formularzy. Jeśli formularz zawiera kod języka Visual Basic Scripting Edition, spróbuj określić, czy coś w theform zapobiega Outlook zamykania. Ponadto wyłączyć wszystkie dodatki COM lub rozszerzenia programu Microsoft Exchange anynon standard. Każda z tych mogą przyczyniać się do problemów.

Wyczyść pamięć podręczną formularzy

Istnieją różne metody, aby wyczyścić pamięć podręczną formularzy programu Outlook. Każda metoda ma wady i zalety. Firma Microsoft zaleca użycie metody 1.
  • Metoda 1

    Użyj metody Wyczyść pamięć podręczną . Aby to zrobić, wykonaj następujące kroki:
    1. W menu Narzędzia kliknij polecenie Opcje, a następnie kliknij kartę inne .
    2. Kliknij przycisk Opcje zaawansowane.
    3. W oknie dialogowym Opcje zaawansowane kliknij przycisk Formularze niestandardowe.
    4. W polu Formularze niestandardowe kliknij przycisk Zarządzaj formularzami.
    5. W polu Menedżer formularzy kliknij przycisk Wyczyść pamięć podręczną.
  • Metoda 2

    Ręczna zmiana nazw lub ręcznie deletespecific składniki pamięci podręcznej, które może być przyczyną problemu. Na przykład ifyou występuje problem z określonym formularzem, można uruchomić poprzez usunięcie folderu odpowiadających im dla tej pamięci podręcznej formularza. Zaleca się tylko używać ta metoda Jeśli jesteś zaawansowanym użytkownikiem.
  • Metoda 3

    Zmień plik Frmcache.dat. Czy nie dothis jako pierwsza próba rozwiązania problemu z pamięci podręcznej formularzy, ponieważ plik Frmcache.dat mogą zawierać informacje na temat innych metod. Jednakże ifyour inne wysiłki, aby wyczyścić pamięć podręczną formularzy się nie uda, może renamethe plik Frmcache.dat. Po zmianie nazwy plik Frmcache.dat, uruchom ponownie program Outlook.
  • Metoda 4

    Zbadanie kluczy rejestru. Theregistry klucze są w następującej lokalizacji:
    HKEY_CURRENT_USER\Software\Classes\CLSID
    Zazwyczaj klucze rejestru nie odgrywa rolę w cacheproblems formularzy. Ale zawierają one informacji o pamięci podręcznej formularzy. Jeśli wszystkie otherefforts na odpowiednim formularzu problem się nie uda, można sprawdzić, że wtym rozdziale rejestru zawiera informacje o formularzu. Można usunąć theinformation o formularzu, a następnie uruchom ponownie program Outlook.

Użyj klucza rejestru ForceFormReload

Gdy pamięć podręczna formularzy wydaje się być przyczyną problemów w sposób przerywany i nie można ustalić przyczynę problemów, można ustawić
ForceFormReload
klucz rejestru w programie Outlook. Gdy
ForceFormReload
klucz rejestru jest włączony i Outlook wystąpi błąd, gdy towar, który jest oparty na formularzu niestandardowe otwierane w programie Outlook, program Outlook automatycznie czyści pamięć podręczną dla tego konkretnego formularza. Program Outlook próbuje następnie, ponownie otwórz element. Chociaż metoda ta nie spowoduje rozwiązania przyczyną problemu pamięci podręcznej formularzy, ta metoda przezroczystego problem do osób używających formularzy niestandardowych.

Aby włączyć
ForceFormReload
Rejestr najważniejsze funkcje, wykonaj następujące kroki:
  1. Uruchom Edytor rejestru.
  2. W rejestrze kliknij następujący klucz:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\12.0\Outlook
  3. W menu Edycja kliknij polecenie AddValue, a następnie dodaj następującą wartość rejestru:
    Zwiń tę tabelęRozwiń tę tabelę
    Nazwa wartości Typ danychDane wartości
    ForceFormReloadREG_DWORD1
  4. Zamknij Edytor rejestru.

    Uwaga Ta funkcja jest dostępna w programie Outlook 2000 i programu Outlook 2002, jeśli masz najnowsze dodatki service Pack zainstalowane. Ta funkcja jest alsoavailable w oryginalnej wersji programu Outlook 2003.

    Aby uzyskać więcej informacji dotyczących sposobu uzyskiwania najnowszych dodatków service pack kliknij następujące numery artykułów w celu wyświetlenia tych artykułów z bazy wiedzy Microsoft Knowledge Base:
    285129 Komunikat o błędzie: "nie można wyświetlić wybranego formularza"
    305403 OL2002: Komunikat o błędzie: formularz wybrany... nie może być wyświetlany, skontaktuj się z administratorem

Rozwiązywania problemów występujących podczas otwierania towar, który jest oparty na konkretnych formularza niestandardowego

Jeśli problem występuje, gdy użytkownik próbuje otworzyć element, który jest oparty na konkretnych formularza niestandardowego, problem może być związany tego konkretnego formularza, a nie sama pamięć podręczna formularzy. Następujące metody opisano sposoby rozwiązywania problemów z określonym formularzem. Należy wykonać metody w kolejności, w jakiej są one wymienione.
  • Metoda 1

    Wyłączanie niestandardowego kodu Visual BasicScripting Edition w formularzu. Może to oznaczać, że problemis związanych z kodem języka Visual Basic Scripting Edition. Aby wyłączyć kod, przytrzymaj wciśnięty klawisz SHIFT podczas otwierania elementu. Zapobiega to kod Visual BasicScripting Edition z systemem.
  • Metoda 2

    Usuń wszystkie formanty ze wszystkich stron theform. Niestandardowe formanty formularza mogą wystąpić problemy inicjowania i mayprevent Outlook otwieranie formularza. Program Outlook nie może otworzyć formularza, jeśli jest spełniony jeden z następujących warunków:
    • Niestandardowe formanty nie są zainstalowane na komputerze lokalnym.
    • Klucz rejestru licencjonowania jest niepoprawna.
    Aby zastosować tę metodę, wykonaj następujące kroki:
    1. Otwórz formularz w trybie projektowania.
    2. Usuń wszystkie formanty ze wszystkich stron formularza.
    3. Ponownie opublikować formularz pod inną nazwą.
    4. Spróbuj otworzyć nowy element, który jest oparty na nowo opublikowany formularz.
    Jeśli ta metoda rozwiąże problem, istnieje problem z kontroli.
  • Metoda 3

    Usuń wszystkie pola niestandardowe z aform. Problemy mogą być związane z polami w formularzu. Pola można containformulas. Te formuły mogą tworzyć odwołań cyklicznych, które można causeperformance problemy lub inne problemy, które mogą wpływać na sposób że formopens. To nie jest powszechne. Ale jeśli podejrzewasz, że formularz może być uszkodzony, usunąć wszystkie niestandardowe pola formularza. Następnie opublikować formularz o nazwie adifferent do testowania.

Właściwości

Numer ID artykułu: 919596 - Ostatnia weryfikacja: 19 listopada 2013 - Weryfikacja: 4.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Office Outlook 2007
Słowa kluczowe: 
kbproductlink kbexpertiseinter kbhowto kbmt KB919596 KbMtpl
Przetłumaczone maszynowo
WAŻNE: Ten artykuł został przetłumaczony przy użyciu oprogramowania firmy Microsoft do tłumaczenia maszynowego i może być poprawiony przy użyciu technologii Community Translation Framework (CTF). Firma Microsoft udostępnia artykuły tłumaczone maszynowo, poprawione przez społeczność, a także tłumaczone przez tłumaczy profesjonalnych, aby zapewnić dostęp do wszystkich artykułów w bazie wiedzy w wielu językach. Artykuły tłumaczone maszynowo i poprawione mogą zawierać błędy pisowni, składniowe i gramatyczne. Firma Microsoft nie ponosi odpowiedzialności za żadne nieścisłości, błędy ani szkody spowodowane przez niepoprawne tłumaczenia zawartości ani przez korzystanie z niej przez klientów. Więcej o strukturze CTF: http://support.microsoft.com/gp/machine-translation-corrections/pl.
Anglojęzyczna wersja tego artykułu to: 919596

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com