Article ID: 920127 - Last Review: September 7, 2006 - Revision: 1.2

Certain post-callout objects do not respond to the events for which the post-callout objects are registered in Microsoft Dynamics CRM 3.0

Expand all | Collapse all

SYMPTOMS

In Microsoft Dynamics CRM 3.0, certain post-callout objects do not respond to the events for which the post-callout objects are registered. This problem occurs after you upgrade Microsoft Business Solutions - CRM 1.0 or Microsoft CRM 1.2 to Microsoft CRM 3.0 and then apply post-callout objects that were created in Microsoft CRM 1.0 or in Microsoft CRM 1.2.

CAUSE

This problem occurs because existing post-callout objects that you created in Microsoft CRM 1.0 or in Microsoft CRM 1.2 are disabled during the upgrade to Microsoft CRM 3.0.

RESOLUTION

To resolve this problem, reenable the post-callout objects that you created in Microsoft CRM 1.0 or in Microsoft CRM 1.2. To do this, run the following Microsoft SQL Server script against the Microsoft CRM Metabase database.
UPDATE EntityEventSubscriber
SET IsEnable=1
WHERE SubscriberId
IN (SELECT SubscriberId From Subscriber Where Name != 'Microsoft CRM Integration module')
Notes
  • Before you run the script, make sure that you back up this database.
  • This script will reactivate post-callout objects that were created in Microsoft CRM 1.0 or in Microsoft CRM 1.2. However, if the post-callout objects are related to the Microsoft CRM Integration for Great Plains, the objects are not reactivated.

MORE INFORMATION

The callout model in Microsoft CRM 1.0 and in Microsoft CRM 1.2 differs from the callout model in Microsoft CRM 3.0. However, post-callout objects that you created in earlier versions of Microsoft CRM are supported in Microsoft CRM 3.0 if the post-callout objects use the classes that Microsoft CRM 3.0 supports. However, you do have to reenable the post-callout objects after you upgrade to Microsoft CRM 3.0.

APPLIES TO
  • Microsoft Dynamics CRM 3.0
Keywords: 
kbmbscrm40no kbtshoot kbmbsadministration kbmbsmigrate kbprb KB920127
 

Article Translations

 

Related Support Centers