Messaggio di errore quando si importa un catalogo in Commerce Server 2007 in un computer: "il catalogo prodotti non importato correttamente"

Traduzione articoli Traduzione articoli
Identificativo articolo: 920867 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si utilizza Microsoft Commerce Server 2007 Catalog Manager per importare un catalogo in un computer basato su Microsoft Windows XP, viene potrebbe essere visualizzato il seguente messaggio di errore nella finestra di dialogo Importazione catalogo prodotti :
Eccezione: Errore durante sul server durante l'operazione. Ritentare l'operazione o contattare l'amministratore se l'errore persiste. I dettagli dell'errore sono presenti nel registro eventi sul server.
Attività da completare:
Il catalogo prodotti non è stato importato correttamente.
Inoltre, il seguente evento viene registrato nel registro applicazione:

Tipo evento: errore
Origine evento: Servizi Web di Commerce Server
Categoria evento: nessuna
ID evento: 1
Data:
Ora:
Utente:
Computer:
Descrizione:
Eccezione nel servizio Web "CatalogWebService". Attenersi alla seguente i dettagli relativi alle eccezioni:

System.ArgumentException: Valore non rientra nell'intervallo previsto.

Traccia di stack del server:
in Microsoft.CommerceServer.Catalog.ICatalogImport.WebServiceImport (String siteName, GUID token, inventoryImport Boolean, String importOptionsXml, ignoreInventorySystem Boolean, string userName, authorizationPolicyPath String)
in System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage (IntPtr md, Object [] args, server oggetti, methodPtr Int32, Boolean fExecuteInContext, Object [] & outArgs)
in System.Runtime.Remoting.Messaging.StackBuilderSink.PrivateProcessMessage (RuntimeMethodHandle md, Object [] args, server oggetti, methodPtr Int32, Boolean fExecuteInContext, Object [] & outArgs)
in System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage (IMessage msg, methodPtr Int32, Boolean fExecuteInContext)

Eccezione generata di nuovo a [0]:
in System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage (IMessage reqMsg, IMessage retMsg)
in System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke (MessageData & msgData, tipo Int32)
in Microsoft.CommerceServer.Catalog.ICatalogImport.WebServiceImport (String siteName, GUID token, inventoryImport Boolean, String importOptionsXmsl, ignoreInventorySystem Boolean, string userName, authorizationPolicyPath String)
in Microsoft.CommerceServer.Catalog.Internal.CatalogServerContextBase.Import (importOptions OpzioniImportazione token, GUID)

Per ulteriori informazioni, vedere la Guida in linea e supporto tecnico all'indirizzo http://support.microsoft.com.

Cause

Questo problema si verifica a causa di un problema la rappresentazione in Windows XP.

Risoluzione

Informazioni sull'hotfix

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si è notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, è necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.

Prerequisiti

Non è richiesto alcun prerequisito.

Necessità di riavvio

È necessario riavviare il computer dopo aver applicato questo hotfix.

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Date e ore dei file sono elencate di in ora UTC (UTC). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello data e ora nel Pannello di controllo.
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensioni fileDataOraPiattaforma
Authz.dll5.1.2600.292562,46408-06-200611: 07x 86

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a".

Informazioni

Per ulteriori informazioni sulla terminologia utilizzati in questo articolo, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Proprietà

Identificativo articolo: 920867 - Ultima modifica: mercoledì 29 agosto 2007 - Revisione: 3.1
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Commerce Server 2007 Developer Edition
Chiavi: 
kbmt kbautohotfix kberrmsg kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug kbhotfixserver kbqfe kbpubtypekc KB920867 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 920867
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com