Problemas que pueden producirse en un equipo basado en Microsoft Windows Small Business Server 2003 después de quitar una instancia de MSDE 2000 SP4, una instancia de SP4 de SQL Server 2000 Desktop Engine (Windows) o una instancia de SQL Server 2000 SP4

Seleccione idioma Seleccione idioma
Id. de artículo: 920899 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Tenga en cuenta la situación siguiente. Quitar una instancia de Microsoft SQL Server 2000 Service Pack 4 (SP4) en un equipo basado en Microsoft Windows Small Business Server 2003. A continuación, todas las instancias de Microsoft SQL Server Desktop Engine (también conocido como MSDE 2000) y las instancias de SQL Server Desktop Engine (Windows) pueden dejar de responder en el equipo.

En este escenario, puede experimentar uno o varios de los síntomas siguientes:
  • No puede conectar con el sitio Web de Microsoft Windows SharePoint Services companyweb. Además, cuando intenta abrir el sitio Web, recibirá el siguiente mensaje de error:
    No puede conectarse a la base de datos de configuración.
  • En el registro de aplicación, también puede recibir mensajes de error similar al siguiente:
    Tipo de suceso: error
    Origen del suceso: Windows SharePoint Services 2.0
    Categoría del suceso: ninguna
    ID. de suceso: 1000
    Fecha: 11/1/2005
    Hora: 5:34:37 P.M.
    Usuario: N/d
    Equipo: ServerName
    Descripción: # 50070: no se puede conectar a la base de datos STS_Config \SharePoint ServerName. Compruebe la información de conexión de base de datos y asegúrese de que el servidor de base de datos se está ejecutando.
    Tipo de suceso: error
    Origen del suceso: Actualización de Windows Server
    Categoría del suceso: Servicios de actualización
    ID. de suceso: 421
    Fecha: 11/1/2005
    Hora: 5:34:37 P.M.
    Usuario: N/d
    Equipo: ServerName
    Descripción: Error de conexión a base de datos. Motivo = SQL Server no existe o acceso denegado. Cadena de conexión: origen de datos = ServerName \WSUS;Initial catálogo = SUSDB; Connection Timeout = 60; nombre de la aplicación = conexión de SQL de WSUS; Trusted_Connection = Yes; agrupación = ? true; ? Max Pool Size = 100
    Tipo de suceso: error
    Origen del suceso: Firewall de Microsoft
    Categoría del suceso: registro
    ID. de suceso: 7
    Fecha: 11/1/2005
    Hora: 5:34:37 P.M.
    Usuario: N/d
    Equipo: ServerName
    Microsoft Firewall no pudo abrir la conexión ADO. La descripción de error de MSDE es: atributo de cadena de conexión no válido. [DBNETLIB][ConnectionOpen (Connect()).]SQL Server no existe o acceso denegado. Para obtener más información acerca de este suceso, vea la Ayuda del servidor ISA.
  • El complemento MMC de informes y Windows Small Business 2003 supervisión del servidor no funciona como se esperaba. Informes no pueden contener la información esperada.
  • Si está instalado Microsoft Windows Server Update Services (WSUS) como en Windows Small Business Server 2003 R2, la funcionalidad de actualización dejará de funcionar.
  • Si está instalado Microsoft Internet Security and Acceleration (ISA) Server 2004, los equipos cliente no podrán tener acceso a Internet o los recursos de servidor. Esto incluye las conexiones entrantes y salientes.
  • El servicio pueden fallar copias (instantáneas).
  • Copias de seguridad que utilizar el programa NTBACKUP pueden incluir advertencias. Copias de seguridad del estado del sistema no funcionen.
  • El comando VSSADMIN LIST ESCRITORES puede tardar mucho.
  • Otros programas que utilizan un SQL Server termina de base de datos, como por ejemplo, Microsoft Small Business Accounting, pueden dejar de funcionar.
Además, considere la situación siguiente. Realizar una o varias de las siguientes tareas en un equipo que ejecuta Windows Small Business Server 2003 R2:
  • Es quitar todas las instancias de SP4 de SQL Server Desktop Engine (Windows) y MSDE 2000 SP4.
  • Instale SQL Server 2000 SP4 y después quita SQL Server 2000 SP4.
En este escenario, cuando intenta abrir WSUS o cuando intenta abrir Windows Small Business Server 2003 Update Services en un equipo basado en Small Business Server 2003, puede recibir el siguiente mensaje de error:
No se pudo cargar msxmlsql.dll
Además, el complemento supervisión de Small Business Server y el informe puede no abrir y se puede registrar el suceso siguiente:
Tipo de suceso: error
Origen del suceso: ServerStatusReports
Categoría del suceso: ninguna
ID. de suceso: 1
Fecha: 30/9/2006
Hora: 4: 05: 15 PM
Usuario: N/d
Equipo: ServerName
Descripción: Informe de estado de servidor: dirección URL: http://localhost/monitoring/perf.aspx?reportMode=0
Error: No se pudo cargar msxmlsql.dll.
Seguimiento de pila: En Micro
Para obtener más información acerca de cómo resolver este problema, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
918767Programas pueden fallar al quitar una instancia de SQL Server 2000, MSDE 2000 o SQL Server 2000 Desktop Engine (Windows)

Causa

  • Recibe el mensaje de error "No se puede conectar a la base de datos de configuración" al quitar una instancia de SQL Server 2000 SP4. En este caso, está desactivada la opción de protocolo de memoria compartida.
  • Normalmente, el mensaje de error "Error al cargar msxmlsql.dll" se produce cuando uno o dos condiciones siguientes son verdaderas:
    • Es quitar todas las instancias de SP4 de Microsoft SQL Server Desktop Engine (Windows) y MSDE 2000 SP4.
    • Quitar una instancia de SQL Server 2000 SP4.
    En este caso, puede quitar el archivo Msxmlsql.dll desde el equipo. Sin embargo, otros programas SQL todavía pueden requerir este archivo. Si recibe este mensaje de error, debe restaurar los archivos Msxmlsql.dll y Msxmlsql.rll. Para obtener más información acerca de cómo hacerlo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
    918767Programas pueden fallar al quitar una instancia de SQL Server 2000, MSDE 2000 o SQL Server 2000 Desktop Engine (Windows)

Solución

Si no puede conectarse a cualquier instancia de MSDE 2000 o instancia de SQL Server Desktop Engine (Windows) en el equipo con Small Business Server 2003, quizás tenga que activar la opción de protocolo de memoria compartida. Para ello, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba cliconfg y, a continuación, haga clic en Aceptar .
  2. En el cuadro de diálogo Herramienta de red de cliente , haga clic para activar la casilla de verificación Habilitar comparte protocolo de memoria y, a continuación, haga clic en Aceptar .
  3. Reinicie el equipo.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información acerca de cómo quitar SQL Server 2000, MSDE 2000 o SQL Server 2000 Desktop Engine (Windows), haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
918767Programas pueden fallar al quitar una instancia de SQL Server 2000, MSDE 2000 o SQL Server 2000 Desktop Engine (Windows)

Propiedades

Id. de artículo: 920899 - Última revisión: lunes, 3 de diciembre de 2007 - Versión: 2.3
La información de este artículo se refiere a:
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
Palabras clave: 
kbmt kbtshoot kbprb KB920899 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 920899

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com