This article discusses a Beta release of a Microsoft product. The information in this article is provided as-is and is subject to change without notice.
No formal product support is available from Microsoft for this Beta product. For information about how to obtain support for a Beta release, see the documentation that is included with the Beta product files, or check the Web location where you downloaded the release.
This article discusses known issues in Microsoft Windows Vista Beta 2.
Note Microsoft has released Windows Vista Release Candidate 1 (RC1), and many of the issues that are documented in this article have been resolved in that release. To determind whether Windows Vista RC1 is available to you for testing, contact the person, program, or Web site that originally provided you with Windows Vista Beta 2.
If you run a program that can play digitally protected media files during the upgrade to Windows Vista Beta 2, you may lose access to the digitally protected content.
Symptom
When you try to play digitally protected media files, you may receive the following error message:
The Windows Media Digital Rights Management (DRM) component encountered a problem.
Cause
This issue may occur if a program that can play digitally protected media files was running during the upgrade to Windows Vista. This issue will be corrected in the next public release of the beta.
Resolution
To avoid this issue, close all programs before you perform the upgrade. For example, close all multimedia players and recording services that may be running in the background.
Note
Look in the notification area for icons that may indicate that an active player or a recording program is running. Typically, you can right-click the icon for such a program and then click Close or Exit to exit the program.
WorkaroundImportant This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756
(http://support.microsoft.com/kb/322756/
)
How to back up and restore the registry in Windows
If you receive this error, you must reset the Windows Media Digital Rights Management (DRM) system.
To do this, follow these steps.
Important
This step deletes all media usage rights. You cannot play any protected files until new media usage rights are downloaded. However, Microsoft Recorded TV Shows (DVR-MS files) are deleted and cannot be replaced.
Verify that Windows is configured to show hidden files and to protect operating system files.
Click Start, and then click Control Panel.
Type folder in the Search Help box, and then press ENTER.
Double-click Folder Options.
Click the View tab.
Click Show hidden files and folders.
Scroll down two lines, and then click to select the Hide protected operating system files (Recommended) check box.
Click Yes in the warning dialog box, and then click OK to close the Folder Options window.
Close Control Panel.
Open the Digital Rights Management folder. By default, the DRM folder is in the following location:
C:\Programdata\Microsoft\DRM
Note
The computer may be using a custom installation that has located the DRM folder elsewhere. If the DRM folder is not in the default location, determine the location for the DRM folder by opening the DataPath entry in the registry. To do this, follow these steps:
Click Start, type regedit in the Start Search box, and then press ENTER.
Locate and then click the following registry subkey:
In the right pane, double-click the DataPath entry.
Note
The binary data in this entry may be difficult to read. This data may resemble the following:
0000 4A 00 63 00 5C 00 44 00 C . : . \ . D .
0008 6F 00 63 00 75 00 6D 00 o . c . u . m .
0010 65 00 6E 00 74 00 73 00 e . n . t . s .
0018 20 00 61 00 6E 00 64 00 . a . n . d .
0020 20 00 53 00 65 00 74 00 . S . e . t .
0028 74 00 69 00 6E 00 67 00 t . i . n . g .
0030 73 00 5C 00 41 00 6C 00 s . \ . A . l .
0038 6C 00 20 00 55 00 73 00 l . . U . s .
0040 65 00 72 00 73 00 5C 00 e . r . s . \ .
0048 44 00 52 00 4D 00 00 00 D . R . M . . .
0050
Note the following information that appears in the rightmost column:
C . : . \ . D .
o . c . u . m .
e . n . t . s .
. a . n . d .
. S . e . t .
t . i . n . g .
s . \ . A . l .
l . . U . s .
e . r . s . \ .
D . R . M . . .
If you remove the extra line breaks, spaces, and periods from this information, you can locate the DRM folder. In this example, the registry key indicates the following custom location for the DRM folder:
C:\Documents and Settings\All Users\DRM
Note the location of the DRM folder.
Exit Registry Editor.
In the remaining steps, the DRM folder is referred to by using the default location. If your DRM folder is located elsewhere, substitute the location of your DRM folder.
Open the Windows Media DRM Folder. To do this, click Start, type c:\programdata\microsoft\drm in the Start Search box, and then press ENTER.
Select all the files in the DRM folder, and then delete them.
To do this, follow these steps.
Note
Do not delete the Server folder. Delete all the files in the DRM folder except the Server folder.
Click any item in the DRM folder so that it is highlighted.
Press CTRL+A on the keyboard to select all the files and folders in the DRM folder.
Press CTRL, and then click the Server folder so that is it not highlighted. All the files in the DRM folder should now be highlighted except for the Server folder.
Press DELETE.
Restart the computer.
To download new media usage rights, start Microsoft Windows Media Player, and then click the media files. Windows Media Player contacts the online store and tries to download new media usage rights.
Note
If you cannot acquire new digital media usage rights, contact the digital media provider for help.
For information about how to contact the digital media provider, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:
65416
(http://support.microsoft.com/kb/65416/
)
Hardware and software vendor contact information, A-K
60781
(http://support.microsoft.com/kb/60781/
)
Hardware and software vendor contact information, L-P
60782
(http://support.microsoft.com/kb/60782/
)
Hardware and software vendor contact information, Q-Z
You must uninstall the Beta 2 version of the 2007 Microsoft Office System before you upgrade from Microsoft Windows XP.
If you are running Windows XP and the Beta 2 version of the 2007 Microsoft Office System, you must uninstall Office before you upgrade to this version of Windows Vista Beta 2. After you upgrade to Windows Vista, you can reinstall the 2007 Microsoft Office System. For more information about the 2007 Microsoft Office System, visit the following Microsoft Web site:
USB keyboards and USB mouse devices may not work correctly during Windows Vista Setup.
Symptom
The computer restarts several times during Windows Vista Setup. Then you are asked several questions about how you want to set up the computer. During this process, the USB Keyboard, the USB mouse, or both devices may stop responding.
Resolution
If you experience this issue, try not to interrupt the Setup process. If you experience this issue and you cannot continue because you are at a screen that requires input, follow these steps:
Press the power button to restart the computer.
Note
You may have to hold the button down for several seconds to force the computer to shut down.
If you receive an incorrect shutdown warning, select the option to start the computer as you typically do.
If the issue still occurs, shut down the computer, switch the USB keyboard or the USB mouse to a different USB port connection on the computer, and then restart the computer.
If the issue still occurs, shut down the computer, connect a PS/2 keyboard, a PS/2 mouse, or both devices to the computer, and then restart the computer.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
894517
(http://support.microsoft.com/kb/894517/
)
How to troubleshoot problems that may occur with Microsoft keyboards and mouse devices that are wired
Immediately after you upgrade to Windows Vista Beta 2
The system clock may display an incorrect time, date, and time zone.
Symptom
The system clock may display the wrong time after you select the time zone during Setup.
Resolution To reset the time, follow these steps:
Click the clock in the notification area.
Click Date and Time Settings.
Use Change Time Zone and Change Date and Time to set the correct date and time.
Windows Vista Beta 2 does not prompt you to restart the computer after you uninstall an update.
Symptom
When you uninstall a Windows Vista-based or Microsoft Windows Server Code Name "Longhorn"-based update, you may not be prompted to restart the computer. However, a restart is required.
Resolution
To make sure that an update has been fully uninstalled, manually restart the computer after you remove an update.
Windows Easy Transfer does not transfer Microsoft Office Outlook Express settings to Windows Mail if Windows Mail has already been started.
Symptom
If you open Windows Mail in Windows Vista and then you use Windows Easy Transfer to import settings from Outlook Express on a Windows XP-based computer, you receive an error message. Additionally, the settings are not transferred.
Resolution
To avoid this issue, use Windows Easy Transfer to migrate settings that you want to transfer from Outlook Express before you start Windows Mail for the first time. If this issue has already occurred, you must manually reconfigure the settings in Windows Mail.
Windows Easy Transfer does not correctly transfer shortcuts to Microsoft Outlook personal folders (.pst files).
Symptom
If you use Windows Easy Transfer and you have Outlook .pst files, you may be unable to access the files after the transfer is finished.
Resolution
To open the Outlook .pst files that were transferred, follow these steps:
Start Outlook, and then click Open
on the File menu.
Click Outlook Data File.
Click Browse, and then click the transferred .pst file.
Click OK.
Outlook 2003 prompts the Microsoft Windows Installer to start and to configure Office 2003 after you upgrade from Windows XP to Windows Vista Beta 2
Symptom
When you use Outlook 2003 after you upgrade to Windows Vista Beta 2 from Windows XP, the Windows Installer starts. You receive a message that resembles the following:
Please wait while Windows configures Outlook
Resolution
To avoid this message, install the latest update for Outlook 2003 Junk E-mail Filter after you upgrade the computer to Windows Vista Beta 2.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
916521
(http://support.microsoft.com/kb/916521/
)
Description of the Outlook 2003 Junk E-Mail filter update: May, 2006
Dial-up networking
Dial-up networking Setup may not connect if another network connection has been used since the last time that you restarted Windows Vista Beta 2.
Symptom
If you connect to a network, disconnect from the network, and then try to set up a dial-up connection by using the Connections tab in Microsoft Internet Explorer, the connection may fail. This issue only occurs when you use certain Internet service providers (ISP).
Resolution
To avoid this issue, configure dial-up connections before you connect to any other network. If you encounter this issue, restart the computer, and then configure dial-up connections.
Media Center
A Media Center recording schedule may not transfer when you upgrade to Windows Vista Beta 2 or when you use Windows Easy Transfer.
Symptom
After you upgrade to Windows Vista or after you use Windows Easy Transfer to migrate files and settings to Windows Vista, part of or all of the Media Center recording schedule may be missing.
Resolution
To resolve this issue, you may be able to manually move the schedule. To do this, follow these steps:
Click Start, type services.msc in the Start Search box, and then press ENTER.
Click Continue when you are prompted by User Account Control.
Right-click Media Center Scheduler Service, and then click Stop.
Open the following folder:
C:\Documents and Settings\All Users\Application Data\Microsoft\eHome
Right-click the Recordings.xml file, and then click Copy.
Open the following folder:
C:\ProgramData\Microsoft\eHome\Recording
Press CTRL+V to paste the Recordings.xml file in the Recording folder.
Click Start, type services.msc in the Start Search box, and then press ENTER.
Click Continue when you are prompted by User Account Control.
Right-click Media Center Scheduler Service, and then click Start.
Restart the computer.
System Restore
Windows Vista System Restore points are deleted on some dual-boot computers.
Symptom
Because of changes in the underlying Volume Shadow Copy Service (VSS) infrastructure, shadow copies and associated restore points may be deleted on computers that use dual-boot configurations. This issue may occur when one boot partition contains Windows Vista or Windows Server "Longhorn," and the other partition contains an earlier version of Windows. If you restart the system by using the earlier version of Windows and then you restart the computer by using Windows Vista or Windows Server "Longhorn," System Restore does not work until a new restore point is created. Shadow copies of earlier versions of files are also affected.
Resolution
To make full use of the System Restore safety features when you restart from a previous operating system to Windows Vista, we recommend that you manually create a restore point. To do this, follow these steps :
Click Start, type systempropertiesprotection in the Start Search box, and then press ENTER.
When you are prompted by User Account Control, click Continue.
Click the System Protection tab, click Create, and then type a name for the restore point. The name can be anything less than 12 characters.
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.