Help and Support
 

powered byLive Search

Options to change wallpaper may be missing or unavailable on a Windows XP-based computer

Article ID:921049
Last Review:August 25, 2006
Revision:1.3

SYMPTOMS

When you try to change the desktop wallpaper in a Microsoft Windows XP-based computer, the options may be missing or unavailable. Therefore, you cannot change your wallpaper or use other options that are located in the Display Properties dialog box. This problem may occur after you remove spyware from the system.

Back to the top

CAUSE

This problem occurs when a registry key is set to hide or to lock the display settings on the computer. The registry key can be set by an administration policy or by malicious software.

Back to the top

RESOLUTION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/) How to back up and restore the registry in Windows


To resolve this problem, follow these steps:
1.Click Start, click Run, type regedit, and then click OK.
2.Locate and then click the following registry subkey:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System
3. In the right-pane, right-click the NoDispAppearancePage value if the value exists, and then click Delete.
4.Repeat step 3 for the following registry values if these values exist in the registry:
NoDispCPL
NoDispBackgroundPage
NoDispScrSavPage
NoDispSettingsPage

Note Locate any registry value that says "Wallpaper" if it exists. In the right pane, right-click the registry value, click Delete, and then click OK.
5.Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE_\Software\Microsoft\Windows\CurrentVersion\Policies\System
6.In the right-pane, right-click the NoDispAppearancePage value if the value exists, and then click Delete.
7.Repeat step 6 for the following registry values if these values exist in the registry:
NoDispCPL
NoDispBackgroundPage
NoDispScrSavPage
NoDispSettingsPage

Note Locate any registry value that says "Wallpaper" if it exists. In the right pane, right-click the registry value, click Delete, and then click OK.
8. For the changes to take effect, you may have to restart the computer after you delete these registry values.

Back to the top

MORE INFORMATION

The following list describes the previous registry values. The list also describes how the settings of these values affect the options that are located in the Display Properties dialog box:

Display Name: Disable Display Control Panel
Description: Prevents the Display icon in Control Panel from working
Value Name: NoDispCPL
Type: DWORD
Setting: 1 = Enabled and 0 (zero) = Disabled

Display Name: Hide Background page
Description: Prevents the displaying of the Background tab
Value Name: NoDispBackgroundPage
Type: DWORD
Setting: 1 = Enabled and 0 (zero) = Disabled

Display Name: Hide Screen Saver page
Description: Prevents the displaying of the Screen Saver tab
Value Name: NoDispScrSavPage
Type: DWORD
Setting: 1 = Enabled and 0 (zero) = Disabled

Display Name: Hide Appearance page
Description: Prevents the displaying of the Appearance tab
Value Name: NoDispAppearancePage
Type:
DWORD Setting: 1 = Enabled and 0 (zero) = Disabled

Display Name: Hide Settings page
Description: Prevents the displaying of the Settings tab
Value Name: NoDispSettingsPage
Type:
DWORD Setting: 1 = Enabled and 0 (zero) = Disabled

Back to the top


APPLIES TO
Microsoft Windows XP Home Edition
Microsoft Windows XP Professional

Back to the top

Keywords: 
kbregistry kbdisplay kbtshoot kbprb KB921049

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.