IIS reagiert auf einem Microsoft Dynamics CRM 3.0-server

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 921065 - Produkte anzeigen, auf die sich dieser Artikel bezieht
wichtig Dieser Artikel enthält Informationen zum Ändern der Registrierung. Stellen Sie sicher, dass Sie die Registrierung sichern bevor Sie Sie ändern. Stellen Sie sicher, dass Sie die Registrierung wiederherstellen kennen, wenn ein Problem auftritt. Weitere Informationen zum Sichern, Wiederherstellen und Bearbeiten der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
322756Zum Sichern und Wiederherstellen der Registrierung in Windows
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Auf einem Microsoft Dynamics CRM 3.0-Server oder eine Microsoft Dynamics CRM 3.0 Professional Edition für Dienstanbieter Server wird Internetinformationsdienste (IIS) unerwartet zurückgesetzt. IIS reagiert anschließend nicht mehr. Wenn IIS nicht mehr reagiert, erhalten Sie eine Fehlermeldung, die folgenden Fehlermeldungen ähnelt.
Fehlermeldung 1
Dienst "IIS-Verwaltungsdienst" wurde unerwartet beendet. Es ist diesem 5 vorgekommen. Folgende Korrekturmaßnahmen Aktion wird in 0 Millisekunden durchgeführt: keine Aktion.
Fehlermeldung 2
Anwendungspopup: w3wp.exe - Anwendungsfehler: die Anweisung in "0x6a2a2fec" verweist auf Speicher in "0x0000000c". Der Speicher konnte nicht "gelesen werden".
Fehlermeldung 3
Beim Öffnen des Workflow-Managers erhalten Sie die Fehlermeldung: "Workflow-Manager kann nicht gestartet werden. Dies kann werden da der Workflowdienst nicht gestartet wurde oder nicht richtig konfiguriert ist."
Fehlermeldung 4
Sie CRM-Plattform Ablaufverfolgung aktivieren Sie erhalten die folgende Fehlermeldung im Inetinfo-Yyyymmddhh.log: Process: Inetinfo |Category: Unmanaged.Platform |Level: Fehler hr = 0 x 80070005 | CProcessT <-klasse CSecLib >:: GetWorkflowConfig Datei: c:\bt\224\src\platform\include\om\crm\workflow.inl Zeile: 2122 Prozess: Inetinfo |Category: Unmanaged.Platform |Level: Fehler <description> kann keine Verbindung zum Workflow-Dienst. </description><file> c:\bt\224\src\platform\include\om\crm\workflow.Inl </file><line> 2123 </line> | InternalCrmSetErrorInfo Datei: c:\bt\224\src\platform\include\util\icrmerror.h Zeile: 362 Prozess: Inetinfo |Thread:1164 |Category: Unmanaged.Platform |Level: Fehler hr = 0x80042647 | CCrmProcess::GetWorkflowConfigInternal Datei: c:\bt\224\src\platform\objectmodel\workflow\crmprocess.cpp Zeile: 4129
Außerdem sind die folgenden Ereignismeldungen im System-Ereignisprotokoll protokolliert.
Ereignismeldung 1

Ein Prozess für Anwendungspool "CRMAppPool" ist ein schwerwiegender Kommunikationsfehler mit dem WWW-Publishingdienst aufgetreten. Die Prozess-Id war '7420'. Das Feld enthält die Fehlernummer.

Ereignismeldung 2

Ein Arbeitsprozess mit Prozesskennung '5864' Bereitstellung Anwendungspool "CRMAppPool" hat eine Wiederverwendung angefordert, da der Arbeitsprozess seine zulässige Betriebszeitlimit erreicht wurde.

Ereignismeldung 3

Ein Prozess für Anwendungspool "CRMAppPool" wurde unerwartet beendet. Die Prozess-Id war '1240'. Der Prozessexitcode lautet '0 x 80'.

Ereignismeldung 4

Anwendungspopup: Dienststeuerungs-Manager: mindestens ein Dienst oder Treiber ist während des Systemstarts fehlgeschlagen. Überprüfen Sie das Ereignisprotokoll in der Ereignisanzeige.

Ereignismeldung 5

Ereignis-ID = 26, Quelle = Anwendung-Popup Beschreibung = "Anwendungs-Popup: Dienststeuerungs-Manager: mindestens ein Dienst oder Treiber ist während des Systemstarts fehlgeschlagen. Überprüfen Sie das Ereignisprotokoll in der Ereignisanzeige. Weitere Informationen finden Sie unter Hilfe- und Supportcenter unter http://go.microsoft.com/fwlink/events.asp."

Nachdem IIS nicht mehr reagiert, müssen Sie neu starten, eine oder beide der folgenden Dienste, wenn diese Dienste automatisch neu starten können:
  • IIS Admin-Dienst
  • WWW-Dienst

Ursache

Das Problem rührt von zwei Threads aktiv, aber nicht synchronisiert sind. Ein Thread ist für die Initialisierung. Dieser Thread startet und beendet den Listener. Der andere Thread implementiert eine Schleife, die die Datenbank abfragt. Wenn diese zwei Threads aktiv, aber nicht synchronisiert sind, kann Microsoft CRM eine Adresse in einem Modul zurückgeben, die entladen wurde.

Lösung

Warnung Schwerwiegende Probleme können auftreten, wenn Sie die Registrierung falsch mithilfe des Registrierungs-Editors oder mithilfe einer anderen Methode ändern. Diese Probleme erfordern möglicherweise eine das Betriebssystem neu installieren. Microsoft kann nicht garantieren, dass diese Probleme gelöst werden können. Ändern Sie die Registrierung auf eigene Gefahr.

Microsoft Dynamics CRM 3.0

Dieses Problem ist in Updaterollup 2 für Microsoft Dynamics CRM 3.0 behoben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
927751Das Updaterollup 2 für Microsoft Dynamics CRM 3.0 ist verfügbar

Microsoft Dynamics CRM 3.0 Professional Edition für Dienstanbieter

Dieses Problem ist im Updaterollup 1 für Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers behoben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
935731Das Updaterollup 1 für Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers ist verfügbar

Microsoft Dynamics CRM 3.0, japanische oder chinesische version

Dieses Problem wird in der vereinfachtes Version von Microsoft Dynamics CRM 3.0 und in der japanischen Version von Updaterollup 2 für Microsoft Dynamics CRM 3.0 behoben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
944372Updaterollup 2 für die Version Chinesisch vereinfacht Microsoft CRM 3.0 und für die japanische Version von Microsoft Dynamics CRM 3.0 ist verfügbar
Dieses Update ist standardmäßig deaktiviert. Um dieses Update zu aktivieren, erstellen Sie einen neuen Registrierungsschlüssel. Gehen Sie hierzu folgendermaßen vor:
  1. Beenden Sie Microsoft Dynamics CRM 3.0.
  2. Klicken Sie auf dem Microsoft CRM-Server auf Start , klicken Sie auf Ausführen , geben Sie regedit ein und klicken Sie dann auf OK .
  3. Klicken Sie auf folgenden Unterschlüssel in der Registrierung:
    HKEY_LOCAL_MACHINE\Software\Microsoft\MSCRM
  4. Klicken Sie im Menü Bearbeiten auf neu , und klicken Sie dann auf DWORD-Wert .
  5. Geben Sie SuspendThreadOnStopListener , und drücken Sie anschließend die [ EINGABETASTE ].
  6. Klicken Sie mit der rechten Maustaste auf SuspendThreadOnStopListener , und klicken Sie dann auf Ändern .
  7. Geben Sie in das Feld Wert 1 ein, und klicken Sie dann auf OK .
  8. Klicken Sie im Menü Datei auf Beenden , um Registrierungseditor zu beenden.
  9. Klicken Sie auf Start , klicken Sie auf Ausführen und geben Sie iisreset ein .
Notizen
  • Dieses Verfahren wird vorübergehend beendet alle aktiven Websites und starten Sie die Websites.
  • Nachdem Sie diesen Hotfix aktiviert haben, werden anstelle von Herunterfahrereignisse festgelegt wird Benachrichtigung Threads angehalten.
Dieses Problem ist nicht in Update-Rollup 1 für die japanische Version oder die chinesische Version von Microsoft Dynamics CRM 3.0 behoben. Wenn Sie Update-Rollup 1 für die japanische Version oder die chinesische Version von Microsoft Dynamics CRM 3.0 verwenden, müssen Sie diesen Hotfix installieren.

Japanische Version und chinesische Version von Microsoft Dynamics CRM 3.0

Hotfix-Informationen

Wenn Sie die japanische Version oder die chinesische Version von Microsoft CRM verwenden, ist jetzt ein unterstützter Hotfix von Microsoft erhältlich. Es ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Wenden Sie es nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf das nächste Update-Rollup warten, das diesen Hotfix enthält.

Dieses Problem sofort beheben möchten, wenden Sie sich an Microsoft Support Services, um den Hotfix zu erhalten. Eine vollständige Liste mit Telefonnummern der Microsoft Product Support Services und Informationen über Supportkosten der folgenden Microsoft-Website:
http://support.Microsoft.com/contactus/?ws=support
Hinweis: PLEASE DO NOT TRANSLATE and DELETE THIS PASSAGE. IT DOES NOT APPLY TO GERMANY.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln. Microsoft Dynamics CRM-Client für Outlook
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeit
Crmcache.dll3.0.5469.1182308,58417-Aug 200702: 35
Crmmetadatacache.dll3.0.5469.1182205,67217-Aug 200702: 35
Crmsecurity.dll3.0.5469.1182771,94417-Aug 200702: 35
Microsoft Dynamics CRM-Client für Outlook-Kompatibilitätsupdate
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeit
V3icclientpatch30.mspNicht zutreffend410,11217-Aug 200703: 00
Crmcache.dll3.0.5469.1182308,58417-Aug 200702: 35
Crmmetadatacache.dll3.0.5469.1182205,67217-Aug 200702: 35
Crmsecurity.dll3.0.5469.1182771,94417-Aug 200702: 35
Microsoft Dynamics CRM 3.0-server
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeit
Crmcache.dll3.0.5469.1182308,58417-Aug 200702: 35
Crmmetadatacache.dll3.0.5469.1182205,67217-Aug 200702: 35
Crmsecurity.dll3.0.5469.1182771,94417-Aug 200702: 35
Crmworkflowservice.exe3.0.5469.11823,928,93617-Aug 200702: 35

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.
Dieses Problem wurde im Updaterollup 2 für Microsoft Dynamics CRM 3.0, Updaterollup 1 für Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers, Update Rollup 2 für die vereinfachtes Version von Microsoft Dynamics CRM 3.0 und die japanische Version von Microsoft Dynamics CRM 3.0 behoben.

Weitere Informationen

Das Log Parser-Tool können Sie die Fehler ermitteln, die auf dem Microsoft Dynamics CRM 3.0-Server aufgetreten. Um das Protokoll Parser-Tool zu erhalten, die folgende Microsoft-Website:
http://www.microsoft.com/downloads/details.aspx?FamilyID=890cd06b-abf8-4c25-91b2-f8d975cf8c07&displaylang=en
Nach der Installation des Log Parser-Tools verwenden Sie dieses Tool Abfrage Fehler. Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf Start , zeigen Sie auf Programme , zeigen Sie auf Log Parser 2.2 und klicken Sie dann auf Log Parser 2.2 .
  2. Geben Sie an der Eingabeaufforderung Log Parser 2.2 den folgenden Befehl ein:
    Logparser "wählen TimeGenerated, SourceName, EventCategoryName, Message in System.csv vom System, in denen EventID IN (7034; 1074; 26) Order by Desc TimeGenerated"
  3. Drücken Sie die [EINGABETASTE].
  4. Öffnen Sie die System.csv-Datei mithilfe einer der folgenden Programme:
    • Microsoft Office Excel
    • Microsoft Office Word
    • Editor
    Hinweis: Die System.csv-Datei wird standardmäßig im folgenden Verzeichnis:
    C:\Programme\Microsoft Files\Log Parser 2.2
Die Datensätze in der Datei System.csv anzeigen aufgetretenen Fehler auf dem Microsoft Dynamics CRM 3.0-Server.

Informationsquellen

Informationen zur Leistungsoptimierung für CRM 3.0 finden Sie unter das folgende Whitepaper:
Optimizing the Performance of Microsoft Dynamics CRM 3.0 White Paper
Weitere Informationen zur Terminologie, mit dem Microsoft Software Updates, finden Sie in der folgenden Artikeln der Microsoft Knowledge Base:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates
887283Microsoft Business Solutions CRM-Softwarehotfix und Update Packen Namensstandards

Eigenschaften

Artikel-ID: 921065 - Geändert am: Donnerstag, 15. Mai 2008 - Version: 8.2
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft CRM 3.0
  • Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers
Keywords: 
kbmt kbautohotfix kbmbsadministration kbhotfixserver kbqfe kbmbsmigrate KB921065 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 921065
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com