Microsoft Dynamics CRM 3.0 サーバーに応答を停止するインターネット インフォメーション サービス

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文書番号: 921065
重要です レジストリを変更する方法についての情報を掲載しています。これを変更する前にレジストリのバックアップを作成することを確認してください。問題が発生した場合にレジストリを復元する方法を知っていることを確認してください。バックアップ、復元、およびレジストリを変更する方法の詳細については、Knowledge Base の資料を参照するのには、次の資料番号をクリックしてください。
322756 Windows でレジストリを復元する方法
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目次

現象

Microsoft Dynamics CRM 3.0 サーバー上または、Microsoft Dynamics CRM 3.0 Professional Edition のサービス ・ プロバイダーのサーバー上には、(IIS) が予期せずにリセットされます。次に、IIS が応答を停止します。IIS が応答を停止すると、次のエラー メッセージのようなエラー メッセージが表示されます。
エラー メッセージ 1
IIS Admin Service サービスは予期せず終了しました。これこれは 5 回発生しています。次の修正動作が 0 ミリ秒以内に実行されます。 操作はありません。
エラー メッセージ 2
アプリケーション ポップアップ: w3wp.exe - アプリケーション エラー:"0x6a2a2fec"での命令が"0x0000000c"のメモリを参照します。メモリ「読み取れませんでした」。
エラー メッセージ 3
ワークフロー マネージャーを開いたときに、エラーが発生:"ワークフロー マネージャーを開始できません。ワークフロー サービスが開始されていないか、正しく構成されていない原因として可能性があります。"
エラー メッセージ 4
CRM プラットフォームのトレースを有効にすると、Inetinfo に次のエラーを取得-yyyymmddhh.log: プロセス: inetinfo |カテゴリ: Unmanaged.Platform |レベル: エラー hr 0x80070005 = |CProcessT<class cseclib="">:: GetWorkflowConfig ファイル: c:\bt\224\src\platform\include\om\crm\workflow.inl 行: 2122年プロセス: inetinfo |カテゴリ: Unmanaged.Platform |レベル: エラーを<description>に接続できません</description>サービス。 ワークフロー<file>c:\bt\224\src\platform\include\om\crm\workflow.inl</file><line>2123</line>|InternalCrmSetErrorInfo ファイル: c:\bt\224\src\platform\include\util\icrmerror.h 行: 362 プロセス: inetinfo |スレッド: 番号 1164年 |カテゴリ: Unmanaged.Platform |レベル: エラー hr = の 0x80042647 |CCrmProcess::GetWorkflowConfigInternal ファイル: c:\bt\224\src\platform\objectmodel\workflow\crmprocess.cpp 行: 4129<b00></b00></class>
また、次のイベント メッセージがシステム イベント ログに記録されます。
イベント メッセージ 1

アプリケーション プール 'CRMAppPool' を提供しているプロセスは、World Wide Web 発行サービスで、致命的な通信エラーを検出しました。プロセス id は '7420' でした。データ フィールドにエラー番号が含まれています。

イベント メッセージ 2

ワーカー プロセスは、許可された処理時間制限に達したため '5864' サービング アプリケーション プール 'CRMAppPool' のプロセス id はワーカー プロセスがリサイクルを要求しました。

イベント メッセージ 3

アプリケーション プール 'CRMAppPool' を提供しているプロセスが突然終了します。プロセス id は '1240' でした。プロセス終了コードは '0x80' でした。

イベント メッセージ 4

アプリケーション ポップアップ: サービス コントロール マネージャー: システム スタートアップの最中、少なくとも 1 つのサービスまたはドライバー失敗しました。イベント ビューアーを使用して、イベント ログの詳細を確認します。

イベント メッセージ 5

イベント Id 26 のソース = アプリケーション ポップアップの説明 = ="アプリケーション ポップアップ: サービス コントロール マネージャー: システム スタートアップの最中、少なくとも 1 つのサービスまたはドライバー失敗しました。イベント ビューアーを使用して、イベント ログの詳細を確認します。詳細については、ヘルプとサポート センターで http://go.microsoft.com/fwlink/events.asp」します。

IIS が応答を停止した後、これらのサービスが自動的に再起動できない場合は、いずれかまたは両方の以下のサービスを再起動することがあります。
  • IIS Admin Service
  • World Wide Web サービス

原因

2 つのスレッドがアクティブが同期化されませんであるため、問題に発生します。1 つのスレッドの初期化です。このスレッドは開始し、リスナーを停止します。他のスレッドでデータベースをクエリするループを実装します。これら 2 つのスレッドがアクティブでない同期したら、Microsoft Dynamics CRM がアンロードされたモジュールのアドレスを返すことがあります。

解決方法

警告 重大な問題、レジストリが誤ってをレジストリ エディターを使用して、または別の方法を使用して変更すると発生します。これらの問題は、オペレーティング システムを再インストールする必要があります。マイクロソフトは、これらの問題を解決できることを保証できません。お客様の責任においてレジストリを変更します。

Microsoft Dynamics CRM 3.0

Microsoft Dynamics CRM 3.0 用の更新プログラムのロールアップ 2 でこの問題を解決します。 詳細については、Knowledge Base の資料を参照するのには、次の資料番号をクリックしてください。
927751Microsoft Dynamics CRM 3.0 用の更新プログラムのロールアップ 2 を利用します。

Microsoft Dynamics CRM 3.0 のサービス ・ プロバイダー向けのプロフェッショナル エディション

この問題を更新プログラム ロールアップ 1 に Microsoft Dynamics CRM 3.0 Professional Edition のサービスプロバイダーに固定されています。 詳細については、Knowledge Base の資料を参照するのには、次の資料番号をクリックしてください。
935731Microsoft Dynamics CRM 3.0 Professional Edition サービス ・ プロバイダー向けの更新プログラム ロールアップ 1 が利用可能です。

Microsoft Dynamics CRM 3.0、日本語または中国語のバージョン

この問題を解決するには、簡体中国語バージョン 3.0 の Microsoft Dynamics CRM と Microsoft Dynamics CRM 3.0 の更新プログラムのロールアップ 2 の日本語版。 詳細については、Knowledge Base の資料を参照するのには、次の資料番号をクリックしてください。
944372更新プログラムのロールアップ 2 Microsoft Dynamics CRM 3.0 の簡体中国語版および日本語版 Microsoft Dynamics CRM 3.0 を利用します。
既定では、この修正プログラムは無効になっています。この修正プログラムを有効にするには、新しいレジストリ キーを作成します。これを行うには、次の手順を実行します。
  1. Microsoft Dynamics CRM 3.0 を終了します。
  2. Microsoft Dynamics CRM を実行しているサーバーをクリックします。 開始をクリックして 実行、タイプ レジストリ エディター、し [OK].
  3. 見つけて、次のレジストリ サブキー] をクリックします。
    HKEY_LOCAL_MACHINE\Software\Microsoft\MSCRM
  4. で、 編集 メニューのポイント 新しい、し DWORD 値.
  5. 種類 SuspendThreadOnStopListener、し、キーを押します。 入力してください。.
  6. 右クリックします。 SuspendThreadOnStopListener、し 変更.
  7. で、 ボックスの種類 1、し [OK].
  8. で、 ファイル メニューをクリックして 終了 レジストリ エディターを終了します。
  9. クリックしてください。 開始をクリックして 実行、し、入力 iisreset.
メモ
  • ここはすぐ実行中のすべての Web サイト] を停止し、Web サイトを起動します。
  • この修正プログラムを有効にすると、シャット ダウンのイベントの代わりに設定されている通知スレッドが中断されます。
この問題の更新プログラム ロールアップ 1 の日本語版または中国語のバージョン 3.0 の Microsoft Dynamics CRM は固定されません。日本語版または中国語バージョンの Microsoft Dynamics CRM 3.0 の更新プログラム ロールアップ 1 を使用している場合は、この修正プログラムをインストールする必要があります。

日本語版、中国語版の 3.0 の Microsoft Dynamics CRM

修正プログラムの情報

日本語版または中国語のバージョン Microsoft Dynamics CRM を使用している場合は、サポートされている修正プログラムを用意しています。ただし、この資料に記載されている問題のみを修正するものです。この問題が発生しているシステムにのみ適用されます。この修正プログラムは、今後さらにテストが表示されます。したがって、この問題で深刻な影響をされていない場合は、この修正プログラムを含む次の更新プログラム ロールアップを待機することをお勧めします。

この問題を解決するには、マイクロソフト カスタマー サポート サービス、修正プログラムを入手するに問い合わせてください。Microsoft カスタマー サポート サービスの電話番号とサポート コストに関する情報の完全な一覧については、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support
メモ Microsoft Support 担当者が特定の更新で問題が解決されると判断した場合は特殊なケースでは、料金が通常のサポート免除されるキャンセルする可能性があります。追加の質問および問題の特定のアップデートの対象とならない問題、通常のサポート料金が適用されます。

ファイル情報

この修正プログラムの英語版がファイル属性 (またはそれ以降のファイル属性) が、次のとおり。日付および時刻これらのファイルを世界協定時刻 (UTC) が表示されます。ファイル情報を表示すると、ローカル時刻に変換します。UTC とローカル時刻との時差を確認するを使用して、 タイム ゾーン タブには 日付と時刻 コントロール パネルの項目。Microsoft Dynamics CRM クライアントの Outlook
元に戻す全体を表示する
ファイル名ファイルのバージョンファイルのサイズ日付時間
Crmcache.dll3.0.5469.1182308,5842007 年 8 月 17 日02: 35
Crmmetadatacache.dll3.0.5469.1182205,6722007 年 8 月 17 日02: 35
Crmsecurity.dll3.0.5469.1182771,9442007 年 8 月 17 日02: 35
Microsoft Dynamics CRM クライアントの互換性に関する更新プログラムの Outlook
元に戻す全体を表示する
ファイル名ファイルのバージョンファイルのサイズ日付時間
V3icclientpatch30.msp該当なし410,1122007 年 8 月 17 日03: 00
Crmcache.dll3.0.5469.1182308,5842007 年 8 月 17 日02: 35
Crmmetadatacache.dll3.0.5469.1182205,6722007 年 8 月 17 日02: 35
Crmsecurity.dll3.0.5469.1182771,9442007 年 8 月 17 日02: 35
Microsoft Dynamics CRM 3.0 サーバー
元に戻す全体を表示する
ファイル名ファイルのバージョンファイルのサイズ日付時間
Crmcache.dll3.0.5469.1182308,5842007 年 8 月 17 日02: 35
Crmmetadatacache.dll3.0.5469.1182205,6722007 年 8 月 17 日02: 35
Crmsecurity.dll3.0.5469.1182771,9442007 年 8 月 17 日02: 35
Crmworkflowservice.exe3.0.5469.11823,928,9362007 年 8 月 17 日02: 35

状況

マイクロソフトでは、この「対象」に記載されているマイクロソフト製品の問題として認識しています。
この問題は、Microsoft Dynamics CRM 3.0 の更新プログラムのロールアップ 2 は、サービスプロバイダーは Microsoft Dynamics CRM 3.0 Professional Edition の更新プログラム ロールアップ 1、簡体中国語版の Microsoft Dynamics CRM の 3.0 の更新プログラムのロールアップ 2 および Microsoft Dynamics CRM 3.0 の日本語版を修正しました。

詳細

Microsoft Dynamics CRM 3.0 サーバー上に発生したエラーを確認するには、ログ パーサー ツールを使用できます。Log Parser ツールを入手するには、次のマイクロソフト Web サイトを参照してください。
ドキュメントですか。FamilyID = の 890cd06b-abf8-4 c 25-91b2-f8d975cf8c07 & displaylang = en
Log Parser ツールをインストールすると、クエリのエラーこのツールを使用します。これを行うには、次の手順を実行します。
  1. クリックしてください。 開始、ポイント すべてのプログラム、ポイント Log Parser 2.2、し Log Parser 2.2.
  2. Log Parser 2.2 のコマンド プロンプトで、次のコマンドを入力します。
    Logparser"選択 TimeGenerated、SourceName、EventCategoryName、System.csv のシステムへのメッセージはイベント Id (7034 1074年; 26) の order by TimeGenerated desc で"
  3. ENTER キーを押します。
  4. 次のプログラムのいずれかを使用して、System.csv ファイルを開きます。
    • Microsoft Office Excel
    • Microsoft Office 語
    • メモ帳
    メモ 既定では、System.csv ファイルで次のディレクトリです。
    Files\Log パーサーの C:\Program 2.2
System.csv ファイル内のレコード Microsoft Dynamics CRM 3.0 サーバー上に発生したエラーを表示します。

関連情報

CRM 3.0 用のパフォーマンスをチューニングする方法の詳細については、次のホワイト ペーパーを参照してください。
Microsoft Dynamics CRM 3.0 のパフォーマンスを最適化するホワイト ペーパー
マイクロソフトのソフトウェア更新プログラムの説明に使用される用語の詳細については、マイクロソフト サポート技術記事を表示するのには、次の資料番号をクリックしてください。
824684マイクロソフトのソフトウェア更新プログラムの説明に使用される一般的な用語の説明
887283 Microsoft ビジネス ソリューションの CRM のソフトウェア修正プログラムおよび更新プログラム パッケージの命名規則

プロパティ

文書番号: 921065 - 最終更新日: 2011年8月8日 - リビジョン: 10.0
キーワード:?
kbqfe kbmbsmigrate kbhotfixserver kbmbsadministration kbautohotfix kbmt KB921065 KbMtja
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英語版 KB:921065
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