Internet Information Services 停止响应 Microsoft 动态 CRM 3.0 的服务器上

文章翻译 文章翻译
文章编号: 921065 - 查看本文应用于的产品
重要本文包含有关如何修改注册表的信息。请确保您对其进行修改之前备份注册表。请确保您知道如何还原注册表发生问题。有关如何备份、 还原,以及修改注册表的详细信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
322756如何备份和还原在 Windows 注册表
展开全部 | 关闭全部

本文内容

症状

Microsoft 动态 CRM 3.0 服务器上或在为服务提供商服务器一个 Microsoft 动态 CRM 3.0 专业版上,Microsoft Internet Information Services (IIS) 被意外重置。接下来,IIS 停止响应。当 IIS 停止响应时,您将收到一条错误消息,类似于以下错误消息。
错误消息 1
在 IIS 管理服务服务意外终止。这已经这 5 次。将在 0 毫秒内采取以下纠正措施: 无操作。
错误消息 2
应用程序弹出: w3wp.exe 的应用程序错误:"0x6a2a2fec"处的指令引用在"0x0000000c"的内存。内存不能将"读取"。
第 3 条错误消息
您在打开工作流程管理器时出现错误: 工作流管理器无法启动。这可能是因为该工作流服务尚未启动或配置不正确"。
错误消息 4
如果您启用了 CRM 平台跟踪您在 Inetinfo 中出现以下错误-yyyymmddhh.log: inetinfo 进程: |Category: Unmanaged.Platform |Level: 错误 hr = 0x80070005 | CProcessT < 类 CSecLib >:: GetWorkflowConfig 文件: c:\bt\224\src\platform\include\om\crm\workflow.inl 行: 2122 inetinfo 进程: |Category: Unmanaged.Platform |Level: 错误 <description>无法连接到工作流服务。</description><file>c:\bt\224\src\platform\include\om\crm\workflow.inl</file><line>2123</line> | InternalCrmSetErrorInfo 文件: c:\bt\224\src\platform\include\util\icrmerror.h 行: 362 inetinfo 进程: |Thread:1164 |Category: Unmanaged.Platform |Level: 错误 hr = 0x80042647 | CCrmProcess::GetWorkflowConfigInternal 文件: c:\bt\224\src\platform\objectmodel\workflow\crmprocess.cpp 行: 4129
此外,在系统事件日志中记录以下事件消息。
事件消息 1

提供服务应用程序池 CRMAppPool 一个进程遇到致命的通信错误的万维网发布服务。进程 id 是"7420"。数据字段中包含错误号。

事件消息 2

具有进程 id 为"5864"服务应用程序池 CRMAppPool 的工作进程已经请求回收,因为工作进程已经达到其允许的处理时间限制。

事件消息 3

进程服务应用程序池 CRMAppPool' 意外终止。进程 id 是"1240"。进程退出代码时"0x80"。

事件消息 4

应用程序弹出: 服务控制管理器: 至少一个服务或驱动程序无法在系统启动过程中。使用事件查看器检查事件日志以了解详细信息。

事件消息 5

EventID = 26 源 = 应用程序弹出说明 ="应用程序弹出: 服务控制管理器: 至少一个服务或驱动程序无法在系统启动过程中。使用事件查看器检查事件日志以了解详细信息。有关详细的信息请参阅帮助和支持中心在 http://go.microsoft.com/fwlink/events.asp"。

IIS 会停止响应后,您必须重新启动一项或两个以下服务,如果这些服务不能自动重新启动:
  • IIS 管理服务
  • 万维网服务

原因

出现该问题的原因是两个线程是活动的但不是同步。一个线程是进行初始化。此线程启动和停止侦听程序。另一个线程实现一个循环来查询数据库。当这些两个线程是活动的但不是同步时,Microsoft 动态 CRM 可能已被卸载的模块中返回地址。

解决方案

警告如果您修改注册表错误地使用注册表编辑器或使用另一种方法,则可能会出现严重问题。这些问题可能需要重新安装操作系统。Microsoft 不能保证可以解决这些问题。修改注册表的风险由您自己承担。

Microsoft CRM 3.0 动态

Microsoft CRM 3.0 动态更新汇总 2 中解决此问题。有关详细的信息请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
927751对于 Microsoft 动态 CRM 3.0 的更新汇总 2 不可用

Microsoft CRM 3.0 动态服务提供商的专业版

在解决此问题在累积更新 1 中的 Microsoft 动态 CRM 3.0 专业版服务提供商。有关详细的信息请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
935731更新汇总 1 的服务提供商的 Microsoft 动态 CRM 3.0 专业版是可用

Microsoft 动态 CRM 3.0、 日语或中文版本

在简体中文版本的 Microsoft 动态 CRM 3.0 中,在日语版的 Microsoft 动态 CRM 3.0 更新汇总 2 中解决此问题。有关详细的信息请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
944372更新汇总 2 为简体中文版本的 Microsoft 动态 CRM 3.0 和日语版的 Microsoft CRM 3.0 动态不可用
默认状态下,禁用此修复程序。若要以便此修复程序创建一个新的注册表项。若要这样做,请按照下列步骤操作:
  1. 退出 Microsoft CRM 3.0 动态。
  2. 正在运行 Microsoft 动态 CRM 在服务器上单击 开始、 单击 运行、 键入 regedit,然后单击 确定
  3. 找到并单击以下注册表子项:
    HKEY_LOCAL_MACHINE\Software\Microsoft\MSCRM
  4. 编辑 菜单上指向 新建,然后单击 DWORD 值
  5. 键入 SuspendThreadOnStopListener,然后按 ENTER 键。
  6. 用鼠标右键单击 SuspendThreadOnStopListener,然后单击 修改
  7. 取值 框中键入 1,然后单击 确定
  8. 文件 菜单上单击以退出注册表编辑器的 退出
  9. 单击 开始,单击 运行,然后键入 iisreset
备注
  • 此过程将暂时停止所有正在运行的 Web 站点,然后启动 Web 站点。
  • 在启用此修补程序后,通知线程被挂起,而不是的设置的关机事件。
此问题不是累积更新 1 在日语版或中文版本的 Microsoft 动态 CRM 3.0 的固定的。如果使用的日语版或中文版本的 Microsoft CRM 3.0 动态进行的更新汇总 1,您必须安装此修补程序。

日语版和 Microsoft 动态 CRM 3.0 的中文版

修补程序信息

如果您使用的日语版或中文版本的 Microsoft 动态 CRM,是现在可以从 Microsoft 获得支持的修补程序。但是,它被用于解决本文中介绍的此问题。它仅应用于出现这一特定问题的系统。此修补程序可能还会接受进一步的测试。因此,如果此问题没有对您造成严重的影响,我们建议您等待包含此修补程序的下一个更新汇总。

要立即解决此问题,请联系 Microsoft 客户支持服务以获取此修复程序。有关 Microsoft 客户支持服务电话号码和关于支持费用的信息的完整列表,请访问下面的 Microsoft 网站:
http://support.microsoft.com/contactus/?ws=support
注意在特殊的情况中如果 Microsoft 支持专业人员确定某个特定更新才能解决您的问题,可能会被取消通常会导致支持电话的费用。将正常收取支持费用将应用于其他支持问题和不需要进行专门更新的问题。

文件信息

此修补程序的英文版具有的文件属性 (或更新的文件属性) 在下表中列出。日期和时间对这些文件列出在协调世界时 (UTC)。当您查看文件信息时,将转换为本地时间。若要 UTC 与本地时间之间的时差使用控制面板中的 日期和时间 项中的 时区 选项卡。outlook 的 Microsoft 动态 CRM 客户端
收起该表格展开该表格
文件的名称文件版本文件大小日期时间
Crmcache.dll3.0.5469.1182308,5842007 年八月 17 日02: 35
Crmmetadatacache.dll3.0.5469.1182205,6722007 年八月 17 日02: 35
Crmsecurity.dll3.0.5469.1182771,9442007 年八月 17 日02: 35
Microsoft 动态 CRM 的 Outlook 兼容性更新的客户端
收起该表格展开该表格
文件的名称文件版本文件大小日期时间
V3icclientpatch30.msp不适用410,1122007 年八月 17 日03: 00
Crmcache.dll3.0.5469.1182308,5842007 年八月 17 日02: 35
Crmmetadatacache.dll3.0.5469.1182205,6722007 年八月 17 日02: 35
Crmsecurity.dll3.0.5469.1182771,9442007 年八月 17 日02: 35
Microsoft 动态 CRM 3.0 服务器
收起该表格展开该表格
文件的名称文件版本文件大小日期时间
Crmcache.dll3.0.5469.1182308,5842007 年八月 17 日02: 35
Crmmetadatacache.dll3.0.5469.1182205,6722007 年八月 17 日02: 35
Crmsecurity.dll3.0.5469.1182771,9442007 年八月 17 日02: 35
Crmworkflowservice.exe3.0.5469.11823,928,9362007 年八月 17 日02: 35

状态

Microsoft 已经确认这是在"适用于"一节中列出的 Microsoft 产品中的问题。
在 Microsoft 动态 CRM 3.0 更新汇总 2、 更新汇总 1 的服务提供商的 Microsoft 动态 CRM 3.0 专业版、 简体中文版本的 Microsoft 动态 CRM 3.0,更新汇总 2 中以及在日语版的 Microsoft 动态 CRM 3.0 中,此问题已得到纠正。

更多信息

使用 Log Parser 工具可以确定在 Microsoft 动态 CRM 3.0 服务器上发生的错误。若要获取 Log Parser 工具,请访问下面的 Microsoft 网站:
http://www.microsoft.com/downloads/details.aspx?FamilyID=890cd06b-abf8-4c25-91b2-f8d975cf8c07&displaylang=en
在安装 Log Parser 工具后,使用此工具可以查询错误。若要这样做,请按照下列步骤操作:
  1. 单击 开始,指向 所有程序、 都指向 日志分析器 2.2,然后单击 日志分析器 2.2
  2. 该日志分析器 2.2 命令处键入以下命令:
    Logparser"选择 TimeGenerated,SourceName,EventCategoryName,System.csv 从系统中的消息位置 EventID IN (7034 ; 1074年 ; 26) 的顺序,按 TimeGenerated desc"
  3. 请按 ENTER 键。
  4. 通过使用下列程序之一打开 System.csv 文件,请执行以下操作:
    • Microsoft Office Excel
    • Microsoft Office Word
    • 记事本
    注意默认状态下,System.csv 文件位于以下目录:
    是 Files\Log Parser 2.2
System.csv 文件中的记录显示在 Microsoft 动态 CRM 3.0 服务器上发生的错误。

参考

关于性能调整的 CRM 3.0 的信息,请参阅以下白皮书:
Optimizing the Performance of Microsoft Dynamics CRM 3.0 White Paper
有关用于描述 Microsoft 软件更新术语的详细信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
824684用于描述 Microsoft 软件更新的标准术语的说明
887283Microsoft 企业解决方案 CRM 软件修补程序和更新包的命名标准

属性

文章编号: 921065 - 最后修改: 2008年5月15日 - 修订: 8.2
这篇文章中的信息适用于:
  • Microsoft CRM 3.0
  • Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers
关键字:?
kbmt kbautohotfix kbmbsadministration kbhotfixserver kbqfe kbmbsmigrate KB921065 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 921065
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com