Internet Explorer genera un mensaje de error que indica que no se puede mostrar una página en un equipo que ejecuta Windows Server 2003 o Windows XP

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Síntomas

Utilice Microsoft Internet Explorer para ver una página Web en un equipo que ejecuta Microsoft Windows Server 2003 o Microsoft Windows XP. Al hacer esto, Internet Explorer genera un mensaje de error que indica que no se puede mostrar la página.

Causa

Este problema puede producirse si se cumplen las condiciones siguientes:
  • Internet Explorer utiliza el comando Conectar para enviar datos, para obtener datos, o configurar una conexión HTTPS.
  • El servidor Web emite una alerta de cierre de Secure Sockets Layer (SSL) 3.0 al mismo tiempo que el puerto está cerrado en el servidor.

Más información

La alerta de cierre se envía por el servidor a Internet Explorer como un paquete cifrado de cero bytes. Sin embargo, se envía el mensaje de cierre completo en dos paquetes diferentes. El servidor envía sólo el primer paquete.

Normalmente, el primer paquete de alerta de cierre incluye la ". AP..." (Ack Push) Indicadores TCP para indicar el programa que está cerrando la sesión de SSL 3.0. Un segundo paquete incluye los indicadores TCP ".A...F" (Ack Fin) para indicar a la capa TCP para cerrar el puerto en el equipo cliente.

Porque los indicadores RESET y FIN TCP no están establecidos cuando llega el primer paquete de la alerta de cierre, el proceso Wininet.dll en el equipo cliente que está ejecutando Internet Explorer no puede comprobar que el paquete no es datos de programa. Por lo tanto, el puerto keep-alive se deja abierto en el equipo cliente hasta que la siguiente llamada de recepción de socket se envía por el equipo cliente. Puesto que Internet Explorer tiene dos puertos keep-alive, que están abiertos en el servidor, el número de reintentos es igual a dos en el equipo cliente.

La llamada de recepción de socket se produce en el cliente después de intenta enviar datos en el primer puerto keep-alive. Cuando se produce la llamada de recepción de socket, se procesa la alerta de cierre de SSL 3.0. A continuación, el cierre TCP se procesa en el cliente. Este paso cierra el primer puerto keep-alive.

Dado que el número de reintentos es ahora uno, el cliente intenta volver a enviar datos en el segundo puerto keep-alive. Sin embargo, este puerto también se ha cerrado en el servidor. Cuando se produce la llamada de recepción de socket en el cliente, se procesa la alerta de cierre de SSL 3.0. A continuación, se procesa el cierre TCP. El recuento de reintentos es ahora cero. Por lo tanto, se genera el mensaje de error que indica que no se puede mostrar la página.

Solución

Información de la actualización de seguridad

Para resolver este problema, instale la actualización de seguridad acumulativa más reciente para Internet Explorer. Para instalar las actualizaciones más recientes, visite el siguiente sitio Web de Microsoft:
http://windowsupdate.microsoft.com
Para información más técnica acerca de la actualización de seguridad acumulativa más reciente para Internet Explorer, visite el siguiente sitio Web:
http://www.microsoft.com/technet/security/current.aspx
Nota Esta actualización se incluyó primero en la actualización de seguridad 942615 (MS07-069).

Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
942615MS07-069: Actualización de seguridad acumulativa para Internet Explorer

Información sobre hotfix de Windows Server 2003

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

No se necesita ningún requisito previo.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SPTipo de servicio
Wininet.dll6.0.3790.549628,73622-Jun-200611: 19x 86NingunoRTMQFE
Wininet.dll6.0.3790.2731665,60022-Jun-200612: 12x 86SP1SP1QFE

Cómo habilitar la revisión

importante Esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por tanto, asegúrese de que siga estos pasos cuidadosamente. Realice una para agregar protección, copia de seguridad del registro antes de modificarlo. A continuación, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo realizar una copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo realizar una copia de seguridad y restaurar el registro de Windows


Después de instalar este hotfix, debe modificar el registro para habilitar la revisión. Para habilitar la revisión, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
  2. Busque y haga clic con el botón secundario en la siguiente subclave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. Seleccione nuevo y, a continuación, haga clic en clave .
  4. Escriba FEATURE_HANDLE_SSL_CLOSE_NOTIFY_KB921090 y, a continuación, presione ENTRAR nombre a la nueva clave.
  5. Haga clic con el botón secundario del mouse en FEATURE_HANDLE_SSL_CLOSE_NOTIFY_KB921090 , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  6. Escriba iexplore.exe y presione ENTRAR para asignar nombre al valor.
  7. Haga clic con el botón secundario del mouse en iexplore.exe y, a continuación, haga clic en Modificar .
  8. En el cuadro datos del valor , escriba 00000001 y, a continuación, haga clic en Aceptar .
  9. Editor de registro de salida.

Información sobre hotfix de Windows XP

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para instalar este hotfix, debe instalar Windows XP Service Pack 2.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Wininet.dll6.0.2900.2936664,57622-Jun-200610: 41x 86

Cómo habilitar la revisión

importante Esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por tanto, asegúrese de que siga estos pasos cuidadosamente. Realice una para agregar protección, copia de seguridad del registro antes de modificarlo. A continuación, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo realizar una copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo realizar una copia de seguridad y restaurar el registro de Windows


Después de instalar este hotfix, debe modificar el registro para habilitar la revisión. Para habilitar la revisión, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
  2. Busque y haga clic con el botón secundario en la siguiente subclave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. Seleccione nuevo y, a continuación, haga clic en clave .
  4. Escriba FEATURE_HANDLE_SSL_CLOSE_NOTIFY_KB921090 y, a continuación, presione ENTRAR nombre a la nueva clave.
  5. Haga clic con el botón secundario del mouse en FEATURE_HANDLE_SSL_CLOSE_NOTIFY_KB921090 , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  6. Escriba iexplore.exe y presione ENTRAR para asignar nombre al valor.
  7. Haga clic con el botón secundario del mouse en iexplore.exe y, a continuación, haga clic en Modificar .
  8. En el cuadro datos del valor , escriba 00000001 y, a continuación, haga clic en Aceptar .
  9. Editor de registro de salida.

Solución

Para evitar este problema, utilice uno de los métodos siguientes:
  • Deshabilitar alertas de cierre de SSL 3.0 en el servidor.
  • Cambie el valor keep-alive de tiempo de espera de 30 segundos a 300 segundos.
Para obtener más información acerca de cómo configurar la configuración de tiempo de espera de mantenimiento, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
183110WinInet limita las conexiones por servidor

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 921090 - Última revisión: jueves, 14 de agosto de 2008 - Versión: 2.0
La información de este artículo se refiere a:
  • Microsoft Internet Explorer 6.0 sobre las siguientes plataformas
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
Palabras clave: 
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