Internet Explorer gera uma mensagem de erro que afirma que uma página não pode ser apresentada num computador com o Windows Server 2003 ou Windows XP

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Sintomas

Utilizar o Microsoft Internet Explorer para visualizar uma página Web num computador com o Microsoft Windows Server 2003 ou Microsoft Windows XP. Quando o fizer, Internet Explorer gera uma mensagem de erro que indica que a página não pode ser apresentada.

Causa

Este problema poderá ocorrer se se verificarem as seguintes condições:
  • Internet Explorer utiliza o comando ligar para colocar dados, para obter dados ou para configurar uma ligação HTTPS.
  • O servidor Web emite um alerta de encerramento de camada segura de sockets (SSL) 3.0 ao mesmo tempo que a porta está fechada no servidor.

Mais Informação

O alerta de encerramento é enviado pelo servidor para o Internet Explorer como um pacote encriptado zero bytes. No entanto, a mensagem de encerramento completo é enviada em dois pacotes diferentes. O servidor envia apenas o primeiro pacote.

Normalmente, o primeiro pacote alerta encerramento inclui a ". AP..." (Emissão de confirmação) Sinalizadores TCP para indicar o programa que é fechar a sessão de SSL 3.0. Um segundo pacote inclui os sinalizadores TCP ".A...F" (campo de Cód. confirmação) para indicar a camada TCP para fechar a porta no computador cliente.

Porque os sinalizadores RESET e TCP FIN não estão definidos quando o alerta de encerramento no pacote primeiro, o processo de Wininet.dll no computador cliente com o Internet Explorer não consegue Verifique se o pacote não está dados do programa. Por este motivo, a porta keep-alive é deixada aberta no computador cliente até que a chamada seguinte socket de recepção é enviada pelo computador cliente. Uma vez que Internet Explorer tem duas portas keep-alive que estão abertas para o servidor, a contagem de tentativas é igual a dois no computador cliente.

A chamada de socket de recepção ocorre no cliente depois de tentar enviar dados na primeira porta keep-alive. Quando ocorre a chamada de socket de recepção, o alerta de encerramento do SSL 3.0 é processado. Em seguida, fecho TCP é processado no cliente. Este passo fecha à primeira porta keep-alive.

Uma vez que a contagem de tentativas é agora um, o cliente tenta enviar dados na segunda porta keep-alive. No entanto, esta porta também foi fechada no servidor. Quando ocorre a chamada de socket de recepção no cliente, o alerta de encerramento do SSL 3.0 é processado. Em seguida, fecho TCP é processado. A contagem de repetição agora é zero. Por este motivo, a mensagem de erro é gerada que indica que a página não pode ser apresentada.

Resolução

Informações sobre a actualização de segurança

Para resolver este problema, instale a actualização de segurança cumulativa mais recente para o Internet Explorer. Para instalar as actualizações mais recentes, visite o seguinte Web site da Microsoft:
http://windowsupdate.microsoft.com
Para informações mais técnicas sobre a actualização de segurança cumulativa mais recente para o Internet Explorer, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/technet/security/current.aspx
Nota Esta actualização foi incluída na actualização de segurança 942615 (MS07-069) pela primeira vez.

Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
942615MS07-069: Actualização de segurança cumulativa do Internet Explorer

Informações sobre a correcção do Windows Server 2003

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisito de reinício

Tem de reiniciar o computador depois de aplicar esta correcção.

Informações sobre substituição de correcções

Esta correcção não substitui quaisquer outras correcções.

Informações do ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item Data e hora no painel de controlo.
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataformaRequisito de SPRamo de serviço
Wininet.dll6.0.3790.549628,73622 De Junho de 200611: 19x 86NenhumRTMQFE
Wininet.dll6.0.3790.2731665,60022 De Junho de 200612: 12x 86SP1SP1QFE

Como activar a correcção

importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Criar uma para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756Como efectuar uma cópia de segurança e restaurar o registo no Windows


Depois de instalar esta correcção, tem de modificar o registo para activar a correcção. Para activar a correcção, siga estes passos:
  1. Clique em Iniciar , clique em Executar , escreva regedit e, em seguida, clique em OK .
  2. Localize e, em seguida, com o botão direito do rato na seguinte subchave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. Aponte para Novo e, em seguida, clique em chave .
  4. Escreva FEATURE_HANDLE_SSL_CLOSE_NOTIFY_KB921090 e, em seguida, prima ENTER para a nova chave de nome.
  5. Clique com o botão direito do rato FEATURE_HANDLE_SSL_CLOSE_NOTIFY_KB921090 , aponte para Novo e, em seguida, clique em Valor DWORD (DWORD Value) .
  6. Escreva iexplore.exe e, em seguida, prima ENTER para nome de valor.
  7. Clique com o botão direito do rato iexplore.exe e, em seguida, clique em Modificar .
  8. Na caixa dados do valor , escreva 00000001 e, em seguida, clique em OK .
  9. Saia do Editor de registo.

Informações sobre a correcção do Windows XP

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Para instalar esta correcção, tem de instalar Windows XP Service Pack 2.

Requisito de reinício

Tem de reiniciar o computador depois de aplicar esta correcção.

Informações sobre substituição de correcções

Esta correcção não substitui quaisquer outras correcções.

Informações do ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item Data e hora no painel de controlo.
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempoPlataforma
Wininet.dll6.0.2900.2936664,57622 De Junho de 200610: 41x 86

Como activar a correcção

importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Criar uma para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756Como efectuar uma cópia de segurança e restaurar o registo no Windows


Depois de instalar esta correcção, tem de modificar o registo para activar a correcção. Para activar a correcção, siga estes passos:
  1. Clique em Iniciar , clique em Executar , escreva regedit e, em seguida, clique em OK .
  2. Localize e, em seguida, com o botão direito do rato na seguinte subchave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. Aponte para Novo e, em seguida, clique em chave .
  4. Escreva FEATURE_HANDLE_SSL_CLOSE_NOTIFY_KB921090 e, em seguida, prima ENTER para a nova chave de nome.
  5. Clique com o botão direito do rato FEATURE_HANDLE_SSL_CLOSE_NOTIFY_KB921090 , aponte para Novo e, em seguida, clique em Valor DWORD (DWORD Value) .
  6. Escreva iexplore.exe e, em seguida, prima ENTER para nome de valor.
  7. Clique com o botão direito do rato iexplore.exe e, em seguida, clique em Modificar .
  8. Na caixa dados do valor , escreva 00000001 e, em seguida, clique em OK .
  9. Saia do Editor de registo.

Como contornar

Para contornar este problema, utilize um dos seguintes métodos:
  • Desactive alertas de encerramento do SSL 3.0 no servidor.
  • Altere a definição tempo de keep-alive de 30 segundos para 300 segundos.
Para obter mais informações sobre como configurar a definição de tempo de keep-alive, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
183110WinInet limita ligações por servidor

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

Propriedades

Artigo: 921090 - Última revisão: 14 de agosto de 2008 - Revisão: 2.0
A informação contida neste artigo aplica-se a:
  • Microsoft Internet Explorer 6.0 nas seguintes plataformas
    • Microsoft Windows Server 2003 Standard Edition
    • Microsoft Windows Server 2003 Enterprise Edition
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional Edition
Palavras-chave: 
kbmt kbautohotfix kbwinserv2003presp2fix kbwinxppresp3fix kbie501fix kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB921090 KbMtpt
Tradução automática
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