Internet Explorer gera uma mensagem de erro que afirma que uma página não pode ser exibida em um computador que está executando o Windows Server 2003 ou o Windows XP

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Sintomas

Usar o Microsoft Internet Explorer para exibir uma página da Web em um computador que esteja executando o Microsoft Windows Server 2003 ou Microsoft Windows XP. Quando você fizer isso, o Internet Explorer gera uma mensagem de erro informando que a página não pode ser exibida.

Causa

Esse problema pode ocorrer se as seguintes condições forem verdadeiras:
  • Internet Explorer usa o comando conectar-se para postar dados, para obter dados ou para configurar uma conexão HTTPS.
  • O servidor Web emite um alerta de encerramento SSL (Secure Sockets Layer) 3.0 ao mesmo tempo que a porta está fechada no servidor.

Mais Informações

O alerta de encerramento é enviado pelo servidor para o Internet Explorer como um pacote criptografado de zero byte. No entanto, a mensagem completa de fechamento é enviada em dois pacotes diferentes. O servidor envia somente o primeiro pacote.

Geralmente, o primeiro pacote alerta fechamento inclui a ". AP..." (Ack Push) Sinalizadores TCP para instruir o programa que está fechando a sessão SSL 3.0. Um segundo pacote inclui os sinalizadores TCP ".A...F" (Ack Fin) para instruir a camada TCP a fechar a porta no computador cliente.

Como os sinalizadores RESET e FIN TCP não estão definidos quando o alerta de encerramento chega no primeiro pacote, o processo de Wininet.dll no computador cliente que está executando o Internet Explorer não é possível Verifique se o pacote não é dados do programa. Portanto, a porta keep-alive é deixada aberta no computador cliente até que a próxima chamada Socket Receive seja enviada pelo computador cliente. Como Internet Explorer possui duas portas keep-alive abertas para o servidor, a contagem retry é igual a dois no computador cliente.

A chamada Socket Receive ocorre no cliente depois que ele tenta enviar dados na primeira porta keep-alive. Quando a chamada Socket Receive ocorre, o alerta de encerramento SSL 3.0 é processado. Em seguida, o encerramento TCP é processado no cliente. Esta etapa fecha a primeira porta keep-alive.

Como a contagem retry é agora um, o cliente tenta enviar novamente dados na segunda porta keep-alive. No entanto, essa porta também foi fechada no servidor. Quando a chamada Socket Receive ocorre no cliente, o alerta de encerramento SSL 3.0 é processado. Em seguida, o encerramento TCP é processado. A contagem retry agora é zero. Portanto, a mensagem de erro é gerada afirmando que a página não pode ser exibida.

Resolução

Informações de atualização de segurança

Para resolver esse problema, instale a actualização de segurança cumulativa mais recente para o Internet Explorer. Para instalar as atualizações mais recentes, visite o seguinte site:
http://windowsupdate.microsoft.com
Para informações mais técnicas sobre a atualização de segurança cumulativa mais atual para o Internet Explorer, visite o seguinte site:
http://www.microsoft.com/technet/security/current.aspx
Observação Essa atualização foi incluída primeiro na atualização de segurança 942615 (MS07-069).

Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
942615MS07-069: Atualização de segurança cumulativa para Internet Explorer

Informações sobre o hotfix Windows Server 2003

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
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Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SPRamificação do serviço
Wininet.dll6.0.3790.549628,73622 De junho de 200611: 19x 86NenhumRTMQFE
Wininet.dll6.0.3790.2731665,60022 De junho de 200612: 12x 86SP1SP1QFE

Como habilitar o hotfix

importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756Como fazer backup e restaurar o registro no Windows


Depois de instalar esse hotfix, você deve modificar o registro para habilitar o hotfix. Para habilitar o hotfix, siga estas etapas:
  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Localize e, em seguida, com o botão direito do rato na seguinte subchave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. Aponte para novo e, em seguida, clique em chave .
  4. Digite FEATURE_HANDLE_SSL_CLOSE_NOTIFY_KB921090 e, em seguida, pressione ENTER para nomear a nova chave.
  5. Clique com o botão direito do mouse FEATURE_HANDLE_SSL_CLOSE_NOTIFY_KB921090 , aponte para novo e, em seguida, clique em Valor DWORD .
  6. Digite iexplore.exe e pressione ENTER para o nome do valor.
  7. Clique com o botão direito do mouse iexplore.exe e, em seguida, clique em Modificar .
  8. Na caixa dados do valor , digite 00000001 e, em seguida, clique em OK .
  9. Feche o Editor do Registro.

Informações sobre o Windows XP hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para instalar esse hotfix, instale o Windows XP Service Pack 2.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Wininet.dll6.0.2900.2936664,57622 De junho de 200610: 41x 86

Como habilitar o hotfix

importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756Como fazer backup e restaurar o registro no Windows


Depois de instalar esse hotfix, você deve modificar o registro para habilitar o hotfix. Para habilitar o hotfix, siga estas etapas:
  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Localize e, em seguida, com o botão direito do rato na seguinte subchave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. Aponte para novo e, em seguida, clique em chave .
  4. Digite FEATURE_HANDLE_SSL_CLOSE_NOTIFY_KB921090 e, em seguida, pressione ENTER para nomear a nova chave.
  5. Clique com o botão direito do mouse FEATURE_HANDLE_SSL_CLOSE_NOTIFY_KB921090 , aponte para novo e, em seguida, clique em Valor DWORD .
  6. Digite iexplore.exe e pressione ENTER para o nome do valor.
  7. Clique com o botão direito do mouse iexplore.exe e, em seguida, clique em Modificar .
  8. Na caixa dados do valor , digite 00000001 e, em seguida, clique em OK .
  9. Feche o Editor do Registro.

Como Contornar

Para contornar este problema, use um dos seguintes métodos:
  • Desative alertas de encerramento do SSL 3.0 no servidor.
  • Altere a configuração de tempo limite keep-alive de 30 segundos para 300 segundos.
Para obter mais informações sobre como configurar o tempo limite keep-alive, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
183110Limites de WinInet conexões por servidor

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software

Propriedades

ID do artigo: 921090 - Última revisão: quinta-feira, 14 de agosto de 2008 - Revisão: 2.0
A informação contida neste artigo aplica-se a:
  • Microsoft Internet Explorer 6.0 nas seguintes plataformas
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
Palavras-chave: 
kbmt kbautohotfix kbwinserv2003presp2fix kbwinxppresp3fix kbie501fix kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB921090 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 921090

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