Help and Support
 

powered byLive Search
Hotfix Download Available

A recipient filter in Exchange Server 2003 does not work when you use Microsoft Solution for Hosted Messaging and Collaboration version 3.5

Article ID:921101
Last Review:October 25, 2007
Revision:3.3

Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/) Description of the Microsoft Windows registry
On This Page

SYMPTOMS

When you try to use a recipient filter in Microsoft Exchange Server 2003, the recipient filter may not work as expected. This symptom occurs if you use Microsoft Solution for Hosted Messaging and Collaboration (HMC) version 3.5. Additionally, you may receive unwanted e-mail messages in this situation.

Back to the top

CAUSE

This problem occurs because HMC uses the Smtpdomx.dll event sink to filter recipients instead of using the Active Directory directory service. The Smtpdomx.dll event sink uses the Domains.dat file to filter recipients. Recipient filtering does not work when the HMC event sink is used because recipient filtering looks up domains in Active Directory. HMC does not keep a list of domains in Active Directory.

Back to the top

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Microsoft Exchange Server 2003 Service Pack 2 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Turflist.dll6.5.7651.37118,27218-Jul-200616:40x86

Back to the top

How to enable the hotfix

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you apply this hotfix, you must modify the registry to enable the hotfix functionality. By default, the hotfix functionality is disabled. The registry setting is loaded when the DLL initializes. To enable the hotfix functionality, follow these steps:
1.Click Start, click Run, type regedit, and then click OK.
2.Expand the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters
3.Right-click Parameters, point to New, and then click DWORD Value.
4.Type CheckAllRecipients, and then press ENTER to name the new value.
5.Right-click CheckAllRecipients, and then click Modify.
6.In the Value data box, type 1, and then click OK.
The relay scenario must be supported by an SMTP virtual server that is not configured to use a recipient policy. Additionally, this registry fix must be used with the Smtpdomx.dll event sink in a hosting environment. After you enable this hotfix and configure an SMTP virtual server, you cannot use that SMTP virtual server for relay. You must create another SMTP virtual server to support relay.

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Back to the top

MORE INFORMATION

For more information about the Microsoft Solution for Hosted Messaging and Collaboration (HMC) version 3.5, visit the following Microsoft Web site:
http://www.microsoft.com/serviceproviders/solutions/hostedmessaging.mspx (http://www.microsoft.com/serviceproviders/solutions/hostedmessaging.mspx)
For more information about the terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates
For more information about the naming schema for Exchange Server software update packages, click the following article number to view the article in the Microsoft Knowledge Base:
817903 (http://support.microsoft.com/kb/817903/) New naming schema for Exchange Server software update packages

Back to the top


APPLIES TO
Microsoft Exchange Server 2003 Standard Edition
Microsoft Exchange Server 2003 Enterprise Edition

Back to the top

Keywords: 
kbautohotfix kbhotfixserver kbqfe kbfix kbbug kbexchange2003presp2fix kbpubtypekc KB921101

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.