Mensagem de erro ao tentar fazer logon no Microsoft Dynamics CRM 3.0: "Logon falhou para usuário Autoridade/Anônimo do NT"

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Sintomas

Ao tentar fazer logon no Microsoft Dynamics CRM 3.0, a seguinte mensagem de erro é exibida:
Logon falhou para usuário Autoridade/Anônimo do NT.
Em seguida, se você pressionar F5, a seguinte mensagem de erro será exibida:
Microsoft CRM não pode fazer logon no sistema. Certifique-se de que seu registro de usuário esteja habilitado e de que você tenha pelo menos uma função de segurança atribuída. Para obter informações adicionais, contate o administrador de sistema.
Além disso, ao tentar usar o Gerenciador de Implantação para acessar o Gerenciador de Usuários, a seguinte mensagem de erro é exibida:
O servidor http://CRMSERVER/MSCRMServices não está respondendo. Isto poderá acontecer se ele estiver indisponível no momento, não for um servidor do Microsoft CRM ou se você não possuir privilégios suficientes para executar o Gerenciador de Usuários. Para obter informações adicionais, contate o administrador de sistema.
Observação CRMSERVER é um espaço reservado que representa um servidor Microsoft Dynamics CRM real.

Causa

Este problema ocorre porque o nome principal de serviço (SPN) não está definido.

Resolução

Para resolver o problema, execute as seguintes etapas:
  1. Faça logon no computador que está executando o Microsoft SQL Server.
  2. Clique em Iniciar, aponte para Todos os programas, para Ferramentas administrativas e clique em Serviços.
  3. Clique com o botão direito do mouse em MSSQLSERVER e clique em Propriedades.
  4. Para ver qual é a conta utilizada como a conta de logon, clique na guia Logon.

    Observação Se a conta do sistema local estiver selecionada, essa conta será a conta do computador. O SPN deve estar adicionado à conta que está executando o serviço MSSQLSERVER.
  5. No computador onde o Microsoft Dynamics CRM está instalado, faça logon como um usuário que tem a função de administrador do domínio.
  6. Instale as Ferramentas de Suporte do Windows no servidor Microsoft Dynamics CRM. As ferramentas estão no CD do Microsoft Windows Server 2003 ou do Microsoft Windows 2000 Server.
  7. Clique em Iniciar, aponte para Todos os programas, aponte para Ferramentas de suporte do Windows e clique em Prompt de comando.
  8. No prompt de comando, execute os seguintes comandos.
    setspn -A MSSQLSVC/SQL_server_name:1433 Service Account
    setspn -A MSSQLSVC/SQL_server_name.Domain_name:1433 Service Account
    Observação SQL_server_name é um espaço reservado que representa um servidor SQL real. Nome_do_domínio é um espaço reservado que representa um nome do domínio real. Conta de serviço é um espaço reservado que representa a conta de serviço que está executando o serviço MSSQLSERVER. O SPN deve estar adicionado à essa conta de serviço. Se a conta do sistema local estiver executando o serviço MSSQLSERVER, utilize o SQL_server_name como nome da conta de serviço. Se uma conta de usuário estiver executando o serviço MSSQLSERVER, utilize Domain_name/user_account_name como nome da conta de serviço.
  9. Para verificar se o SPN está definido, execute o seguinte comando no prompt de comando.
    setspn -L Service Account

Propriedades

ID do artigo: 921393 - Última revisão: quarta-feira, 31 de outubro de 2007 - Revisão: 1.2
A informação contida neste artigo aplica-se a:
  • Microsoft Dynamics CRM 3.0
Palavras-chave: 
kberrmsg kbtshoot kbprb kbmbsmigrate kbmbsinstallation kbmbsadministration kbmbscrm40no KB921393

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