Artikkelin tunnus: 921541 - Näytä tuotteet, joita tämä artikkeli koskee.

Tämä artikkeli on mukautettu seuraavista aiemmin saatavana olleista artikkeleista: 820919, 821713, 822908, 821715, 821716, 822127, 319299, 319153, 319154, 319155, 319156 ja 319157
Laajenna kaikki | Kutista kaikki

Tällä sivulla

Yhteenveto

Tässä artikkelissa kuvataan, miten voidaan tehdä Microsoft Office Word 2010:n, Microsoft Office Word 2007:n, Microsoft Office Word 2003:n tai Microsoft Word 2002:n käynnistyksen tai käyttämisen aikana ilmenevien ongelmien vianmääritys. Kuvattujen tapojen avulla voit selvittää ongelman syyn Wordin avulla, kun ongelmaa ei voi tunnistaa muilla tavoilla.

Microsoft suosittelee, että käyt Microsoft Word -tuotteen ratkaisukeskuksessa ja katsot, löytyykö sieltä ongelmaasi liittyviä tietoja, ennen kuin kokeilet näiden toimien tekemistä:

http://support.microsoft.com/ph/939#tab0

Huomautus Löydät mahdollisesti kohtaamiasi tiettyjä ongelmia käsitteleviä artikkeleita etsimällä Microsoft Knowledge Base -tietokannasta. Voit tehdä tämän käymällä seuraavassa Microsoftin WWW-sivustossa:
http://support.microsoft.com/default.aspx



Korjaa ongelma puolestani



Jos haluat, että tämä ongelma korjataan automaattisesti, napsauta Fix it -ratkaisun painiketta tai linkkiä. Valitse Tiedostojen lataaminen -valintaikkunassa Suorita ja noudata sitten ohjatun Fix it -toiminnon ohjeita.


Korjaa tämä ongelma
Microsoftin Fix it -ratkaisu 30017
Huomautuksia
  • Tämä ohjattu toiminto saattaa olla vain englanninkielinen. Automaattinen korjaus toimii kuitenkin myös muiden Windowsin kieliversioiden kanssa.
  • Jos et ole käyttämässä tietokonetta, jossa tämä ongelma ilmenee, tallenna Fix it -ratkaisu muistitikkuun tai CD-levylle ja suorita se sitten tietokoneessa, jossa ongelma ilmenee.



Wordin käynnistyksen tai käyttämisen aikana ilmenevien ongelmien vianmäärityksen manuaaliset vaiheet

Tärkeää Tässä osassa, tavassa tai tehtävässä olevissa vaiheissa kerrotaan, miten rekisteriä muokataan. Vakavia ongelmia saattaa kuitenkin ilmetä, jos rekisteriä muokataan virheellisesti. Varmista siis, että noudatat ohjeita huolellisesti. Varmuuskopioi rekisteri varmuuden vuoksi ennen sen muokkaamista. Tällöin voit palauttaa sen, jos ongelmia ilmenee. Lisätietoja rekisterin varmuuskopioimisesta ja palauttamisesta saat napsauttamalla seuraavaa artikkelin numeroa, jolloin pääset lukemaan artikkelin Microsoft Knowledge Base -tietokannassa:
322756 Rekisterin varmuuskopioiminen ja palauttaminen Windowsissa

Wordin Data-rekisteriavaimen poistaminen

Suurin osa Wordin usein käytetyistä asetuksista on tallennettu Wordin Data-rekisteriavaimeen. Yleinen vianmääritystoimi on poistaa Wordin Data-rekisteriavain. Kun käynnistät Wordin seuraavan kerran, Word luo Data-rekisteriavaimen uudelleen käyttäen oletusasetuksia.

Voit tarkastella näitä asetuksia Word 2002:ssa tai Word 2003:ssa valitsemalla Työkalut-valikosta Asetukset.

Voit tarkastella näitä asetuksia Word 2007:ssä napsauttamalla Microsoft Office -painiketta ja valitsemalla sitten Wordin asetukset.

Huomautus Kun poistat Wordin Data-rekisteriavaimen, Word palauttaa useita asetuksia niiden oletusasetuksiksi. Yksi näistä asetuksista on Tiedosto-valikon viimeksi käytettyjen tiedostojen luettelo. Lisäksi Word palauttaa useita Asetukset-valintaikkunassa mukautettavia asetuksia.

Voit poistaa Wordin Data-rekisteriavaimen seuraavasti:
  1. Sulje kaikki Office-ohjelmat.
  2. Napsauta Käynnistä-painiketta, valitse Suorita, kirjoita regedit ja valitse sitten OK.
  3. Etsi seuraava rekisterin aliavain käytössä olevan Wordin version mukaisesti:
    • Word 2002:
      HKEY_CURRENT_USER\Software\Microsoft \Office\10.0\Word\Data
    • Word 2003:
      HKEY_CURRENT_USER\Software\Microsoft\ Office\11.0\Word\Data
    • Word 2007:
      HKEY_CURRENT_USER\Software\Microsoft\ Office\12.0\Word\Data
    • Word 2010:
      HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Word\Data
  4. Valitse Data ja valitse sitten Tiedosto-valikosta Vie.
  5. Anna tiedostolle nimeksi Wddata.reg ja tallenna tiedosto sitten työpöydälle.
  6. Valitse Muokkaa-valikosta Poista ja valitse sitten Kyllä.
  7. Sulje Rekisterieditori.
  8. Käynnistä Word.
Jos Word käynnistyy ja toimii oikein, ongelma on ratkennut. Ongelma aiheutui vioittuneesta Wordin Data-rekisteriavaimesta. Jos haluat palauttaa haluamasi Wordin asetukset, saatat joutua muuttamaan joitakin asetuksia.

Jos ongelma ei ratkennut, palauta alkuperäinen Wordin Data-rekisteriavain. Lue sitten Wordin Options-rekisteriavaimen poistaminen -aihe.

Voit palauttaa alkuperäisen Wordin Data-rekisteriavaimen seuraavasti:
  1. Sulje kaikki Office-ohjelmat.
  2. Kaksoisnapsauta työpöydän Wddata.reg-kuvaketta.
  3. Valitse Kyllä ja valitse sitten OK.

Wordin Options-rekisteriavaimen poistaminen

Wordin Options-rekisteriavaimeen on tallennettu asetukset, jotka määritetään valikkovaihtoehtojen muuttamisen avulla. Asetukset on jaettu oletusasetuksiin ja valinnaisiin asetuksiin.

Oletusasetukset luodaan asennuksen aikana. Voit muuttaa oletusasetuksia muuttamalla asetuksia Wordissa. Valinnaisia asetuksia ei luoda asennuksen aikana.


Voit poistaa Wordin Options-rekisteriavaimen seuraavasti:
  1. Sulje kaikki Office-ohjelmat.
  2. Napsauta Käynnistä-painiketta, valitse Suorita, kirjoita regedit ja valitse sitten OK.
  3. Etsi seuraava rekisterin aliavain käytössä olevan Wordin version mukaisesti:
    • Word 2002:
      HKEY_CURRENT_USER\Software\Microsoft\ Office\10.0\Word\Options
    • Word 2003:
      HKEY_CURRENT_USER\Software\Microsoft\ Office\11.0\Word\Options
    • Word 2007:
      HKEY_CURRENT_USER\Software\Microsoft\ Office\12.0\Word\Options
    • Word 2010:
      HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Word\Options
  4. Valitse Options ja valitse sitten Tiedosto-valikosta Vie.
  5. Anna tiedostolle nimeksi Wdoptn.reg ja tallenna tiedosto sitten työpöydälle.
  6. Valitse Muokkaa-valikosta Poista ja valitse sitten Kyllä.
  7. Sulje Rekisterieditori.
  8. Käynnistä Word.
Jos Word käynnistyy ja toimii oikein, ongelma on ratkennut. Ongelma aiheutui vioittuneesta Wordin Options-rekisteriavaimesta. Jos haluat palauttaa haluamasi Wordin asetukset, saatat joutua muuttamaan joitakin asetuksia.

Jos ongelma ei ratkennut, palauta alkuperäinen Wordin Options-rekisteriavain. Lue sitten Yleisen Normal.dot- tai Normal.dotm-mallitiedoston nimeäminen uudelleen -aihe.

Voit palauttaa alkuperäisen Wordin Options-rekisteriavaimen seuraavasti:
  1. Sulje kaikki Office-ohjelmat.
  2. Kaksoisnapsauta työpöydän Wdoptn.reg-kuvaketta.
  3. Valitse Kyllä ja valitse sitten OK.

Yleisen Normal.dot- tai Normal.dotm-mallitiedoston nimeäminen uudelleen

Voit estää yleiseen mallitiedostoon tallennettujen muotoilujen, automaattisen tekstin ja makrojen vaikutuksen Wordiin ja avattaviin asiakirjoihin nimeämällä yleisen mallitiedoston uudelleen. Kun käynnistät Wordin uudelleen normaalisti, Word luo uuden yleisen mallitiedoston.

Tärkeää Kun nimeät yleisen mallitiedoston uudelleen, useita asetuksia palautetaan niiden oletusasetuksiksi. Näitä palautettuja asetuksia ovat esimerkiksi mukautetut tyylit, mukautetut työkalurivit, makrot ja automaattiset tekstit. Tämän vuoksi Microsoft suosittelee, että et poista yleistä mallitiedostoa.

Tietyissä tilanteissa voidaan luoda useita yleisiä mallitiedostoja. Seuraavassa on esimerkkejä näistä tilanteista:
  • Samassa tietokoneessa on useita Word-versioita.
  • Samassa tietokoneessa on useita työasema-asennuksia.
Varmista näissä tilanteissa, että nimeät uudelleen yleisen mallitiedoston oikean kopion.

Voit nimetä yleisen mallitiedoston uudelleen seuraavasti:
  1. Sulje kaikki Office-ohjelmat.
  2. Napsauta Käynnistä-painiketta, valitse Suorita, kirjoita tekstikenttään cmd ja valitse sitten OK.
  3. Kirjoita seuraava komento käytössä olevan Wordin version mukaisesti ja paina sitten ENTER-näppäintä:
    • Word 2002 ja Word 2003:
      Windows XP: ren %userprofile%\Application Data\Microsoft\Templates\Normal.dot OldNormal.dot

      Windows Vista tai Windows 7: ren %userprofile%\AppData\Roaming\Microsoft\Templates\Normal.dot OldNormal.dot
    • Word 2007 ja Word 2010:
      Windows XP: ren %userprofile%\Application Data\Microsoft\Templates\Normal.dotm OldNormal.dotm

      Windows Vista tai Windows 7: ren %userprofile%\AppData\Roaming\Microsoft\Templates\Normal.dotm OldNormal.dotm
  4. Kirjoita exit ja paina sitten ENTER-näppäintä.
  5. Käynnistä Word.
Jos Word käynnistyy oikein, ongelma on ratkennut. Tässä tapauksessa ongelma aiheutuu vahingoittuneesta yleisestä mallitiedostosta. Jos haluat palauttaa valitsemasi asetukset, saatat joutua muuttamaan joitakin asetuksia.

Yleinen mallitiedosto, jonka nimesit uudelleen, saattaa sisältää mukautuksia, joita ei voi luoda helposti uudelleen. Tällaisia mukautuksia voivat olla esimerkiksi tyylit, makrot ja automaattiset tekstit. Tässä tapauksessa saatat pystyä kopioimaan mukautukset vanhasta yleisestä mallitiedostosta uuteen yleiseen mallitiedostoon arkistoinnin avulla.

Saat lisätietoja makrojen nimeämisestä uudelleen arkistoinnin avulla valitsemalla Ohje-valikosta Microsoft Word Ohje, kirjoittamalla Etsi-ruutuun makrojen nimeäminen uudelleen ja tuomalla ohjeaiheen näyttöön valitsemalla sitten Etsi.

Jos ongelma ei ole ratkennut, palauta alkuperäinen yleinen mallitiedosto ja lue sitten Käynnistyskansion apuohjelmien poistaminen käytöstä -aihe.

Voit palauttaa alkuperäisen yleisen mallitiedoston seuraavasti:
  1. Sulje kaikki Office-ohjelmat.
  2. Napsauta Käynnistä-painiketta, valitse Suorita, kirjoita tekstikenttään cmd ja valitse sitten OK.
  3. Kirjoita seuraava komento käytössä olevan Wordin version mukaisesti ja paina sitten ENTER-näppäintä:
    • Word 2002 ja Word 2003:
      ren %userprofile%\Application Data\Microsoft\Templates\OldNormal.dot Normal.dot
    • Word 2007:
      ren %userprofile%\Application Data\Microsoft\Templates\OldNormal.dotm Normal.dotm
  4. Kirjoita exit ja paina sitten ENTER-näppäintä.
  5. Käynnistä Word.


Käynnistyskansion apuohjelmien poistaminen käytöstä

Kun käynnistät Wordin, Word lataa käynnistyskansioissa olevat mallit ja apuohjelmat automaattisesti. Wordin ongelmat saattavat aiheutua apuohjelmiin liittyvistä ongelmista ja ristiriidoista. Voit selvittää, aiheutuuko ongelma jostakin käynnistyskansiossa olevasta kohteesta, poistamalla näihin apuohjelmiin viittaavan rekisteriasetuksen käytöstä väliaikaisesti.

Voit tehdä tämän seuraavasti:
  1. Sulje kaikki Office-ohjelmat.
  2. Käytä jotakin seuraavista toimista käyttämäsi Wordin version mukaan:
    • Word 2002:
      Napsauta Käynnistä-painiketta, valitse Suorita, kirjoita %programfiles%\Microsoft\Office\Office10\Startup\ ja valitse sitten OK.
    • Word 2003:
      Napsauta Käynnistä-painiketta, valitse Suorita, kirjoita %programfiles%\Microsoft\Office\Office11\Startup\ ja valitse sitten OK.
    • Word 2007:
      Napsauta Käynnistä-painiketta, valitse Suorita, kirjoita %programfiles%\Microsoft\Office\Office12\Startup\ ja valitse sitten OK.
    • Word 2010:
      Napsauta Käynnistä-painiketta, valitse Suorita, kirjoita %programfiles%\Microsoft Office\Office14\Startup\ ja valitse sitten OK.
  3. Napsauta jotakin kansiossa olevaa tiedostoa hiiren kakkospainikkeella ja valitse sitten Nimeä uudelleen.
  4. Kirjoita tiedostonimen jälkeen .old ja paina sitten ENTER-näppäintä.

    Tärkeää Kirjoita tiedoston alkuperäinen nimi muistiin. Sinun on nimettävä tiedosto myöhemmin uudelleen käyttäen sen alkuperäistä nimeä.
  5. Käynnistä Word.
  6. Jos et pysty enää toistamaan ongelmaa, olet löytänyt ongelman aiheuttavan apuohjelman. Jos tarvitset kyseisen apuohjelman tarjoamia ominaisuuksia, ota yhteyttä apuohjelman valmistajaan ja kysy, onko apuohjelmalle olemassa päivitystä.

    Jos ongelma ei ole ratkennut, nimeä apuohjelma uudelleen käyttäen sen alkuperäistä nimeä ja toista sitten vaiheet 3?5 kullekin käynnistyskansiossa olevalle tiedostolle.
  7. Jos pystyt yhä toistamaan ongelman, napsauta Käynnistä-painiketta, valitse Suorita, kirjoita %userprofile%\Application Data\Microsoft\Word\Startup (Windows XP) tai %userprofile%\AppData\Roaming\Microsoft\Word\Startup (Windows Vista tai Windows 7) ja valitse sitten OK.
  8. Toista vaiheet 3?5 kullekin tässä käynnistyskansiossa olevalle tiedostolle.
Jos ongelma ei ole ratkennut sen jälkeen, kun olet poistanut käytöstä käynnistyskansion apuohjelmat, lue COM-apuohjelmien rekisteriavainten poistaminen -osa.

COM-apuohjelmien rekisteriavainten poistaminen

COM-apuohjelmat saattavat olla asennettuina mihin tahansa sijaintiin. Wordin kanssa vuorovaikutuksessa olevat ohjelmat asentavat COM-apuohjelmia. Poista COM-apuohjelmien rekisteriavaimet ja käynnistä Word sitten uudelleen.

Voit poistaa COM-apuohjelmien rekisteriavaimet seuraavasti:
  1. Sulje kaikki Office-ohjelmat.
  2. Napsauta Käynnistä-painiketta, valitse Suorita, kirjoita regedit ja valitse sitten OK.
  3. Etsi seuraava rekisterin aliavain käytössä olevan Wordin version mukaisesti:
    • Word 2002:
      HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins
    • Word 2003:
      HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins
    • Word 2007:
      HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins
    • Word 2010:
      HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins
  4. Valitse Addins ja valitse sitten Tiedosto-valikosta Vie.
  5. Anna tiedostolle nimeksi WdaddinHKCU.reg ja tallenna tiedosto sitten työpöydälle.
  6. Valitse Muokkaa-valikosta Poista ja valitse sitten Kyllä.
  7. Etsi seuraava rekisterin aliavain:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Office\Word\Addins
  8. Valitse Addins ja valitse sitten Tiedosto-valikosta Vie.
  9. Anna tiedostolle nimeksi WdaddinHKLM.reg ja tallenna tiedosto sitten työpöydälle.
  10. Valitse Muokkaa-valikosta Poista ja valitse sitten Kyllä.
  11. Sulje Rekisterieditori.
  12. Käynnistä Word.
Jos ongelma on ratkennut, olet selvittänyt ongelman aiheutuvan jostakin COM-apuohjelmasta. Seuraavaksi sinun on selvitettävä, mikä COM-apuohjelma aiheuttaa ongelman.

Ongelman aiheuttavan COM-apuohjelman selvittäminen

Voit tehdä tämän tekemällä seuraavat toimet:
  1. Sulje kaikki Office-ohjelmat.
  2. Kaksoisnapsauta työpöydän Wdaddin.reg-kuvaketta.
  3. Valitse Kyllä ja valitse sitten OK.
  4. Jos käytössä on Word 2007, siirry vaiheeseen 5.

    Jos käytössä on Word 2002 tai Word 2003, toimi seuraavasti:
    1. Käynnistä Word ja valitse sitten Työkalut-valikosta Mukauta.
    2. Valitse Mukauta-valintaikkunassa Komennot.
    3. Valitse Luokat-luettelosta Työkalut.
    4. Valitse Komennot-luettelosta COM-apuohjelmat ja vedä komento sitten johonkin työkaluriviin. Sulje Mukauttaminen-valintaikkuna.
  5. Käytä jotakin seuraavista toimista käyttämäsi Wordin version mukaan:

    Word 2002 ja Word 2003:
    1. Valitse työkalurivillä COM-apuohjelmat. Lisäsit tämän työkaluriviin vaiheessa 4.
    2. Jos COM-apuohjelmat-valintaikkunassa näkyy yksi apuohjelma, poista sen valintaruudun valinta. Jos luettelossa on useita apuohjelmia, poista vain yhden apuohjelman valintaruudun valinta kerrallaan, jotta voit selvittää, mikä apuohjelma aiheuttaa ongelman.
    3. Sulje COM-apuohjelmat-valintaikkuna valitsemalla OK.
    4. Valitse Tiedosto-valikosta Lopeta.
    Word 2007:
    1. Napsauta Microsoft Office -painiketta ja valitse sitten Wordin asetukset.
    2. Valitse Apuohjelmat.
    3. Valitse Hallinta-kohdassa COM-apuohjelmat ja valitse sitten Siirry.
    4. Jos COM-apuohjelmat-valintaikkunassa näkyy yksi apuohjelma, poista sen valintaruudun valinta. Jos luettelossa on useita apuohjelmia, poista vain yhden apuohjelman valintaruudun valinta kerrallaan, jotta voit selvittää, mikä apuohjelma aiheuttaa ongelman.
    5. Sulje COM-apuohjelmat-valintaikkuna valitsemalla OK.
    6. Napsauta Microsoft Office -painiketta ja valitse sitten Lopeta Word.
    Word 2010:
    1. Valitse Tiedosto ja valitse sitten Asetukset.
    2. Valitse Apuohjelmat.
    3. Valitse Hallinta-kohdassa COM-apuohjelmat ja valitse sitten Siirry.
    4. Jos COM-apuohjelmat-valintaikkunassa näkyy yksi apuohjelma, poista sen valintaruudun valinta. Jos luettelossa on useita apuohjelmia, poista vain yhden apuohjelman valintaruudun valinta kerrallaan, jotta voit selvittää, mikä apuohjelma aiheuttaa ongelman.
    5. Sulje COM-apuohjelmat-valintaikkuna valitsemalla OK.
    6. Valitse Tiedosto-valikosta Lopeta.
  6. Käynnistä Word.
  7. Jos ongelma on ratkennut, kun käynnistät Wordin, olet selvittänyt, mikä COM-apuohjelma aiheuttaa ongelman. Jos tarvitset apuohjelman tarjoamat ominaisuudet, sinun on selvitettävä, mikä apuohjelma sisältää kyseiset ominaisuudet, jotta voit pyytää päivitystä apuohjelman valmistajalta.

    Jos ongelma ei ole ratkennut, kun käynnistät Wordin, toista vaiheita 5 ja 6 kullekin luettelossa olevalle COM-apuohjelmalle. Toista näitä toimia kullekin apuohjelmalle, kunnes selvität, mikä apuohjelma aiheuttaa ongelman.
  8. Jos haluat palauttaa COM-apuohjelmat, toista vaihe 5, mutta valitse kunkin palautettavan COM-apuohjelman valintaruudut.

Microsoft-tukipalveluvaihtoehdot

Jos et pysty ratkaisemaan tätä ongelmaa, käytettävissäsi on useita tukipalveluvaihtoehtoja. Microsoft Online Support -tukipalvelun avulla voit hakea Microsoft Knowledge Base -tietokannasta sekä muista teknisistä resursseista nopeita ja tarkkoja vastauksia. Voit myös mukauttaa sivustoa, jotta voit hallita hakuasi. Voit aloittaa haun käymällä seuraavassa Microsoftin WWW-sivustosta:
http://www.microsoft.com/support/

Ominaisuudet

Artikkelin tunnus: 921541 - Viimeisin tarkistus: 28. joulukuuta 2011 - Versio: 6.0
Artikkelin tiedot koskevat seuraavia tuotteita:
  • Microsoft Word 2002 Standard Edition
  • Microsoft Office Word 2003
  • Microsoft Office Word 2007
  • Microsoft Word 2010
Hakusanat: 
kbacwsurvey kbexpertisebeginner kbregistry kbaddin kbhowtomaster kbfixme kbmsifixme KB921541

Anna palautetta

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com