Виправлення неполадок під час запуску або використання програми Word 2010, Word 2007 або Word 2003

Переклади статей Переклади статей
Номер статті: 921541 - Показ продуктів, яких стосується ця стаття.

Ця стаття поєднує такі раніше опубліковані статті: 820919, 821713, 822908, 821715, 821716, 822127, 319299, 319153, 319154, 319155, 319156 і 319157.
Розгорнути все | Згорнути все

На цій сторінці

ПІДСУМКИ

У цій статті описано способи вирішення проблем, що виникають під час запуску або використання Microsoft Office Word 2010, Microsoft Office Word 2007, Microsoft Office Word 2003 або Microsoft Word 2002. Описані в ній методи допоможуть визначити причину проблеми у Word, якщо це не вдається зробити в інший спосіб.

Перш ніж виконувати наведені у статті кроки, корпорація Майкрософт рекомендує відвідати центр рішень Microsoft Word і перевірити наявність докладніших відомостей про проблему.

http://support.microsoft.com/ph/939#tab0

Примітка. Щоб знайти статті, присвячені проблемам, з якими ви стикаєтеся, виконайте пошук за відповідним запитом у базі знань Microsoft. Для цього перейдіть на веб-сайт Microsoft за цією адресою:
http://support.microsoft.com/?ln=uk-ua



Автоматичне виправлення



Щоб вирішити цю проблему автоматично, натисніть кнопку Fix it або посилання під нею. У діалоговому вікні Завантаження файлу клацніть Виконати й дотримуйтесь інструкцій майстра Fix it.


Вирішити проблему
Microsoft Fix it 30017
Примітки
  • Цей майстер може бути лише англійською мовою. Проте автоматичне виправлення можна застосовувати також до інших мовних версій Windows.
  • Якщо ви працюєте не за тим комп’ютером, на якому виявлено неполадку, рішення Fix it можна зберегти на флеш-пам’ять або компакт-диск, а потім запустити на потрібному комп’ютері.



Самостійне вирішення проблем, які виникають під час запуску або використання програми Word

Увага! У цьому розділі, способі або завданні описано процес змінення реєстру. Неправильне змінення реєстру може призвести до серйозних проблем. Тому будьте уважні, виконуючи ці кроки. Перш ніж вносити зміни, обов’язково створіть резервну копію реєстру. Якщо виникне проблема, його можна буде відновити до попереднього стану. Докладні відомості про створення резервної копії та відновлення реєстру див. в цій статті бази знань Microsoft:
322756 Створення резервної копії та відновлення реєстру в ОС Windows

Видалення розділу реєстру з даними Word

Більшість параметрів Word, які часто використовуються, зберігаються в розділі реєстру з даними Word. Один із поширених способів виправлення неполадок – видалити розділ реєстру з даними Word. Після видалення цього розділу під час наступного запуску програма Word повторно створить розділ реєстру з даними Word, використовуючи параметри за промовчанням.

Щоб переглянути ці параметри у програмі Word 2002 або Word 2003, у меню Tools (знаряддя) виберіть пункт Options (параметри).

Щоб переглянути доступні параметри у програмі Word 2007, натисніть кнопку Microsoft Office, а потім – Параметри Word.

Примітка. У разі видалення розділу реєстру з даними Word деякі параметри Word буде скинуто до значень за промовчанням. Один із таких параметрів – це список нещодавно використовуваних файлів у меню Файл. Окрім того, у програмі Word скидається більшість настройок із діалогового вікна параметрів.

Щоб видалити розділ реєстру з даними Word, виконайте наведені нижче дії.
  1. Закрийте всі програми Office.
  2. Натисніть кнопку Пуск, виберіть команду Виконати, введіть regedit і натисніть кнопку ОК.
  3. Знайдіть підрозділ реєстру, що відповідає інстальованій на комп’ютері версії Word.
    • Word 2002
      HKEY_CURRENT_USER\Software\Microsoft \Office\10.0\Word\Data
    • Word 2003
      HKEY_CURRENT_USER\Software\Microsoft\ Office\11.0\Word\Data
    • Word 2007
      HKEY_CURRENT_USER\Software\Microsoft\ Office\12.0\Word\Data
    • Word 2010
      HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Word\Data
  4. Клацніть пункт Data, а потім у меню File (файл) виберіть пункт Export (експорт).
  5. Призначте файлу ім’я Wddata.reg, а потім збережіть його на робочому столі.
  6. У меню Edit (редагування) виберіть пункт Delete (видалити), а потім натисніть кнопку Так.
  7. Закрийте редактор реєстру.
  8. Запустіть програму Word.
Якщо після цього програма Word запускається та працює нормально, проблему вирішено. Причина полягала в пошкодженому розділі реєстру з даними Word. Щоб відновити потрібні настройки у програмі Word, потрібно змінити кілька параметрів.

Якщо проблему не вдалося вирішити таким чином, відновіть оригінальний розділ реєстру з даними Word. Після цього перегляньте розділ "Видалення розділу реєстру з параметрами Word".

Щоб відновити розділ реєстру з даними Word, виконайте наведені нижче дії.
  1. Закрийте всі програми Office.
  2. Двічі клацніть піктограму Wddata.reg на робочому столі.
  3. Натисніть кнопку Так, а потім – ОК.

Видалення розділу реєстру з параметрами Word

Розділ реєстру Options для програми Word містить параметри, які можна встановити у програмі Word зміненням параметрів меню. Ці параметри поділяються на дві групи: параметри за промовчанням і додаткові параметри.

Параметри за промовчанням створюються під час інсталяції. Щоб їх змінити, потрібно змінити параметри у програмі Word. Додаткові параметри не створюються під час інсталяції.


Щоб видалити розділ реєстру з параметрами Word, виконайте наведені нижче дії.
  1. Закрийте всі програми Office.
  2. Натисніть кнопку Пуск, виберіть команду Виконати, введіть regedit і натисніть кнопку ОК.
  3. Знайдіть підрозділ реєстру, що відповідає інстальованій на комп’ютері версії Word.
    • Word 2002
      HKEY_CURRENT_USER\Software\Microsoft\ Office\10.0\Word\Options
    • Word 2003
      HKEY_CURRENT_USER\Software\Microsoft\ Office\11.0\Word\Options
    • Word 2007
      HKEY_CURRENT_USER\Software\Microsoft\ Office\12.0\Word\Options
    • Word 2010
      HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Word\Options
  4. Клацніть пункт Options, а потім у меню File (файл) виберіть пункт Export (експорт).
  5. Призначте файлу ім’я Wdoptn.reg, а потім збережіть його на робочому столі.
  6. У меню Edit (редагування) виберіть пункт Delete (видалити), а потім натисніть кнопку Так.
  7. Закрийте редактор реєстру.
  8. Запустіть програму Word.
Якщо після цього програма Word запускається та працює нормально, проблему вирішено. Причина полягала в пошкодженому розділі реєстру з параметрами Word. Щоб відновити потрібні настройки у програмі Word, потрібно змінити кілька параметрів.

Якщо проблему не вдалося вирішити таким чином, відновіть оригінальний розділ реєстру з параметрами Word. Після цього перегляньте розділ "Перейменування файлу глобального шаблону Normal.dot або Normal.dotm".

Щоб відновити оригінальний розділ реєстру з параметрами Word, виконайте наведені нижче дії.
  1. Закрийте всі програми Office.
  2. Двічі клацніть піктограму Wdoptn.reg на робочому столі.
  3. Натисніть кнопку Так, а потім – ОК.

Перейменування файлу глобального шаблону Normal.dot або Normal.dotm

Можна запобігти впливу форматування, записів автотексту та макросів, збережених у файлі глобального шаблону, на роботу програми Word і відкриті в ньому документи. Для цього файл глобального шаблону потрібно перейменувати. Під час повторного запуску програми Word у звичному режимі створюється новий файл глобального шаблону.

Увага! Після перейменування файлу глобального шаблону для деяких параметрів буде відновлено значення за промовчанням. До параметрів, для яких відновлюються значення за промовчанням, належать настроювані стилі, настроювані панелі інструментів, макроси та записи автотексту. Через це не варто видаляти файл глобального шаблону.

У деяких ситуаціях можна створити кілька файлів глобального шаблону. Приклади таких ситуацій наведено нижче.
  • На одному комп’ютері працюють кілька версій Word.
  • На одному комп’ютері є кілька інсталяцій робочих станцій.
У таких ситуаціях слід переконатися, що перейменовано належну копію файлу глобального шаблону.

Щоб перейменувати файл глобального шаблону, виконайте наведені нижче дії.
  1. Закрийте всі програми Office.
  2. Натисніть кнопку Пуск, виберіть команду Виконати, введіть cmd та натисніть кнопку ОК.
  3. Введіть одну з наведених нижче команд відповідно до використовуваної версії Word, а потім натисніть клавішу Enter.
    • Word 2002 та Word 2003
      Windows XP: ren %userprofile%\Application Data\Microsoft\Templates\Normal.dot OldNormal.dot.

      Windows Vista або Windows 7: ren %userprofile%\AppData\Roaming\Microsoft\Templates\Normal.dot OldNormal.dot.
    • Word 2007 і Word 2010
      Windows XP: ren %userprofile%\Application Data\Microsoft\Templates\Normal.dotm OldNormal.dotm.

      Windows Vista або Windows 7: ren %userprofile%\AppData\Roaming\Microsoft\Templates\Normal.dotm OldNormal.dotm.
  4. Введіть команду exit і натисніть клавішу Enter.
  5. Запустіть програму Word.
Якщо після цього програма Word запускається нормально, проблему вирішено. У цьому випадку причина полягала в пошкодженому файлі глобального шаблону. Щоб відновити потрібні настройки, необхідно змінити кілька параметрів.

Перейменований файл глобального шаблону може містити настройки, відновлення яких потребує виконання складних операцій. До таких настройок належать стилі, макроси або записи автотексту. У такому випадку можна скопіювати настройки зі старого файлу глобального шаблону до нового за допомогою організатора.

Щоб отримати додаткові відомості про використання організатора для перейменування макросів, у меню Help (довідка) виберіть пункт Microsoft Word Help (довідка програми Microsoft Word), введіть перейменувати макроси в полі Search for (пошук), а потім клацніть Search (знайти), щоб переглянути розділ.

Якщо проблему не вдалося вирішити, відновіть оригінальний файл глобального шаблону, а потім перегляньте розділ "Вимкнення надбудов із папки автозавантаження".

Щоб відновити оригінальний файл глобального шаблону, виконайте наведені нижче дії.
  1. Закрийте всі програми Office.
  2. Натисніть кнопку Пуск, виберіть команду Виконати, введіть cmd та натисніть кнопку ОК.
  3. Введіть одну з наведених нижче команд відповідно до використовуваної версії Word, а потім натисніть клавішу Enter.
    • Word 2002 та Word 2003
      ren %userprofile%\Application Data\Microsoft\Templates\OldNormal.dot Normal.dot
    • Word 2007
      ren %userprofile%\Application Data\Microsoft\Templates\OldNormal.dotm Normal.dotm
  4. Введіть команду exit і натисніть клавішу Enter.
  5. Запустіть програму Word.


Вимкнення надбудов із папки автозавантаження

Під час запуску програми Word автоматично завантажуються шаблони та надбудови, розміщені в папках автозавантаження. Проблеми у програмі Word можуть спричиняти конфлікти між надбудовами або їх неполадки. Щоб визначити елемент у папці автозавантаження, який зумовив проблему, тимчасово вимкніть параметр реєстру, що стосується цих надбудов.

Для цього виконайте наведені нижче дії.
  1. Закрийте всі програми Office.
  2. Скористайтесь одним із запропонованих способів відповідно до версії Word, інстальованої на комп’ютері.
    • Word 2002
      Натисніть кнопку Пуск, виберіть пункт Виконати, введіть %programfiles%\Microsoft\Office\Office10\Startup\, а потім натисніть кнопку ОК.
    • Word 2003
      Натисніть кнопку Пуск, виберіть пункт Виконати, введіть %programfiles%\Microsoft\Office\Office11\Startup\, а потім натисніть кнопку ОК.
    • Word 2007
      Натисніть кнопку Пуск, виберіть пункт Виконати, введіть %programfiles%\Microsoft\Office\Office12\Startup\, а потім натисніть кнопку ОК.
    • Word 2010
      Натисніть кнопку Пуск, виберіть пункт Виконати, введіть %programfiles%\Microsoft Office\Office14\Startup\, а потім натисніть кнопку ОК.
  3. Правою кнопкою миші клацніть один із файлів, які зберігаються в папці, і виберіть пункт Перейменувати.
  4. Введіть ім’я файлу, а потім – розширення .old і натисніть клавішу Enter.

    Увага! Занотуйте оригінальне ім’я файлу. Пізніше може знадобитися відновити оригінальне ім’я файлу.
  5. Запустіть програму Word.
  6. Якщо проблема більше не виникає, її причина полягала в певній надбудові. Щоб скористатися функціями, які пропонує надбудова, зверніться до її постачальника, щоб отримати оновлення.

    Якщо проблему не вдалося вирішити, відновіть оригінальне ім’я надбудови, а потім повторіть кроки 3–5 для кожного файлу в папці автозавантаження.
  7. Якщо проблема виникає знову, натисніть кнопку Пуск, виберіть пункт Виконати, введіть %userprofile%\Application Data\Microsoft\Word\Startup (в ОС Windows XP) або %userprofile%\AppData\Roaming\Microsoft\Word\Startup (в ОС Windows Vista чи Windows 7), а потім натисніть кнопку ОК.
  8. Повторіть кроки 3–5 для кожного файлу в папці автозавантаження.
Якщо після вимкнення надбудов у папці автозавантаження проблему не вдалося вирішити, див. розділ "Видалення розділу реєстру для надбудов COM".

Видалення розділів реєстру для надбудов COM

Надбудови COM можна інсталювати в будь-якому розташуванні. Їх інсталюють програми, які взаємодіють із застосунком Word. Видаліть розділи реєстру для надбудов COM, після чого повторно запустіть програму Word.

Щоб видалити розділи реєстру для надбудов COM, виконайте наведені нижче дії.
  1. Закрийте всі програми Office.
  2. Натисніть кнопку Пуск, виберіть команду Виконати, введіть regedit і натисніть кнопку ОК.
  3. Знайдіть підрозділ реєстру, що відповідає інстальованій на комп’ютері версії Word.
    • Word 2002
      HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins
    • Word 2003
      HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins
    • Word 2007
      HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins
    • Word 2010
      HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins
  4. Клацніть розділ Addins, а потім у меню File (файл) виберіть пункт Export (експорт).
  5. Призначте файлу ім’я WdaddinHKCU.reg, а потім збережіть його на робочому столі.
  6. У меню Edit (редагування) виберіть пункт Delete (видалити), а потім натисніть кнопку Так.
  7. Знайдіть такий підрозділ реєстру:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Office\Word\Addins
  8. Клацніть розділ Addins, а потім у меню File (файл) виберіть пункт Export (експорт).
  9. Призначте файлу ім’я WdaddinHKLM.reg, а потім збережіть його на робочому столі.
  10. У меню Edit (редагування) виберіть команду Delete (видалити), а потім натисніть кнопку Так.
  11. Закрийте редактор реєстру.
  12. Запустіть програму Word.
Якщо проблему вирішено, її причина полягала в надбудові COM. Після цього потрібно визначити, яка саме надбудова COM призводить до виникнення проблеми.

Визначення надбудови COM, яка спричиняє проблему

Для цього виконайте наведені нижче дії.
  1. Закрийте всі програми Office.
  2. Двічі клацніть піктограму Wdaddin.reg на робочому столі.
  3. Натисніть кнопку Так, а потім – ОК.
  4. Якщо використовується програма Word 2007, перейдіть до кроку 5.

    Якщо на комп’ютері інстальовано програму Word 2002 або Word 2003, виконайте наведені нижче дії.
    1. Запустіть програму Word, а потім у меню Tools (знаряддя) виберіть пункт Customize (настроїти).
    2. У діалоговому вікні Customize (настроювання) відкрийте вкладку Commands (команди).
    3. У списку Categories (категорії) виберіть пункт Tools (знаряддя).
    4. У списку Commands (команди) виберіть пункт COM Add-Ins (надбудови COM), а потім перетягніть команду на одну з панелей інструментів. Закрийте діалогове вікно Customize (настроювання).
  5. Скористайтесь одним із запропонованих способів відповідно до версії Word, інстальованої на комп’ютері.

    Word 2002 та Word 2003
    1. На панелі інструментів клацніть COM Add-Ins (надбудови COM). Цей елемент додано на панель інструментів під час виконання кроку 4.
    2. Якщо надбудову наведено в діалоговому вікні COM Add-Ins (надбудови COM), зніміть прапорець біля неї. Якщо в діалоговому вікні вказано кілька надбудов, знімайте по одному прапорцю щоразу. Це дасть змогу визначити, яка саме надбудова призводить до виникнення проблеми.
    3. Натисніть кнопку ОК, щоб закрити діалогове вікно COM Add-Ins (надбудови COM).
    4. У меню File (файл) виберіть команду Exit (вихід).
    Word 2007
    1. Натисніть кнопку Microsoft Office, а потім – Word options (параметри Word).
    2. Виберіть пункт Add-ins (надбудови).
    3. У списку Manage (керування) виберіть пункт COM Add-ins (надбудови COM), а потім натисніть кнопку Go (перейти).
    4. Якщо надбудову наведено в діалоговому вікні COM Add-Ins (надбудови COM), зніміть прапорець біля неї. Якщо в діалоговому вікні вказано кілька надбудов, знімайте по одному прапорцю щоразу. Це дасть змогу визначити, яка саме надбудова призводить до виникнення проблеми.
    5. Натисніть кнопку ОК, щоб закрити діалогове вікно COM Add-Ins (надбудови COM).
    6. Натисніть кнопку Microsoft Office, а потім – Exit Word (вийти із програми Word).
    Word 2010
    1. Клацніть Файл і виберіть пункт Параметри.
    2. Натисніть кнопку Надбудови.
    3. У списку Керування клацніть пункт Надбудови COM, а потім натисніть Перейти.
    4. Якщо надбудову наведено в діалоговому вікні Надбудови COM, зніміть прапорець біля неї. Якщо в діалоговому вікні вказано кілька надбудов, знімайте по одному прапорцю за раз. Це дасть змогу визначити, яка саме надбудова призводить до виникнення проблеми.
    5. Натисніть кнопку ОК, щоб закрити діалогове вікно Надбудови COM.
    6. Клацніть Файл і виберіть Вихід.
  6. Запустіть програму Word.
  7. Якщо під час наступного запуску програми Word проблема не виникає, надбудову COM, яка спричиняла проблему, визначено. Щоб скористатися функціями, які пропонує надбудова, що спричинила проблему, зверніться до постачальника, щоб отримати оновлення для надбудови.

    Якщо під час наступного запуску програми Word проблема виникає знову, повторіть кроки 5 і 6 для кожної надбудови COM, наведеної у списку. Повторюйте цю процедуру для кожної надбудови, доки не буде визначено ту, яка призводить до виникнення проблеми.
  8. Щоб відновити надбудови COM, повторіть крок 5, але цього разу встановіть прапорці для кожної надбудови COM, яку потрібно відновити.

Варіанти підтримки Microsoft

Якщо проблему вирішити не вдалося, скористайтеся кількома доступними варіантами підтримки. На веб-сайті служби підтримки Microsoft можна знайти точні відповіді на свої запитання в базі знань Microsoft та інших технічних ресурсах. Сайт також можна настроїти, щоб керувати процесом пошуку. Щоб розпочати пошук, відвідайте веб-сайт Microsoft:
http://support.microsoft.com/?ln=uk

Властивості

Номер статті: 921541 - Востаннє переглянуто: 28 грудня 2011 р. - Редакція: 5.0
ЗАСТОСОВУЄТЬСЯ ДО:
  • Microsoft Word 2002 - стандартний випуск
  • Microsoft Office Word 2003
  • Microsoft Office Word 2007
  • Microsoft Word 2010
Ключові слова: 
kbacwsurvey kbexpertisebeginner kbregistry kbaddin kbhowtomaster kbfixme kbmsifixme KB921541

Надіслати відгук

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com