Article ID: 921546 - Last Review: January 4, 2008 - Revision: 3.0

Error message when you try to run a report or upload a report in Microsoft Dynamics CRM: "The request failed with HTTP status 401: Unauthorized" or "Server Error in ‘/’ Application"

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SYMPTOMS

Symptom 1

When you try to run a report in Microsoft Dynamics CRM 3.0, you receive the following error message:
The request failed with HTTP status 401: Unauthorized.
When you try to run a report in Microsoft Dynamics CRM 4.0, you receive the following error message:
An error occurred while trying to add the report to Microsoft Dynamics CRM.

Try this action again. If the problem continues, check the Microsoft Dynamics CRM Community for solutions or contact your organization's Microsoft Dynamics CRM Administrator. Finally, you can contact Microsoft Support.

Error code: 0x80048298

Symptom 2

Consider the following scenario in Microsoft Dynamics CRM:
  • You build a custom report by using Microsoft Visual Studio 2003 or by using a similar tool.
  • You try to upload the report to the Microsoft Dynamics CRM system.
In this scenario, you receive the following error message:
Server Error in ‘/’ Application. Exception of type Microsoft.Crm.CrmException was thrown.
If the DevErrors parameter is enabled, you receive this error message on the screen.

This error message occurs in some configurations. For example, this error message may occur if the following conditions are true:
  • The following products are installed on the same server:
    • Microsoft SQL Server
    • SQL Server Reporting Services (SRS)
  • Microsoft Dynamics CRM is installed on a separate server.

CAUSE

This problem occurs because the security account for the CRMAppPool application pool does not have the Publisher for Microsoft Dynamics CRM role in Report Manager.

RESOLUTION

To resolve this problem, follow these steps:
  1. Find the user. To do this, follow these steps:
    1. On the Microsoft Dynamics CRM server, click Start, click Run, type compmgmt.msc /s, and then click OK to open Computer Management.
    2. Expand Services and Applications, expand Internet Information Services (IIS) Manager, expand Application Pools, right-click CRMAppPool, and then click Properties.
    3. In the CRMAppPool Properties dialog box, note the value in the Predefined box on the Identity tab.

      Note The value is the user who you want to find.
  2. Set the Publisher for Microsoft Dynamics CRM role to the user. To do this, follow these steps:
    1. On the Microsoft Dynamics CRM server, type the following address in the Address bar in Microsoft Internet Explorer, and then click Go to open Reporting Services Report Manager:
      http://SRSServer/Reports
      Note SRSServer is a placeholder that represents an actual name of a Microsoft SQL Server Reporting Services server.
    2. Click the Microsoft Dynamics CRM company name.

      Note The Microsoft Dynamics CRM company name resembles the following:
      CRM_Company_Name_MSCRM
    3. On the Properties tab, click Security.
    4. Check to see whether the user who you found in step 1 is listed.

      Note If the user is not listed, click New Role Assignment.
    5. In the Group or user name box, type the name of the user who you noted in step 1c.

      Note If the name of the user is "Network Service," type the following name in the Group or user name box:
      NT Authority\Network Service
    6. Click to select the Publisher for Microsoft CRM check box, and then click OK.

APPLIES TO
  • Microsoft Dynamics CRM 4.0
  • Microsoft Dynamics CRM 3.0
Keywords: 
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