Article ID: 921604 - Last Review: October 9, 2011 - Revision: 2.0

FIX: WMI corrupts the pool from which the CommandLine buffer is allocated in Windows Services for UNIX 3.5

Hotfix download is availableHotfix Download Available
View and request hotfix downloads
System TipThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.

On This Page

Expand all | Collapse all

SYMPTOMS

When you enumerate a Microsoft Win32 process in Microsoft Windows Services for UNIX 3.5, Windows Management Instrumentation (WMI) corrupts the pool from which the CommandLine buffer is allocated.

CAUSE

This problem occurs because the CommandLine buffer in the RTL_USER_PROCESS_PARAMETERS structure is of the UNICODE_STRING type. Because the buffer is of a wide-character type, the MaximumLength property is always even. The Microsoft Interix process CommandLine buffer is of a character type. Therefore, the MaximumLength property can be either odd or even. Because WMI assumes that the MaximumLength property is even, WMI corrupts the pool from which the CommandLine buffer is allocated when you enumerate the Win32 process.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Posix.exe8.0.1969.47130,04815-Sep-200608:55
Psxdll.dll8.0.1969.47345,08815-Sep-200608:55
Psxrun.exe8.0.1969.47104,44815-Sep-200608:55
Psxss.exe8.0.1969.47780,80015-Sep-200608:55

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows Services for UNIX 3.5
Keywords: 
kbautohotfix kbfix kbbug kbHotfixServer kbqfe KB921604