Help and Support

文書番号: 921913 - 最終更新日: 2007年4月17日 - リビジョン: 1.3

NIS のサーバーがドメインにインストールされているときに、UNIX 属性] タブは、Active Directory ユーザーとコンピューター MMC スナップインで表示されません。

すべて展開する | すべて折りたたむ

現象

以下のシナリオを考えます。 サーバー ネットワーク情報サービス (NIS) は、ドメインにインストールされます。 NIS サーバーが UNIX 用の Microsoft Windows サービスには含まれます。 Active Directory ユーザーとコンピューター Microsoft 管理コンソール (MMC) スナップインには、ユーザー、グループ、またはコンピューターのプロパティを開きます。 このシナリオでは、 UNIX 属性 ] タブは表示されません。

原因

この問題は、次の条件のいずれかに当てはまる場合に発生します。
  • Active Directory ユーザーとコンピューター MMC スナップインを実行してがコンピューターにインストール NIS サーバーにはありません。
  • Active Directory ユーザーとコンピューター MMC スナップインを実行しているコンピューターがインストールされている NIS サーバーにします。 ただし、Nisprop.dll ライブラリに問題が表示されない UNIX 属性 ] タブになります。

解決方法

この問題を解決するには、次のいずれかの手順に従います:
  • Active Directory ユーザーとコンピューター MMC スナップインで実行しているコンピューターに NIS サーバーをインストールします。
  • Nisprop.dll ライブラリを登録します。 これを行うには、次の手順を実行します。
    1. 実行されている Mmc.exe のインスタンスがないことを Windows タスク マネージャーで、確認してください。

      メモ ターミナル サーバーにログオンしている場合はすべてのユーザーからのプロセスの表示を有効にすることを確認します。
    2. タブを表示するコンピューターの % SFUDIR % フォルダーには、UNIX インストール ソース用のサービスで、NIS サブフォルダーから、Nisprop.dll ファイルをコピーします。
    3. Nisprop.dll の登録を解除します。 これを行うには、コマンド プロンプト、 regsvr32/u %SFUDIR%\nisprop.dll を入力して、Enter を押します。
    4. Nisprop.dll を登録します。 これを行うには、コマンド プロンプト、 regsvr32 %SFUDIR%\nisprop.dll を入力して、Enter を押します。
メモ Microsoft Windows XP または Windows Server 2003 で、Microsoft Windows Server 2003 R2 UNIX 属性の管理を有効にする次の手順に従います。
  1. Windows XP では、最新バージョンを Windows Server 2003 R2 の管理ツール パックをインストールします。 そのためには、次のマイクロソフト Web サイトを参照してください:
    http://www.microsoft.com/downloads/details.aspx?FamilyID=9bfb44f5-232a-4fb5-bc14-45bfd81b7ac1&DisplayLang=en (http://www.microsoft.com/downloads/details.aspx?FamilyID=9bfb44f5-232a-4fb5-bc14-45bfd81b7ac1&DisplayLang=en)
    Windows Server 2003 で Windows Server 2003 の最新のサービス パックをインストールします。 関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください:
    889100? (http://support.microsoft.com/kb/889100/ ) Windows Server 2003 の最新の Service Pack を入手する方法
  2. Microsoft .NET Framework 2. 0 をインストールします。 .NET Framework 2. 0 を入手するには、次のマイクロソフト Web サイトを参照してください。
    http://www.microsoft.com/downloads/details.aspx?amp;displaylang=en&familyid=0856eacb-4362-4b0d-8edd-aab15c5e04f5&displaylang=en (http://www.microsoft.com/downloads/details.aspx?amp;displaylang=en&familyid=0856eacb-4362-4b0d-8edd-aab15c5e04f5&displaylang=en)
  3. MMC 3. 0 を入手するにはのいずれかの次の Web サイトを参照してください Microsoft 管理コンソール 3. 0 のインストールします。
    Windows XP この修正プログラム (Windows XP 英語版) の属性は次のとおりです
    http://www.microsoft.com/downloads/details.aspx?familyid=61FC1C66-06F2-463C-82A2-CF20902FFAE0&displaylang=en (http://www.microsoft.com/downloads/details.aspx?familyid=61FC1C66-06F2-463C-82A2-CF20902FFAE0&displaylang=en)

    Windows Server 2003
    http://www.microsoft.com/downloads/details.aspx?familyid=4C84F80B-908D-4B5D-8AA8-27B962566D9F&displaylang=en (http://www.microsoft.com/downloads/details.aspx?familyid=4C84F80B-908D-4B5D-8AA8-27B962566D9F&displaylang=en)
    メモ MMC 3. 0 は、Windows Server 2003 R2 に含まれている 2 つ目の CD 上の管理フォルダーでも使用できます。
  4. Idmu.exe を実行します。 Idmu.exe を取得するには、次のマイクロソフト Web サイトを参照してください。
    http://www.microsoft.com/downloads/details.aspx?FamilyID=9bfb44f5-232a-4fb5-bc14-45bfd81b7ac1&DisplayLang=en (http://www.microsoft.com/downloads/details.aspx?FamilyID=9bfb44f5-232a-4fb5-bc14-45bfd81b7ac1&DisplayLang=en)
    メモ Idmu.exe は、Windows Server 2003 R2 に含まれている 2 つ目の CD に収録もいます。
Regsvr32 コマンドの詳細についてをクリックして次資料「サポート技術情報」(Microsoft Knowledge Base) 資料を参照。
249873? (http://support.microsoft.com/kb/249873/ ) Regsvr32 ツールの使用法とエラー メッセージについて

この資料は以下の製品について記述したものです。
  • Microsoft Windows Services for UNIX 2.0 Standard Edition
  • Microsoft Windows Services for UNIX 3.0 Standard Edition
  • Microsoft Windows Services for UNIX 3.5
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
キーワード:?
kbmt kbtshoot kbprb KB921913 KbMtja
機械翻訳機械翻訳
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:921913? (http://support.microsoft.com/kb/921913/en-us/ )
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

サポート技術情報の翻訳