Mensaje de error y código de error "0xc0040357" al utilizar la característica de exportación o la característica de copia de seguridad en ISA Server 2004: "El servidor ISA no puede cargar la página de propiedades"

Seleccione idioma Seleccione idioma
Id. de artículo: 922222 - Ver los productos a los que se aplica este artículo
importante Este artículo contiene información acerca de cómo modificar el registro. Compruebe que ha hecho una copia de seguridad del Registro antes de modificarlo. Compruebe que sabe restaurar el Registro en caso de que se produzca algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986Definición del Registro de Microsoft Windows
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando se utiliza la característica de exportación o la característica copia de seguridad en un equipo que ejecuta Microsoft Internet Security and Acceleration (ISA) Server 2004, puede recibir un mensaje de error similar a uno de los procedimientos siguientes.

ISA Server 2004, Standard Edition

ISA Server no puede cargar la página de propiedades.
Error: 0xc0040357
El servidor hace referencia a matriz ArrayName no existe

ISA Server 2004, Enterprise Edition

ISA Server no puede cargar la página de propiedades.
Error: 0xc0040357
Error en el objeto ArrayName de Array en el ámbito de clase de matriz ArrayName.
Para obtener más información acerca de la característica de exportación y la característica copia de seguridad de ISA Server 2004, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
838375Las diferencias entre la característica de copia y la característica de exportación en ISA Server 2004 y las diferencias entre la característica de restauración y la característica Importar en ISA Server 2004

Causa

Este problema puede producirse si un valor de msFPCName de trabajo de informe es diferente del valor de entrada del Registro
CurrentServerGUID
. Cada definición de trabajo de informe se almacena con un valor de msFPCName bajo la siguiente subclave del registro. Esta subclave del registro corresponde a la instancia del servidor ISA en la que está programado el trabajo de informe para ejecutarse.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Fpc\Storage\Array-Root\Arrays\{CurrentArrayGUID}\Reports\ReportJobs\{ReportJobGUID}\Server

Solución

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o utilizando otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.

Para resolver este problema, utilice uno de estos pasos:
  1. Coincide con el valor msFPCName con el valor de registro
    CurrentServerGUID
    . Para ello, siga estos pasos según la edición de ISA Server 2004.

    Para ISA Server 2004, Standard Edition

    1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
    2. Busque y haga clic en la siguiente subclave del Registro:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Fpc
    3. En el panel derecho, haga clic con el botón secundario del mouse en CurrentServerGUID y, a continuación, haga clic en Modificar .
    4. Copie el valor en el cuadro de datos de valor .
      Nota Haga clic en Cancelar si no desea cambiar el valor.
    5. Busque y haga clic en la siguiente subclave del Registro:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Fpc\Storage\Array-Root\Arrays\ {<currentarrayguid>} \Reports\ReportJobs\ {<reportjobguid>} \Server
    6. Si el valor del registro no coincide con el valor que ha copiado en el paso d, haga clic con el botón secundario en la entrada del registro de
      msFpcname
      y, a continuación, haga clic en Modificar .
    7. En el cuadro datos del valor , pegue el valor que copió en el paso d.
    8. Editor de registro de salida.

    Para ISA Server 2004, Enterprise Edition

    Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o utilizando otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.
    1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
    2. Busque y haga clic en la siguiente subclave del Registro:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Fpc
    3. En el panel derecho, haga clic con el botón secundario del mouse en CurrentServerGUID y, a continuación, anote el valor que se muestra en el cuadro de datos de valor .
    4. Inicie sesión para contenido Storage Server (CSS) con una cuenta que tenga derechos administrativos.
    5. Haga clic en Inicio , seleccione Todos los programas , elija a ADAM y a continuación, haga clic en ADAM ADSI Edit .
    6. En el árbol de consola, haga clic con el botón secundario en ADAM ADSI Edit y, a continuación, haga clic en Conectar a .
    7. En el cuadro de diálogo Configuración de conexión , escriba CSS en el cuadro Nombre de conexión.
    8. En la lista nombre del servidor , haga clic en localhost .
    9. En el cuadro puerto , escriba uno de los siguientes valores:
      • CSS que está configurado para autenticación de Windows (modo de dominio), escriba 2171 .
      • CSS que está configurado para autenticación SSL (modo de grupo de trabajo), escriba 2172 .
    10. Haga clic en completo (DN) de nombre o contexto de nomenclatura y, a continuación, escriba CN = FpcConfiguration .
    11. En Conectar usando estas credenciales , haga clic en la cuenta del usuario que actualmente ha iniciado la sesión de y, a continuación, haga clic en Aceptar .
    12. En el árbol de consola, expanda CSS [localhost: Port] .
    13. Expanda CN = fpcconfiguration , expanda CN = ArrayRoot , expanda CN = Arrays y a continuación, expanda CN = {CurrentArrayGUID} .
    14. En el panel derecho, haga clic en CN = servidores .
    15. Anote el valor de cada entrada {ServerGUID} que aparece bajo el CN = servidores entrada.

      Nota El CN = parte de la CN = {ServerGUID} entrada no es relevante cuando se comparan datos.
    16. En el árbol de consola, expanda CN = informes .
    17. Expanda CN = {ReportJobGUID} , haga clic con el botón secundario del mouse en CN = servidores y a continuación, haga clic en Propiedades .
    18. En el CN = servidores propiedades diálogo cuadro, haga doble clic en msFPCName en la lista atributos .
    19. Asegúrese de que el valor que se muestra en el cuadro valor coincide con uno de los valores {ServerGUID} que anotó en el paso p.
    20. Si no coinciden los valores para cualquiera de los servidores que aparecen bajo CN = servidores , cambie el valor que se muestra en el cuadro valor . Hacer que el valor coincide con una de las entradas { ServerGUID } válidas que anotó en el paso m y, a continuación, haga clic en Aceptar .
    21. Haga clic en Aplicar y, a continuación, haga clic en Aceptar .
    22. Repita los pasos q a través de t para cada CN = {ReportJobGUID} entrada que se encuentra bajo el CN = informes entrada.
    23. Cierre el complemento MMC Edición de ADSI de ADAM.
  2. Eliminar trabajos de informes pendientes. Para ello, siga estos pasos:
    1. Inicie Administración del servidor ISA.
    2. Expanda ServerName donde es ServerName y, a continuación, haga clic en supervisión .
    3. Haga clic en la ficha informes .
    4. En la ficha tareas , haga clic en crear y configurar trabajos de informes .
    5. Haga clic en el informe que desea eliminar y, a continuación, haga clic en Quitar .

Propiedades

Id. de artículo: 922222 - Última revisión: martes, 4 de diciembre de 2007 - Versión: 1.7
La información de este artículo se refiere a:
  • Microsoft Internet Security and Acceleration Server 2004 Enterprise Edition
  • Microsoft Internet Security and Acceleration Server 2004 Standard Edition
Palabras clave: 
kbmt kbtshoot kbprb KB922222 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 922222

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com