Messaggio di errore quando si tenta di scaricare un file utilizzando il servizio trasferimento intelligente in background: "download di contenuto del file non riuscito"

Traduzione articoli Traduzione articoli
Identificativo articolo: 922330 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si tenta di scaricare un file utilizzando il servizio trasferimento intelligente in background (BITS), sono non riuscito. Inoltre, il seguente messaggio di errore viene registrato nel registro applicazione:
Tipo evento: errore
Origine evento: Windows Server Update Services
Categoria evento: (2)
ID evento: 364
Data: date
Ora: time
Utente: N/d
Computer: ServerName
Descrizione: Download del contenuto del file non riuscito. Motivo: Il server non supporta il protocollo HTTP necessario. Servizio trasferimento intelligente in background (BITS) richiede che il server supporti l'intestazione di protocollo Range.
Questo problema si verifica in particolare, se si tenta di eseguire una o entrambe delle seguenti operazioni:
  • ╚ approvare un aggiornamento in Microsoft Windows Server Update Services (WSUS). In questo caso, viene attivato il processo di download. Tuttavia, l'operazione di download Ŕ riuscita. Viene visualizzata una X di colore rosso tramite l'aggiornamento.
  • Si tenta di scaricare il file Mssecure.cab per Baseline Security Analyzer (MBSA) Management Pack per Microsoft Operations Manager (MOM) 2005.

Cause

Questo problema pu˛ verificarsi se un computer Ŕ un firewall o dietro un server proxy. Questo problema si verifica se una delle seguenti condizioni Ŕ vera:
  • L'ambiente del server proxy non supporta la funzionalitÓ di richiesta di intervallo HTTP 1.1.
  • Ti trovi dietro un dispositivo di firewall SonicWALL, e l'impostazione della richiesta di attivazione HTTP byte-intervallo con gateway antivirus non Ŕ abilitato per la periferica.
Quando si copia un file utilizzando BITS modalitÓ secondo piano, il file viene copiato in pi¨ parti di piccole dimensioni. Per eseguire questo tipo di operazione di copia, BITS utilizza l'intestazione Content-Range di HTTP 1.1. Se si trova dietro un server proxy o dietro un firewall che rimuove questa intestazione, l'operazione di copia di file ha esito negativo.

Nota Quando BITS copia file in modalitÓ primo piano, BITS non utilizza questa intestazione.

Risoluzione

Per risolvere il problema, utilizzare uno dei metodi descritti di seguito, a seconda della situazione.

Metodo 1: Il server di proxy non supporta le richieste di intervallo di HTTP 1.1

Modificare le impostazioni del server proxy per supportare le richieste di intervallo di HTTP 1.1. Se non Ŕ possibile modificare il server proxy in questo modo, Ŕ necessario configurare BITS per lavorare in modalitÓ primo piano. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Fare clic su Start , scegliere Esegui , digitare uno dei seguenti comandi e quindi fare clic su OK .

    Se si utilizza WSUS 2.0 con un database MSDE o WMSDE creato da un'installazione di WSUS predefinita, digitare il seguente comando:
    %programfiles%\Update Services\tools\osql\osql.exe -S %computername%\WSUS -E -b - n -Q "USE SUSDB aggiornamento tbConfigurationC impostare BitsDownloadPriorityForeground = 1"
    Se Ŕ stato configurato WSUS 2.0 per utilizzare un'installazione esistente di Microsoft SQL Server, digitare il seguente comando:
    %programfiles%\Update Services\tools\osql\osql.exe "% -S nome di computer % -E -b - n -Q" USE SUSDB aggiornamento tbConfigurationC impostare BitsDownloadPriorityForeground = 1 "
    Se si utilizza WSUS 3.0 con un database interno di Windows creato da un'installazione di WSUS predefinita, digitare il seguente comando:
    %programfiles%\Update Services\Setup\ExecuteSQL.exe -S %computername%\MICROSOFT##SSEE -d "SUSDB" -Q "aggiornamento tbConfigurationC impostare BitsDownloadPriorityForeground = 1"
    Se Ŕ stato configurato WSUS 3.0 per utilizzare un'installazione esistente di SQL Server, digitare il seguente comando:
    % %programfiles%\Update Services\Setup\ExecuteSQL.exe -S nome di computer % -d "SUSDB" -Q "aggiornamento tbConfigurationC impostare BitsDownloadPriorityForeground = 1"
  2. Riavviare il servizio Update Services. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic su Start , scegliere Esegui , digitare services.msc e quindi fare clic su OK .
    2. Nella finestra di dialogo Services fare clic con il pulsante destro del mouse sul Update Services e quindi scegliere Riavvia .

Metodo 2: L'impostazione "Intervallo di byte attiva HTTP richiesta con gateway antivirus" non Ŕ attivato

Fare clic per selezionare la casella richiesta di attivazione HTTP byte-intervallo con gateway antivirus nella pagina Impostazioni interni dello strumento di configurazione SonicWALL. Per ulteriori informazioni su come modificare il firewall SonicWALL, contattare il supporto di SonicWALL. A questo scopo visitare il seguente sito SonicWALL Web:
http://www.SonicWALL.com/support
Microsoft fornisce informazioni su come contattare altri produttori allo scopo di facilitare l'individuazione del supporto tecnico. Queste informazioni sono pertanto soggette a modifica senza preavviso. Microsoft non garantisce l'accuratezza delle informazioni sul contatti-altri produttori.

Informazioni

I prodotti di terze parti che in questo articolo viene descritto sono forniti da produttori indipendenti. Microsoft non rilascia alcuna garanzia, implicita o esplicita, sulle prestazioni o all'affidabilitÓ di questi prodotti.

ProprietÓ

Identificativo articolo: 922330 - Ultima modifica: mercoledý 16 settembre 2009 - Revisione: 6.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Operations Manager 2005 Enterprise Edition
  • Microsoft Software Update Services 1.0
  • Microsoft Windows Server Update Services 2.0
  • Microsoft Windows Server Update Services 3.0
Chiavi:á
kbmt kbeventlog kbprb kbtshoot KB922330 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 922330
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com