เกิดข้อผิดพลาดเมื่อคุณพยายามดาวน์โหลดแฟ้ม โดยใช้พื้นหลังของพอร์โอนบริการได้: "ดาวน์โหลดเนื้อหาของแฟ้มที่ล้มเหลว"

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 922330 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

เมื่อคุณพยายามที่จะดาวน์โหลดแฟ้ม โดยใช้พื้นหลังของพอร์ Transfer Service (BITS), คุณจะไม่สำเร็จ นอกจากนี้ ข้อความแสดงข้อผิดพลาดต่อไปนี้ถูกบันทึกลงในบันทึกของโปรแกรมประยุกต์:
ชนิดเหตุการณ์: ข้อผิดพลาด
แหล่งที่มาของเหตุการณ์: Windows Server Update Services
ประเภทเหตุการณ์: (2)
รหัสเหตุการณ์: 364
วันที่:วันที่
เวลา:เวลา
ผู้ใช้: n/a
คอมพิวเตอร์:Servername
คำอธิบาย: ดาวน์โหลดเนื้อหาของแฟ้มไม่สำเร็จ เหตุผล: เซิร์ฟเวอร์ไม่สนับสนุนโพรโทคอล HTTP จำเป็น พื้นหลังพอร์ Transfer Service (BITS) ต้องการให้เซิร์ฟเวอร์ที่สนับสนุนส่วนหัวของช่วงโพรโทคอล
โดยเฉพาะอย่างยิ่ง คุณพบปัญหานี้หากคุณพยายามดำเนินการหนึ่งหรือทั้งสองของการดำเนินการต่อไปนี้:
  • คุณอนุมัติการปรับปรุงใน Microsoft Windows Server Update Services (WSUS) ในสถานการณ์เช่นนี้ กระบวนการดาวน์โหลดจะถูกทริกเกอร์ อย่างไรก็ตาม การดำเนินการดาวน์โหลดไม่สำเร็จ หมาย X สีแดงปรากฏอยู่เหนือการปรับปรุง
  • คุณพยายามดาวน์โหลดแฟ้ม Mssecure.cab สำหรับชุดการจัดการการวิเคราะห์ความปลอดภัยบรรทัดหลักของ Microsoft (MBSA) สำหรับ Microsoft ดำเนิน Manager (MOM) 2005

สาเหตุ

คุณอาจพบปัญหานี้หากคอมพิวเตอร์ที่อยู่ หลังไฟร์วอลล์ หรือ หลังพร็อกซีเซิร์ฟเวอร์ ปัญหานี้จะเกิดขึ้นหากเงื่อนไขใดๆ ต่อไปนี้เป็นจริง::
  • สภาพแวดล้อมพร็อกซีเซิร์ฟเวอร์ไม่สนับสนุนคุณลักษณะร้องขอ HTTP 1.1 ช่วง
  • คุณกำลังหลังอุปกรณ์ไฟร์วอลล์ SonicWALL และการเปิดใช้งานการร้องขอ HTTP ไบต์ช่วง AV เกตเวย์การตั้งค่าไม่ได้เปิดใช้งานสำหรับอุปกรณ์
เมื่อคุณคัดลอกแฟ้ม ด้วย BITS ในโหมดพื้นหลัง แฟ้มจะถูกคัดลอกในส่วนต่าง ๆ ที่ขนาดเล็ก เมื่อต้องการทำการดำเนินการคัดลอกชนิดนี้ BITS ใช้ส่วนหัวของ HTTP 1.1 เนื้อหาช่วง ถ้าคุณกำลัง หลังพร็อกซีเซิร์ฟเวอร์ หรือ หลังไฟร์วอลล์ที่หัวข้อนี้ในการเอาออก การดำเนินการคัดลอกแฟ้มไม่สำเร็จ

หมายเหตุ:เมื่อ BITS คัดลอกแฟ้มต่าง ๆ ในโหมดการทำงานเบื้องหน้า BITS ไม่ใช้หัวข้อนี้

การแก้ไข

เมื่อต้องการแก้ไขปัญหานี้ ใช้วิธีต่อไปนี้ อย่างใดอย่างหนึ่งตามความเหมาะสมกับสถานการณ์ของคุณ

วิธีที่ 1: พร็อกซีเซิร์ฟเวอร์ไม่สนับสนุนการร้องขอช่วง HTTP 1.1

ปรับเปลี่ยนการตั้งค่าพร็อกซีของเซิร์ฟเวอร์เพื่อสนับสนุนการร้องขอช่วง HTTP 1.1 ถ้าคุณไม่สามารถแก้ไขพร็อกซี่เซิร์ฟเวอร์ในลักษณะนี้ กำหนดค่า BITS การทำงานในโหมดการทำงานเบื้องหน้า โดยให้ทำตามขั้นตอนต่อไปนี้::
  1. คลิกเริ่มการทำงานคลิกเรียกใช้พิมพ์คำสั่งต่อไปนี้อย่างใดอย่างหนึ่ง และจากนั้น คลิกตกลง.

    ถ้าคุณกำลังใช้ WSUS 2.0 กับฐานข้อมูล MSDE หรือ WMSDE ที่ถูกสร้างขึ้น โดยการเริ่มต้นการติดตั้ง WSUS พิมพ์คำสั่งต่อไปนี้:
    %programfiles%\Update Services\tools\osql\osql.exe -S %Computername%\WSUS -E -b - n -Q " tbConfigurationC การปรับปรุง SUSDB USE เซ็ต BitsDownloadPriorityForeground = 1 "
    ถ้าคุณได้กำหนดค่า WSUS 2.0 จะใช้การติดตั้งที่มีอยู่ของ Microsoft SQL Server พิมพ์คำสั่งต่อไปนี้:
    % -S %programfiles%\Update Services\tools\osql\osql.exe" Computername % -E -b -n -Q " tbConfigurationC การปรับปรุง SUSDB USE เซ็ต BitsDownloadPriorityForeground = 1 "
    ถ้าคุณกำลังใช้ WSUS 3.0 กับฐานข้อมูลภายใน Windows ซึ่งถูกสร้างขึ้น โดยการเริ่มต้นการติดตั้ง WSUS พิมพ์คำสั่งต่อไปนี้:
    %programfiles%\Update Services\Setup\ExecuteSQL.exe -S %Computername%\MICROSOFT##SSEE -d "SUSDB" -Q "การตั้งค่าการปรับปรุง tbConfigurationC BitsDownloadPriorityForeground = 1 "
    ถ้าคุณได้กำหนดค่า 3.0 WSUS เพื่อใช้การติดตั้งที่มีอยู่ของ SQL Server พิมพ์คำสั่งต่อไปนี้:
    % %programfiles%\Update Services\Setup\ExecuteSQL.exe -S Computername % -d "SUSDB" -Q "การตั้งค่าการปรับปรุง tbConfigurationC BitsDownloadPriorityForeground = 1 "
  2. เริ่มบริการบริการการปรับปรุงใหม่ โดยให้ทำตามขั้นตอนต่อไปนี้::
    1. คลิกเริ่มการทำงานคลิกเรียกใช้ประเภท:services.mscแล้ว คลิกตกลง.
    2. ในการบริการกล่องโต้ตอบ คลิกขวาบริการการปรับปรุงแล้ว คลิกเริ่มต้นใหม่.

วิธีที่ 2: การตั้งค่า "เปิดใช้งาน HTTP ไบต์ช่วงร้องขอ มีเกตเวย์ AV" ที่ไม่เปิดใช้งาน

คลิกเพื่อเลือกนั้นการเปิดใช้งานการร้องขอ HTTP ไบต์ช่วง AV เกตเวย์กล่องกาเครื่องหมายที่อยู่ในนั้นการตั้งค่าภายในหน้าของเครื่องมือการตั้งค่าคอนฟิก SonicWALL สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการปรับเปลี่ยนลักษณะการทำงานไฟร์วอลล์ SonicWALL ติดต่อฝ่ายสนับสนุน SonicWALL เมื่อต้องการทำเช่นนี้ ไปที่ SonicWALL เว็บไซต์ต่อไปนี้:
http://www.SonicWALL.com/support
Microsoft จะให้ข้อมูลติดต่อของบริษัทอื่น เพื่อช่วยให้คุณสามารถขอรับการสนับสนุนทางเทคนิคได้ ข้อมูลติดต่อนี้อาจเปลี่ยนแปลงโดยไม่ต้องแจ้งให้ทราบล่วงหน้า Microsoft ไม่รับประกันความถูกต้องของข้อมูลการติดต่อกับบริษัทอื่นๆ เหล่านี้

ข้อมูลเพิ่มเติม

ผลิตภัณฑ์ของบุคคลที่สามที่กล่าวถึงในบทความนี้ ผลิตขึ้นโดยบริษัทที่ไม่ขึ้นอยู่กับ Microsoft Microsoft ไม่รับประกัน ทั้งโดยนัยหรืออย่างอื่นใด เกี่ยวกับประสิทธิภาพหรือความน่าเชื่อถือของผลิตภัณฑ์เหล่านี้

คุณสมบัติ

หมายเลขบทความ (Article ID): 922330 - รีวิวครั้งสุดท้าย: 11 กันยายน 2554 - Revision: 5.0
ใช้กับ
  • Microsoft Operations Manager 2005 Enterprise Edition
  • Microsoft Windows Server Update Services
  • Microsoft Windows Server Update Services 3.0
Keywords: 
kbeventlog kbprb kbtshoot kbmt KB922330 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:922330

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com