Arka Plan Akıllı Aktarım Hizmeti'ni kullanarak bir dosyayı karşıdan yüklemeye çalıştığınızda hata iletisi: "içerik dosya karşıdan yükleme başarısız oldu"

Makale çevirileri Makale çevirileri
Makale numarası: 922330 - Bu makalenin geçerli olduğu ürünleri görün.
Hepsini aç | Hepsini kapa

Bu Sayfada

Belirtiler

Arka Plan Akıllı Aktarım Hizmeti (BITS) kullanarak bir dosya yüklemeye çalıştığınızda işlem başarısız olur. Ayrıca, uygulama günlüğüne aşağıdaki hata iletisini günlüğe kaydedilir:
Olay türü: hata
Olay kaynağı: Windows Server Update Services
Olay kategorisi: (2)
Olay KIMLIĞI: 364
Tarihi: date
Süre: time
Kullanı.: Yok
ServerName bilgisayar:
Açıklama: İçerik dosyasını karşıdan yükleme başarısız oldu. Neden: Sunucu gerekli HTTP protokolünü desteklemiyor. Arka Plan Akıllı Aktarım Hizmeti (BITS) sunucunun Range protokol üstbilgisini desteklemesini gerektirir.
Özellikle, aşağıdaki eylemlerden birini veya her ikisini birden gerçekleştirmeye çalışırsanız bu sorunla karşılaşırsınız:
  • Güncelleştirme, Microsoft Windows Server Update Services (WSUS) onaylayın. Bu durumda, yükleme işlemi başlatılır. Ancak, yükleme işlemi başarısız olur. Kırmızı BIR X, güncelleştirmenin üzerinde görünür.
  • MSSecure.cab dosyasını Microsoft Operations Manager (MOM) 2005 için için Microsoft Baseline Security Analyzer (MBSA) yönetim paketi yüklemeye çalışın.

Neden

Bir güvenlik duvarı veya proxy sunucu arkasındaki bilgisayarsa, bu sorunla karşılaşabilirsiniz. Bu sorun aşağıdaki durumlardan biri doğruysa oluşur:
  • Proxy sunucu ortamında, HTTP 1.1 Aralık isteği özelliğini desteklemiyor.
  • Bir SonicWALL güvenlik duvarı aygıtının arkasına sorumlususunuz ve aygıt için Gateway AV istekle Enable HTTP bayt aralığı ayarı etkin değildir.
BITS arka plan modunda kullanarak bir dosyayı kopyaladığınız zaman, dosyayı birden çok küçük bir bölümü de kopyalanır. BITS bu tür bir kopyalama işlemi gerçekleştirmek için <a0></a0>, HTTP 1.1 Content-Range başlığını kullanır. Bir proxy sunucu arkasındaki veya bu üstbilgi silen bir güvenlik duvarının arkasında, dosya kopyalama işlemi başarısız olur.

Not BITS kopyaladığında dosyaları ön plan modunda, BITS kullanmıyor bu başlığı.

Çözüm

Bu sorunu gidermek için, aşağıdaki yöntemlerden durumunuza uygun olanını kullanın.

Yöntem 1: Proxy sunucusu, HTTP 1.1 Aralık istekleri desteklemiyor

HTTP 1.1 Aralık istekleri desteklemek için proxy sunucu ayarlarını değiştirin. Proxy sunucusu bu şekilde değiştiremezsiniz, ön plan modda çalışmak için BITS yapılandırın. Bunu yapmak için şu adımları izleyin:
  1. Başlat ' ı tıklatın, Çalıştır ' ı tıklatın, aşağıdaki komutlardan birini yazın ve Tamam ' ı tıklatın.

    WSUS 2.0 varsayılan WSUS yüklemesi tarafından oluşturulan bir veritabanıyla MSDE veya WMSDE kullanıyorsanız, aşağıdaki komutu yazın:
    %programfiles%\Update Services\tools\osql\osql.exe -S %Computername%\WSUS -E -b - n -Q "USE SUSDB güncelleştirme tbConfigurationC BitsDownloadPriorityForeground ayarlamak = 1"
    WSUS 2.0, varolan bir Microsoft SQL Server yüklemesini kullanmak üzere yapılandırılmışsa, aşağıdaki komutu yazın:
    %programfiles%\Update Services\tools\osql\osql.exe "bilgisayar adı % -E -b - n -S % -Q" USE SUSDB güncelleştirme tbConfigurationC BitsDownloadPriorityForeground ayarlamak = 1 "
    Bir Windows iç varsayılan WSUS yüklemesi tarafından oluşturulan veritabanı ile WSUS 3.0 kullanıyorsanız, aşağıdaki komutu yazın:
    %programfiles%\Update Services\Setup\ExecuteSQL.exe -S %Computername%\MICROSOFT##SSEE -d "SUSDB" -Q "Güncelleştirme tbConfigurationC BitsDownloadPriorityForeground ayarlamak = 1"
    WSUS 3. 0'ı varolan bir SQL Server yüklemesini kullanmak üzere yapılandırılmışsa, aşağıdaki komutu yazın:
    %programfiles%\Update Services\Setup\ExecuteSQL.exe -S % bilgisayar adı % -d "SUSDB" -Q "Güncelleştirme tbConfigurationC BitsDownloadPriorityForeground ayarlamak = 1"
  2. Update Services hizmeti yeniden başlatın. Bunu yapmak için şu adımları izleyin:
    1. Başlat ' ı tıklatın, Çalıştır ' ı tıklatın, services.msc yazın ve Tamam ' ı tıklatın.
    2. Hizmetler iletişim kutusunda, Update Services ' ı sağ tıklatın ve sonra da <a2>Yeniden Başlat</a2>'ı tıklatın.

Yöntem 2: "Gateway AV isteğiyle etkin HTTP bayt aralığı" ayarı etkin değil

SonicWALL Yapılandırma Aracı'nın İç ayarları sayfasında Gateway AV Enable HTTP bayt aralığı isteğiyle onay kutusunu seçmek için tıklatın. SonicWALL güvenlik duvarı özelliklerini değiştirme hakkında daha fazla bilgi için SonicWALL desteğine başvurun. Bunu yapmak için <a0></a0>, aşağıdaki SonicWALL Web sitesini ziyaret edin:
http://www.SonicWALL.com/support
Microsoft, teknik destek bulmanıza yardımcı olmak üzere üçüncü taraf iletişim bilgilerini sağlamaktadır. Bu bilgiler haber verilmeden değişebilir. Microsoft bu üçüncü taraf iletişim bilgilerinin doğruluğunu garanti etmez.

Daha fazla bilgi

Bu makalede adı geçen üçüncü taraf ürünleri Microsoft'tan bağımsız şirketler tarafından üretilmektedir. Microsoft bu ürünlerin performansı veya güvenilirliği hakkında hiçbir garanti vermez.

Özellikler

Makale numarası: 922330 - Last Review: 16 Eylül 2009 Çarşamba - Gözden geçirme: 6.0
Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Operations Manager 2005 Enterprise Edition
  • Microsoft Software Update Services
  • Microsoft Windows Server Update Services
  • Microsoft Windows Server Update Services 3.0
Anahtar Kelimeler: 
kbmt kbeventlog kbprb kbtshoot KB922330 KbMttr
Machine-translated Article
ÖNEMLİ: Bu makale, bir kişi tarafından çevrilmek yerine, Microsoft makine-çevirisi yazılımı ile çevrilmiştir. Microsoft size hem kişiler tarafından çevrilmiş, hem de makine-çevrisi ile çevrilmiş makaleler sunar. Böylelikle, bilgi bankamızdaki tüm makalelere, kendi dilinizde ulaşmış olursunuz. Bununla birlikte, makine tarafından çevrilmiş makaleler mükemmel değildir. Bir yabancının sizin dilinizde konuşurken yapabileceği hatalar gibi, makale; kelime dağarcığı, söz dizim kuralları veya dil bilgisi açısından yanlışlar içerebilir. Microsoft, içeriğin yanlış çevrimi veya onun müşteri tarafından kullanımından doğan; kusur, hata veya zarardan sorumlu değildir. Microsoft ayrıca makine çevirisi yazılımını sıkça güncellemektedir.
Makalenin İngilizcesi aşağıdaki gibidir:922330

Geri Bildirim Ver

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com