<filepath>REVISIÓN: Un mensaje de error cuando intenta ejecutar una aplicación Web ASP.NET 2.0 que incluye servicios Web: "no existe el archivo <rutaarchivo>"

Seleccione idioma Seleccione idioma
Id. de artículo: 922345 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando intenta ejecutar una aplicación Web de Microsoft ASP.NET 2.0 que incluye servicios Web, recibirá continuamente el mensaje de error siguientes:
El archivo <FilePath> no existe
Nota En este mensaje de error <FilePath> es la ruta de acceso del archivo .aspx de marcador de posición.

Recibe continuamente este mensaje de error hasta el grupo de aplicación de servicios de información de Internet de Microsoft (IIS) que hosts de la aplicación de Web de ASP.NET 2.0 es reciclar.

Este problema puede producirse al ejecutar la aplicación Web de ASP.NET 2.0 en un entorno de carga alta.

Causa

Este problema se produce porque el código que genera el archivo de lenguaje de descripción de servicios Web (WSDL) puede anular el registro cualquier clase VirtualPathProviders que se utiliza por la aplicación Web ASP.NET 2.0. Este problema puede producirse si ayuda WSDL más de una solicitud está en proceso. Si las clases VirtualPathProviders no están registrados, cualquier contenido que reside en la ruta de acceso virtual puede quedar inaccesible.

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Debe tener ASP.NET 2.0 instalado para aplicar esta revisión.

Requisito de reinicio

No es necesario reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Esta revisión reemplaza las revisiones que se describen en los siguientes artículos de Microsoft Knowledge Base:
911276REVISIÓN: Un mensaje de error cuando intenta ir a una página de ASP.NET mediante una dirección URL que contiene caracteres Unicode: "HTTP error 400 ' solicitud incorrecta'"
913393REVISIÓN: Recibe una excepción mensaje de error cuando especifica un encabezado HTTP Content-Length que es mayor que 2 GB en ASP.NET 2.0
915782REVISIÓN: Puede recibir un error InvalidCastException en una aplicación Web conectada con ASP.NET
918181REVISIÓN: Puede recibe una excepción ThreadAbortException en una aplicación Web ASP.NET basado en .NET Framework 2.0 cuando la propiedad de directiva de página asincrónica está establecida en true
920970REVISIÓN: Puede experimentar un reinicio de AppDomain inesperado en una aplicación Web ASP.NET que se basa en .NET Framework 2.0

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Microsoft .NET Framework 2.0, x 86
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempo
Aspnet_wp.exe2.0.50727.17423.04001-Jul-200606: 53
Webengine.dll2.0.50727.174300.03201-Jul-200606: 53
System.Web.dll2.0.50727.1745,025,79201-Jul-200606: 53
Microsoft .NET Framework 2.0, las versiones de 64 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempo
Aspnet_wp.exe2.0.50727.17434,81630-Jun-200622: 12
Aspnet_wp.exe2.0.50727.17423.04001-Jul-200606: 53
Webengine.dll2.0.50727.174540,67230-Jun-200622: 12
Webengine.dll2.0.50727.174300.03201-Jul-200606: 53
System.Web.dll2.0.50727.1744,960,25601-Jul-200612: 03
System.Web.dll2.0.50727.1745,025,79201-Jul-200606: 53
Microsoft .NET Framework 2.0, versiones basadas en Itanium
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempo
Aspnet_wp.exe2.0.50727.17473.72830-Jun-200622: 18
Aspnet_wp.exe2.0.50727.17423.04001-Jul-200606: 53
Webengine.dll2.0.50727.174868,86430-Jun-200622: 18
Webengine.dll2.0.50727.174300.03201-Jul-200606: 53
System.Web.dll2.0.50727.1744,595,71201-Jul-200604: 00
System.Web.dll2.0.50727.1745,025,79201-Jul-200606: 53

Solución

Para evitar este problema, reciclar el grupo de aplicaciones de IIS que aloja la aplicación Web ASP.NET 2.0 volver a registrar las clases VirtualPathProviders . Para ello, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba inetmgr y, a continuación, haga clic en Aceptar .
  2. Expanda <Server Name> y a continuación, expanda Grupos de aplicaciones .

    Nota <Server Name> es un marcador de posición para el nombre del equipo en el que desea reciclar el grupo de aplicaciones de IIS.
  3. Haga clic con el botón secundario en el grupo de aplicaciones de IIS que desea reciclar y, a continuación, haga clic en reciclaje .
  4. Haga clic con el botón secundario en <Server Name>.
  5. Haga clic en Todas las tareas y, a continuación, haga clic en Reiniciar IIS .
  6. Haga clic en Aceptar .

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Se esta revisión hace efectiva la próxima vez que se recicla el grupo de aplicaciones de IIS.

Para obtener más información acerca de la terminología relativa de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 922345 - Última revisión: jueves, 15 de noviembre de 2007 - Versión: 1.3
La información de este artículo se refiere a:
  • Microsoft ASP.NET 2.0
Palabras clave: 
kbmt kbautohotfix kbexpertiseadvanced kbfix kbhotfixserver kbqfe kbpubtypekc KB922345 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 922345

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com