El servicio host del agente de SMS no se inicia después de reiniciar un equipo cliente de Systems Management Server 2003

En este artículo se proporciona una solución para el problema por el que el servicio host del agente SMS no se inicia después de reiniciar un equipo cliente de Systems Management Server 2003.

Se aplica a todas las ediciones de Windows 10
Número de KB original: 922362

Importante

Este artículo contiene información sobre cómo modificar el Registro. Antes de modificar el Registro, asegúrese de hacer una copia de seguridad del mismo y Asegúrese de saber cómo recuperar el registro en caso de producirse algún problema. Para obtener más información sobre cómo realizar copias de seguridad, restaurar y modificar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986 Descripción del registro de Microsoft Windows

Síntomas

Después de reiniciar un equipo cliente de Microsoft Systems Management Server (SMS) 2003, el servicio host del agente sms (Ccmexec.exe) no se inicia. Cuando se produce este problema, pueden aparecer entradas de error similares a las siguientes en el archivo CCMExec.log en el equipo cliente SMS:

CCMExec.log entrada de archivo 1
Inicio del servicio CCMEXEC... $$<CcmExec><Fri 13 feb 8:13:13.819 2004 Central Standard Time><thread=1216 (0x4C0)>
Ejecución en el equipo NombreDeEquipo como SISTEMA de usuario.
$$<CcmExec><Fri febrero 13 8:13:13.859 2004 Central Standard Time><thread=1216 (0x4C0)>
¡¡ERROR!! WBEM no se encuentra en la ruta de acceso del sistema. $$<CcmExec><Fri febrero 13 8:13:13.859 2004 Central Standard Time><thread=1216 (0x4C0)>
Se ha agregado correctamente WBEM a la variable de entorno de proceso PATH. $$<CcmExec><Fri febrero 13 8:13:13.859 2004 Central Standard Time><thread=1216 (0x4C0)>
Inicialización de COM. $$<CcmExec><Fri febrero 13 8:13:13.859 2004 Central Standard Time><thread=1216 (0x4C0)>
Registrarse para registrar notificaciones de cambios. $$<CcmExec><Fri 13 feb 8:13:13.869 2004 Central Standard Time><thread=1216 (0x4C0)>
Establecer el componente de registro predeterminado para el proceso. $$<CcmExec><Fri 13 feb 8:13:13.869 2004 Central Standard Time><thread=1216 (0x4C0)>
Establecer el estado del servicio en RUNNING. $$<CcmExec><Fri 13 feb 8:13:13.869 2004 Central Standard Time><thread=1216 (0x4C0)>
Comprobar si se requiere reparación. $$<CcmExec><Fri 13 feb 8:13:13.889 2004 Central Standard Time><thread=1216 (0x4C0)>
No se pudo abrir el espacio de nombres WMI '\\.\root\ccm' (80004002) $$<CcmExec><Fri 13 de febrero 8:13:17.224 2004 Central Standard Time><thread=1216 (0x4C0)>
CCMExec.log entrada de archivo 2
1/25/2006 9:16:35 PMFailed para abrir el espacio de nombres WMI '\\.\root\ccm' (8004100a)
1/25/2006 9:16:35 PMCCMDoCertificateMaintenance error (0x8004100a).
1/25/2006 9:16:35 PMFailed para abrir el espacio de nombres WMI '\\.\root\CCM\Events' (8004100a)
1/25/2006 9:16:35 PMCCMDoCertificateMaintenance() se generó CCM_ServiceHost_CertificateOperationsFailure evento de estado.
1/25/2006 9:16:35 PMConfiguración del servicio de carga.
1/25/2006 9:16:35 PMFailed para abrir el espacio de nombres WMI '\\.\root\ccm\Policy\Machine' (8004100a)
1/25/2006 9:16:35 PMError cargando la configuración del servicio. Código 0x8004100a
Error de inicialización del 1/25/2006 9:16:35 PMPhase 0 (0x8004100a).
25/1/2006 9:16:35 Error de inicialización de PMService (0x8004100a).
1/25/2006 9:16:35 P.M. Bajar AdditonallyCCMEXEC...
Además, el archivo Wbemcore.log puede contener una entrada de error similar a la siguiente:
(13 de febrero de 08:13:13 2004.69289): la entrada del Registro indica que se está ejecutando una instalación.
(Viernes 13 de febrero 08:14:13 2004.129856) : Construcción CFactory
(Viernes 13 de febrero 08:14:13 2004.129886) : CFactory destruct
(Viernes 13 de febrero 08:14:13 2004.129896) : Creado WINMGMT_ACTIVE exclusión mutua
(Viernes 13 de febrero de 08:14:13 2004.129946) : Lectura de la información de configuración del registro
(Viernes 13 de febrero 08:14:16 2004.132800): Preparación de una solicitud de inicialización de espacio de nombres para el espacio de nombres activo //./ROOT/ccm/policy
(Viernes 13 de febrero 08:14:16 2004.132901): Preparación de una solicitud de inicialización de espacio de nombres para el espacio de nombres activo //./root/CIMV2
(13 de febrero de 08:14:16 2004.132961): preparación de una solicitud de inicialización de espacio de nombres para el espacio de nombres activo //./root/subscription
(13 de febrero de 08:14:16 2004.133021): Inicialización del espacio de nombres //./ROOT/ccm/policy
(Viernes 13 de febrero 08:14:16 2004.133041): Inicialización del espacio de nombres //./root

Causa

Este problema se produce cuando se cumplen una o ambas condiciones:

  • La variable de ruta de acceso %SystemRoot%\System32\Wbem no aparece en la ruta de acceso del sistema en el equipo cliente.
  • El tipo de la entrada del Registro path es incorrecto en el equipo cliente SMS.

El problema también puede producirse cuando el servicio Instrumental de administración de Windows (WMI) no se inicia de forma oportuna.

Solución

Para resolver el problema, use uno de los siguientes métodos.

Método 1: Asegúrese de que la variable %SystemRoot%\System32\Wbem aparece en la ruta de acceso del sistema en el equipo cliente.

  1. Haga clic en Inicio, en Ejecutar, escriba sysdm.cpl y, a continuación, haga clic en Aceptar.

  2. Haga clic en la pestaña Opciones avanzadas y, a continuación, haga clic en Variables de entorno.

  3. En Variables del sistema, haga clic en Ruta de accesoy, a continuación, haga clic en Editar.

  4. Asegúrese de que %SystemRoot%\System32\Wbem aparece en el cuadro Valor de variable. Si este valor no aparece en la lista, debe agregarlo. Para ello, siga estos pasos:

    1. En el cuadro de diálogo Editar variable del sistema , haga clic después del final del texto en el cuadro Valor de variable y, a continuación, escriba:
      ;%SystemRoot%\System32\Wbem

    2. Haga clic tres veces en Aceptar para guardar los cambios.

Método 2: establezca el tipo de la entrada del Registro path en REG_EXPAND_SZ

Advertencia

Es posible que se produzcan problemas graves si modifica el Registro de forma incorrecta mediante el Editor del Registro u otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de estos problemas. Modifique el Registro bajo su propia responsabilidad.

  1. Haga clic en Inicio y en Ejecutar, escriba regedit y, luego, haga clic en Aceptar.

  2. En Editor del Registro, busque y, a continuación, haga clic en la siguiente subclave del Registro:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

  3. Asegúrese de que el tipo de la entrada Path está REG_EXPAND_SZ y no REG_SZ. Si el tipo de esta entrada se REG_SZ, debe copiar la información de la ruta de acceso, eliminar la entrada Path existente y, a continuación, crear una nueva entrada de tipo REG_EXPAND_SZ. Para ello, siga estos pasos:

    1. En Editor del Registro, haga doble clic en el valor Ruta de acceso.
    2. Haga clic con el botón derecho en el texto del cuadro Datos de valor , haga clic en Copiary, a continuación, haga clic en Cancelar.
    3. Pegue el texto en un documento del Bloc de notas.
    4. En Editor del Registro, haga clic con el botón derecho en Ruta de acceso y, a continuación, haga clic en Eliminar.
    5. En la barra de menús, haga clic en Editar, seleccione Nuevo y, a continuación, haga clic en Valor de cadena expansible.
    6. Escriba Ruta de acceso y, a continuación, presione ENTRAR.
    7. Haga doble clic en Ruta de acceso.
    8. Haga clic con el botón derecho en el cuadro Datos de valor , haga clic en Pegary, a continuación, haga clic en Aceptar.
    9. Salga del Editor del Registro.

Más información

Para obtener más información sobre la solución de problemas de las instalaciones de inserción de cliente avanzadas, consulte el siguiente artículo en Microsoft Knowledge Base:

928282 Solución de problemas de instalación avanzada de inserción de cliente en Systems Management Server 2003 y System Center Configuration Manager 2007