Bir Systems Management Server 2003 istemci bilgisayarı yeniden başlatıldıktan sonra SMS Aracısı Ana Bilgisayarı hizmeti başlatılmıyor

Bu makalede, bir Systems Management Server 2003 istemci bilgisayarı yeniden başlatıldıktan sonra SMS Aracısı Ana Bilgisayar hizmetinin başlatılmaması sorununa yönelik bir çözüm sağlanır.

Şunlar için geçerlidir: Windows 10 - tüm sürümler
Özgün KB numarası: 922362

Önemli

Bu makale, kayıt defterinin nasıl değiştirileceği hakkında bilgiler içerir. Değiştirmeden önce kayıt defterini yedeklemeyi unutmayın. Bir sorun olduğunda kayıt defterinin nasıl geri yükleneceğini bildiğinizden emin olun. Kayıt defterini yedekleme, geri yükleme ve değiştirme hakkında daha fazla bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
256986 Microsoft Windows kayıt defterinin açıklaması

Belirtiler

Microsoft Systems Management Server (SMS) 2003 istemci bilgisayarını yeniden başlattıktan sonra SMS Aracısı Ana Bilgisayar hizmeti (Ccmexec.exe) başlatılmaz. Bu sorun oluştuğunda, SMS istemci bilgisayarındaki CCMExec.log dosyasında aşağıdakine benzer hata girişleri görünebilir:

CCMExec.log dosya girdisi 1
CCMEXEC hizmeti başlatılıyor... $$<CcmExec><Şub 13 8:13:13.819 2004 Central Standard Time><thread=1216 (0x4C0)>
ComputerName makinesinde system kullanıcısı olarak çalıştırılıyor.
$$<CcmExec><Fri 13 Şub 8:13:13.859 2004 Central Standard Time><thread=1216 (0x4C0)>
HATA!! WBEM sistem yolunda bulunamadı. $$<CcmExec><Fri 13 Şub 8:13:13.859 2004 Central Standard Time><thread=1216 (0x4C0)>
PATH işlem ortamı değişkenine WBEM başarıyla eklendi. $$<CcmExec><Fri 13 Şub 8:13:13.859 2004 Central Standard Time><thread=1216 (0x4C0)>
COM başlatıldı. $$<CcmExec><Fri 13 Şub 8:13:13.859 2004 Central Standard Time><thread=1216 (0x4C0)>
Değişiklik bildirimlerini günlüğe kaydetme. $$<CcmExec><Fri 13 Şub 8:13:13.869 2004 Central Standard Time><thread=1216 (0x4C0)>
İşlem için varsayılan günlük bileşenini ayarlama. $$<CcmExec><Fri 13 Şub 8:13:13.869 2004 Central Standard Time><thread=1216 (0x4C0)>
Hizmet durumunu ÇALıŞıYOR olarak ayarlama. $$<CcmExec><Fri 13 Şub 8:13:13.869 2004 Central Standard Time><thread=1216 (0x4C0)>
Onarım gerekip gerekmediğini denetleme. $$<CcmExec><Fri 13 Şub 8:13:13.889 2004 Central Standard Time><thread=1216 (0x4C0)>
'\\.\root\ccm' (80004002) $$<CcmExec><Fri 13 8:13:17.224 2004 Central Standard Time><thread=1216 (0x4C0) WMI ad alanına açılamadı>
CCMExec.log dosya girişi 2
25.1.2006 9:16:35 WMI ad alanı '\\.\root\ccm' (8004100a) için açıldı
25/1/2006 9:16:35 PMCCMDoCertificateMaintenance başarısız oldu (0x8004100a).
25.1.2006 9:16:35 PMFailed to open to WMI namespace '\\.\root\CCM\Events' (8004100a)
25.1.2006 9:16:35 PMCCMDoCertificateMaintenance() CCM_ServiceHost_CertificateOperationsFailure durum olayını tetikledi.
25.01.2006 21:16:35 Hizmet ayarlarını yükleme.
25.1.2006 9:16:35 PMFailed to open to WMI ad alanı '\\.\root\ccm\Policy\Machine' (8004100a)
25.01.2006 21:16:35Hata ayarları yükleniyor. Kod 0x8004100a
25/1/2006 9:16:35 PMPhase 0 başlatma başarısız oldu (0x8004100a).
25.01.2006 21:16:35Hizmet başlatma başarısız oldu (0x8004100a).
25/1/2006 9:16:35 AdditonallyCCMEXEC...
Ayrıca, Wbemcore.log dosyası aşağıdakine benzer bir hata girdisi içerebilir:
(13 Şubat 08:13:13 2004.69289) : Kayıt defteri girdisi bir kurulumun çalıştığını gösteriyor
(Cum 13 Şubat 08:14:13 2004.129856) : CFactory yapısı
(Cum 13 Şubat 08:14:13 2004.129886) : CFactory yok
(Cum 13 Şubat 08:14:13 2004.129896) : Mutex WINMGMT_ACTIVE oluşturuldu
(Cum 13 Şubat 08:14:13 2004.129946) : Kayıt defterinden yapılandırma bilgilerini okuma
(13 Şubat 08:14:16 2004.132800) : Etkin ad alanı için ad alanı başlatma isteği hazırlama //./ROOT/ccm/policy
(Cum 13 Şubat 08:14:16 2004.132901) : Etkin ad alanı için ad alanı başlatma isteği hazırlama //./root/CIMV2
(Cum 13 Şubat 08:14:16 2004.132961) : Etkin ad alanı için ad alanı başlatma isteği hazırlama //./root/subscription
(Cum 13 Şubat 08:14:16 2004.133021) : Ad alanı başlatılıyor //./ROOT/ccm/policy
(Cum 13 Şubat 08:14:16 2004.133041) : Ad alanı başlatılıyor //./root

Neden

Bu sorun, aşağıdaki koşullardan biri veya her ikisi de doğru olduğunda oluşur:

  • %SystemRoot%\System32\Wbem yol değişkeni, istemci bilgisayardaki sistem yolunda listelenmiyor.
  • SMS istemci bilgisayarında Yol kayıt defteri girdisinin türü yanlış.

Windows Yönetim Araçları (WMI) hizmeti zamanında başlatılmadığında da sorun oluşabilir.

Çözüm

Bu sorunu gidermek için aşağıdaki yöntemlerden birini kullanın:

Yöntem 1: %SystemRoot%\System32\Wbem değişkeninin istemci bilgisayardaki sistem yolunda listelendiğinden emin olun

  1. Başlat'a tıklayın, Çalıştır'a tıklayın, sysdm.cpl yazın ve tamam'a tıklayın.

  2. Gelişmiş sekmesine ve ardından Ortam Değişkenleri'ne tıklayın.

  3. Sistem değişkenleri'nin altında Yol'a ve ardından Düzenle'ye tıklayın.

  4. Değişken değer kutusunda %SystemRoot%\System32\Wbem öğesinin listelendiğinden emin olun. Bu değer listelenmiyorsa, eklemeniz gerekir. Bunu yapmak için şu adımları uygulayın:

    1. Sistem Değişkenini Düzenle iletişim kutusunda, Değişken değer kutusundaki metnin sonundan sonraya tıklayın ve şunu yazın:
      ;%SystemRoot%\System32\Wbem

    2. Değişiklikleri kaydetmek için Üç kez Tamam'a tıklayın.

Yöntem 2: Yol kayıt defteri girdisinin türünü REG_EXPAND_SZ olarak ayarlayın

Uyarı

Kayıt Defteri Düzenleyicisi'ni veya başka bir yöntemi kullanarak kayıt defterini hatalı olarak değiştirirseniz önemli sorunlar oluşabilir. Bu sorunlar, işletim sisteminizi yeniden yüklemenizi gerektirebilir. Microsoft, bu sorunların çözülebileceğini garanti edemez. Kayıt defterini değiştirmek kendi sorumluluğunuzdadır.

  1. Başlat'ı, ardından Çalıştır'ı tıklayın, regedit yazın ve Tamam'ı tıklayın.

  2. Kayıt Defteri Düzenleyici aşağıdaki kayıt defteri alt anahtarını bulun ve tıklatın:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

  3. Yol girdisinin türünün REG_SZ değil REG_EXPAND_SZ olduğundan emin olun. Bu girdinin türü REG_SZ, yol bilgilerini kopyalamanız, var olan Yol girdisini silmeniz ve ardından REG_EXPAND_SZ türünde yeni bir giriş oluşturmanız gerekir. Bunu yapmak için şu adımları uygulayın:

    1. Kayıt Defteri Düzenleyici Yol değerine çift tıklayın.
    2. Değer verileri kutusundaki metne sağ tıklayın, Kopyala'ya ve ardından İptal'e tıklayın.
    3. Metni Not Defteri belgesine yapıştırın.
    4. Kayıt Defteri Düzenleyici Yol'a sağ tıklayın ve ardından Sil'e tıklayın.
    5. Menü çubuğunda Düzenle'ye tıklayın, Yeni'nin üzerine gelin ve Genişletilebilir Dize Değeri'ne tıklayın.
    6. Yol yazın ve ENTER tuşuna basın.
    7. Yol'a çift tıklayın.
    8. Değer verileri kutusuna sağ tıklayın, Yapıştır'a ve ardından Tamam'a tıklayın.
    9. Kayıt Defteri Düzenleyicisi'nden çıkın.

Daha fazla bilgi

Gelişmiş İstemci Anında yükleme sorunlarını giderme hakkında daha fazla bilgi için Microsoft Bilgi Bankası'ndaki aşağıdaki makaleye bakın:

928282 Systems Management Server 2003 ve System Center Configuration Manager 2007'de Gelişmiş İstemci Anında Yükleme Sorunlarını Giderme